Community discussions

 
negge
newbie
Topic Author
Posts: 36
Joined: Fri Jul 10, 2009 11:05 am

Ident doesn't work with RouterOS

Sun Aug 29, 2010 3:09 pm

Hi guys,

I'm trying to figure out a way to run an ident daemon on a NATed server behind a RouterOS router. The thing is that all daemons out there work out of the box with a standard SOHO router, but not with RouterOS. The way I see it is that RouterOS changes the port of a packet when it NATs them, but ident doesn't understand that so it can't find the proper connection (read up a bit on how ident works if you don't know what I'm talking about), while a standard SOHO router doesn't do that.

So my question is, has anyone here gotten ident to work with a RouterOS NAT setup? Or is there a way to tell RouterOS to only change the address (not the port) of NATted packages?

Sincere thanks,

negge
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8280
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Ident doesn't work with RouterOS

Mon Sep 13, 2010 7:22 pm

any example and how you want it to be?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
psamsig
Member Candidate
Member Candidate
Posts: 161
Joined: Sun Dec 06, 2009 1:36 pm
Location: Denmark

Re: Ident doesn't work with RouterOS

Mon Sep 13, 2010 7:45 pm

all daemons out there work out of the box with a standard SOHO router
I tend to disagree on that, no router, SOHO or otherwise, I have ever layed my hands on, come with preconfigured inbound NAT, at most they may come with preenabled UPnP (shiver).
Never the less, it should be easy enough (especially if you read up on how NAT works in RouterOS)
Given that you WAN interface is named Wan, that it has IP 1.1.1.1 and that your ident daemon is on 192.168.1.1, then this should get you up and running
/ip firewall nat
add action=dst-nat chain=dstnat comment="" disabled=no dst-address=1.1.1.1 dst-port=113 in-interface=Wan protocol=tcp to-addresses=192.168.1.1

Who is online

Users browsing this forum: No registered users and 54 guests