Community discussions

MikroTik App
 
ctech4285
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Sat Aug 15, 2009 8:49 pm

how do i use different routing table?

Wed Sep 08, 2010 2:25 am

i need to test if a route is up via ping without actually using it for routing traffic. ping interface=wlan2 google.com or so is not enough, i need to check the whole route....

you can do ping routing-table=blah google.com, but have no idea how to create these table. googleing did not turn up anythign usefull...

kind regards
 
blake
Member
Member
Posts: 426
Joined: Mon May 31, 2010 10:46 pm
Location: Arizona

Re: how do i use different routing table?

Wed Sep 08, 2010 2:36 am

/ip route
add gateway=192.0.2.1 routing-mark=test-routing

/ping routing-table=test-routing google.com
IT consultant. Network manager. Packet junkie.
1-928-328-1509
 
ctech4285
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Sat Aug 15, 2009 8:49 pm

Re: how do i use different routing table?

Wed Sep 08, 2010 2:41 am

ah perfect thank you
 
ctech4285
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Sat Aug 15, 2009 8:49 pm

Re: how do i use different routing table?

Wed Sep 08, 2010 8:38 pm

hmm
here is a problem in this sernario:
internet-default-----rb750------rb433ah----internet-backup
if i ping google.com from rb750 throw internet-backup and it happen to be down i get a route redirected result and script things it is up

if ([ping 208.67.222.222 routing-table=Backup-Gateway count=1] = 0) do={/log info message="Backup-Gateway down"}
 
cheretbe
just joined
Posts: 2
Joined: Thu Sep 25, 2014 9:48 am

Re: how do i use different routing table?

Thu Sep 25, 2014 9:56 am

This is an old topic. But for fellow googler's sake here is the routing rule to disable other routing tables lookup:
/ip route rule
add action=lookup-only-in-table routing-mark=test-routing table=test-routing
Took me a good while to figure this out. Hope this will help somebody else.

Who is online

Users browsing this forum: No registered users and 103 guests