Community discussions

 
gmsmstr
Trainer
Trainer
Topic Author
Posts: 940
Joined: Fri Jun 04, 2004 2:22 am
Location: St. Louis, MO
Contact:

RouterOS reply to Pings from All IPs

Mon Jan 10, 2011 5:58 pm

Just wondering if someone thought up a way to allow your Router to reply to ALL pings to a subnet routed to the router? tried to do some redirects and such, not much working..
Dennis Burgess, MCTCE, MTCNA, MCTCTE, MTCWE, MTCNIE, A+, N+, MCP, MTCSE Mikrotik Certified Consultant / Trainer
Need Mikrotik Support: http://www.linktechs.net -- Link Technologies, Inc.
-- Author of "Learn RouterOS: Second Edition"
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: RouterOS reply to Pings from All IPs

Wed Jan 12, 2011 5:55 pm

Assuming a router has an IP address of 192.168.1.1/24 on an interface called LAN and 1.1.1.1/30 on another interface called WAN, the following should forward all incoming ICMP echo requests for 192.168.1.0/24 through 1.1.1.1 to the router itself and cause it to reply unless you're blocking that via firewall filters:
/ip firewall nat
add chain=dstnat in-interface=WAN dst-address=192.168.1.0/24 protocol=icmp icmp-options=0:8 action=redirect
Is that what you're trying to do?
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.
 
gmsmstr
Trainer
Trainer
Topic Author
Posts: 940
Joined: Fri Jun 04, 2004 2:22 am
Location: St. Louis, MO
Contact:

Re: RouterOS reply to Pings from All IPs

Wed Jan 12, 2011 6:08 pm

In this case, we have a public subnet, some devices are out there on the subnet, but we want to show ALL ips as reachable with pings. I forgot about the ICMP options, in our case I did.
add action=redirect chain=dstnat comment="" disabled=no dst-address=x.x.x.0/24 icmp-options=0:8 in-bridge-port=WAN protocol=\
    icmp
but those IPs still do not work. Keep in mind in this unit we are bridging though so that might be our issue :(
Dennis Burgess, MCTCE, MTCNA, MCTCTE, MTCWE, MTCNIE, A+, N+, MCP, MTCSE Mikrotik Certified Consultant / Trainer
Need Mikrotik Support: http://www.linktechs.net -- Link Technologies, Inc.
-- Author of "Learn RouterOS: Second Edition"

Who is online

Users browsing this forum: No registered users and 62 guests