Community discussions

MUM Europe 2020
 
paulojrandrade
just joined
Topic Author
Posts: 8
Joined: Wed Jul 15, 2009 9:51 pm

Server PC PPPOE - Crash

Fri Jan 21, 2011 2:44 pm

Bom dia a todos, desculpem mas meu ingles é péssimos, então postarei em Portugues e Ingles traduzido.
Venho pedir ajuda aos amigos, pois depois de uns 3 anos que migrei para PPPOE, do nada o Server começou a travar, no log aparece erros de "Time Out " no Radius, entrei em contato com a empresa do sistema Radius, eles me informaram que tinha problema, mas nao tinha na haver com a conexão cliente server. Bom, troquei de maquina, memoria, HD, CPU, Placa Mae, teste de memoria, de HD, de stress, resumindo, verifiquei tudo.
Licenciei o MK para a versão 4.13... atualizei para a 4.15... continuou a travar, menas vezes mas continuou. Um amigo aconselhou a fazer um downgrade para a 4.11, ficou uns 20 dias sem travar agora voltou a travar.
Vou enviar algumas informações aos amigos, assim q puder enviarei prints das telas que aparencem nos logs, e na propria tela do Winbox.

Grato desde ja pela atenção de todos.

#########################
#########################

Good morning everyone, sorry but my English is bad, then I'll post in Portuguese and English translation.
I've been asking for help to friends, because after about three years that I migrated to PPPOE, of anything started freezing Server, appears in the log errors "Time Out" at Radius, I contacted the company Radius system, they informed me that was okay, but not be had in connection with the client server. Well, I changed the machine, memory, HDD, CPU, Motherboard, test memory, HD, stress, in short, checked everything.
MK graduated to version 4.13 ... upgraded to 4.15 ... continued to hang, but continued menas times. A friend advised him to make a downgrade to 4.11, was about 20 days now without crashing halt again.
Will send some information to friends, so q can send screenshots of the design that appearance in the logs, and Winbox own screen.

Thank you in advance for your attention.

###################################
jan/03/2011 08:47:31 system,error,critical router was rebooted without proper shutdown
jan/04/2011 11:21:13 system,error,critical login failure for user admin from 201.64.198.243 via winbox
jan/07/2011 10:34:22 system,error,critical router was rebooted without proper shutdown
jan/10/2011 11:01:56 system,error,critical login failure for user admin from 201.64.198.164 via winbox
jan/10/2011 11:02:29 system,error,critical login failure for user admin from 201.64.198.164 via winbox
jan/10/2011 11:02:44 system,error,critical login failure for user admin from 201.64.198.164 via winbox
jan/14/2011 10:19:57 system,error,critical login failure for user admin via winbox
jan/20/2011 15:55:32 system,error,critical System rebooted because of kernel failure
[paulo@SRV_PPPOE] >

#####
[paulo@SRV_PPPOE] > system hardware print
multi-cpu: no

#####
[paulo@SRV_PPPOE] > system resource print
uptime: 55m5s
version: "4.11"
free-memory: 231744kB
total-memory: 255716kB
cpu: "AMD"
cpu-count: 1
cpu-frequency: 1800MHz
cpu-load: 42
free-hdd-space: 38311192kB
total-hdd-space: 38488468kB
write-sect-since-reboot: 32674
write-sect-total: 214074
architecture-name: "x86"
board-name: "x86"
platform: "MikroTik"
#####

[paulo@SRV_PPPOE] > interface pppoe-server server print
Flags: X - disabled
0 service-name="PPPOE" interface=CLIENTES max-mtu=1480 max-mru=1492 mrru=disabled authentication=pap
keepalive-timeout=10 one-session-per-host=no max-sessions=0 default-profile=default
#####

[paulo@SRV_PPPOE] > radius print
Flags: X - disabled
# SERVICE CALLED-ID DOMAIN ADDRESS SECRET
0 X ;;; RADIUS IP INTERNO
ppp 172.17.254.2 xxxxxxxx
1 ;;; RADIUS IP VALIDO
ppp 200.183.146.195 xxxxxxx
#####
 
User avatar
omidkosari
Trainer
Trainer
Posts: 617
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: Server PC PPPOE - Crash

Mon Jan 24, 2011 7:31 pm

This bug persisted more than 4 years in mikrotik since version 3.x . i have sent several email to support and forum . they always say that you should upgrade to next version . this is the worst bug in mikrotik .
 
romanse
just joined
Posts: 24
Joined: Fri Apr 10, 2009 8:16 pm

Re: Server PC PPPOE - Crash

Wed Jan 26, 2011 11:53 am

I have the such situation I have 600 sim pppoe users
one time in day I am to reboot the server - because all traffic in LAN interface wont go in - all ppp sessions broke and anyone cant log in
I had 3.30 version - sent suppout.rif many times but support told me to upgrade new version
Yesterday I installed 5.0 7rc - and tonight in 01:02 its crashed again - our support just rebooted it and haven`t made suppout.rif
today I shall monitor on crash again

Dear support of great thing such RouterOS please help when I send supout.rif

We had tired to reboot every day PPPoe server
or just disable and enable LAN interface - and all ok!!


Some problem present with RouterOS - Please help!!!!!
 
paulojrandrade
just joined
Topic Author
Posts: 8
Joined: Wed Jul 15, 2009 9:51 pm

Re: Server PC PPPOE - Crash

Wed Jan 26, 2011 1:15 pm

- O problema aqui ainda persiste !!! Faz 4 dias sem travar ou reiniciar verssao 4.11 mas pronto para colocar a 4.16.

- The problem still persists here! Makes 4 days without crashing or rebooting version 4.11 but ready to put 4.16.


Thanks my friend
 
romanse
just joined
Posts: 24
Joined: Fri Apr 10, 2009 8:16 pm

Re: Server PC PPPOE - Crash

Wed Jan 26, 2011 3:12 pm

I have found that RouterOS on PC (for pppoe server) on LAN interface dont want to learn apr replays

192.168.20.1 - RouterOS
192.168.20.159 - my comp


I ping from my comp routerOS and have not get replays from RouterOS
root@nat:/etc# tcpdump -i eth1 -n host 192.168.20.1
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), capture size 96 bytes
13:54:22.368919 arp who-has 192.168.20.100 tell 192.168.20.1
13:54:22.420975 IP 192.168.20.159 > 192.168.20.1: ICMP echo request, id 21599, seq 73, length 64
13:54:22.521401 IP 192.168.20.159 > 192.168.20.1: ICMP echo request, id 48734, seq 680, length 64
13:54:22.536383 arp who-has 192.168.20.159 tell 192.168.20.1
13:54:22.536391 arp reply 192.168.20.159 is-at 00:e0:4c:d3:6c:cd
13:54:22.545170 arp who-has 192.168.20.12 tell 192.168.20.1
13:54:23.421057 IP 192.168.20.159 > 192.168.20.1: ICMP echo request, id 21599, seq 74, length 64
13:54:23.521413 IP 192.168.20.159 > 192.168.20.1: ICMP echo request, id 48734, seq 681, length 64
13:54:24.371175 arp who-has 192.168.20.100 tell 192.168.20.1
13:54:24.421139 IP 192.168.20.159 > 192.168.20.1: ICMP echo request, id 21599, seq 75, length 64
13:54:24.525131 IP 192.168.20.159 > 192.168.20.1: ICMP echo request, id 48734, seq 682, length 64
13:54:25.215756 arp who-has 192.168.20.12 tell 192.168.20.1
13:54:25.368288 arp who-has 192.168.20.100 tell 192.168.20.1
13:54:25.421174 IP 192.168.20.159 > 192.168.20.1: ICMP echo request, id 21599, seq 76, length 64
13:54:25.451570 arp who-has 192.168.20.159 tell 192.168.20.1
13:54:25.451583 arp reply 192.168.20.159 is-at 00:e0:4c:d3:6c:cd
13:54:25.460113 arp who-has 192.168.20.251 tell 192.168.20.1
13:54:25.525177 IP 192.168.20.159 > 192.168.20.1: ICMP echo request, id 48734, seq 683, length 64
13:54:26.145834 arp who-has 192.168.20.7 tell 192.168.20.1
13:54:26.217683 arp who-has 192.168.20.12 tell 192.168.20.1
13:54:26.371985 arp who-has 192.168.20.100 tell 192.168.20.1
13:54:26.429573 IP 192.168.20.159 > 192.168.20.1: ICMP echo request, id 21599, seq 77, length 64
13:54:26.442561 arp who-has 192.168.20.159 tell 192.168.20.1
13:54:26.442575 arp reply 192.168.20.159 is-at 00:e0:4c:d3:6c:cd
13:54:26.525205 IP 192.168.20.159 > 192.168.20.1: ICMP echo request, id 48734, seq 684, length 64

as soon as I make static arp on RouterOS
22 192.168.20.159 00:E0:4C:D3:6C:CD ether3
I get replays from RouterOS

as soon as I reboot server or disable and then enable ether3 - everything is ok arp works - and then day pass or not pass (4-40 hours) situation repeats
 
romanse
just joined
Posts: 24
Joined: Fri Apr 10, 2009 8:16 pm

Re: Server PC PPPOE - Crash

Wed Jan 26, 2011 5:35 pm

to paulojrandrade

How much sim clients you have on your pppoe server?
 
User avatar
omidkosari
Trainer
Trainer
Posts: 617
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: Server PC PPPOE - Crash

Tue Feb 01, 2011 9:45 am

Confirmed . the radius crash problem does not appear in 4.11 but the bug exists in 4.12 and later . even 4.16 is the worst one .
 
wildbill442
Forum Guru
Forum Guru
Posts: 1050
Joined: Wed Dec 08, 2004 7:29 am
Location: Sacramento, CA

Re: Server PC PPPOE - Crash

Tue Feb 01, 2011 7:07 pm

Can Mikrotik confirm this?

I have multiple PPPoE Servers however they are on different versions and different hardware and have not experienced this problem, however, I'm running pre-4.12 releases.

Two are Portwell NAR-5060's running 4.11 and 4.7. A mikrotik RB800 running 4.11 and a RB600 running 4.11. I have yet to upgrade the devices because they're running just fine at their current versions.

If there is a problem I'd like to get confirmation from Mikrotik, because I do plan to roll out ROSv5 when it becomes stable.
William Burnett
Network Engineer
 
paulojrandrade
just joined
Topic Author
Posts: 8
Joined: Wed Jul 15, 2009 9:51 pm

Re: Server PC PPPOE - Crash

Thu Feb 03, 2011 1:28 pm

Bom dia, apos 4 dias travou novamente, eis algumas imagens e arquivos de suport.
PS: Agora esta rodando a versão 4.16
Grato a todos

Romanse !!! online nao passa de 400... hoje esta no máximo com 220... e isso começou de um tempo pra cá esse server já ficou 2 anos sem problema algum. Ele tinha a versão 3.22, qndo começou esses problemas coloquei a verão paga, mas percistiu o problema.
PS: já troquei todo o hardware...
You do not have the required permissions to view the files attached to this post.
Last edited by paulojrandrade on Thu Feb 03, 2011 1:33 pm, edited 1 time in total.
 
paulojrandrade
just joined
Topic Author
Posts: 8
Joined: Wed Jul 15, 2009 9:51 pm

Re: Server PC PPPOE - Crash

Thu Feb 03, 2011 1:29 pm

continuando...
You do not have the required permissions to view the files attached to this post.
 
User avatar
omidkosari
Trainer
Trainer
Posts: 617
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: Server PC PPPOE - Crash

Thu Mar 03, 2011 6:44 pm

Does the problem solved in 4.17 or even 5.0rc11 ?
Any report please
 
User avatar
marioclep
Trainer
Trainer
Posts: 140
Joined: Sat Jul 11, 2009 4:36 pm
Location: Cordoba - Argentina
Contact:

Re: Server PC PPPOE - Crash

Thu Mar 03, 2011 9:57 pm

continuando...
Have you tried by netinstalling RouterOS again? The log says Kernel Failure...
---------------------

Ing. Mario D. Clep
CTO - MKE Solutions
MikroTik Certified Trainer
 
sankarklm
just joined
Posts: 20
Joined: Fri Aug 13, 2010 7:05 pm
Location: Bangalore,India

Re: Server PC PPPOE - Crash

Fri May 27, 2011 6:20 am

Hi

We are running PPPoE server for lan client with radius integrated, initial days it used to hung or doesn't allow lan traffic. Finally we have upgraded Hardware with 4 core Xeon server with 4gb RAM to run around 500+ client. Instead of Hard Disk we use SATA flash drives
Currently using Mikrotik Version: 4.17 degraded from 5.RCxx due to frequent connection drop.

Rgds
Sankar.S

Who is online

Users browsing this forum: MSN [Bot] and 67 guests