Community discussions

MikroTik App
 
Viclay
just joined
Topic Author
Posts: 2
Joined: Sun Feb 06, 2011 1:41 pm

Using two 3G modems with routerboard

Sun Feb 06, 2011 10:59 pm

Please I need you all in the house to help with the loadbalancing issue and the layer 2 bonding procedures to effectively use two 3G modems at the same time.
 
mdaitc
newbie
Posts: 34
Joined: Mon Mar 22, 2010 5:18 am

Re: Using two 3G modems with routerboard

Mon Feb 07, 2011 3:32 am

here's what i'm using: ( http://www.mikrotik-routeros.com/?p=12&cpage=1#comments as reference)

/ip route


add check-gateway=arp comment="WAN 2 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ppp-out1 routing-mark=wan2
add check-gateway=arp comment="WAN 1 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ppp-out2 routing-mark=wan1

add check-gateway=arp comment="WAN 1 - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=ppp-out1 routing-mark=wan1
add check-gateway=arp comment="WAN 2 - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=ppp-out2 routing-mark=wan2



add check-gateway=arp comment="Default Route - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ppp-out2
add check-gateway=arp comment="Default Route - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=ppp-out1

add check-gateway=arp comment="Static Route - WAN1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ppp-out2 routing-mark=static-wan1

add check-gateway=arp comment="Static Route - WAN2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=ppp-out1 routing-mark=static-wan2

 

/ip firewall mangle

add action=mark-connection chain=input comment="Mark new inbound connection wan1" connection-state=new disabled=no in-interface=ppp-out2 new-connection-mark=wan1 \
passthrough=yes

add action=mark-connection chain=input comment="Mark new inbound connection wan2" connection-state=new disabled=no in-interface=ppp-out1 new-connection-mark=wan2 \
passthrough=yes


add action=mark-connection chain=prerouting comment="Mark established inbound connection wan1" connection-state=established disabled=no in-interface=ppp-out2 \
new-connection-mark=wan1 passthrough=yes
add action=mark-connection chain=prerouting comment="Mark established inbound connection wan2" connection-state=established disabled=no in-interface=ppp-out1 \
new-connection-mark=wan2 passthrough=yes
add action=mark-connection chain=prerouting comment="Mark related inbound connection wan1" connection-state=related disabled=no in-interface=ppp-out2 \
new-connection-mark=wan1 passthrough=yes
add action=mark-connection chain=prerouting comment="Mark related inbound connection wan2" connection-state=related disabled=no in-interface=ppp-out1 \
new-connection-mark=wan2 passthrough=yes
add action=mark-routing chain=output comment="Mark new inbound route wan1" connection-mark=wan1 disabled=no new-routing-mark=static-wan1 passthrough=no
add action=mark-routing chain=output comment="Mark new inbound route wan2" connection-mark=wan2 disabled=no new-routing-mark=static-wan2 passthrough=no


add action=mark-connection chain=prerouting comment="Mark traffic that isn't local with PCC mark rand (2 possibilities) - option 1" connection-state=new disabled=no \
dst-address-type=!local in-interface=ether1 new-connection-mark=wan1_pcc_conn passthrough=yes per-connection-classifier=both-addresses:2/0
add action=mark-connection chain=prerouting comment="Mark traffic that isn't local with PCC mark rand (2 possibilities) - option 2" connection-state=new disabled=no \
dst-address-type=!local in-interface=ether1 new-connection-mark=wan2_pcc_conn passthrough=yes per-connection-classifier=both-addresses:2/1



add action=mark-connection chain=prerouting comment="Mark established traffic that isn't local with PCC mark rand (2 possibilities) - option 1" connection-state=\
established disabled=no dst-address-type=!local in-interface=ether1 new-connection-mark=wan1_pcc_conn passthrough=yes per-connection-classifier=\
both-addresses:2/0
add action=mark-connection chain=prerouting comment="Mark established traffic that isn't local with PCC mark rand (2 possibilities) - option 2" connection-state=\
established disabled=no dst-address-type=!local in-interface=ether1 new-connection-mark=wan2_pcc_conn passthrough=yes per-connection-classifier=\
both-addresses:2/1


add action=mark-connection chain=prerouting comment="Mark related traffic that isn't local with PCC mark rand (3 possibilities) - option 1" connection-state=related \
disabled=no dst-address-type=!local in-interface=ether1 new-connection-mark=wan1_pcc_conn passthrough=yes per-connection-classifier=both-addresses:2/0
add action=mark-connection chain=prerouting comment="Mark related traffic that isn't local with PCC mark rand (3 possibilities) - option 2" connection-state=related \
disabled=no dst-address-type=!local in-interface=ether1 new-connection-mark=wan2_pcc_conn passthrough=yes per-connection-classifier=both-addresses:2/1



add action=mark-routing chain=prerouting comment="Mark routing for  PCC mark - option 1" connection-mark=wan1_pcc_conn disabled=no new-routing-mark=wan1 passthrough=\
yes
add action=mark-routing chain=prerouting comment="Mark routing for  PCC mark - option 2" connection-mark=wan2_pcc_conn disabled=no new-routing-mark=wan2 passthrough=\
yes
 
Viclay
just joined
Topic Author
Posts: 2
Joined: Sun Feb 06, 2011 1:41 pm

Re: Using two 3G modems with routerboard

Mon Feb 07, 2011 11:47 am

Thanks very much man.
What am I going to use as my DST ADDRESS? is it my lan and wlan IP, or the routerboard IP, or the subnet generated by my ISP when they lease an IP address to me?
 
mdaitc
newbie
Posts: 34
Joined: Mon Mar 22, 2010 5:18 am

Re: Using two 3G modems with routerboard

Mon Feb 07, 2011 2:53 pm

The 0.0.0.0/0 is what you'll most likely need to use.. It basically means "all routes for which you don't have one specified"

You'll also need a NAT rule (src NAT) and any other firewall rules you need

Who is online

Users browsing this forum: jhbarrantes, MauriceW, Velos and 101 guests