Community discussions

MUM Europe 2020
 
proweb
newbie
Topic Author
Posts: 48
Joined: Sat Oct 08, 2005 10:04 pm

[REQ]HELP config Transparant Web-proxy

Wed Oct 12, 2005 10:41 pm

Thanks man
Last edited by proweb on Mon Oct 17, 2005 11:55 pm, edited 3 times in total.
 
boardman
Member Candidate
Member Candidate
Posts: 260
Joined: Fri May 28, 2004 11:10 pm
Location: Mexico
Contact:

Try this

Thu Oct 13, 2005 12:41 am

/ip firewall nat add in-interface=PUBLIC dst-port=80 protocol=tcp action=redirect to-ports=3128 chain=dstnat

assuming your webproxy is up and running in port 3128 with transparent mode enabled, replace the PUBLIC for your actual interface name.

Hope this help.


Best

Jorge
 
proweb
newbie
Topic Author
Posts: 48
Joined: Sat Oct 08, 2005 10:04 pm

Please give me input and the way out....

Thu Oct 13, 2005 12:50 am

Thanks man
Last edited by proweb on Mon Oct 17, 2005 11:55 pm, edited 1 time in total.
 
boardman
Member Candidate
Member Candidate
Posts: 260
Joined: Fri May 28, 2004 11:10 pm
Location: Mexico
Contact:

try this

Thu Oct 13, 2005 1:16 am

your web-proxy conf looks good, but leave the src-address: 202.22.90.44
blank.

and

If you are using mikrotik version 2.9.x just do the following and it will work:

/ip firewall nat add in-interface=ether1 dst-port=80 protocol=tcp action=redirect to-ports=3128 chain=dstnat

if you are using 2.8.X do a DST-NAT rule as you did it -->

add in-interface=ether1 protocol=tcp \
dst-address=!192.168.0.2/32:80 action=redirect to-dst-port=8080

BUT WATCH OUT YOU ARE REDIRECTING TO PORT 8080 AND YOR WEB-PROXY IS RUNNING IN PORT 3128 !!!!!!


Hope this help...

Best

Jorge
 
proweb
newbie
Topic Author
Posts: 48
Joined: Sat Oct 08, 2005 10:04 pm

Re: try this

Thu Oct 13, 2005 1:32 am

Thanks man
Last edited by proweb on Mon Oct 17, 2005 11:56 pm, edited 1 time in total.
 
proweb
newbie
Topic Author
Posts: 48
Joined: Sat Oct 08, 2005 10:04 pm

Thu Oct 13, 2005 2:37 am

I want to like this bagan


Internet ---> [Ip Public]Mikrotik[Ip Local] ----> Clients
[Proxy Transparant-Bandwitdh Limitting]

I set My computer :
Image

How bout MT 2.8.6 to built MRTG?? Please helpp me
Last edited by proweb on Mon Oct 17, 2005 11:56 pm, edited 2 times in total.
 
proweb
newbie
Topic Author
Posts: 48
Joined: Sat Oct 08, 2005 10:04 pm

[REQ]Please Help Me...to setup Web-Proxy Transparant

Thu Oct 13, 2005 2:38 am

Still strezzz
Last edited by proweb on Mon Oct 17, 2005 11:57 pm, edited 2 times in total.
 
boardman
Member Candidate
Member Candidate
Posts: 260
Joined: Fri May 28, 2004 11:10 pm
Location: Mexico
Contact:

mmmm

Thu Oct 13, 2005 3:10 am

Ok, I guess I am starting to understand what you want......

You want to block porno-offensive sites and also display a deny page....

Ok I did that once, but I left it aside because those test were made at the time when mikrotik was version 2.X and I was unable to properly control the bandwidth .... but anyway here is what you need.

You need a linux box with fedora or redhat or the flavor you like most.....

In that box configure the following:

- Firewall
- Squid
- Dansguardian

The idea is this can be little offset has been a long time since then...., in your mikrotik activate parent proxy and point that to the ip of your linux box, ...

Your linux box will proxy thru squid(webcache) and dansguardian(filter).... there is a lot of info in the web for this matter. And probably you can also add clamantivirus to your filtering deployment.......

By the way... be carefull the "engine" of your linux box has to be capable of handling all that work...... Lots of RAM and fast harddrive....!!!

Best

Jorge Boardman
http://www.laredonet.com
http://www.laredonet.net
http://www.boardman.com.mx
http://www.autophone.net

Who is online

Users browsing this forum: McSee, mktkRB, MSN [Bot], SiB and 137 guests