Community discussions

MUM Europe 2020
 
Nutcracker
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 66
Joined: Mon Jun 04, 2007 5:03 pm

RB's freezing on 4.16 upgrades

Wed Feb 16, 2011 1:06 pm

Hi folks

Just want to find out if any of you have been experiencing routerboards freezing when upgrading them to RouterOS 4.16? We have had 2 x RB493AH, 1 x RB450G and 1 x RB600A freeze after the upgrade.

To do the upgrade we run this script:
/system scheduler
add comment="" disabled=no interval=0s name=upgrade1 on-event="/system routerboard upgrade" policy=reboot,read,write,policy,test,password,sniff,sensitive start-date=feb/03/2011 \
    start-time=04:17:00
add comment="" disabled=no interval=0s name=reboot2 on-event="/system reboot" policy=reboot,read,write,policy,test,password,sniff,sensitive start-date=feb/03/2011 start-time=\
    04:20:00
add comment="" disabled=no interval=0s name=reboot1 on-event="/system reboot" policy=reboot,read,write,policy,test,password,sniff,sensitive start-date=feb/03/2011 start-time=\
    04:00:00
add comment="" disabled=no interval=0s name=remove1 on-event=remove1 policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive start-date=feb/03/2011 start-time=\
    04:40:00
..
/system script
add name=remove1 policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="/system scheduler remove reboot1\r\
    \n/system scheduler remove reboot2\r\
    \n/system scheduler remove upgrade1\r\
    \n/system scheduler remove remove1\r\
    \n/system script remove remove1"
From what we can tell, it does the RouterOS upgrade fine, but then it crashes/freezes on the firmware upgrade.

Any info would be appreciated.
 
User avatar
Ibersystems
Forum Guru
Forum Guru
Posts: 1684
Joined: Wed Apr 12, 2006 12:29 am
Location: Cabrils, Barcelona - Spain
Contact:

Re: RB's freezing on 4.16 upgrades

Thu Feb 17, 2011 11:53 pm

+1.

We have same problems. You reboot the board directly from power supply and solved. Its a hard problem with remote RBs x(
Martín
martinruiz at ibersystems.es
Experto en redes WiFi y enlaces WiFi.

Facebook: @Ibersystems
Twitter: @Ibersystems

Certified in Traffic Shaping, Wireless, Internetworking, Routing and User Management.
MTCTCE - MTCWE - MTCINE - MTCUME - MTCRE
 
User avatar
nest
Forum Veteran
Forum Veteran
Posts: 817
Joined: Tue Feb 27, 2007 1:52 am
Location: UK
Contact:

Re: RB's freezing on 4.16 upgrades

Fri Feb 18, 2011 1:46 am

But doesn't the script hang waiting for someone to press "y" for the upgrade command?

Or does ROS, when running this command via a script automatically know to bypass the [y/n] prompt?
Ron Touw - Mikrotik Certified Trainer
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/category/166
Largest Official UK MikroTik Distributor
IRC channel: #routerboard on irc.z.je (IPv4), 6.irc.z.je (IPv6)
 
hopp
just joined
Posts: 6
Joined: Thu Sep 03, 2009 5:39 pm

Re: RB's freezing on 4.16 upgrades

Fri Feb 18, 2011 11:17 pm

I had a 493AH hang up like this on a winbox Downgrade from 5.0rc9 to 4.16. I heard the router reboot but it didn't respond to any network traffic. When I tok a look at it, every other switch light was on whether there was a physical link or an empty port. A manual power cycle fixed it.
 
Nutcracker
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 66
Joined: Mon Jun 04, 2007 5:03 pm

Re: RB's freezing on 4.16 upgrades

Tue Feb 22, 2011 8:15 am

But doesn't the script hang waiting for someone to press "y" for the upgrade command?

Or does ROS, when running this command via a script automatically know to bypass the [y/n] prompt?
RouterOS automatically bypasses the [y/n] prompt.
Its good(for me, bad for you) to hear that other people are also experiencing the same problem. I just wish MT would help in some way other than asking for a serial terminal cable to be plugged in during the outage.

Who is online

Users browsing this forum: akosikazim, MSN [Bot], najmul92 and 101 guests