Page 1 of 1

Routing Problem with Routing Marks

Posted: Thu Feb 17, 2011 5:26 pm
by dominicbatty
Hi, could someone tell me if I am missing something.

2 internet links on an RB493G router (both PPPoE if it makes any difference), link 1 is the default gateway for the router. i.e. using link1 as the gateway.
Incoming L2TP IPSEC connections coming in through link1 work fine and connect with no problems

Now I want to get the IPSEC VPN traffic coming into the router on link2 but still leave the default gateway for the router as link1 so I have created another route on the router as with routing-mark=link2 using gateway link2.

I have taken a single incoming IPSEC clients with IP address and set that client to connect to the IP address of link2 instead of link1.

In order to ensure inbound traffic from link2 is sent back out of link2 I have tried adding a mangle rule that traps all traffic with destination IP (not ideal but serves to test this) and adds routing-mark=link2 to it to force it to use the other route when a routing decision is made. I have tried this in both the OUTPUT and PRE-ROUTING chains but traffic is still trying to use the default route as though the routing-mark I have set in the mangle rule has had no effect in the routing decision.

I'd be really grateful if anyone can shed some light on this for me, I suspect I've got the wrong end of the stick here?

Thanks, Dominic.

Re: Routing Problem with Routing Marks

Posted: Mon Feb 21, 2011 10:30 am
by dominicbatty
Just for information, whatever was causing this problem was still apparent in v5.0rc9 but has been solved with v5.0rc10

Cheers, Dom.