Community discussions

MUM Europe 2020
 
rini
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 76
Joined: Wed Sep 22, 2010 1:28 am

PCC PROBLEM

Fri Apr 01, 2011 11:16 pm

hi there
I have 5xDSL lines

conn1 5 Mbps
conn2 5 Mbps
conn3 3.5 Mbps
conn4 3.5 Mbps
conn5 2.5 Mbps

I see a problem that all of 5 dsl lines get the same traffic

/ip firewall mangle export

add action=accept chain=prerouting comment="" disabled=no dst-address=\
192.168.1.0/24 in-interface=LAN
add action=accept chain=prerouting comment="" disabled=no dst-address=\
192.168.2.0/24 in-interface=LAN
add action=accept chain=prerouting comment="" disabled=no dst-address=\
192.168.3.0/24 in-interface=LAN
add action=accept chain=prerouting comment="" disabled=no dst-address=\
192.168.4.0/24 in-interface=LAN
add action=accept chain=prerouting comment="" disabled=no dst-address=\
192.168.5.0/24 in-interface=LAN
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark \
disabled=no in-interface=ISP1 new-connection-mark=conn1 passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark \
disabled=no in-interface=ISP2 new-connection-mark=conn2 passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark \
disabled=no in-interface=ISP3 new-connection-mark=conn3 passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark \
disabled=no in-interface=ISP4 new-connection-mark=conn4 passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark \
disabled=no in-interface=ISP5 new-connection-mark=conn5 passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark \
disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=\
conn1 passthrough=yes per-connection-classifier=both-addresses:5/0
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark \
disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=\
conn2 passthrough=yes per-connection-classifier=both-addresses:5/1
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark \
disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=\
conn3 passthrough=yes per-connection-classifier=both-addresses:5/2
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark \
disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=\
conn4 passthrough=yes per-connection-classifier=both-addresses:5/3
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark \
disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=\
conn5 passthrough=yes per-connection-classifier=both-addresses:5/4
add action=mark-routing chain=prerouting comment="" connection-mark=conn1 \
disabled=no in-interface=LAN new-routing-mark=to_conn1 passthrough=\
yes
add action=mark-routing chain=prerouting comment="" connection-mark=conn2 \
disabled=no in-interface=LAN new-routing-mark=to_conn2 passthrough=\
yes
add action=mark-routing chain=prerouting comment="" connection-mark=conn3 \
disabled=no in-interface=LAN new-routing-mark=to_conn3 passthrough=\
yes
add action=mark-routing chain=prerouting comment="" connection-mark=conn4 \
disabled=no in-interface=LAN new-routing-mark=to_conn4 passthrough=\
yes
add action=mark-routing chain=prerouting comment="" connection-mark=conn5 \
disabled=no in-interface=LAN new-routing-mark=to_conn5 passthrough=\
yes
add action=mark-routing chain=output comment="" connection-mark=conn1 \
disabled=no new-routing-mark=to_conn1 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=conn2 \
disabled=no new-routing-mark=to_conn2 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=conn3 \
disabled=no new-routing-mark=to_conn3 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=conn4 \
disabled=no new-routing-mark=to_conn4 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=conn5 \
disabled=no new-routing-mark=to_conn5 passthrough=yes



I know that my problem is to per connection classifier denominator/remainder

please tell me what should i put to this denominator/reminder for the 5 dsl lines i have
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: PCC PROBLEM

Fri Apr 01, 2011 11:23 pm

For a completely even split, the smallest common denominator is 0.5 - 10 lines for 5 meg, 7 lines for 3.5 meg, 5 lines for 2.5 meg. That doesn't scale well as that results in 39 lines total.

I would think it better to live with 2.5 meg splits, which will leave your 3.5 meg lines slightly underutilized:
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn1 passthrough=yes per-connection-classifier=both-addresses:7/0
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn1 passthrough=yes per-connection-classifier=both-addresses:7/1
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn2 passthrough=yes per-connection-classifier=both-addresses:7/2
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn2 passthrough=yes per-connection-classifier=both-addresses:7/3
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn3 passthrough=yes per-connection-classifier=both-addresses:7/4
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn4 passthrough=yes per-connection-classifier=both-addresses:7/5
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn5 passthrough=yes per-connection-classifier=both-addresses:7/6
For reference, the 39 lines would be:
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn1 passthrough=yes per-connection-classifier=both-addresses:39/0
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn1 passthrough=yes per-connection-classifier=both-addresses:39/1
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn1 passthrough=yes per-connection-classifier=both-addresses:39/2
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn1 passthrough=yes per-connection-classifier=both-addresses:39/3
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn1 passthrough=yes per-connection-classifier=both-addresses:39/4
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn1 passthrough=yes per-connection-classifier=both-addresses:39/5
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn1 passthrough=yes per-connection-classifier=both-addresses:39/6
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn1 passthrough=yes per-connection-classifier=both-addresses:39/7
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn1 passthrough=yes per-connection-classifier=both-addresses:39/8
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn1 passthrough=yes per-connection-classifier=both-addresses:39/9

add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn2 passthrough=yes per-connection-classifier=both-addresses:39/10
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn2 passthrough=yes per-connection-classifier=both-addresses:39/11
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn2 passthrough=yes per-connection-classifier=both-addresses:39/12
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn2 passthrough=yes per-connection-classifier=both-addresses:39/13
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn2 passthrough=yes per-connection-classifier=both-addresses:39/14
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn2 passthrough=yes per-connection-classifier=both-addresses:39/15
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn2 passthrough=yes per-connection-classifier=both-addresses:39/16
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn2 passthrough=yes per-connection-classifier=both-addresses:39/17
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn2 passthrough=yes per-connection-classifier=both-addresses:39/18
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn2 passthrough=yes per-connection-classifier=both-addresses:39/19

add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn3 passthrough=yes per-connection-classifier=both-addresses:39/20
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn3 passthrough=yes per-connection-classifier=both-addresses:39/21
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn3 passthrough=yes per-connection-classifier=both-addresses:39/22
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn3 passthrough=yes per-connection-classifier=both-addresses:39/23
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn3 passthrough=yes per-connection-classifier=both-addresses:39/24
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn3 passthrough=yes per-connection-classifier=both-addresses:39/25
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn3 passthrough=yes per-connection-classifier=both-addresses:39/26

add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn4 passthrough=yes per-connection-classifier=both-addresses:39/27
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn4 passthrough=yes per-connection-classifier=both-addresses:39/28
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn4 passthrough=yes per-connection-classifier=both-addresses:39/29
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn4 passthrough=yes per-connection-classifier=both-addresses:39/30
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn4 passthrough=yes per-connection-classifier=both-addresses:39/31
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn4 passthrough=yes per-connection-classifier=both-addresses:39/32
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn4 passthrough=yes per-connection-classifier=both-addresses:39/33

add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn5 passthrough=yes per-connection-classifier=both-addresses:39/34
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn5 passthrough=yes per-connection-classifier=both-addresses:39/35
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn5 passthrough=yes per-connection-classifier=both-addresses:39/36
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn5 passthrough=yes per-connection-classifier=both-addresses:39/37
add action=mark-connection chain=prerouting comment="" connection-mark=no-mark disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=conn5 passthrough=yes per-connection-classifier=both-addresses:39/38
But again: I wouldn't use that.

On a sidenote, I hope this makes it clear how to derive those values. This is basic math, it's very, very simple. You're trying to find the smallest number that that 5, 3.5 and 2.5 cleanly divide by. That is 0.5. Then you need 5/0.5 = 10 lines for 5 meg pipes, 3.5/0.5 = 7 lines for 3.5 meg pipes, etc.

In your case that results in too many lines of configuration for packets to have to traverse, so it's better to find a closer value that doesn't completely fairly spread traffic, but results in less configuration. That value is 2.5 - it's a clean division for 5 and 2.5, and 3.5 is a pretty close match for a factor of 1.
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.
 
rini
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 76
Joined: Wed Sep 22, 2010 1:28 am

Re: PCC PROBLEM

Fri Apr 01, 2011 11:31 pm

fewi i hope for you to respond

i understand this
please kindly tell me what is the best configuration for me?
you write a lot of rules here.
please please help me

if i make the all 5 lines 3.5mb what configuration can i put ?
 
rini
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 76
Joined: Wed Sep 22, 2010 1:28 am

Re: PCC PROBLEM

Fri Apr 01, 2011 11:38 pm

I understand now
very very thanks fewi

Who is online

Users browsing this forum: pooyatavan and 140 guests