Community discussions

MUM Europe 2020
 
User avatar
zervan
Member
Member
Topic Author
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

graphs deleted after reboot on v.5.0 / slow NTP sync

Thu Apr 07, 2011 10:33 pm

I am using graphing set to store data on disk. After upgrade RouterOS to v.5.0, graphs are deleted 5 minutes after reboot (using RB750G and RB433). Maybe the problem is that clock is still not synchronized after 5 minutes (it takes 5 minutes and 20 seconds to synchronize using NTP Client and package ntp). So that 5 minutes after rebooting, system is generating graphs with clock set to year 2002 and probably deleting previously saved graphs from year 2011.

Is it a bug? I didn't have any problems with graphs on v.4.xx.
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
parsiansystem
just joined
Posts: 15
Joined: Thu Apr 07, 2011 5:11 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Fri Apr 08, 2011 9:21 am

no it isn't a bug!
your job is ok
but you can change the timr of updating the graphs in "graphs".
after any restarting.
you lost the previous graphs!
it is the rule of routers
good luck
Babak Mohammadpour
Manager of Technisions in ISP's
http://www.parsianet.com
 
User avatar
zervan
Member
Member
Topic Author
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Fri Apr 08, 2011 9:31 am

but you can change the timr of updating the graphs in "graphs".
I know only setting how often graphs are saved to disk (1 hour or 5 minutes). Where can I change time of updating graphs?
after any restarting. you lost the previous graphs! it is the rule of routers
I've restarted routerOS v.4.xx many times and graphs were not lost (at most only last hour) - that's because data were saved to disk every hour.
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
arpadffy
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon Jan 17, 2011 1:52 am
Location: Stockholm, Sweden
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Fri Apr 08, 2011 4:13 pm

but you can change the timr of updating the graphs in "graphs".
I know only setting how often graphs are saved to disk (1 hour or 5 minutes). Where can I change time of updating graphs?
after any restarting. you lost the previous graphs! it is the rule of routers
I've restarted routerOS v.4.xx many times and graphs were not lost (at most only last hour) - that's because data were saved to disk every hour.
I just run into the same problem. The graphs disappeared.

print the values
[admin@MikroTik] > tool graphing print
   store-every: 5min
  page-refresh: 300
set store-every
[admin@MikroTik] > tool graphing set store-every=

StoreEvery ::= 24hours | 5min | hour

[admin@MikroTik] > tool graphing set store-every=5min
Please note I have set store-on-disk=yes for each resource/interface
[admin@MikroTik] > tool graphing interface print detail
Flags: X - disabled
 0   interface=all allow-address=0.0.0.0/0 store-on-disk=yes
From other side my NTP is fast and router has correct time right after the boot...
Regardless the old graphs are up for some 5 minutes (I guess StoreEvery time) and then they are overwritten instead of updated.

It would be very nice to have this graph continuous.

Regards,
Z
 
User avatar
zervan
Member
Member
Topic Author
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Fri Apr 08, 2011 10:58 pm

Problem still remains in v.5.1
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
parsiansystem
just joined
Posts: 15
Joined: Thu Apr 07, 2011 5:11 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Sat Apr 09, 2011 11:49 am

plz see the picture
You do not have the required permissions to view the files attached to this post.
Babak Mohammadpour
Manager of Technisions in ISP's
http://www.parsianet.com
 
User avatar
zervan
Member
Member
Topic Author
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Sun Apr 10, 2011 9:22 am

plz see the picture
Yes, this allows to set the frequency of storing data to disk. I'm using 5 minutes on some routers and 1 hour on some other - but all of them delete data after reboot in RouterOS v. 5.0 and 5.1. That's the problem (and was not a problem in v. 4.x).
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
tiggda
newbie
Posts: 29
Joined: Fri Mar 04, 2011 11:07 am

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Wed Apr 20, 2011 4:21 pm

I also suffer from disappearing graphs ;-) Should we file a bug report? I'm running RouterOS 5.1.


Edit:
Once the graphs lasted after reboot, but only once. Since i did more than one reboot i'm not satisfied with the results...
 
tiggda
newbie
Posts: 29
Joined: Fri Mar 04, 2011 11:07 am

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Thu Apr 21, 2011 11:03 am

It really looks like NTP synchronization problems and data gets overwritten. Does anyone tested if changing store time to 1hr fixes the problem? NTP should be synced by that time...
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8321
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Thu Apr 21, 2011 11:32 am

seems like ROS should simply check whether current time is in the past compared to last graphs update. MT Staff?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
arpadffy
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon Jan 17, 2011 1:52 am
Location: Stockholm, Sweden
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Thu Apr 21, 2011 3:15 pm

Hello,

I do not thing that this issue has anything to do with NTP sync.
My RB450G on 5.1 gets the correct time in few seconds - regardless the graphs last some 5 minutes after the reboot (I do have store-every=5min) and then they are re-setted.

Reagrds,
Z
 
tiggda
newbie
Posts: 29
Joined: Fri Mar 04, 2011 11:07 am

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Wed Apr 27, 2011 10:43 pm

Well, I did some tests with synchronizing NTP as fast as possible and the graphs stayed after reboot in 6 out of 12 tests. It looks like a random "feature".
 
arpadffy
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon Jan 17, 2011 1:52 am
Location: Stockholm, Sweden
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Thu Apr 28, 2011 10:41 am

Hello,

unfortunately v5.2 does not solve this issue :(

Regards,
Z
 
tiggda
newbie
Posts: 29
Joined: Fri Mar 04, 2011 11:07 am

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Sat May 28, 2011 7:15 pm

Anyone tried the new 5.4 and graphs? Do they still disappear?
 
User avatar
elgo
Member Candidate
Member Candidate
Posts: 151
Joined: Sat Apr 02, 2011 2:34 am
Location: France

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Mon Jun 06, 2011 7:11 pm

Anyone tried the new 5.4 and graphs? Do they still disappear?
I recently updated from v4.17 to v5.4 and still graphs resetted after each reboot of my 450G (NTP servers on internet, need pppoe interface to come up first).
RB450G - OpenWrt (so much more stable than with routerOS)
-> now: UBNT EdgeRouter Lite

(very unlikely to be MT customer again in the future)
 
User avatar
zervan
Member
Member
Topic Author
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Thu Jun 30, 2011 12:01 am

Problem remains in 5.5 as well :(

It seems that it is appearing only if the NTP package is installed - couold you confirm this idea?
I have uninstalled NTP package on some routers and they are remembering graphs after reboot now. But I don't want to uninstall the package because I'd like to have an internal NTP time server.
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8321
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Thu Jun 30, 2011 3:29 pm

AFAIR, SNTP client synchronizes much faster than NTP client...
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
DBob
Frequent Visitor
Frequent Visitor
Posts: 79
Joined: Fri Jun 10, 2011 4:13 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Tue Jul 05, 2011 10:31 pm

Has anyone reported this bug/"feature" already?
 
User avatar
zervan
Member
Member
Topic Author
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Tue Jul 05, 2011 10:42 pm

Has anyone reported this bug/"feature" already?
Probably not.
Let's make sure that this problem is appearing only if the NTP package is installed - reporting this fact would probably help to fix the problem.
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
User avatar
zervan
Member
Member
Topic Author
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Mon Jul 11, 2011 8:56 am

If you do need NTP Server and you have to disable package NTP, you may use this workaround:
/ip firewall nat add action=dst-nat chain=dstnat comment="redirecting NTP" disabled=no dst-address-type=local dst-port=123 protocol=udp to-addresses=217.73.16.2
(where 217.73.16.2 is NTP server, you should use your favorite one)

If you would like to have exactly the same NTP server for the router and for clients as well, you may use scrpt like that:
:local ntp [:resolve sk.pool.ntp.org]
/system ntp client
set primary-ntp=$ntp
set secondary-ntp=$ntp
/ip firewall nat set to-address=$ntp [find comment="redirecting NTP"]
(where sk.pool.ntp.org is NTP server, you sholud use your favorite one)

I have scheduled this script to run every morning.
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Mon Jul 11, 2011 3:45 pm

how slow is NTP synchronization? I have tried on several routers and sync times are quite good (against router running RouterOS with synced time)
 
TKITFrank
Member Candidate
Member Candidate
Posts: 236
Joined: Tue Jul 07, 2009 2:55 pm
Location: Sweden

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Mon Jul 11, 2011 3:52 pm

I have ROS 5.5 with ntp packet installed and it takes about 5-7min for the timesync to complete.
I am going to the ip of ntp1.sp.se and ntp2.sp.se (62.119.40.98 and 193.10.7.246)

This was fast on ROS 4.xx seems to be something with ROS 5
[xxxxxxx@hades.xxxxxxx.org] /system ntp> export 
# jul/11/2011 14:50:23 by RouterOS 5.5
# software id = xxxx-xxxx
#
/system ntp client
set enabled=yes mode=unicast primary-ntp=62.119.40.98 secondary-ntp=\
    193.10.7.246
/system ntp server
set broadcast=no enabled=yes manycast=no multicast=no
MTCNA

"I don't believe UNIX is Utopia. It's just the best set of tools around."
 
User avatar
elgo
Member Candidate
Member Candidate
Posts: 151
Joined: Sat Apr 02, 2011 2:34 am
Location: France

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Tue Jul 12, 2011 11:21 am

Is it sure it's a ntp "slowlyness" related problem? I mean, NTP, ok, but for what I've seen, graphes are deleted right when NTP sync occurs...
(NTP package installed)
RB450G - OpenWrt (so much more stable than with routerOS)
-> now: UBNT EdgeRouter Lite

(very unlikely to be MT customer again in the future)
 
User avatar
zervan
Member
Member
Topic Author
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Wed Jul 13, 2011 7:07 pm

Is it sure it's a ntp "slowlyness" related problem? I mean, NTP, ok, but for what I've seen, graphes are deleted right when NTP sync occurs...
(NTP package installed)
I have new RB1200, so I tried some things. I've installed NTP package. After reboot clock shows Jan/01/2002 and it takes 5 minutes 15 seconds to synchronize time with external time server (from ntp.org). Once the time is synchronized, every next synchronization takes only few (6) seconds (also after NTP server change) so only the first synchronization makes problems and is too slow. Graphs are deleted after each reboot.

Then I tried to set local NTP server (RB750G). I thought that time synchronization will be faster, but it was not so there is no difference.

So I decided to set time manually after reboot - graphs were remained. Time synchronization was finished later, but graphs were still there.

Final word: Yes, it is NTP package "slowlyness" related problem. First graphs are generated 5 minutes after system reboot and if system date is still unsychronized Jan/01/2002 (as it is every time NTP package is installed due to its slowlyness), previous graphs are deleted.

I think I may report it to Mikrotik support now.
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
User avatar
zervan
Member
Member
Topic Author
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Wed Jul 20, 2011 12:40 am

Support says: "This problem is detected and will be fixed in future releases." :)
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
User avatar
zervan
Member
Member
Topic Author
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Thu Sep 15, 2011 4:29 pm

Problem still remains in 5.7
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
DBob
Frequent Visitor
Frequent Visitor
Posts: 79
Joined: Fri Jun 10, 2011 4:13 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Fri Sep 16, 2011 10:05 am

Problem still remains in 5.7
That's sad, because thats the only reason for me to upgrade from 5.4 @ RB450G :(
 
tjc
Member Candidate
Member Candidate
Posts: 279
Joined: Sun Jul 10, 2011 3:08 am

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Sat Sep 17, 2011 5:21 am

I got bit by this again last night after rebooting to upgrade to 5.7, despite setting the "update to disk interval" to an hour so the NTP client would have time to sync.

As a software guy, Chupaka's suggestion makes a lot of sense, if you know that the current time is bogus, and the file date is far in the future, don't scribble over the top of it.
 
mm690
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Sat Aug 21, 2010 8:38 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Mon Nov 21, 2011 6:26 am

Does this problem still persist in 5.8? Do graphs still disappear after reboot?
 
tjc
Member Candidate
Member Candidate
Posts: 279
Joined: Sun Jul 10, 2011 3:08 am

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Mon Nov 21, 2011 7:06 pm

Yes.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Tue Nov 22, 2011 9:06 am

as a workaround add scheduled script on the router with delay depending on how fast your router is:
:delay 15;
/system ntp client set enabled=no;
/system ntp client set enabled=yes;
 
User avatar
elgo
Member Candidate
Member Candidate
Posts: 151
Joined: Sat Apr 02, 2011 2:34 am
Location: France

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Wed Nov 30, 2011 12:10 pm

What's new in 5.9 (2011-Nov-29 14:32):

*) ntp client - faster initial synchronization;
Sooooo, anyone who upgraded to report if graphs issue is finally resolved?
RB450G - OpenWrt (so much more stable than with routerOS)
-> now: UBNT EdgeRouter Lite

(very unlikely to be MT customer again in the future)
 
User avatar
zervan
Member
Member
Topic Author
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Wed Nov 30, 2011 2:03 pm

Sooooo, anyone who upgraded to report if graphs issue is finally resolved?
Yes, it seems it is working now - finally! :)
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
tjc
Member Candidate
Member Candidate
Posts: 279
Joined: Sun Jul 10, 2011 3:08 am

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Mon Dec 05, 2011 1:16 am

Same here. With the NTP sync improvement in 5.9 my graphs have now survived multiple reboots. :)
 
User avatar
m4rk0
Member Candidate
Member Candidate
Posts: 195
Joined: Sat Feb 16, 2008 8:30 pm
Location: BA

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Sat Jan 07, 2012 12:54 pm

Hello,

I have RB1000 and ROS 5.11, but after power loss I lost my graphs :?
How to save graphs?? Why ROS doesn't save graphs on internal memory or CF card??
http://www.mreza-wisp.ba/
Please, give Karma if I fix your problem
Certified MTCNA
 
tjc
Member Candidate
Member Candidate
Posts: 279
Joined: Sun Jul 10, 2011 3:08 am

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Sat Jan 07, 2012 8:00 pm

Do this:
/tool graphing export
Check the top level "store-every=" value. Typically 5 minutes or 1 hour.
For each graphing category check for "store-on-disk=yes"

For example:
[admin@MikroTik] /tool graphing> /tool graphing export
# jan/07/2012 12:56:49 by RouterOS 5.9
# software id = 1BS6-EST0
#
/tool graphing
set page-refresh=300 store-every=hour
/tool graphing interface
add allow-address=192.168.1.0/24 disabled=no interface=all store-on-disk=yes
/tool graphing resource
add allow-address=192.168.1.0/24 disabled=no store-on-disk=yes
 
User avatar
m4rk0
Member Candidate
Member Candidate
Posts: 195
Joined: Sat Feb 16, 2008 8:30 pm
Location: BA

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Sun Jan 08, 2012 1:51 pm

Do this:
/tool graphing export
Check the top level "store-every=" value. Typically 5 minutes or 1 hour.
For each graphing category check for "store-on-disk=yes"
Hello,
It's already set to store-on-disk, but this problem is why this doesn't always happen...
store-every: 5min
  page-refresh: 300
http://www.mreza-wisp.ba/
Please, give Karma if I fix your problem
Certified MTCNA
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Thu Jan 12, 2012 11:38 am

is NTP set up, so that router has correct time? After reboot, router is in year 1970 and gathered data is overwritten since it has same time as entries already saved.
 
User avatar
delix
just joined
Posts: 15
Joined: Mon Aug 06, 2012 12:09 am
Location: Simferopol, Ukraine

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Mon Aug 06, 2012 12:29 am

Hi all!
Pls help me with issue! ROs 5.18.
I need a script which would copy current (synchronized) time/date to default time/date on flash, that after reboot or power loss I have last right time. It saves my old graphs(all graphs before default time/date) from overwrite befor next ntp-synchronization.
I know that device could be off for an hour or even more and there would be some blanks after synchronization... Anyway it's better than lose all graphs.
 
iwantcomputer
just joined
Posts: 2
Joined: Fri May 03, 2013 2:47 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Wed May 08, 2013 6:42 am

I got a RB951G-2HnD with ROS 5.25 , and this problem happens randomly, and I set the ntp client always, but today I found that the graphing data has gone , it just never happened before.

maybe this is the problem of ntp sync , but I think ros can just set a option about deleting graphcs only after ntp sync is finished :?
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Mon Jul 29, 2013 5:53 pm

I have RB2011 with ROS 6.1. This problem occurs everytime I restart it. All graphs are lost.
I have NTP package installed and activated.
Correct time is set about 20 seconds after power on. So definitely no delay in time setting could cause this error.
Of course, the saving graphs to disk every 5 minutes is set correctly (I also tried 1 hour - no effect).

I also have running ntp client off / on few seconds after reboot with no effect.

How I can be sure that graphs saving is done?
How can I force graphs saving on my own (e.g. by script or by command)?

What is the final solution from Mikrotik company for this? I cannot believe that for years repeatedly reported problem, moreover that looks like really easy-to-be-solved bug, is stil unsolved.

Addendum: Deactivating NTP package did not help.
 
weheartwebsites
just joined
Posts: 1
Joined: Tue Jul 30, 2013 6:00 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Tue Jul 30, 2013 6:02 pm

still having the issue on RouterOS 6.1 Deactivating NTP is not an option.
 
hugleo
newbie
Posts: 32
Joined: Wed Aug 06, 2008 8:20 am

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Mon Aug 12, 2013 3:42 pm

The problem was solved in 6.0rc13 version but the problem goes back in later versions. At least in the 6.1 version is not working anymore.

What's new in 6.0rc13 (2013-Apr-08 14:25):

*) pppoe, l2tp, pptp server - increased lcp retransmit count to 10;
*) pptp, l2tp & pppoe clients - added ability to specify keepalive timeout;
*) graphing - fixed problem were interface graphs are lost on reboot;
*) dhcpv6 - added relay;
*) sstp server - restore (disabled in rc12) test mode which allows
running server without certificate;
*) lcd - added option for turning backlight on/off;
*) bgp - fix med comparison check if routes are received from iBGP peer;
*) fixed simple queues - sometimes some simple queues did not limit traffic
(bug introduced in 6.0rc12);
*) allow to change arp timeout (in /ip settings);
*) added /ip neighbor discovery settings setting "default-for-dynamic" to control
discovery on new dynamic interfaces (off by default);
 
Semir
newbie
Posts: 37
Joined: Tue Aug 20, 2013 6:29 am

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Sun Sep 01, 2013 3:14 am

Appeared again in 6.2
 
User avatar
zervan
Member
Member
Topic Author
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Tue Sep 03, 2013 10:25 am

Appeared again in 6.2
Yes - interface graphs are lost on various RB models, but CPU, HDD and memory graphs remain. It seems to be a new bug, not the same as it was long time ago. Nevertheless, it is said that once fixed bug it is appearing still again in the other forms.

Mikrotik stuff: please check graphing functions in each new version - interface graphs are very usefull.
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Tue Sep 03, 2013 2:56 pm

we are working on the issue.
 
HWTest
newbie
Posts: 40
Joined: Tue Apr 17, 2007 7:20 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Mon Sep 16, 2013 8:51 pm

There are still problems with interface graphs in ROS 6.4 on my RB533.

Graphs for LAN1 LAN2 and WAN interfaces survive a reboot, but graphs for WLAN, Bridge and VPN interfaces are lost :-(
 
Semir
newbie
Posts: 37
Joined: Tue Aug 20, 2013 6:29 am

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Tue Sep 17, 2013 8:04 am

Hi,

I had this problem on 6.4.
I did no update, but first I disabled all graphs and turned off saving to disk then waited for a reboot. After that I reenabled them and saving to disk and now all my graphs survived the last reboot. (However, I only use interface and resource graphs.)

Bests,
Semir
 
krg
just joined
Posts: 3
Joined: Sun Dec 22, 2013 10:21 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Mon Jan 20, 2014 9:28 am

first I disabled all graphs and turned off saving to disk then waited for a reboot. After that I reenabled them and saving to disk and now all my graphs survived the last reboot.

This worked for me. Version 6.7, graphing everything I can graph, interfaces, queues, resources. Alas, I had to discover this bug the hard way, losing two months of data.
 
pooyan5
just joined
Posts: 4
Joined: Thu Jan 17, 2013 2:58 pm
Location: Caracas

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Thu Jan 30, 2014 8:51 pm

first I disabled all graphs and turned off saving to disk then waited for a reboot. After that I reenabled them and saving to disk and now all my graphs survived the last reboot.

This worked for me. Version 6.7, graphing everything I can graph, interfaces, queues, resources. Alas, I had to discover this bug the hard way, losing two months of data.
Hi,

Could you please explain what you did???? I faced with the same issue from last night! After upgrading from 6.X to 6.7! All graphing history was deleted!

Thanks you in advance
 
zabullet
just joined
Posts: 7
Joined: Tue Jul 22, 2014 10:38 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Sat Nov 22, 2014 8:39 pm

I still get this behaviour on 6.22.
 
volkirik
just joined
Posts: 7
Joined: Sat Jul 23, 2016 2:03 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Sat Jun 23, 2018 6:52 pm

I still get this behaviour on 6.43rc32 after power-outage.

PPPoE client statistics (graphs) got deleted after power-loss

Graphs of other interfaces , CPU , Memory , Disk usage remains.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5988
Joined: Mon Jun 08, 2015 12:09 pm

Re: graphs deleted after reboot on v.5.0 / slow NTP sync

Sat Jun 23, 2018 8:25 pm

Note that enabling save-to-disk on graphs results in a large number of flash writes and eventual failure.
I switched off all save-to-disk options when noticing this.

Who is online

Users browsing this forum: No registered users and 75 guests