Community discussions

 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

v5.1 hangs in /export

Sat Apr 09, 2011 9:52 pm

Hi,

I have two routerboard. RB433AH and RG450G. Both hangs when I issue the /export or /interface export command:
[admin@RB433AH] > /interface export                                                                                                            
# jan/02/1970 07:36:19 by RouterOS 5.1
# software id = XXXX-XXXX
#
/interface ethernet
set 0 arp=enabled auto-negotiation=yes disabled=no full-duplex=yes l2mtu=1526 mac-address=00:0C:42:2F:8A:8F mtu=1500 name=ether1 speed=\       
    100Mbps                                                                                                                                    
set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=yes full-duplex=yes l2mtu=1522 mac-address=00:0C:42:2F:8A:90 \
    master-port=none mtu=1500 name=ether2 speed=100Mbps                                                                                        
set 2 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=yes full-duplex=yes l2mtu=1522 mac-address=00:0C:42:2F:8A:91 \
    master-port=none mtu=1500 name=ether3 speed=100Mbps                                                                                        
/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes disabled=no forward-delay=15s l2mtu=1526 max-message-age=20s mtu=\     
    1500 name=bridge priority=0x8000 protocol-mode=none transmit-hold-count=6                                                                  
/interface ethernet switch
...hang...
Then I can't login to the routerboard with any method:
$ telnet 192.168.5.2
Trying 192.168.5.2...
Connected to 192.168.5.2.
Escape character is '^]'.

MikroTik v5.1
Login: admin
Password: 








  MMM      MMM       KKK                          TTTTTTTTTTT      KKK
  MMMM    MMMM       KKK                          TTTTTTTTTTT      KKK
  MMM MMMM MMM  III  KKK  KKK  RRRRRR     OOOOOO      TTT     III  KKK  KKK
  MMM  MM  MMM  III  KKKKK     RRR  RRR  OOO  OOO     TTT     III  KKKKK
  MMM      MMM  III  KKK KKK   RRRRRR    OOO  OOO     TTT     III  KKK KKK
  MMM      MMM  III  KKK  KKK  RRR  RRR   OOOOOO      TTT     III  KKK  KKK

  MikroTik RouterOS 5.1 (c) 1999-2011       http://www.mikrotik.com/

...hang...
What happens?
 
ditonet
Forum Veteran
Forum Veteran
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: v5.1 hangs in /export

Sun Apr 10, 2011 11:37 am

Confirmed on my RB433AH
Console process eats up to 100% CPU and make router unresponsible to telnet and SSH.
Only reboot via Winbox helps in this case.

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v5.1 hangs in /export

Mon Apr 11, 2011 11:58 am

For support from Mikrotik staff, write to support@mikrotik.com - Mikrotik does not generally offer support on the forum, this is a user forum.

Please, send us report with your configuration support output file.
I have tried export on my RB433, it works fine for me. So there is specific configuration, which does not work properly on export.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: v5.1 hangs in /export

Mon Apr 11, 2011 11:58 am

please send supout.rif files to support.
 
ditonet
Forum Veteran
Forum Veteran
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: v5.1 hangs in /export

Mon Apr 11, 2011 12:51 pm

I started creation of 'supout.rif' 30 minutes ago and I'm still waiting for finish.
How long this process could be?

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
alexspils
Member Candidate
Member Candidate
Posts: 176
Joined: Thu Jun 05, 2008 8:57 pm

Re: v5.1 hangs in /export

Mon Apr 11, 2011 12:52 pm

do it from telnet
 
ditonet
Forum Veteran
Forum Veteran
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: v5.1 hangs in /export

Mon Apr 11, 2011 1:01 pm

It's ready, after 40 minutes :)

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v5.1 hangs in /export

Mon Apr 11, 2011 1:03 pm

I did it from telnet on my RouterBOARD 433.
Both commands worked without any problems.

export
system sup-output
 
ditonet
Forum Veteran
Forum Veteran
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: v5.1 hangs in /export

Mon Apr 11, 2011 1:33 pm

Maybe this is a relation between these two problems.
During creation of 'supout.rif' file and after finish, 'console' process was 99-100%.
There was need to restart router.

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v5.1 hangs in /export

Mon Apr 11, 2011 1:37 pm

ditonet, yes you are correct.
We need to find out, which piece of configuration causes the particular problem.
 
dataway
just joined
Posts: 3
Joined: Fri Aug 13, 2010 4:22 pm

Re: v5.1 hangs in /export

Mon Apr 11, 2011 7:57 pm

I have the same issue (RB450G), should I also send in the supout.rif?
 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

Re: v5.1 hangs in /export

Mon Apr 11, 2011 10:39 pm

I started the sup-output process for 2 hours. I hope it will finish till I should go to work...
 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

Re: v5.1 hangs in /export

Tue Apr 12, 2011 12:26 am

I started the sup-output process for 2 hours. I hope it will finish till I should go to work...
It's still running...
 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

Re: v5.1 hangs in /export

Tue Apr 12, 2011 11:19 am

I can't generate supout.rif but I will try again today...
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v5.1 hangs in /export

Tue Apr 12, 2011 11:33 am

Not sure if it is related, but RB1100's spike to 100% when generating a supout.rif and do not appear to go down
You do not have the required permissions to view the files attached to this post.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v5.1 hangs in /export

Tue Apr 12, 2011 3:23 pm

oreggin and nz_monkey, please contact support with support output file from the router.
 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

Re: v5.1 hangs in /export

Tue Apr 12, 2011 3:51 pm

oreggin and nz_monkey, please contact support with support output file from the router.
Ok, I will send e-mail to support soon.
 
Solaris
Member Candidate
Member Candidate
Posts: 100
Joined: Thu Apr 29, 2010 5:05 pm

Re: v5.1 hangs in /export

Wed Apr 13, 2011 9:28 am

My 450g also got this problems, support.rif sent.
 
oreggin
Member Candidate
Member Candidate
Topic Author
Posts: 102
Joined: Fri Oct 16, 2009 9:21 pm

Re: v5.1 hangs in /export

Wed Apr 13, 2011 11:02 am

I can't generate supout.rif :(
I was tried over SSH and serial console...
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v5.1 hangs in /export

Wed Apr 13, 2011 11:03 am

Thank you very much for your reports.
We found the problem and working on the fix. It will be fixed in the next RouterOS version.
 
ditonet
Forum Veteran
Forum Veteran
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: v5.1 hangs in /export

Wed Apr 13, 2011 12:06 pm

@sergejs
Thanks for information.

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
Cupholder
just joined
Posts: 6
Joined: Sun Apr 17, 2011 11:46 pm

Re: v5.1 hangs in /export

Sun Apr 17, 2011 11:51 pm

I registered on the forum to report hitting this bug as well on my 750G. Glad that Support was able to reproduce the problem.
 
tanjil
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Sun Jun 06, 2010 11:15 pm

Re: v5.1 hangs in /export

Sat Apr 23, 2011 10:06 pm

cant reboot the Os properly.. it takes 10 or 20 mins time ... after restart the router /sys log Kernel failure....
how to solve this...

i have send the supout file already

thanks
 
Mrvn
just joined
Posts: 5
Joined: Sat Mar 12, 2011 12:16 am

Re: v5.1 hangs in /export

Tue Apr 26, 2011 3:10 pm

I can confirm that on RB750. You can't do /export or support.rif -> router hangs.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24278
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v5.1 hangs in /export

Tue Apr 26, 2011 3:11 pm

it's a known issue confirmed many times here. v5.2 will fix it.
No answer to your question? How to write posts
 
arpadffy
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon Jan 17, 2011 1:52 am
Location: Stockholm, Sweden
Contact:

Re: v5.1 hangs in /export

Tue Apr 26, 2011 3:15 pm

Hello,

do you have any estimation when the 5.2 will be released?
Thank you.

Regards,
Z
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24278
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v5.1 hangs in /export

Tue Apr 26, 2011 3:19 pm

we will try to release it this week, if all known issues will be fixed and tested
No answer to your question? How to write posts
 
tanjil
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Sun Jun 06, 2010 11:15 pm

Re: v5.1 hangs in /export

Fri Apr 29, 2011 3:54 am

same problem occured on 5.2 version .. its not fixed yet

cant reboot the Os properly.. it takes 10 or 20 mins time ... after restart the router /sys log Kernel failure....
how to solve this...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24278
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v5.1 hangs in /export

Fri Apr 29, 2011 7:47 am

same problem occured on 5.2 version .. its not fixed yet

cant reboot the Os properly.. it takes 10 or 20 mins time ... after restart the router /sys log Kernel failure....
how to solve this...
what is not fixed? export works fine now.
No answer to your question? How to write posts

Who is online

Users browsing this forum: Google [Bot] and 69 guests