Community discussions

MikroTik App
 
amigota
just joined
Topic Author
Posts: 10
Joined: Tue Jun 30, 2009 7:38 am

Reply-Message for Mikrotik from freeradius

Thu Apr 28, 2011 7:55 am

Hi all,

I have been trying to get value of Reply-Message attribute from freeRadius when Access-Accept or Access-Reject,
but I can't find any solution yet.
I know where to edit Mikrotik message "errors.txt" in hotspot directory.
That Reply-Message should be appeared in Login page (error), or Status page; therefore, I only get "RADIUS server is not responding" when I login fail or I changed Reply-Message value.

Any help please?

Here is my example message of FR debug:
.......
Sending Access-Accept of id 2 to 10.8.8.8 port 1024
        Acct-Interim-Interval := 60
        Reply-Message := "Message to be taken by Mikrotik"
Finished request 0.
Going to the next request
Waking up in 4.9 seconds.
 
User avatar
MichelePietravalle
Trainer
Trainer
Posts: 99
Joined: Sun Apr 19, 2009 9:03 pm

Re: Reply-Message for Mikrotik from freeradius

Mon Jan 02, 2012 1:42 pm

+1 ....
Variables $error or $error-orig cannot help me :(

i have opened a ticket to Mikrotik Support some minutes ago.
 
amigota
just joined
Topic Author
Posts: 10
Joined: Tue Jun 30, 2009 7:38 am

Re: Reply-Message for Mikrotik from freeradius

Mon Feb 27, 2012 9:53 am

Please help? I have tried to do many times.
 
User avatar
MichelePietravalle
Trainer
Trainer
Posts: 99
Joined: Sun Apr 19, 2009 9:03 pm

Re: Reply-Message for Mikrotik from freeradius

Mon Feb 27, 2012 9:57 am

+1....
 
User avatar
acim
Member
Member
Posts: 424
Joined: Mon Sep 12, 2005 12:26 am
Location: Serbia
Contact:

Re: Reply-Message for Mikrotik from freeradius

Fri Mar 02, 2012 1:24 am

Have you solved this?

Everything worked fine for us while we were using older version of freeradius (comming with Fedora Core 4), but we migrated to freeradius 2.1 I think (on FC11) and we have the same problem with error messages now.

When users type bad username/password they get message "Radius server is not responding". We can see the same message in Mikrotik logs. What is the way to fix this? Some freeradius settings?
 
User avatar
acim
Member
Member
Posts: 424
Joined: Mon Sep 12, 2005 12:26 am
Location: Serbia
Contact:

Re: Reply-Message for Mikrotik from freeradius

Fri Mar 02, 2012 2:04 am

This may be the answer, I'll try it tomorrow:

http://freeradius.org/radiusd/doc/Post-Auth-Type

In /etc/raddb/sites-enabled/default need to add similar to:
post-auth {
   my_sql_accept
   Post-Auth-Type REJECT {
      my_sql_reject
   }
}
 
User avatar
acim
Member
Member
Posts: 424
Joined: Mon Sep 12, 2005 12:26 am
Location: Serbia
Contact:

Re: Reply-Message for Mikrotik from freeradius

Sat Apr 07, 2012 12:32 am

I solved the problem with higher timeout value in /radius setting on Mikrotik.

Who is online

Users browsing this forum: matxanh, maxb, sid5632 and 106 guests