Community discussions

MikroTik App
 
duvi
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 70
Joined: Fri Jun 05, 2009 12:32 pm
Contact:

WARNING upgrade 4.16->5.2

Wed May 04, 2011 4:35 pm

Upgrade for me failed from 4.16 to 5.2 on an RB450G

The switch vlan settings did not get transferred correctly, the CPU port was left out and replaced with unknown.

Settings exported from 4.16:

/interface ethernet switch vlan
add disabled=no ports=cpu,ether3,ether4,ether5 switch=switch1 vlan-id=20
add disabled=no ports=cpu,ether3,ether4,ether5 switch=switch1 vlan-id=21
add disabled=no ports=cpu,ether3,ether4,ether5 switch=switch1 vlan-id=1
add disabled=no ports=cpu,ether3,ether4,ether5 switch=switch1 vlan-id=10


Settings after upgrade to 5.2:

/interface ethernet switch vlan
add disabled=no ports=unknown,ether3,ether4,ether5 switch=switch1 vlan-id=20
add disabled=no ports=unknown,ether3,ether4,ether5 switch=switch1 vlan-id=21
add disabled=no ports=unknown,ether3,ether4,ether5 switch=switch1 vlan-id=1
add disabled=no ports=unknown,ether3,ether4,ether5 switch=switch1 vlan-id=10

So basically the router got unresponsive on all vlans.
 
User avatar
elgo
Member Candidate
Member Candidate
Posts: 151
Joined: Sat Apr 02, 2011 2:34 am
Location: France

Re: WARNING upgrade 4.16->5.2

Thu May 05, 2011 6:43 pm

Mmmmm, I was told this issue would be fixed in v5.1 when I pointed this out there (amongst other things): http://forum.mikrotik.com/viewtopic.php?f=2&t=50538

But I reverted back to 4.17 and never went to 5.x again after that, so I can't really help you :/
RB450G - OpenWrt (so much more stable than with routerOS)
-> now: UBNT EdgeRouter Lite

(very unlikely to be MT customer again in the future)

Who is online

Users browsing this forum: Bing [Bot], DavidHigh, Egert143, MarcDE, Me3do, sindy and 142 guests