Page 1 of 1

How to block MAC Addresses

Posted: Sun May 08, 2011 7:19 pm
by pclay
Am running DHCP in a large Campground. Are not using Hotspot or Usermanager. Is there a way to block the MAC addresses or refuse a DHCP lease?

Re: How to block MAC Addresses

Posted: Tue May 10, 2011 12:11 pm
by imrankosi
you can use mac filltering option


d/t forgot to give karam

Re: How to block MAC Addresses

Posted: Sun May 15, 2011 4:41 am
by pclay
I've been looking around in the manual and don't think I have found the correct area. Can you please point me to the proper area of the manual? Are there any examples?

Thanks

Re: How to block MAC Addresses

Posted: Sun May 15, 2011 6:27 am
by fewi
Are you looking to blacklist (default permit, deny a few specific addresses) or whitelist (default deny, permit a few specific addresses)?

Re: How to block MAC Addresses

Posted: Mon May 16, 2011 12:57 am
by pclay
We need to deny a few stations when they abuse their bandwidth share. This will probably not happen more than once a week during the summer only.

Thanks

Re: How to block MAC Addresses

Posted: Mon May 16, 2011 1:09 am
by fewi
/ip firewall filter
add chain=forward src-mac-address=aa:bb:cc:dd:ee:ff action=drop

Re: How to block MAC Addresses

Posted: Fri May 20, 2011 5:33 pm
by pclay
Thanks much, we will try this soon

Re: How to block MAC Addresses

Posted: Fri Jul 15, 2011 8:43 am
by Mashimoto
Is there a way to block MAC from getting dhcp lease?

I have this one MAC address that's filling up my log b/c it can't get the lease with success...

I tried the above, but dchp still trying to give out lease...

Re: How to block MAC Addresses

Posted: Mon Jul 18, 2011 11:05 pm
by Mashimoto
SOLVED. Tried the filter rules, but none worked for me.

Not sure how to do code so someone else can translate if they like but here's what worked for me:

IP --> DHCP Server --> Leases --> Add new --> General="Pool_Name", MAC Address="MAC address of desired blocked", Server="Name of DHCP Server failing", Block access = yes, Address List = Black-list

Hope that helps someone else

Re: How to block MAC Addresses

Posted: Thu May 09, 2013 7:10 am
by ElmerHomeroP
SOLVED. Tried the filter rules, but none worked for me.

Not sure how to do code so someone else can translate if they like but here's what worked for me:

IP --> DHCP Server --> Leases --> Add new --> General="Pool_Name", MAC Address="MAC address of desired blocked", Server="Name of DHCP Server failing", Block access = yes, Address List = Black-list

Hope that helps someone else

I tried this and the offending MAC addresses still got their IP address perfectly OK. Not only that, but as can be seen on the attached file, one of the offending MAC addresses ALSO got a lease for 99 days instead of the 8 days programmed in DHCP server, like all other leases.

Note: I DO NOT have a list of addresses called "black-list". I did, however, try first with that box empty, with the same result.

I rebooted the whole system each time.

Please help.

Re: How to block MAC Addresses

Posted: Fri Apr 04, 2014 3:10 pm
by airforce1
make the mac have a static address (click make static) edt the static address to a diff subnet

Re: How to block MAC Addresses

Posted: Wed Nov 02, 2016 8:54 am
by alihamid435
Dear Users, I am new to use Mikrotik router, I want to ask that i have a user who make hotspot with the LAN, and use internet very much, and i want to block the MAC of this device A4:08:EA:06:13:BE

Can any one tell me how to block MAC address in Mikrotik Router.

Re: How to block MAC Addresses

Posted: Wed Nov 02, 2016 4:21 pm
by alihamid435
I have an issue ,i blocked one MAC of a user with this method but it is not working:

On the “Firewall” window, select the “+” sign (add).
On the “Firewall Rule” window, select the tab “General” and set the “chain” to “forward”.
IF you want to block MAC, go to “Advanced” tab and add the MAC to the “Scr. MAC Address” field.
Then, on the “Action” tab, set the “Action” to “drop”.
Finally, click “Apply” to save the new rule.

But when i check again , this person is again connected with the same MAC Address . Why

Re: How to block MAC Addresses

Posted: Tue Jan 17, 2017 2:25 pm
by chinbaa
Dear Users, I am new to use Mikrotik router, I want to ask that i have a user who make hotspot with the LAN, and use internet very much, and i want to block the MAC of this device A4:08:EA:06:13:BE

Can any one tell me how to block MAC address in Mikrotik Router.
Dear Sir, did u get solve your problem?

Re: How to block MAC Addresses

Posted: Tue Jan 17, 2017 2:57 pm
by freemannnn
when you block a mac address in firewall filter (forward and input chain) you block internet access and not dhcp lease.

/ip firewall filter
add chain=input src-mac-address=aa:bb:cc:dd:ee:ff action=drop
add chain=forward src-mac-address=aa:bb:cc:dd:ee:ff action=drop

if you want to block dhcp lease....

1. set a dynamic lease to static lease "make static".
2. tick "block access" to static lease. restart the router (or wait that static lease to expire) and the specific mac address will not get address from dhcp.

both are working for me in my vmware test machine. i just test them.
i have done this many times to my customers.

Re: How to block MAC Addresses

Posted: Tue Jan 17, 2017 3:33 pm
by chinbaa
when you block a mac address in firewall filter (forward and input chain) you block internet access and not dhcp lease.

/ip firewall filter
add chain=input src-mac-address=aa:bb:cc:dd:ee:ff action=drop
add chain=forward src-mac-address=aa:bb:cc:dd:ee:ff action=drop

if you want to block dhcp lease....

1. set a dynamic lease to static lease "make static".
2. tick "block access" to static lease. restart the router and the specific mac address will not get address from dhcp.

both are working for me in my vmware test machine. i just test them.
i have done this many times to my customers.
Dear Sir,
I want to chat with you PM? how to contact you

Re: How to block MAC Addresses

Posted: Tue Jan 17, 2017 10:44 pm
by freemannnn
you didnt succeed? sent me your skype or viber or facebook or email with pm

Re: How to block MAC Addresses

Posted: Sat Apr 01, 2017 4:27 pm
by sonnyboy
when you block a mac address in firewall filter (forward and input chain) you block internet access and not dhcp lease.

/ip firewall filter
add chain=input src-mac-address=aa:bb:cc:dd:ee:ff action=drop
add chain=forward src-mac-address=aa:bb:cc:dd:ee:ff action=drop

both are working for me in my vmware test machine. i just test them.
i have done this many times to my customers.
Works so good thanks for this :)

Re: How to block MAC Addresses

Posted: Fri Aug 18, 2017 6:52 am
by DaveBrowning
Can you do this for a MAC OUI, instead of a full MAC address?

Re: How to block MAC Addresses

Posted: Wed Mar 28, 2018 2:50 pm
by Bitmann
This works for me
/ip firewall filter add chain=forward src-mac-address=02:09:85:F9:71:6B action=drop disabled=no comment="Block 02:09:85:F9:71:6B"

Re: How to block MAC Addresses

Posted: Sat Oct 13, 2018 1:12 pm
by medi01
Added rules:

1) chain = forward
2) chain = input
src IP = IP of my phone
action = drop

ip firewall filter print shows:
...
7 chain=input action=drop src-address=192.168.0.138 log=no log-prefix=""
8 chain=forward action=drop src-address=192.168.0.138 log=no log-prefix=""
.

Any ideas? :(

Re: How to block MAC Addresses

Posted: Sat Oct 13, 2018 3:07 pm
by sindy
Given how brief you post is and what is missing in it, I dare to suggest a supercharged introduction into how the firewall works.