Community discussions

MUM Europe 2020
 
Jivo
newbie
Topic Author
Posts: 34
Joined: Wed Jun 08, 2011 11:44 pm

Wierd problems with Winbox

Thu Jun 09, 2011 12:01 am

I have a wierd problem with Winbox logging to one RB450G: Winbox hangs on connection attempt, showing "Retrieving preferences ....". After some time it reports "Router has been disconnected".

I have checked and found many suggestions, all pointing to damaged plugin or something similar, but the reason must lie somewhere else. Here are the facts:

Chaniging Winbox version only generated the fault in a different phase of login.
Changing router OS from 4.11 to 5.4 did not change a thing.
Any version of Winbox on that very machine can login to 20 different other routers I have access to.
If I VPN to my company LAN, I am suddenly able to login to the router with very same Winbox(es) that did not work before.

Does anyone have any idea where to look?
 
nelsonjax
just joined
Posts: 14
Joined: Fri Apr 15, 2011 3:16 pm

Re: Wierd problems with Winbox

Fri Jun 10, 2011 5:46 pm

If you connect via VPN and it works, but connect directly (presumabely from an external wan-derived IP) and it does not that would infer firewall interference of some sort. Is port 8291 allowed at your networks gateway?

-Nelson
 
Jivo
newbie
Topic Author
Posts: 34
Joined: Wed Jun 08, 2011 11:44 pm

Re: Wierd problems with Winbox

Sun Jun 12, 2011 2:37 pm

No, everything i OK with 8291 port traffic.
I am able to connect from other locations to this router, and I am able to connect to other routers from the critical location. I am totally puzzled.
The big issue is (aside of the general scarry fact that this CAN be an issue), that I cannot connect to this router from customer's main management server - which can normally connect to the rest of the 10 affiliate routers.
Let me throw in another fact: Looking at the router's log during the attempt to connect from the critical site, I can see that I have connected and disconnected - just like everything was OK. It look s like the router is not aware that Winbox did not manage to get pass the "Loading preferences..." screen.
 
cdemers
Member Candidate
Member Candidate
Posts: 184
Joined: Sun Feb 26, 2006 3:32 pm
Location: Canada
Contact:

Re: Wierd problems with Winbox

Sun Jun 12, 2011 3:05 pm

Have you tried setting winbox to not load previous session and see if the problem still exists. I had a similar problem at one time and that fixed it.
 
Jivo
newbie
Topic Author
Posts: 34
Joined: Wed Jun 08, 2011 11:44 pm

Re: Wierd problems with Winbox

Sun Jun 12, 2011 3:17 pm

Yes, I tried. It did not help.
In fact, I tried to untick both "Previous session" and "Secure mode" (one by one), but it did not fix the problem. I tried a different version of Winbox too. The difference was that the older version gets stuck at loading preferences, while the newer version gets stuck on loading plugins.
Both versions work for ALL other routers always, and they work with the critical router if I re-route through a VPN to some other network.

Is there a way to debug that from router side, or should I dig into Wireshark to pinpoint the problem?
 
boardman
Member Candidate
Member Candidate
Posts: 260
Joined: Fri May 28, 2004 11:10 pm
Location: Mexico
Contact:

Re: Wierd problems with Winbox

Thu May 02, 2013 4:53 am

Did you found the solution to this issue?

I am experiencing it on every router that is connected thru a VPLS .... any ideas?

J. Boardman
 
jtommasi
just joined
Posts: 20
Joined: Tue Aug 09, 2011 9:27 pm

Re: Wierd problems with Winbox

Thu Jan 08, 2015 8:56 pm

I had this problem in the past and it was due to a MTU issue. Resolved by enable jumbo frames on one switch.

Who is online

Users browsing this forum: nwmurphy and 103 guests