Page 1 of 1

PPPoE ip Pool problem

Posted: Tue Jun 14, 2011 12:28 pm
by rpengineering
Dear,
i've a pppoe-server mtik based, in the configuration i use the default gw address for local address and for remote address i've an address pool,
in this configuration the peer remote address is always the same, not change , it work as static ip but i need that the ip of the peer change when there is a disconnection .

when i assign a local address pool and a remote address pool , the server works. but i've this situation
private address 10.0.0.x and public address 91.x.x.x

Re: PPPoE ip Pool problem

Posted: Sat Jun 18, 2011 11:08 am
by litu
please post your details settings of network & mikrotik config to help you better.

regards

Re: PPPoE ip Pool problem

Posted: Mon Jun 20, 2011 4:05 pm
by rpengineering
this is the ip pool
/ip pool
add name=Wisp-Internal3 ranges=100.55.2.0/24
add name=Wisp-External3 ranges=31.x.xxx.1-31.x.xxx.254
add name=Wisp-Internal2 next-pool=Wisp-External3 ranges=100.55.1.0/24
add name=Wisp-External2 next-pool=Wisp-External3 ranges=\
    91.2xx.x5.1-91.2xx.x5.254
add name=Wisp-External next-pool=Wisp-External2 ranges=\
    91.2xx.x6.1-91.xxx.x6.254
add name=Wisp-Internal next-pool=Wisp-Internal2 ranges=100.55.0.0/24
this is the pppoe profile
/ppp profile
set default change-tcp-mss=yes comment="" dns-server=91.xxx.x2.33,91.xxx.x2.34 \
    local-address=91.xxx.x2.1 name=default only-one=default remote-address=\
    Wisp-External use-compression=default use-encryption=default \
    use-vj-compression=default
the ip 91.xxx.x2.1 is on the ether1 of pppoe server

this is the pppoe-server
/interface pppoe-server server
add authentication=pap,chap default-profile=default disabled=no interface=\
ether2 keepalive-timeout=10 max-mru=1492 max-mtu=1492 max-sessions=0 mrru=\
disabled one-session-per-host=yes service-name=pppoe.bridged
i this config the remote address of the peer is assigned correctly but never change after peer disconnection like a static ip

if the profile configuration is this
/ppp profile
set default change-tcp-mss=yes comment="" dns-server=91.xxx.x2.33,91.xxx.x2.34 \
    local-address=Wisp-Internal name=default only-one=default remote-address=\
    Wisp-External use-compression=default use-encryption=default \
    use-vj-compression=default
the remote peer address change correctly after user disconnection
but i've this situation

internal ip 100.55.xx.1 external ip 91.xxx.x5.1

but i not like it for some problems with routers and voce appliance

Re: PPPoE ip Pool problem

Posted: Mon Jul 18, 2011 5:35 pm
by rpengineering
Dear,
SomeOne Can Help Me ??

Regards

Re: PPPoE ip Pool problem

Posted: Fri Feb 22, 2019 11:55 am
by mukeshchaubey
I have issue in PPPoE ppol .when in pool i have define the pool 192.168.1.10-192.168.2.250 .. but found issue that no one get ip from 192.168.2.x series .when the ip get full from 192.168.1.x . no next client get from next series i.e 192.168.2.x ..

Re: PPPoE ip Pool problem

Posted: Fri Feb 22, 2019 12:03 pm
by mkx
I have issue in PPPoE ppol .when in pool i have define the pool 192.168.1.10-192.168.2.250 .. but found issue that no one get ip from 192.168.2.x series .when the ip get full from 192.168.1.x . no next client get from next series i.e 192.168.2.x ..
Post output of the following commands:

/ip pool export
/ip dhcp-server export

Re: PPPoE ip Pool problem

Posted: Thu Feb 28, 2019 7:06 pm
by mukeshchaubey
/ip pool

add name=POOL-192-series ranges=192.168.1.192.168.2.253



/ip dhcp-server

add address-pool=POOL-192 interface=ENT-VLAN-901 lease-time=23h59m name=Vlan-901

/ip dhcp-server option

/ip dhcp-server network
add address=192.168.0.0/23 dns-server=8.8.8.8,4.2.2.2,8.8.4.4 gateway=192.168.1.1 netmask=23