Community discussions

MUM Europe 2020
 
hci
Long time Member
Long time Member
Topic Author
Posts: 605
Joined: Fri May 28, 2004 5:10 pm

routing-test-2.9.7.npk

Wed Nov 02, 2005 8:06 pm

What does this do?

Matthew
 
changeip
Forum Guru
Forum Guru
Posts: 3804
Joined: Fri May 28, 2004 5:22 pm

Wed Nov 02, 2005 8:41 pm

This is the beta routing package that has better BGP implemented.

I just upgraded to 2.9.7 and routing-test seems to have a problem with keeping state with the peer. I am debugging more and will send a report shortly, but at first glance I unplugged the ethernet to the peer and 10 minutes later its still thinking its connected... Whereas the previous version would hit the hold-timer and delete routes when it expired. Short on time but will formalize a report later.

Sam
 
changeip
Forum Guru
Forum Guru
Posts: 3804
Joined: Fri May 28, 2004 5:22 pm

Thu Nov 03, 2005 8:40 am

i believe routing-test 2.9.7 has problems with detecting a broken peering session... if you disconnect the hold timer never lets go and the routes stay forever.

Sam
 
User avatar
Eugene
Forum Veteran
Forum Veteran
Posts: 993
Joined: Mon May 31, 2004 5:06 pm
Location: Cranfield, UK

Fri Nov 04, 2005 6:36 pm

Just tested, works for us.
Tout individu a droit à la vie, à la liberté et à la sûreté de sa personne.
 
changeip
Forum Guru
Forum Guru
Posts: 3804
Joined: Fri May 28, 2004 5:22 pm

Fri Nov 04, 2005 6:43 pm

I'm still looking into this. I think I ran into a situation where the router was at 100% cpu trying to recalc routes or something and it decided to lose track of the peering session all together - and left the routes in the table that were learned by that peer. The only thing I could do is reboot to get it back in sync. I can't tell if this was a fluke or something reproduceable, I will know more later today. I'm making sure to test thoroughly before I make a bug report on it. It may just be that having debug on caused a problem : )

That was going to be a question I wanted to ask - by making debugging available does it slow down the router, even when its not being used?

Thx,
Sam
 
User avatar
Eugene
Forum Veteran
Forum Veteran
Posts: 993
Joined: Mon May 31, 2004 5:06 pm
Location: Cranfield, UK

Fri Nov 04, 2005 6:50 pm

Of course (because something is being written continuously somewhere :)
Tout individu a droit à la vie, à la liberté et à la sûreté de sa personne.
 
ysam
just joined
Posts: 22
Joined: Fri Sep 02, 2005 9:26 pm

Thu Nov 10, 2005 12:37 am

but at first glance I unplugged the ethernet to the peer and 10 minutes later its still thinking its connected...
Confirmed. Same in all kinds of Interfaces. Wireless and Ethernet.

bgp thinks session is up and established. Routes don't get to be used though since next-hop is unreachable. At least something works there :)
I assume hold-time etc don't work at all.

Also for unknown reasons if a peer goes down or up the router either forgets to update the other peers or it thinks it has. Sure thing is no updates on the other side and thus we need to disable/enable by hand or script in order to work. This came up on 2.9.x and up to 2.9.7 so far on routing-test package.

One more bad thing that came up is that router goes 100% cpu after a period of time.

Anybody else has these issues?
 
changeip
Forum Guru
Forum Guru
Posts: 3804
Joined: Fri May 28, 2004 5:22 pm

Thu Nov 10, 2005 12:44 am

I have been able to reproduce it almost every time, but not all times. Seems if you abrupty disconnect from the peer without a proper tcp close the routes are never taken out.

I have been short on time but will put together more details on whats exactly happening. I need to get some formal support tickets filed on this one but feel bad sending them so many bug reports... one thing i like is that they actually fix them usually.

Sam
 
changeip
Forum Guru
Forum Guru
Posts: 3804
Joined: Fri May 28, 2004 5:22 pm

Thu Nov 10, 2005 2:01 am

I have been able to reproduce it almost every time, but not all times. Seems if you abrupty disconnect from the peer without a proper tcp close the routes are never taken out.

I have been short on time but will put together more details on whats exactly happening. I need to get some formal support tickets filed on this one but feel bad sending them so many bug reports... one thing i like is that they actually fix them usually.

Sam

Who is online

Users browsing this forum: Bing [Bot], bunnylove, carlouthetha, MSN [Bot], OlofL and 169 guests