Community discussions

MikroTik App
 
mySYS
just joined
Topic Author
Posts: 7
Joined: Tue Mar 24, 2009 1:37 pm

RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and v6)

Tue Jun 28, 2011 7:47 am

Hi @ All

we use a RB1200 as BGP Corerouter and noticed, that the board reboot randomly about once a day.

We also contacted MT Support and they pleased us to wait for version 5.5 (but that didn't help so far)

Yesterday evening I replaced the board with a new RB1200 and today it started to reboot.

Can this be an issue with BGPv6 ???

Best Regards,
Martin
 
ste
Forum Guru
Forum Guru
Posts: 1850
Joined: Sun Feb 13, 2005 11:21 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Jun 28, 2011 8:35 am

Hi @ All

we use a RB1200 as BGP Corerouter and noticed, that the board reboot randomly about once a day.

We also contacted MT Support and they pleased us to wait for version 5.5 (but that didn't help so far)

Yesterday evening I replaced the board with a new RB1200 and today it started to reboot.

Can this be an issue with BGPv6 ???

Best Regards,
Martin
It's crazy to use 5.x this early as corerouter. We just upgraded one of our
corerouters to 4.17.
 
petrn
Member Candidate
Member Candidate
Posts: 179
Joined: Thu Jul 29, 2010 3:56 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Jun 28, 2011 7:14 pm

It's crazy to use 5.x this early as corerouter. We just upgraded one of our
corerouters to 4.17.
Very true, i would expand that to production networks even it makes Normis jump.
Petr
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24713
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Wed Jun 29, 2011 11:08 am

Hi @ All

we use a RB1200 as BGP Corerouter and noticed, that the board reboot randomly about once a day.

We also contacted MT Support and they pleased us to wait for version 5.5 (but that didn't help so far)

Yesterday evening I replaced the board with a new RB1200 and today it started to reboot.

Can this be an issue with BGPv6 ???

Best Regards,
Martin
tell me the support ticket number and I will investigate why the upgrade didn't fix your problem
No answer to your question? How to write posts
 
OpiumDream
newbie
Posts: 30
Joined: Fri May 22, 2009 6:44 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Wed Jun 29, 2011 4:47 pm

same problem here (we don't have bgp) it reboots once a day with this msg in logs system rebooted because of kernel failure (even with clear config)
we sold 3 units to customer all 3 have same problem.
5.5 version does not help.
 
mySYS
just joined
Topic Author
Posts: 7
Joined: Tue Mar 24, 2009 1:37 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Wed Jun 29, 2011 8:36 pm

Hello agaon, the ticket number was #2011061266000288, can I downgrade the board to 4,17 until you have fixed this problem ?

Best Regards,
Martin (mySYS Telekom)
 
yogii
Member Candidate
Member Candidate
Posts: 148
Joined: Wed Jun 16, 2010 5:38 am
Location: Batam, Indonesia

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Jun 30, 2011 1:28 pm

can I downgrade the board to 4,17 until you have fixed this problem ?
i guess you cann't, see this Mr. Janisk posted.
http://forum.mikrotik.com/viewtopic.php?f=3&t=52957
Last edited by yogii on Thu Jun 30, 2011 1:31 pm, edited 1 time in total.
 
hedele
Member
Member
Posts: 338
Joined: Tue Feb 24, 2009 11:23 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Jun 30, 2011 1:30 pm

NO you cannot!
RB 1200 is not supported by ROS 4.17.
Trying to downgrade will effectively brick the Router, and
you will have to netinstall it again with ROS 5.5

There is a thread somewhere in the General section where someone tried to do that and failed.
 
romanse
just joined
Posts: 24
Joined: Fri Apr 10, 2009 8:16 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Sat Jul 02, 2011 10:22 am

Does this problem resolved?
it crashes every 2-4 hour - after I changed my RB493 ин 1200
 
User avatar
semakka
Member Candidate
Member Candidate
Posts: 196
Joined: Mon Sep 11, 2006 10:59 am
Location: Moraira, Alicante, Spain
Contact:

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Jul 12, 2011 11:59 am

Same problem here RB1200 reboots randomly, ticket number [Ticket#2011071266000188].

Need to mention that after 2 days of working another RB1200 died. Just died, i've opened it up and the power addapter is fine, the LED is on untill plugging into board, then goes off....

not very happy with the new kit...
 
romanse
just joined
Posts: 24
Joined: Fri Apr 10, 2009 8:16 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Mon Jul 18, 2011 10:21 am

Have this problem solved?
I have bought 4 devices
And I am to change my 493 by 1200 - but I cant do this due it reboots
 
Arnis
just joined
Posts: 4
Joined: Tue Aug 02, 2011 12:24 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Aug 02, 2011 12:58 pm

I have the same problem with two RB1200 routers - I temporally substituted them with RB493G with the same 5.5 firmware and problem has been gone. So my guess is that the problem is in particular RB1200 hardware or 2.33 firmware that runs the router.
BTW - one of the routers was used to connect branch office with central through an IPSec tunnel where is quite active crypted traffic and this one was crashing each 30sec!!! Second router just once a day.

One interesting thing that I found was that after a crash I can see in winbox - system\routerboard field "current firmware" is empty!! and deeper in settings - CPU frequency was 666Mhz (lowest possible)..

MikroTik gave me RouterOS v.5.6, but there were no change in crashing - still the same timings between crashes.
 
Arnis
just joined
Posts: 4
Joined: Tue Aug 02, 2011 12:24 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Wed Aug 03, 2011 5:20 pm

one more update - I moved one RB1200 to the test location and without hi workload through it (there are just one client that goes through IPSec and browse web directly), there are no more crashes within 2 days. So I would say that frequency of crashes are dependent on the load.
 
SebaPL
just joined
Posts: 2
Joined: Fri Aug 05, 2011 12:56 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Aug 05, 2011 1:20 am

We have the same situation here, six RB1200 running as PPPoE ACs - 5 of them reboots randomly each 1-2 days, sometimes even few times a day. One was running constantly for 13 days and rebooted today, load (cpu / bandwidth) was comparable on each one of them.
Two other RB1200 that are running as plain routers with some bgp/ospf and bandwidth utilization about 10-20 Mbps (CPU 2-5%) are running normally - 4 weeks of constant uptime....

As we're dealing with this problem for some time we've ruled out some possible causes. First was overheating - as our RB are placed in rack without any gaps between them, and that the top one was running stable for 13 days, but graphing of temperature sensor showed that there were no anomalies before reboot.
Second suspicion was about proper grounding of board, but this also hadn't helped.
Now we're running out of ideas....
 
Arnis
just joined
Posts: 4
Joined: Tue Aug 02, 2011 12:24 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Aug 05, 2011 2:10 pm

Could anyone from MikroTik can tell whats happening with these routers and how to fix that?

if it helps, I logged the serial port output and in the crash form there looks like this:

MikroTik Login: Oops: Exception in kernel mode, sig: 5 [#1]
RB1200
last sysfs file: /sys/devices/plb.0/opb.3/gpio-leds.6/leds/user-led/max_brightness
NIP: a90be8d8 LR: a90be8bc CTR: 8000dae8
REGS: 9fff3de0 TRAP: 0700 Tainted: P (2.6.35-440)
MSR: 00029000 <EE,ME,CE> CR: 44b50928 XER: 20000000
TASK = 80300300[0] 'swapper' THREAD: 80318000
GPR00: 806fed22 9fff3e90 80300300 9f8a0240 efe0e03b 00000000 1e26927a 00000250
GPR08: 00000001 00000001 efe0a000 0000003c 1e269000 bfbffea9 03712f90 00002000
GPR16: a90bf5c8 8032688c 80294438 9fff3ea4 80300000 00000000 9fff3ea0 9e29b348
GPR24: 9f012890 9fff3ea8 9fff3e9c 9fff3eb8 9fff3e98 9f012840 00000000 00000214
NIP [a90be8d8] 0xa90be8d8
LR [a90be8bc] 0xa90be8bc
Call Trace:
[9fff3e90] [a90be9b4] 0xa90be9b4 (unreliable)
[9fff3f00] [a90bf594] crypto4xx_pd_done+0x358/0x498 [crypto4xx]
[9fff3f30] [a90bf64c] crypto4xx_pd_done+0x410/0x498 [crypto4xx]
[9fff3f50] [8003ec68] run_timer_softirq+0xf8/0x1dc
[9fff3fb0] [80038ad0] __do_softirq+0xb8/0x134
[9fff3ff0] [8000de38] call_do_softirq+0x14/0x24
[80319e80] [80003b7c] do_softirq+0x74/0x80
[80319ea0] [80038c14] irq_exit+0x60/0x70
[80319eb0] [8000aac0] timer_interrupt+0xf8/0x118
[80319ed0] [8000eab4] ret_from_except+0x0/0x18
--- Exception: 901 at ppc44x_idle+0x10/0x20
LR = cpu_idle+0x84/0xd4
[80319f90] [800075ac] cpu_idle+0xd0/0xd4 (unreliable)
[80319fb0] [800019d8] rest_init+0x64/0x74
[80319fc0] [802d972c] start_kernel+0x2a4/0x2b8
[80319ff0] [80000060] _start+0x60/0x9c
Instruction dump:
419e0014 39000001 39200000 7c0903a6 4e800421 80010028 2f800000 419e00fc
80170000 70090002 418200f4 39200001 <0f090000> 418200f8 3ae00000 409efef0
Kernel panic - not syncing: Fatal exception in interrupt
 
kobzan
just joined
Posts: 11
Joined: Tue Sep 14, 2010 1:23 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Aug 05, 2011 10:22 pm

5.6 version doesn't change anything
 
SebaPL
just joined
Posts: 2
Joined: Fri Aug 05, 2011 12:56 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Wed Sep 07, 2011 12:32 pm

Any news, somebody from Mikrotik can tell something - such faulty equipment makes really bad reputation to your new flagship called RB1200 ;)

What can we do more, change power supply, install extra cooling on cpu?
 
82nikita82
just joined
Posts: 1
Joined: Fri Sep 16, 2011 10:03 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Sep 16, 2011 10:06 am

Hello,
we have the same problem.

We tried to upgrade to v.5.7 but the result is the same.

What can we do?

Thank you very much.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8465
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Sep 16, 2011 12:13 pm

have you checked firmware upgrades?
/sys routerb print
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
felipesantos
newbie
Posts: 34
Joined: Mon Sep 19, 2011 3:20 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Sep 20, 2011 6:10 pm

Random reboot I have the same problem with version 5.7 with a patch that MikroTik current-firmware: 2.36.1 with the same problem.
 
felipesantos
newbie
Posts: 34
Joined: Mon Sep 19, 2011 3:20 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Sep 20, 2011 6:42 pm

[Ticket#2011091966000037] Problem
 
zdiv
just joined
Posts: 7
Joined: Thu Sep 01, 2011 12:06 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Oct 27, 2011 12:43 pm

Same thing here.
RB1200
/sys routerb print
routerboard: yes
model: 1200
serial-number: 2CD4011D2FFF
current-firmware: 2.33
upgrade-firmware: 2.33

/system resource print
uptime: 33m15s
version: 5.7
free-memory: 487256KiB
total-memory: 516560KiB
cpu: 460GT
cpu-count: 1
cpu-frequency: 999MHz
cpu-load: 39%
free-hdd-space: 30564KiB
total-hdd-space: 61440KiB
write-sect-since-reboot: 612
write-sect-total: 385499
bad-blocks: 0%
architecture-name: powerpc
board-name: RB1200
platform: MikroTik

Router reboots regularly few times a day.
every two days (approx) router gets frozen, all ethernet ports get in down state. Watchdog does not help. Router must be power cycled to recover .

It all started when CPU usage got on more than 50%
Bigger CPU usage is, more often router reboots or gets frozen.
 
dufyd
just joined
Posts: 4
Joined: Fri Nov 04, 2011 8:18 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Nov 04, 2011 8:41 pm

High UDP traffic over IPSec tunnel caused the 1200 to reboot, that was "fixed" on 5.7, however we still had the problem after the 5.7 update. We found that upgrading the firmware fixed this problem.

You do this under system - routerboard

Good luck.
 
zdiv
just joined
Posts: 7
Joined: Thu Sep 01, 2011 12:06 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Nov 17, 2011 3:48 pm

model: 1200
version: 5.8
current-firmware: 2.37
uptime: 58m16s
cpu-load: 84%

Upgrade does not help regarding reboot issue.
Router still reboots and frequency of reboots depends directly of CPU usage.
 
erx
just joined
Posts: 2
Joined: Fri Nov 18, 2011 10:02 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Nov 18, 2011 10:12 am

Any news about this problem?

i got same problem running RoS 5.8 on RB1200.
But can't notice that cpu will go up before reboot.
 
davidbinomix
just joined
Posts: 9
Joined: Fri May 14, 2010 1:28 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Nov 18, 2011 7:02 pm

I can confirm same issue since our rb1200 is getting big traffic and its cpu is over 80% all the time.

model: 1200
version: 5.8
current-firmware: 2.37

We saw the bug (reboots) with 5.6, and we experienced the same issue on 5.7 and now with 5.8, so the bug still is there.

Maybe mangle rules?
 
erx
just joined
Posts: 2
Joined: Fri Nov 18, 2011 10:02 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Nov 18, 2011 7:08 pm

I don't think it's mangle problem.

I only have filter rules (input and forward) and conntract disabled.
Also i have 1 dhcp-relay and 2 vlan interfaces.

And thats all. Router was running with this configuration some weeks without any problems.
But now when it's getting 20-100Mbit/s traffic, problems begin.

I never saw cpu usage higger that 25%.
 
davidbinomix
just joined
Posts: 9
Joined: Fri May 14, 2010 1:28 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Nov 18, 2011 7:22 pm

Then we can rule out more things:
We have no dhcp-relay or vlans, but we also have filter rules (may be we can try to disable it for a period and see if reboots disappears, we will report ...).

So, seemingly the problem is not mangle rules, dhcp-relays, vlans, ... and another big thing in play is the queue trees for QoS ...
 
davidbinomix
just joined
Posts: 9
Joined: Fri May 14, 2010 1:28 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Sun Nov 20, 2011 11:38 am

Then we can rule out more things:
We have no dhcp-relay or vlans, but we also have filter rules (may be we can try to disable it for a period and see if reboots disappears, we will report ...).

So, seemingly the problem is not mangle rules, dhcp-relays, vlans, ... and another big thing in play is the queue trees for QoS ...
I can confirm that without filter rules it still reboots :(
 
cfarina
just joined
Posts: 2
Joined: Wed Aug 17, 2011 1:34 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Nov 22, 2011 8:43 pm

Hi all, a question regarding this issue...
Background: in Argentina the rb1200 is delivered with with v5.2 & firmware 2.33.
Question: Is there any reason to keep it in 5.2 and do NOT be updated to 5.8?
Thanks in advance,
manuel.
 
zdiv
just joined
Posts: 7
Joined: Thu Sep 01, 2011 12:06 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Wed Nov 23, 2011 11:45 am

It looks problem is only with traffic and board itself.
We have this particular problem only with RB1200.
Marking packets in bridge/firewall and running queue-tree

I have tested all ROS versions up to 5.8 and FW up to 2.37.
ALL ROS versions are affected.
ALL FW versions are affected.

With traffic bigger than 20mbps router reboots.
more traffic == more reboots
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2321
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Nov 25, 2011 4:12 pm

Hello. Try downgrade frekvency to 667Mhz if it helps.
LAN, FTTx, Wireless. ISP operator
 
User avatar
karina
Member
Member
Posts: 450
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Sun Nov 27, 2011 8:35 pm

Hi All,

Is this problem Fixed. need to know as about to deploy 6 RB1200s in critical Locations. Be well unhappy if just blown a grand on duff gear.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2321
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Sun Nov 27, 2011 9:06 pm

Hi All,

Is this problem Fixed. need to know as about to deploy 6 RB1200s in critical Locations. Be well unhappy if just blown a grand on duff gear.
ZDIV wrote 23.November - latest firmware and still reboot
LAN, FTTx, Wireless. ISP operator
 
User avatar
karina
Member
Member
Posts: 450
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Mon Nov 28, 2011 3:06 pm

Hi,
Can anybody at Mikrotik add to this please. I need confirmation if this a general issue on the RB1200 or just isolated cases
 
interprime
just joined
Posts: 15
Joined: Wed Jun 08, 2011 1:08 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Nov 29, 2011 1:15 am

Karina,

It is a problem in RB. The staff of the Mikrotik does not respond to calls no more related to this problem, I recommend you buy the RB1100, Ticket 2011112566000593
 
User avatar
karina
Member
Member
Posts: 450
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Nov 29, 2011 12:37 pm

Does not sound good.

And also noticed 5.8 is no longer available on the download site. MK what is happening?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24713
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Nov 29, 2011 12:44 pm

Does not sound good.

And also noticed 5.8 is no longer available on the download site. MK what is happening?
it's available as always, what's the problem?
No answer to your question? How to write posts
 
User avatar
karina
Member
Member
Posts: 450
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Nov 29, 2011 12:54 pm

I only see 5.7 as latest listed on the site ??
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24713
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Nov 29, 2011 12:56 pm

I only see 5.7 as latest listed on the site ??
sorry, a small side-effect of web server upgrade. it will be back in a short while
No answer to your question? How to write posts
 
rigan123
just joined
Posts: 13
Joined: Mon Nov 28, 2011 12:50 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Nov 29, 2011 3:15 pm

Hi All,

Mikrotik RouterBoard may reboot for several issues.Most common one is for Watchdog Utilities. To check it
Go to System>Watchdog.Check that if timer is on/off.And also check 'ping start after reboot'.Just uncheck the timer.

You should check log to identify the issue.If it is kernel panic then contact to support center or try to upgrade/downgrade.

Best Regards,
Rigan
MCSA,ITILV3F
 
User avatar
karina
Member
Member
Posts: 450
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Nov 29, 2011 4:28 pm

ok I have RB1200 running on 5.8 all looks good. some Ethernet ports would not come up at first had to reboot but ok now. 46Mbps traffic 31% CPU. Using switch on ports 1 to 5.
varoius Firewall filter rules running and also NAT. will report back if any problems
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2321
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Nov 29, 2011 6:42 pm

will be fixed in 5.10?
LAN, FTTx, Wireless. ISP operator
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24713
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Wed Nov 30, 2011 8:09 am

Watchdog doesn't seem to help after all. We found that the issue is to not use ports 9 and 10 and then the problem will stop. We will fix the issue in v5.10

So - UNPLUG CABLES FROM PORTS 9 AND 10 and see if it helps!
No answer to your question? How to write posts
 
felipesantos
newbie
Posts: 34
Joined: Mon Sep 19, 2011 3:20 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Dec 01, 2011 3:21 am

After five months on the shelf RB1200 finally detected the problem of Random reboots. I will try now to see resolved.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2321
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Dec 01, 2011 12:53 pm

After five months on the shelf RB1200 finally detected the problem of Random reboots. I will try now to see resolved.
We have the same problem reported 21.Sep Ticket#2011092166000416
That we avoid the problems so we missed the switch chip port 1-5 and we started from ports 6,7,8,9
LAN, FTTx, Wireless. ISP operator
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24713
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Dec 01, 2011 1:02 pm

anyone with these issues, please write to support, as we have a pre-release of v5.10 that fixes the issue
No answer to your question? How to write posts
 
davidbinomix
just joined
Posts: 9
Joined: Fri May 14, 2010 1:28 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Dec 01, 2011 1:07 pm

We've moved the ethernets ports 9 and 10 to other ports and We can confirm since that We haven't experienced reboots anymore (usually in less than 6 hours), so it seems that it worked.
 
miahac
Long time Member
Long time Member
Posts: 516
Joined: Wed Dec 14, 2005 5:04 pm
Location: Wichita, KS

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Dec 01, 2011 10:38 pm

THIS ISSUE COST ME DEARLY TODAY. Affecting almost 200 small business to government office customers. I also do not think the issue is with ports 9-10. I think it is memory related. Unless the memory issue is also related to those ports.

I had a vital router (RB1200) fail today no amount of reboots could get it back up. I had a recent export and started rebuilding the config in a spare 1100AH but several functions were not working. Finally we replaced the memory in the RB1200(hynix 5123MB 1Rx16 PC2-6400S-666-12) with some memory (Kingston ??) from another spare 1100AH and the 1200 fired up instantly.

I have 10 of these in the field. Each is critical to its prospective customer base. I really need to rely on them. So is 5.10 really the answer? Dont use ports 9,10? Should I replace all the memory? This is a real black eye for me, my company and my trust in MT.
Network Consultant in Wichita, KS
 
miahac
Long time Member
Long time Member
Posts: 516
Joined: Wed Dec 14, 2005 5:04 pm
Location: Wichita, KS

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Dec 01, 2011 10:46 pm

THIS ISSUE COST ME DEARLY TODAY. Affecting almost 200 small business to government office customers. I also do not think the issue is with ports 9-10. I think it is memory related. Unless the memory issue is also related to those ports.

I had a vital router (RB1200) fail today no amount of reboots could get it back up. I had a recent export and started rebuilding the config in a spare 1100AH but several functions were not working. Finally we replaced the memory in the RB1200(hynix 5123MB 1Rx16 PC2-6400S-666-12) with some memory (Kingston ??) from another spare 1100AH and the 1200 fired up instantly.

I have 10 of these in the field. Each is critical to its prospective customer base. I really need to rely on them. So is 5.10 really the answer? Dont use ports 9,10? Should I replace all the memory? This is a real black eye for me, my company and my trust in MT.
Just to note I am using 5.8 with 2.37 firmware, which did seem at first to make these things more reliable, after I had problems from 5.2 - 5.5 with lockups.
Network Consultant in Wichita, KS
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1735
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Dec 02, 2011 9:15 am

So is 5.10 really the answer? Dont use ports 9,10? Should I replace all the memory? This is a real black eye for me, my company and my trust in MT.
Not using ports ether9, ether10 was temporary solution before MT come up with the fix. This fix was implemented in pre-release version 5.10.
I do not know where is your memory idea is coming from - there is not enough information what exactly was fixed to jump to conclusions.

Anyway if there are some kind of crashes with v5.10 you need to provide all information to MT so that they can finalize fix to final release of 5.10
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24713
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Dec 02, 2011 9:18 am

After v5.10 is installed, you can use all ports again. Suggestion for not using those ports is only in affect until you install v5.10. Then - everything returns to normal and you can use all ports as before.
No answer to your question? How to write posts
 
marekm
Member Candidate
Member Candidate
Posts: 236
Joined: Tue Feb 01, 2011 11:27 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Dec 02, 2011 4:13 pm

Watchdog doesn't seem to help after all. We found that the issue is to not use ports 9 and 10 and then the problem will stop. We will fix the issue in v5.10

So - UNPLUG CABLES FROM PORTS 9 AND 10 and see if it helps!
Hmm, are you sure it's that simple? I'm using port 10 _only_ (connected to a switch with many VLANs) and my RB1200 has been running fine, OSPF and PPPoE (~170 customers, up to about 60% CPU load under about 40Mb/s of traffic), for a few days so far.
 
felipesantos
newbie
Posts: 34
Joined: Mon Sep 19, 2011 3:20 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Sat Dec 03, 2011 4:17 am

After v5.10 is installed, you can use all ports again. Suggestion for not using those ports is only in affect until you install v5.10. Then - everything returns to normal and you can use all ports as before.
Speaking of network interface, what is happening with the network interface RB435G, stop responding. In version 5.7/2.36 and 2.37. Upgrade to 5.9 now I am testing.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24713
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Mon Dec 05, 2011 10:37 am

After v5.10 is installed, you can use all ports again. Suggestion for not using those ports is only in affect until you install v5.10. Then - everything returns to normal and you can use all ports as before.
Speaking of network interface, what is happening with the network interface RB435G, stop responding. In version 5.7/2.36 and 2.37. Upgrade to 5.9 now I am testing.
please make a new topic about a different issue.
No answer to your question? How to write posts
 
User avatar
ndasjowo
just joined
Posts: 5
Joined: Mon Jul 05, 2010 12:15 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Wed Jan 04, 2012 9:32 pm

i'm Not using ports ether9, ether10 ( only port 1,6,7 and 8 )
  • /sys rou pr
    routerboard: yes
    model: 1200
    serial-number: 2CD4011D00**
    current-firmware: 2.37
    upgrade-firmware: 2.37

    /sys rou set pr
    baud-rate: 115200
    boot-delay: 5s
    enter-setup-on: any-key
    boot-device: nand-if-fail-then-ethernet
    cpu-frequency: 1GHz<500DDR>
    boot-protocol: bootp
    enable-jumper-reset: yes
    force-backup-booter: no
    silent-boot: no
    /sys reso pr
    uptime: 29m57s
    version: 5.11
    free-memory: 999284KiB
    total-memory: 1036356KiB
    cpu: 460GT
    cpu-count: 1
    cpu-frequency: 999MHz
    cpu-load: 5%
    free-hdd-space: 26360KiB
    total-hdd-space: 61440KiB
    write-sect-since-reboot: 1383
    write-sect-total: 137633
    bad-blocks: 0%
    architecture-name: powerpc
    board-name: RB1200
    platform: MikroTik
    /sys he pr
    voltage: 12V
    temperature: 44C
    cpu-temperature: 62C
And the still board reboot randomly about once a day.
why .... ?
 
zdiv
just joined
Posts: 7
Joined: Thu Sep 01, 2011 12:06 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Jan 06, 2012 4:39 pm

version: 5.11
current-firmware: 2.37

It is same.
Router reboots randomly and from time to time gets stuck only cold reboot helps.
Watchdog usually does not help.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1735
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Mon Jan 09, 2012 11:34 am

Usual story - make supout.rif file after crash reboot and send it to support@mikrotik.com
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
tyronzn
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Thu May 24, 2007 4:55 pm
Location: Durban,South Africa
Contact:

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Mon Jan 23, 2012 10:02 pm

could you guys give details as to what your current board and cpu temperatures are? /system health
I've seen this problem occur in the rackmount series routers situated in cabinets with no spacing between devices,also are you seeing kernel panic errors in log files after they reboot?
 
engppu
just joined
Posts: 9
Joined: Mon Nov 05, 2012 9:31 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Mar 12, 2013 10:32 pm

i faced the same problem with RB 1200 5.9 2.37 Firmware !
the problem appear after i have upgrade the firmware to 2.37 !
i try to upgrade to 5.10 but the same problem is appear ,,,
 
Maescool
just joined
Posts: 10
Joined: Thu Nov 25, 2010 3:31 am
Location: Belgium
Contact:

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Apr 04, 2013 2:58 pm

I get this kernel panic on my RB1200 every couple of minutes since yesterday afternoon.
RouterOS version 5.24
RB1200
last sysfs file: /sys/devices/plb.0/opb.3/gpio-leds.6/leds/user-led/max_brightness
NIP: 801c74c8 LR: a96491bc CTR: 801c749c
REGS: 9fff3df0 TRAP: 0700 Not tainted (2.6.35-440)
MSR: 00029000 <EE,ME,CE> CR: 42000028 XER: 00000000
TASK = 80301300[0] 'swapper' THREAD: 8031a000
GPR00: 000005c4 9fff3ea0 80301300 00000000 00000004 00000000 2f000000 9d532510
GPR08: 00000001 9d55b620 ac1ffe02 00000001 24000084 10019670 03712904 00002000
GPR16: 00000000 d0014b51 00000001 000000ff fffff9f4 00000003 8029228c 00100100
GPR24: 9d55b6e0 9d433400 00000800 9d8d9898 00000000 9d8d9884 9d55b620 9f3abf00
NIP [801c74c8] skb_pull+0x2c/0x40
LR [a96491bc] 0xa96491bc [ipgre@0xa9649000]
Call Trace:
[9fff3ea0] [00000003] 0x3 (unreliable)
[9fff3ec0] [a963e0e4] register_gre_proto+0xe4/0x148 [gre@0xa963e000]
[9fff3ed0] [801f8468] ip_local_deliver_finish+0x130/0x25c
[9fff3ef0] [801f7df8] ip_rcv_finish+0x138/0x3b8
[9fff3f10] [801d10fc] __netif_receive_skb+0x424/0x474
[9fff3f50] [801d11e0] process_backlog+0x94/0x144
[9fff3f80] [801d1548] net_rx_action+0xa4/0x144
[9fff3fb0] [80038ad0] __do_softirq+0xb8/0x134
[9fff3ff0] [8000de38] call_do_softirq+0x14/0x24
[8031be80] [80003b7c] do_softirq+0x74/0x80
[8031bea0] [80038c14] irq_exit+0x60/0x70
[8031beb0] [8000aac0] timer_interrupt+0xf8/0x118
[8031bed0] [8000eab4] ret_from_except+0x0/0x18
--- Exception: 901 at ppc44x_idle+0x10/0x20
LR = cpu_idle+0x84/0xd4
[8031bf90] [800075ac] cpu_idle+0xd0/0xd4 (unreliable)
[8031bfb0] [800019d8] rest_init+0x64/0x74
[8031bfc0] [802d972c] start_kernel+0x2a4/0x2b8
[8031bff0] [80000060] _start+0x60/0x9c
Instruction dump:
4e800020 80030050 7c691b78 38600000 7f840040 4d9d0020 81690054 7c040050
90090050 7d6b0010 7d6b5910 7d6b00d0 <0f0b0000> 806900b8 7c632214 906900b8
Kernel panic - not syncing: Fatal exception in interrupt

panicSaver: dumping panic to flash
flash: erase 10
flash: prg 10
flash: prg err 0
Rebooting in 1 seconds..

RouterBOOT booter 3.02

RouterBoard 1200

CPU frequency: 666 MHz
Memory size: 512 MiB
NAND size: 64 MiB
Looks like something goes fishy with IPSEC/GRE?
I'm now going to disable these features and see if that makes it stable.

Take note: nothing has changed in configuration since a couple of weeks.. the crashes just appeared..
my gut feeling says there is a bug in the ipsec/gre that get crashed by outside attack?
That or the cpu just gets to hot?

[****@RSW] > /system health print
voltage: 12.1V
temperature: 44C
cpu-temperature: 58C
 
Maescool
just joined
Posts: 10
Joined: Thu Nov 25, 2010 3:31 am
Location: Belgium
Contact:

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Apr 04, 2013 5:21 pm

Another grab of the console (it's really hard to grab, since the screen clears after boot, so when i hear it beep, i have to quickly grab it.)
[****@RSW] > Oops: Exception in kernel mode, sig: 5 [#1]
RB1200
last sysfs file: /sys/devices/plb.0/opb.3/gpio-leds.6/leds/user-led/max_brightness
NIP: 801c74c8 LR: a964a1bc CTR: 801c749c
REGS: 9fff3df0 TRAP: 0700   Not tainted  (2.6.35-440)
MSR: 00029000 <EE,ME,CE>  CR: 42000028  XER: 00000000
TASK = 80301300[0] 'swapper' THREAD: 8031a000
GPR00: 000005c4 9fff3ea0 80301300 00000000 00000004 00000000 2f000000 9dbe45b0 
GPR08: 00000001 9dabf620 ac1ffe02 00000001 24000084 10019670 03712904 00002000 
GPR16: 00000000 d0014b51 00000001 000000ff fffff9f4 00000003 8029228c 00100100 
GPR24: 9dabf6e0 9d429800 00000800 9c5fe098 00000000 9c5fe084 9dabf620 9f2fff00 
NIP [801c74c8] skb_pull+0x2c/0x40
LR [a964a1bc] 0xa964a1bc [ipgre@0xa964a000]
Call Trace:
[9fff3ea0] [00000003] 0x3 (unreliable)
[9fff3ec0] [a963f0e4] register_gre_proto+0xe4/0x148 [gre@0xa963f000]
[9fff3ed0] [801f8468] ip_local_deliver_finish+0x130/0x25c
[9fff3ef0] [801f7df8] ip_rcv_finish+0x138/0x3b8
[9fff3f10] [801d10fc] __netif_receive_skb+0x424/0x474
[9fff3f50] [801d11e0] process_backlog+0x94/0x144
[9fff3f80] [801d1548] net_rx_action+0xa4/0x144
[9fff3fb0] [80038ad0] __do_softirq+0xb8/0x134
[9fff3ff0] [8000de38] call_do_softirq+0x14/0x24
[8031be80] [80003b7c] do_softirq+0x74/0x80
[8031bea0] [80038c14] irq_exit+0x60/0x70
[8031beb0] [8000aac0] timer_interrupt+0xf8/0x118
[8031bed0] [8000eab4] ret_from_except+0x0/0x18
--- Exception: 901 at ppc44x_idle+0x10/0x20
    LR = cpu_idle+0x84/0xd4
[8031bf90] [800075ac] cpu_idle+0xd0/0xd4 (unreliable)
[8031bfb0] [800019d8] rest_init+0x64/0x74
[8031bfc0] [802d972c] start_kernel+0x2a4/0x2b8
[8031bff0] [80000060] _start+0x60/0x9c
Instruction dump:
4e800020 80030050 7c691b78 38600000 7f840040 4d9d0020 81690054 7c040050 
90090050 7d6b0010 7d6b5910 7d6b00d0 <0f0b0000> 806900b8 7c632214 906900b8 
Kernel panic - not syncing: Fatal exception in interrupt

panicSaver: dumping panic to flash
flash: erase 10
flash: prg 10
flash: prg err 0
Rebooting in 1 seconds..

RouterBOOT booter 3.02

RouterBoard 1200

CPU frequency: 666 MHz
  Memory size: 512 MiB
    NAND size:  64 MiB

Press any key within 2 seconds to enter setup..

loading kernel from nand... OK
setting up elf image... OK
jumping to kernel code
It really looks the same like my previous post.. but this is from the last time it crashed

So what is broken? anybody? :(
 
Maescool
just joined
Posts: 10
Joined: Thu Nov 25, 2010 3:31 am
Location: Belgium
Contact:

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Mon Apr 08, 2013 6:56 pm

It seems a IPSEC/GRE tunnel bug, as soon as I disable this, the Router is stable again..
It was running this config stable for over a year though..

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], eworm, Google [Bot], xvo and 116 guests