Community discussions

 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Dec 02, 2011 9:15 am

So is 5.10 really the answer? Dont use ports 9,10? Should I replace all the memory? This is a real black eye for me, my company and my trust in MT.
Not using ports ether9, ether10 was temporary solution before MT come up with the fix. This fix was implemented in pre-release version 5.10.
I do not know where is your memory idea is coming from - there is not enough information what exactly was fixed to jump to conclusions.

Anyway if there are some kind of crashes with v5.10 you need to provide all information to MT so that they can finalize fix to final release of 5.10
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Dec 02, 2011 9:18 am

After v5.10 is installed, you can use all ports again. Suggestion for not using those ports is only in affect until you install v5.10. Then - everything returns to normal and you can use all ports as before.
No answer to your question? How to write posts
 
marekm
Member Candidate
Member Candidate
Posts: 196
Joined: Tue Feb 01, 2011 11:27 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Dec 02, 2011 4:13 pm

Watchdog doesn't seem to help after all. We found that the issue is to not use ports 9 and 10 and then the problem will stop. We will fix the issue in v5.10

So - UNPLUG CABLES FROM PORTS 9 AND 10 and see if it helps!
Hmm, are you sure it's that simple? I'm using port 10 _only_ (connected to a switch with many VLANs) and my RB1200 has been running fine, OSPF and PPPoE (~170 customers, up to about 60% CPU load under about 40Mb/s of traffic), for a few days so far.
 
felipesantos
newbie
Posts: 34
Joined: Mon Sep 19, 2011 3:20 am

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Sat Dec 03, 2011 4:17 am

After v5.10 is installed, you can use all ports again. Suggestion for not using those ports is only in affect until you install v5.10. Then - everything returns to normal and you can use all ports as before.
Speaking of network interface, what is happening with the network interface RB435G, stop responding. In version 5.7/2.36 and 2.37. Upgrade to 5.9 now I am testing.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Mon Dec 05, 2011 10:37 am

After v5.10 is installed, you can use all ports again. Suggestion for not using those ports is only in affect until you install v5.10. Then - everything returns to normal and you can use all ports as before.
Speaking of network interface, what is happening with the network interface RB435G, stop responding. In version 5.7/2.36 and 2.37. Upgrade to 5.9 now I am testing.
please make a new topic about a different issue.
No answer to your question? How to write posts
 
User avatar
ndasjowo
just joined
Posts: 5
Joined: Mon Jul 05, 2010 12:15 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Wed Jan 04, 2012 9:32 pm

i'm Not using ports ether9, ether10 ( only port 1,6,7 and 8 )
  • /sys rou pr
    routerboard: yes
    model: 1200
    serial-number: 2CD4011D00**
    current-firmware: 2.37
    upgrade-firmware: 2.37

    /sys rou set pr
    baud-rate: 115200
    boot-delay: 5s
    enter-setup-on: any-key
    boot-device: nand-if-fail-then-ethernet
    cpu-frequency: 1GHz<500DDR>
    boot-protocol: bootp
    enable-jumper-reset: yes
    force-backup-booter: no
    silent-boot: no
    /sys reso pr
    uptime: 29m57s
    version: 5.11
    free-memory: 999284KiB
    total-memory: 1036356KiB
    cpu: 460GT
    cpu-count: 1
    cpu-frequency: 999MHz
    cpu-load: 5%
    free-hdd-space: 26360KiB
    total-hdd-space: 61440KiB
    write-sect-since-reboot: 1383
    write-sect-total: 137633
    bad-blocks: 0%
    architecture-name: powerpc
    board-name: RB1200
    platform: MikroTik
    /sys he pr
    voltage: 12V
    temperature: 44C
    cpu-temperature: 62C
And the still board reboot randomly about once a day.
why .... ?
 
zdiv
just joined
Posts: 6
Joined: Thu Sep 01, 2011 12:06 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Fri Jan 06, 2012 4:39 pm

version: 5.11
current-firmware: 2.37

It is same.
Router reboots randomly and from time to time gets stuck only cold reboot helps.
Watchdog usually does not help.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Mon Jan 09, 2012 11:34 am

Usual story - make supout.rif file after crash reboot and send it to support@mikrotik.com
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
tyronzn
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Thu May 24, 2007 4:55 pm
Location: Durban,South Africa
Contact:

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Mon Jan 23, 2012 10:02 pm

could you guys give details as to what your current board and cpu temperatures are? /system health
I've seen this problem occur in the rackmount series routers situated in cabinets with no spacing between devices,also are you seeing kernel panic errors in log files after they reboot?
 
engppu
just joined
Posts: 9
Joined: Mon Nov 05, 2012 9:31 pm

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Tue Mar 12, 2013 10:32 pm

i faced the same problem with RB 1200 5.9 2.37 Firmware !
the problem appear after i have upgrade the firmware to 2.37 !
i try to upgrade to 5.10 but the same problem is appear ,,,
 
Maescool
just joined
Posts: 10
Joined: Thu Nov 25, 2010 3:31 am
Location: Belgium
Contact:

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Apr 04, 2013 2:58 pm

I get this kernel panic on my RB1200 every couple of minutes since yesterday afternoon.
RouterOS version 5.24
RB1200
last sysfs file: /sys/devices/plb.0/opb.3/gpio-leds.6/leds/user-led/max_brightness
NIP: 801c74c8 LR: a96491bc CTR: 801c749c
REGS: 9fff3df0 TRAP: 0700 Not tainted (2.6.35-440)
MSR: 00029000 <EE,ME,CE> CR: 42000028 XER: 00000000
TASK = 80301300[0] 'swapper' THREAD: 8031a000
GPR00: 000005c4 9fff3ea0 80301300 00000000 00000004 00000000 2f000000 9d532510
GPR08: 00000001 9d55b620 ac1ffe02 00000001 24000084 10019670 03712904 00002000
GPR16: 00000000 d0014b51 00000001 000000ff fffff9f4 00000003 8029228c 00100100
GPR24: 9d55b6e0 9d433400 00000800 9d8d9898 00000000 9d8d9884 9d55b620 9f3abf00
NIP [801c74c8] skb_pull+0x2c/0x40
LR [a96491bc] 0xa96491bc [ipgre@0xa9649000]
Call Trace:
[9fff3ea0] [00000003] 0x3 (unreliable)
[9fff3ec0] [a963e0e4] register_gre_proto+0xe4/0x148 [gre@0xa963e000]
[9fff3ed0] [801f8468] ip_local_deliver_finish+0x130/0x25c
[9fff3ef0] [801f7df8] ip_rcv_finish+0x138/0x3b8
[9fff3f10] [801d10fc] __netif_receive_skb+0x424/0x474
[9fff3f50] [801d11e0] process_backlog+0x94/0x144
[9fff3f80] [801d1548] net_rx_action+0xa4/0x144
[9fff3fb0] [80038ad0] __do_softirq+0xb8/0x134
[9fff3ff0] [8000de38] call_do_softirq+0x14/0x24
[8031be80] [80003b7c] do_softirq+0x74/0x80
[8031bea0] [80038c14] irq_exit+0x60/0x70
[8031beb0] [8000aac0] timer_interrupt+0xf8/0x118
[8031bed0] [8000eab4] ret_from_except+0x0/0x18
--- Exception: 901 at ppc44x_idle+0x10/0x20
LR = cpu_idle+0x84/0xd4
[8031bf90] [800075ac] cpu_idle+0xd0/0xd4 (unreliable)
[8031bfb0] [800019d8] rest_init+0x64/0x74
[8031bfc0] [802d972c] start_kernel+0x2a4/0x2b8
[8031bff0] [80000060] _start+0x60/0x9c
Instruction dump:
4e800020 80030050 7c691b78 38600000 7f840040 4d9d0020 81690054 7c040050
90090050 7d6b0010 7d6b5910 7d6b00d0 <0f0b0000> 806900b8 7c632214 906900b8
Kernel panic - not syncing: Fatal exception in interrupt

panicSaver: dumping panic to flash
flash: erase 10
flash: prg 10
flash: prg err 0
Rebooting in 1 seconds..

RouterBOOT booter 3.02

RouterBoard 1200

CPU frequency: 666 MHz
Memory size: 512 MiB
NAND size: 64 MiB
Looks like something goes fishy with IPSEC/GRE?
I'm now going to disable these features and see if that makes it stable.

Take note: nothing has changed in configuration since a couple of weeks.. the crashes just appeared..
my gut feeling says there is a bug in the ipsec/gre that get crashed by outside attack?
That or the cpu just gets to hot?

[****@RSW] > /system health print
voltage: 12.1V
temperature: 44C
cpu-temperature: 58C
 
Maescool
just joined
Posts: 10
Joined: Thu Nov 25, 2010 3:31 am
Location: Belgium
Contact:

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Thu Apr 04, 2013 5:21 pm

Another grab of the console (it's really hard to grab, since the screen clears after boot, so when i hear it beep, i have to quickly grab it.)
[****@RSW] > Oops: Exception in kernel mode, sig: 5 [#1]
RB1200
last sysfs file: /sys/devices/plb.0/opb.3/gpio-leds.6/leds/user-led/max_brightness
NIP: 801c74c8 LR: a964a1bc CTR: 801c749c
REGS: 9fff3df0 TRAP: 0700   Not tainted  (2.6.35-440)
MSR: 00029000 <EE,ME,CE>  CR: 42000028  XER: 00000000
TASK = 80301300[0] 'swapper' THREAD: 8031a000
GPR00: 000005c4 9fff3ea0 80301300 00000000 00000004 00000000 2f000000 9dbe45b0 
GPR08: 00000001 9dabf620 ac1ffe02 00000001 24000084 10019670 03712904 00002000 
GPR16: 00000000 d0014b51 00000001 000000ff fffff9f4 00000003 8029228c 00100100 
GPR24: 9dabf6e0 9d429800 00000800 9c5fe098 00000000 9c5fe084 9dabf620 9f2fff00 
NIP [801c74c8] skb_pull+0x2c/0x40
LR [a964a1bc] 0xa964a1bc [ipgre@0xa964a000]
Call Trace:
[9fff3ea0] [00000003] 0x3 (unreliable)
[9fff3ec0] [a963f0e4] register_gre_proto+0xe4/0x148 [gre@0xa963f000]
[9fff3ed0] [801f8468] ip_local_deliver_finish+0x130/0x25c
[9fff3ef0] [801f7df8] ip_rcv_finish+0x138/0x3b8
[9fff3f10] [801d10fc] __netif_receive_skb+0x424/0x474
[9fff3f50] [801d11e0] process_backlog+0x94/0x144
[9fff3f80] [801d1548] net_rx_action+0xa4/0x144
[9fff3fb0] [80038ad0] __do_softirq+0xb8/0x134
[9fff3ff0] [8000de38] call_do_softirq+0x14/0x24
[8031be80] [80003b7c] do_softirq+0x74/0x80
[8031bea0] [80038c14] irq_exit+0x60/0x70
[8031beb0] [8000aac0] timer_interrupt+0xf8/0x118
[8031bed0] [8000eab4] ret_from_except+0x0/0x18
--- Exception: 901 at ppc44x_idle+0x10/0x20
    LR = cpu_idle+0x84/0xd4
[8031bf90] [800075ac] cpu_idle+0xd0/0xd4 (unreliable)
[8031bfb0] [800019d8] rest_init+0x64/0x74
[8031bfc0] [802d972c] start_kernel+0x2a4/0x2b8
[8031bff0] [80000060] _start+0x60/0x9c
Instruction dump:
4e800020 80030050 7c691b78 38600000 7f840040 4d9d0020 81690054 7c040050 
90090050 7d6b0010 7d6b5910 7d6b00d0 <0f0b0000> 806900b8 7c632214 906900b8 
Kernel panic - not syncing: Fatal exception in interrupt

panicSaver: dumping panic to flash
flash: erase 10
flash: prg 10
flash: prg err 0
Rebooting in 1 seconds..

RouterBOOT booter 3.02

RouterBoard 1200

CPU frequency: 666 MHz
  Memory size: 512 MiB
    NAND size:  64 MiB

Press any key within 2 seconds to enter setup..

loading kernel from nand... OK
setting up elf image... OK
jumping to kernel code
It really looks the same like my previous post.. but this is from the last time it crashed

So what is broken? anybody? :(
 
Maescool
just joined
Posts: 10
Joined: Thu Nov 25, 2010 3:31 am
Location: Belgium
Contact:

Re: RB1200 ROS 5.0 - up to 5.5 - randomly reboots (BGPv4 and

Mon Apr 08, 2013 6:56 pm

It seems a IPSEC/GRE tunnel bug, as soon as I disable this, the Router is stable again..
It was running this config stable for over a year though..

Who is online

Users browsing this forum: Majestic-12 [Bot] and 73 guests