Community discussions

MUM Europe 2020
 
butteryak
newbie
Topic Author
Posts: 40
Joined: Fri Sep 12, 2008 1:16 am

Can connect to PPTP on LAN but not WAN?

Thu Jul 28, 2011 9:47 am

So i can connect to the PPTP server from my LAN, to my LAN address 192.168.1.1, but I cannot seem to connect from the outside world to my WAN address. Disabled firewall doesnt seem to make a difference. I followed directions in mikrotik documentation closely. This is basically for being able to connect to office network from laptop.

Here is essentially what I did:



ppp secret> add name=ex service=pptp password=lkjrht
local-address=192.168.1.X remote-address=192.168.1.X

interface pptp-server>add name=test user=testXXX

interace pptp-server server> set enabled=yes

set etherLAN arp=proxy-arp

initially could not connect from LAN either, but added firewall rules:

/ip firewall filter
add chain=input protocol=tcp dst-port=1723 action=accept
add chain=input protocol=gre action=accept

So yeah, when attemting to connect to PPTP server with the server address set as 192.168.1.1 connects just fine. but attempting to do the same with my WAN address from outside and I get nada. I'm not even seeing any hits in my logs, nothing....completely disabling firewall, still nothing.

What might I be missing?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5962
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Can connect to PPTP on LAN but not WAN?

Fri Jul 29, 2011 1:43 pm

* server address is not reachable from that location
* firewall drops packets
* your ISP is blocking pptp
...
 
butteryak
newbie
Topic Author
Posts: 40
Joined: Fri Sep 12, 2008 1:16 am

Re: Can connect to PPTP on LAN but not WAN? or L2TP

Wed Aug 17, 2011 7:19 pm

Doesnt look like any of those are affecting the connection. Disabling the firewall has no effect. Checked with ISP, nothing is blocked(I previously had a cisco router with VPN, had no problems connecting). Also shouldn't I be able to connect to my VPN on the WAN port from my LAN? any other thoughts?
 
derr12
Member
Member
Posts: 411
Joined: Fri May 01, 2009 11:32 pm

Re: Can connect to PPTP on LAN but not WAN?

Sat Aug 20, 2011 3:29 am

On mine in the ppp-profile my pptp server points to, i have not specified a local or remote address and it works. Actually after looking, my pptp profile is just using the default-encryption profile and works from wherever.


1 * name="default-encryption" use-compression=default
use-vj-compression=default use-encryption=yes only-one=default
change-tcp-mss=yes
 
User avatar
dasiu
Trainer
Trainer
Posts: 232
Joined: Fri Jan 30, 2009 11:41 am
Location: Reading, UK
Contact:

Re: Can connect to PPTP on LAN but not WAN?

Sat Aug 20, 2011 10:15 am

Have you tried to disconnect the pptp server from the WAN, and connect your other device there with an IP address of your provider (gateway)? I would check that. And - also - I would use torch, sniff, debug - to see if there is anything going :).
 
eXtremer
Frequent Visitor
Frequent Visitor
Posts: 90
Joined: Fri Nov 26, 2010 10:33 am

Re: Can connect to PPTP on LAN but not WAN?

Wed Nov 14, 2012 3:00 pm

I have exactly the same issue, can connect to PPTP Server from LAN IP but can't connect from WAN (my hope PC) there aren't any packet hits on the firewall, what could be the problem ?

1. The provider isn't blocking any ports
2. I can RDP through mikrotik (so the WAN interface is reachable on mikrotik)
3. I don't any dropped packets on the firewall

Help needed. Thank you.

Who is online

Users browsing this forum: Amakesh, bpwl, JamesT42, mkx, zeynelyenici and 81 guests