Community discussions

MikroTik App
 
cicserver
Member
Member
Topic Author
Posts: 303
Joined: Sun Jul 24, 2011 12:04 pm

LAN DNS working , PPPoE DNS not !

Thu Aug 18, 2011 12:33 pm

Hi,

I have following setup.

Hotspot is configured on RB750, It does not offer internet services , just to redirect users to my local Radius billing web page.. So when users comes on LAN, he gets ip , gw and dns from rb750.

2nd Mikrotik is configured as pppoe server, when users dials he gets pppoe poool ip and my linux box dns server ip. But the problem is all users DNS requests goes to rb750, which i don't want.

I want to force pppoe users to use my Linux BOX as Default DNS server ? How to do this ?
 
User avatar
aacable
Member
Member
Posts: 431
Joined: Wed Sep 17, 2008 11:58 am
Location: ISLAMIC Republic of PAKISTAN
Contact:

Re: LAN DNS working , PPPoE DNS not !

Thu Aug 18, 2011 1:00 pm

Hi,

I have following setup.

Hotspot is configured on RB750, It does not offer internet services , just to redirect users to my local Radius billing web page.. So when users comes on LAN, he gets ip , gw and dns from rb750.
2nd Mikrotik is configured as pppoe server, when users dials he gets pppoe poool ip and my linux box dns server ip. But the problem is all users DNS requests goes to rb750, which i don't want.
I want to force pppoe users to use my Linux BOX as Default DNS server ? How to do this ?
Following code will send all DNS traffic coming from your client to your desired DNS Server.
/ip firewall nat add action=dst-nat chain=dstnat disabled=no dst-port=53 in-interface=ether1 protocol=udp to-addresses=192.168.2.4 to-ports=53

Also if you want to redirect all dns traffic to local mikrotik dns server, you can use.
/ip firewall nat add protocol=udp dst-port=53 action=redirect to-ports=53
/ip firewall nat add protocol=tcp dst-port=53 action=redirect to-ports=53
_____________
Regard's

Syed Jahanzaib
Web: http://aacable.wordpress.com
Email: aacable [at] hotmail.com

Who is online

Users browsing this forum: ezy, RWH70, timotei and 51 guests