Community discussions

 
andrijco
just joined
Topic Author
Posts: 17
Joined: Mon Aug 23, 2010 3:45 am

DHCP problem

Mon Sep 19, 2011 10:32 am

Successfully upgraded to 5.7 x86 intel core i5 - 2 days up with no problems


i started notice this since RC versions of ros 5
and unfortunately this problem persist in 5.7 version =(

so after reboot my system starts normally , but all or few dhcp servers is marked red.

i try to change configuration but this changes take no effect, so i try to disable ip address that belong to that red marked(invalid) dhcp server(interface).

after i enable that ip address again - dhcp starts functioning again + red marker goes away!

so tell me guys , it's common problem ?

if yes , when it will be fixed ? (or at least forward me to corresponding topic )
if no , remind me where i have to send support.rif file ?

Dear developers please help me
it's nothing critical but after every upgrade/reboot i forget to re-enable that dhcp servers
 
User avatar
martini
Member Candidate
Member Candidate
Posts: 296
Joined: Tue Dec 21, 2004 12:13 am

Re: DHCP problem

Mon Sep 19, 2011 3:30 pm

are you use bridge ? post you dhcp config.
Its problem was in beta version, but in RC all ok, more than 300 DHCP servers works ok
 
andrijco
just joined
Topic Author
Posts: 17
Joined: Mon Aug 23, 2010 3:45 am

Re: DHCP problem

Mon Sep 19, 2011 5:08 pm

it's multi-purpose router
i use PPP VPN DHCP static-routing BGP VLAN KVM
and also bridge , but not for networks that dhcp servers is in

please tell me what part of config i need to export here
because full config is realy huge
 
User avatar
martini
Member Candidate
Member Candidate
Posts: 296
Joined: Tue Dec 21, 2004 12:13 am

Re: DHCP problem

Mon Sep 19, 2011 8:44 pm

dhcp server configured on bridge interface ? or on interface that included in bridge ?
 
andrijco
just joined
Topic Author
Posts: 17
Joined: Mon Aug 23, 2010 3:45 am

Re: DHCP problem

Tue Sep 20, 2011 2:18 am

none of the above =(

topology of all dhcp servers
ethernet ===> vlan1 ===> <=dhcp-server

topology of bridge i use
ethernet ===> vlan2 ===> BRIDGE <=== eoip tunnel
 
User avatar
martini
Member Candidate
Member Candidate
Posts: 296
Joined: Tue Dec 21, 2004 12:13 am

Re: DHCP problem

Tue Sep 20, 2011 10:18 pm

do you have any ip address on dhcp vlan ?
 
andrijco
just joined
Topic Author
Posts: 17
Joined: Mon Aug 23, 2010 3:45 am

Re: DHCP problem

Wed Sep 21, 2011 4:15 pm

yes

ip
dhcp-server
/ip dhcp-server> export
/ip dhcp-server
add add-arp=yes address-pool=185 always-broadcast=yes authoritative=yes \
disabled=no interface=vlan185 lease-time=1d name=185
add add-arp=yes address-pool=3001 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3001 lease-time=1d name=\
3001
add add-arp=yes address-pool=3002 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3002 lease-time=1d name=\
3002
add add-arp=yes address-pool=3003 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3003 lease-time=1d name=\
3003
add add-arp=yes address-pool=3004 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3004 lease-time=1d name=\
3004
add add-arp=yes address-pool=3005 always-broadcast=yes authoritative=yes \
bootp-lease-time=lease-time bootp-support=dynamic disabled=no interface=\
vlan3005 lease-time=1d name=3005
add add-arp=yes address-pool=3006 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3006 lease-time=1d name=\
3006
add add-arp=yes address-pool=3007 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3007 lease-time=1d name=\
3007
add add-arp=yes address-pool=3010 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3010 lease-time=1d name=\
3010
add add-arp=yes address-pool=3011 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3011 lease-time=1d name=\
3011
add add-arp=yes address-pool=3012 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3012 lease-time=1d name=\
3012
add add-arp=yes address-pool=3014 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3014 lease-time=1d name=\
3014
add add-arp=yes address-pool=3015 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3015 lease-time=3d name=\
3015
add add-arp=yes address-pool=3016 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3016 lease-time=1d name=\
3016
add add-arp=yes address-pool=3017 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3017 lease-time=1d name=\
3017
add add-arp=yes address-pool=3018 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3018 lease-time=1d name=\
3018
add add-arp=yes address-pool=3019 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3019 lease-time=1d name=\
3019
add add-arp=yes address-pool=3020 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3020 lease-time=1d name=\
3020
add add-arp=yes address-pool=3021 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3021 lease-time=1d name=\
3021
add add-arp=yes address-pool=3022 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3022 lease-time=1d name=\
3022
add add-arp=yes address-pool=3023 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3023 lease-time=1d name=\
3023
add add-arp=yes address-pool=3013 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3013 lease-time=1d name=\
3013
add add-arp=yes address-pool=3024 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3024 lease-time=1d name=\
3024
add add-arp=yes address-pool=3025 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3025 lease-time=1d name=\
3025
add add-arp=yes address-pool=3026 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3026 lease-time=1d name=\
3026
add add-arp=yes address-pool=3028 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3027 lease-time=1d name=\
3027
add add-arp=yes address-pool=3029 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3029 lease-time=1d name=\
3029
add add-arp=yes address-pool=449 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan449 lease-time=1d name=449
add add-arp=yes address-pool=355-2 always-broadcast=yes authoritative=yes \
disabled=no interface=vlan355 lease-time=1d name=335
add add-arp=yes address-pool=3030 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3030 lease-time=1d name=\
3030
add add-arp=yes address-pool=566 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan566 lease-time=1d name=566
add add-arp=yes address-pool=3032 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3032 lease-time=1d name=\
3032
add add-arp=yes address-pool=3008 always-broadcast=yes authoritative=yes \
disabled=no interface=vlan3008 lease-time=3d name=3008
add add-arp=yes address-pool=3033 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3033 lease-time=1d name=\
3033
add add-arp=yes address-pool=3034 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3034 lease-time=1d name=\
3034
add add-arp=yes address-pool=3035 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3035 lease-time=1d name=\
3035
add add-arp=yes address-pool=3036 always-broadcast=yes authoritative=yes \
bootp-support=static disabled=no interface=vlan3036 lease-time=1d name=\
3036
add add-arp=yes address-pool=3027 always-broadcast=yes bootp-lease-time=\
lease-time bootp-support=dynamic disabled=no interface=vlan3028 \
lease-time=1d name=3028
add add-arp=yes address-pool=649 always-broadcast=yes authoritative=yes \
disabled=no interface=vlan649 lease-time=1d name=649
add add-arp=yes address-pool=3037 always-broadcast=yes authoritative=yes \
disabled=no interface=vlan3037 lease-time=1d name=3037
add add-arp=yes address-pool=3038 always-broadcast=yes authoritative=yes \
disabled=no interface=vlan3038 lease-time=3d name=3038
/ip dhcp-server option
add code=249 name=185 value="0x15AC1F08AC1F000414AC1F10AC1F000413AC1F20AC1F000\
412AC1F40AC1F000411AC1F80AC1F0004"
add code=249 name=3001 value="0x15AC1F00AC1F0A0117AC1F08AC1F0A0118AC1F0BAC1F0A\
0116AC1F0cAC1F0A0114AC1F10AC1F0A0113AC1F20AC1F0A0112AC1F40AC1F0A0111AC1F80\
AC1F0A01"
add code=249 name=3002 value="0x15AC1F00AC1F0B0117AC1F08AC1F0B0118AC1F0AAC1F0B\
0116AC1F0CAC1F0B0114AC1F10AC1F0B0113AC1F20AC1F0B0112AC1F40AC1F0B0111AC1F80\
AC1F0B01"
add code=249 name=3003 value="0x15AC1F00AC1F0C0116AC1F08AC1F0C0118AC1F0DAC1F0C\
0115AC1F0EAC1F0C0114AC1F10AC1F0C0113AC1F20AC1F0C0112AC1F40AC1F0C0111AC1F80\
AC1F0C01"
add code=249 name=3004 value="0x15AC1F00AC1F0D0116AC1F08AC1F0D0118AC1F0CAC1F0D\
0115AC1F0EAC1F0D0114AC1F10AC1F0D0113AC1F20AC1F0D0112AC1F40AC1F0D0111AC1F80\
AC1F0D01"
add code=249 name=3005 value="0x15AC1F00AC1F0E0116AC1F08AC1F0E0117AC1F0CAC1F0E\
0118AC1F0FAC1F0E0114AC1F10AC1F0E0113AC1F20AC1F0E0112AC1F40AC1F0E0111AC1F80\
AC1F0E01"
add code=249 name=3006 value="0x15AC1F00AC1F0F0116AC1F08AC1F0F0117AC1F0CAC1F0F\
0118AC1F0EAC1F0F0114AC1F10AC1F0F0113AC1F20AC1F0F0112AC1F40AC1F0F0111AC1F80\
AC1F0F01"
add code=249 name=3007 value="0x14AC1F00AC1F100118AC1F11AC1F100117AC1F12AC1F10\
0116AC1F14AC1F100115AC1F18AC1F100113AC1F20AC1F100112AC1F40AC1F100111AC1F80\
AC1F1001"
add code=249 name=3008 value="0x14AC1F00AC1F110118AC1F10AC1F110117AC1F12AC1F11\
0116AC1F14AC1F110115AC1F18AC1F110113AC1F20AC1F110112AC1F40AC1F110111AC1F80\
AC1F1101"
add code=249 name=3009 value="0x14AC1F00AC1F120117AC1F10AC1F120118AC1F13AC1F12\
0116AC1F14AC1F120115AC1F18AC1F120113AC1F20AC1F120112AC1F40AC1F120111AC1F80\
AC1F1201"
add code=249 name=3010 value="0x14AC1F00AC1F130117AC1F10AC1F130118AC1F12AC1F13\
0116AC1F14AC1F130115AC1F18AC1F130113AC1F20AC1F130112AC1F40AC1F130111AC1F80\
AC1F1301"
add code=249 name=3011 value="0x14AC1F00AC1F140116AC1F10AC1F140118AC1F15AC1F14\
0117AC1F16AC1F140115AC1F1FAC1F140113AC1F20AC1F140112AC1F40AC1F140111AC1F80\
AC1F1401"
add code=249 name=3012 value="0x14AC1F00AC1F150116AC1F10AC1F150118AC1F14AC1F15\
0117AC1F16AC1F150115AC1F18AC1F150113AC1F20AC1F150112AC1F40AC1F150111AC1F80\
AC1F1501"
add code=249 name=3013 value="0x14AC1F00AC1F170116AC1F10AC1F170117AC1F14AC1F17\
0118AC1F16AC1F170115AC1F18AC1F170113AC1F20AC1F170112AC1F40AC1F170111AC1F80\
AC1F1701"
add code=249 name=3014 value="0x14AC1F00AC1F180115AC1F10AC1F180118AC1F19AC1F18\
0117AC1F1AAC1F180116AC1F1CAC1F180113AC1F20AC1F180112AC1F40AC1F180111AC1F80\
AC1F1801"
add code=249 name=3015 value="0x14AC1F00AC1F190115AC1F10AC1F190118AC1F18AC1F19\
0117AC1F1AAC1F190116AC1F1CAC1F190113AC1F20AC1F190112AC1F40AC1F190111AC1F80\
AC1F1901"
add code=249 name=3016 value="0x14AC1F00AC1F1A0115AC1F08AC1F1A0117AC1F18AC1F1A\
0118AC1F1BAC1F1A0116AC1F1CAC1F1A0113AC1F20AC1F1A0112AC1F40AC1F1A0111AC1F80\
AC1F1A01"
add code=249 name=3017 value="0x14AC1F00AC1F1B0115AC1F08AC1F1B0117AC1F18AC1F1B\
0118AC1F1AAC1F1B0116AC1F1CAC1F1B0113AC1F20AC1F1B0112AC1F40AC1F1B0111AC1F80\
AC1F1B01"
add code=249 name=3018 value="0x14AC1F00AC1F1C0115AC1F10AC1F1C0116AC1F18AC1F1C\
0118AC1F1DAC1F1C0117AC1F1EAC1F1C0113AC1F20AC1F1C0112AC1F40AC1F1C0111AC1F80\
AC1F1C01"
add code=249 name=3019 value="0x14AC1F00AC1F1D0115AC1F10AC1F1D0116AC1F18AC1F1D\
0118AC1F1CAC1F1D0117AC1F1EAC1F1D0113AC1F20AC1F1D0112AC1F40AC1F1D0111AC1F80\
AC1F1D01"
add code=249 name=3020 value="0x14AC1F00AC1F1E0115AC1F10AC1F1E0116AC1F18AC1F1E\
0117AC1F1CAC1F1E0118AC1F1FAC1F1E0113AC1F20AC1F1E0112AC1F40AC1F1E0111AC1F80\
AC1F1E01"
add code=249 name=3021 value="0x14AC1F00AC1F1F0115AC1F10AC1F1F0116AC1F18AC1F1F\
0117AC1F1CAC1F1F0118AC1F1EAC1F1F0113AC1F20AC1F1F0112AC1F40AC1F1F0111AC1F80\
AC1F1F01"
add code=249 name=3022 value="0x13AC1F00AC1F200118AC1F21AC1F200117AC1F22AC1F20\
0116AC1F24AC1F200115Ac1F28AC1F200114AC1F30AC1F200112AC1F40AC1F200111AC1F80\
AC1F2001"
add code=249 name=3023 value="0x13AC1F00AC1F210118AC1F20AC1F210117AC1F22AC1F21\
0116AC1F24AC1F210115Ac1F28AC1F210114AC1F30AC1F210112AC1F40AC1F210111AC1F80\
AC1F2101"
add code=249 name=3024 value="0x13AC1F00AC1F220117AC1F20AC1F220118AC1F23AC1F22\
0116AC1F24AC1F220115AC1F28AC1F220114AC1F31AC1F220112AC1F40AC1F220111AC1F80\
AC1F2201"
add code=249 name=3025 value="0x13AC1F00AC1F230117AC1F20AC1F230118AC1F22AC1F23\
0116AC1F24AC1F230115AC1F28AC1F230114AC1F30AC1F230112AC1F40AC1F230111AC1F80\
AC1F2301"
add code=249 name=3026 value="0x13AC1F00AC1F240116AC1F20AC1F240118AC1F25AC1F24\
0117AC1F26AC1F240115AC1F28AC1F240114AC1F30AC1F240112AC1F40AC1F240111AC1F80\
AC1F2401"
add code=249 name=3027 value="0x13AC1F00AC1F250116AC1F20AC1F250118AC1F24AC1F25\
0117AC1F26AC1F250115AC1F28AC1F250114AC1F30AC1F250112AC1F40AC1F250111AC1F80\
AC1F2501"
add code=249 name=3028 value="0x13AC1F00AC1F260116AC1F20AC1F260117AC1F24AC1F26\
0118AC1F27AC1F260115AC1F28AC1F260114AC1F30AC1F260112AC1F40AC1F260111AC1F80\
AC1F2601"
add code=249 name=3029 value="0x13AC1F00AC1F270116AC1F20AC1F270117AC1F24AC1F27\
0118AC1F26AC1F270115AC1F28AC1F270114AC1F30AC1F270112AC1F40AC1F270111AC1F80\
AC1F2701"
add code=121 name=185-2 value="0x15AC1F08AC1F000414AC1F10AC1F000413AC1F20AC1F0\
00412AC1F40AC1F000411AC1F80AC1F0004"
add code=249 name=3036 value=0x18AC1F16AC1F3001
/ip dhcp-server config
set store-leases-disk=immediately
/ip dhcp-server network
add address=172.31.0.0/21 boot-file-name=pxelinux.0 dhcp-option=185 \
dns-server=195.211.84.1,8.8.8.8 domain=wenet.lviv.ua gateway=172.31.0.4 \
next-server=172.31.2.2 ntp-server=172.31.0.4
add address=172.31.10.0/24 dhcp-option=3001 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.10.1
add address=172.31.11.0/24 dhcp-option=3002 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.11.1
add address=172.31.12.0/24 dhcp-option=3003 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.12.1
add address=172.31.13.0/24 dhcp-option=3004 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.13.1
add address=172.31.14.0/24 boot-file-name=pxelinux.0 dhcp-option=3005 \
dns-server=195.211.84.1,8.8.8.8 domain=wenet.lviv.ua gateway=172.31.14.1 \
next-server=172.31.22.1
add address=172.31.15.0/24 dhcp-option=3006 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.15.1
add address=172.31.16.0/24 dhcp-option=3007 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.16.1
add address=172.31.17.0/24 dhcp-option=3008 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.17.1
add address=172.31.18.0/24 dhcp-option=3009 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.18.1
add address=172.31.19.0/24 dhcp-option=3010 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.19.1
add address=172.31.20.0/24 dhcp-option=3011 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.20.1
add address=172.31.21.0/24 dhcp-option=3012 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.21.1
add address=172.31.22.0/24 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.22.2
add address=172.31.23.0/24 dhcp-option=3013 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.23.1
add address=172.31.24.0/24 dhcp-option=3014 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.24.1
add address=172.31.25.0/24 dhcp-option=3015 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.25.1
add address=172.31.26.0/24 dhcp-option=3016 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.26.1
add address=172.31.27.0/24 dhcp-option=3017 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.27.1
add address=172.31.28.0/24 dhcp-option=3018 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.28.1
add address=172.31.29.0/24 dhcp-option=3019 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.29.1
add address=172.31.30.0/24 dhcp-option=3020 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.30.1
add address=172.31.31.0/24 dhcp-option=3021 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.31.1
add address=172.31.32.0/24 dhcp-option=3022 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.32.1
add address=172.31.33.0/24 dhcp-option=3023 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.33.1
add address=172.31.34.0/24 dhcp-option=3024 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.34.1
add address=172.31.35.0/24 dhcp-option=3025 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.35.1
add address=172.31.36.0/24 dhcp-option=3026 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.36.1
add address=172.31.37.0/24 dhcp-option=3027 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.37.1
add address=172.31.38.0/24 dhcp-option=3028 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.38.1
add address=172.31.39.0/24 dhcp-option=3029 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.39.1
add address=172.31.40.0/24 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.40.1
add address=172.31.41.0/24 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.41.1
add address=172.31.42.0/24 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.42.1
add address=172.31.43.0/24 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.43.1
add address=172.31.44.0/24 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.44.1
add address=172.31.45.0/24 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.45.1
add address=172.31.46.0/24 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.46.1
add address=172.31.47.0/24 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.47.1
add address=172.31.48.0/24 dhcp-option=3036 dns-server=195.211.84.1,8.8.8.8 \
domain=wenet.lviv.ua gateway=172.31.48.1
add address=172.31.49.0/24 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.49.1
add address=172.31.50.0/24 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.50.1
add address=172.31.52.0/22 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.52.1
add address=172.31.56.0/24 dns-server=195.211.84.1,8.8.8.8 domain=\
wenet.lviv.ua gateway=172.31.56.1
/ip dhcp-server>
 
User avatar
martini
Member Candidate
Member Candidate
Posts: 296
Joined: Tue Dec 21, 2004 12:13 am

Re: DHCP problem

Wed Sep 21, 2011 5:33 pm

привіт Львову ))
Всі настройки нормальні, спробуй з нуля настроїти ДХЦП, (видалити старі повністю) , на бета версії мені допомогало.
 
mer
just joined
Posts: 7
Joined: Wed Sep 21, 2011 11:55 pm

Re: DHCP problem

Thu Sep 22, 2011 12:16 am

I have same problem with dhcp-server
My router is 5.7, i3 CPU /3 lans,ppp with radius, & 50 vlans each vlan have dhcp-server & ip pool

after rebooting few or all dhcp-server mark as red

How can i fix the problem
 
spork
just joined
Posts: 11
Joined: Wed Jun 24, 2009 7:59 pm

Re: DHCP problem

Wed Oct 05, 2011 2:47 pm

I came Gross the same problem.
DHCP doesnt work and CPU is fully 100% occupied
This happens only when DHCP works with VLAN,which is above bridge interface.

RoS: 5.6 - ok
RoS: 5.7 - dhcp not working

HW: RB433AH
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: DHCP problem

Wed Oct 05, 2011 3:17 pm

problem is known (how you could have found on the forum) and will be fixed in 5.8 when released.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: DHCP problem

Wed Oct 05, 2011 4:25 pm

I had the problem with invalid DHCP servers after reboot on v4.2 or something on the single router. after upgrade to v5.4 they appeared invalid again, but next reboot fixed things - no problem since then...
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
andrijco
just joined
Topic Author
Posts: 17
Joined: Mon Aug 23, 2010 3:45 am

Re: DHCP problem

Wed Oct 05, 2011 10:32 pm

bypassed problem via dhcp relay and L3-switch static routing
waiting for new release and new minor bugs

bay the way where i can post new futures suggestions ?
 
mer
just joined
Posts: 7
Joined: Wed Sep 21, 2011 11:55 pm

Re: DHCP problem

Mon Oct 10, 2011 1:10 pm

in v4.0 DHCP working normal :-( ,but in 4.1 up to 5.7 not working normal

Who is online

Users browsing this forum: MSN [Bot] and 62 guests