Community discussions

MUM Europe 2020
 
User avatar
awacenter
Member Candidate
Member Candidate
Topic Author
Posts: 200
Joined: Thu Dec 09, 2004 12:58 pm
Location: Castellón
Contact:

Multicast strikes back

Sat Sep 24, 2011 1:04 pm

Hi forum!

I just get into multicasting on routeros so I have limited knowledge. I am trying to set up such simple network:

VLC SERVER (rtp://224.0.1.20:5004) ----- VLC CLIENT [Works fine!!]
VLC SERVER (rtp://224.0.1.20:5004) ----- [ether1]ROUTEROSv3.3[ether2] ----- VLC CLIENT [BADDD!!!]

VLC SERVER IP-DefaultGW: 10.0.2.2/24 - 10.0.2.1

RouterOS ether1: 10.0.2.1/24
RouterOS ether2: 10.0.0.2/24
No NAT, No masquerade, No filter rules, No more routes
/routing pim interface add all
/routing pim rp add address 10.0.0.2

VLC CLIENT IP-DefaultGW: 10.0.0.1/24 - 10.0.0.2

I just follow the Mikrotik Multicast Sample but making it simplier.

When I play VLC on server I can see traffic at ether1 of RouterOS and half of that traffic on ether2 but nothing at VLC Client. I can see VLCServer joined at join list.

I guess this is the simpliest setup I could build up and still not working. I have tried to accept input and output streams and also to make NAT forwarding 5004 but still nothing.

Any ideas????

Thanks in advance.
Nando.
ImageImage
 
changeip
Forum Guru
Forum Guru
Posts: 3804
Joined: Fri May 28, 2004 5:22 pm

Re: Multicast strikes back

Sun Sep 25, 2011 6:27 am

routeros 3.3 is anchient and has been improved much since then. at least 3.30 is stable in that branch. you should upgrade to 4.17 or 5.7 and try again.
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
User avatar
Belyivulk
Member Candidate
Member Candidate
Posts: 285
Joined: Mon Mar 06, 2006 10:53 pm
Location: Whangarei, New Zealand
Contact:

Re: Multicast strikes back

Sun Sep 25, 2011 6:28 am

I agree with ChangeIP, if you can afford it i would suggest going to 5.7; even in ROS 4.xx we had some minor issues with multicast; and MT have done an enormous amount of work on ROS in 5.xx; so do that if you can!
 
User avatar
awacenter
Member Candidate
Member Candidate
Topic Author
Posts: 200
Joined: Thu Dec 09, 2004 12:58 pm
Location: Castellón
Contact:

Re: Multicast strikes back

Sun Sep 25, 2011 10:44 am

Thanks for answering!!

Sorry I sais v3.3 but I meant 3.30. I'll try to upgrade to v5 though. So, do you think my configuration is fine?

Thanks again!
ImageImage
 
User avatar
awacenter
Member Candidate
Member Candidate
Topic Author
Posts: 200
Joined: Thu Dec 09, 2004 12:58 pm
Location: Castellón
Contact:

Re: Multicast strikes back

Sun Sep 25, 2011 12:28 pm

Hi again!

I just replaced routerosv3.30 by a new routerosv5.7 and happens exactly the same. I attached a shot.

Thanks!

Image
ImageImage
 
User avatar
awacenter
Member Candidate
Member Candidate
Topic Author
Posts: 200
Joined: Thu Dec 09, 2004 12:58 pm
Location: Castellón
Contact:

Re: Multicast strikes back

Wed Sep 28, 2011 9:45 am

It finally worked!! The problem was the TTL of the VLC Server which was set up to -1 so it takes the SO default, probably 1, teherfore the packets were being discarded on the router.

Regards and thanks for your help.
Nando.
ImageImage

Who is online

Users browsing this forum: lweidig, marek263, MSN [Bot], rioven and 59 guests