Community discussions

MikroTik App
 
drzen
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 82
Joined: Thu Aug 09, 2007 3:59 pm
Location: Pordenone, Italy
Contact:

Windows 2008 Virtual IP and hotspot

Thu Oct 20, 2011 3:36 pm

Hi,

anyone have experiences with windows 2008 terminal service Virtual IP and mikrotik hotspot functionality?

Thanks in advance
v.
(Rate my posts? If you want... no pressure...)
 
navidrasi
just joined
Posts: 9
Joined: Sun Sep 18, 2011 11:22 pm

Re: Windows 2008 Virtual IP and hotspot

Thu Oct 27, 2011 1:56 pm

hi
i had installed RDS virtual ip and mikrotik
i had some difficulties with ARP and some Problem with DHCP
but i had finally get it to work
tel me if i can help you ?
 
drzen
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 82
Joined: Thu Aug 09, 2007 3:59 pm
Location: Pordenone, Italy
Contact:

Re: Windows 2008 Virtual IP and hotspot

Thu Oct 27, 2011 1:59 pm

Any help is good.
DHCP work fine... seem an ARP problem.

v.
(Rate my posts? If you want... no pressure...)
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Windows 2008 Virtual IP and hotspot

Thu Oct 27, 2011 3:23 pm

Try disabling the 1:1 NAT on the hotspot. That will arp poison the localnet if you don't disable it.
/ip hotspot
print
set X address-pool=none
 
drzen
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 82
Joined: Thu Aug 09, 2007 3:59 pm
Location: Pordenone, Italy
Contact:

Re: Windows 2008 Virtual IP and hotspot

Thu Oct 27, 2011 3:27 pm

Try disabling the 1:1 NAT on the hotspot. That will arp poison the localnet if you don't disable it.
/ip hotspot
print
set X address-pool=none
Just done! But no effect.
TS clients receive the second ip address but when I try to surf the web I can not (page expired).
If I disable hotspot all go right.

v.
Last edited by drzen on Thu Oct 27, 2011 3:40 pm, edited 1 time in total.
(Rate my posts? If you want... no pressure...)
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Windows 2008 Virtual IP and hotspot

Thu Oct 27, 2011 3:31 pm

Try disabling the 1:1 NAT on the hotspot. That will arp poison the localnet if you don't disable it.
/ip hotspot
print
set X address-pool=none
Just done! But no effect.

v.
No effect? What are you trying to do? Windows 2008 computer won't ping? Can't ping from another localnet computer? Can't ping from the router? Can't ping from the internet?
 
drzen
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 82
Joined: Thu Aug 09, 2007 3:59 pm
Location: Pordenone, Italy
Contact:

Re: Windows 2008 Virtual IP and hotspot

Thu Oct 27, 2011 3:42 pm

Try disabling the 1:1 NAT on the hotspot. That will arp poison the localnet if you don't disable it.
/ip hotspot
print
set X address-pool=none
Just done! But no effect.

v.
No effect? What are you trying to do? Windows 2008 computer won't ping? Can't ping from another localnet computer? Can't ping from the router? Can't ping from the internet?
Sorry for the edit ;-)

TS clients receive the second ip address but when I try to surf the web I can not (page expired). Pings go right (to local network machines).
If I disable hotspot all go right.

v.
(Rate my posts? If you want... no pressure...)
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Windows 2008 Virtual IP and hotspot

Thu Oct 27, 2011 3:51 pm

OK. Check here and insure all is going ok. This is also where you can see the 1:1 NAT work.
/ip hotspot host
The hotspot will stop almost all port services until you login with the web browser on that computer, or bypass the ip/mac in
/ip hotspot ip-binding
add address=x.x.x.x type=bypassed
Same works for the mac address if the ip might be different.

Who is online

Users browsing this forum: boxxed, eguun, mkx and 95 guests