Community discussions

 
ilius168
Member Candidate
Member Candidate
Posts: 255
Joined: Sat Apr 07, 2007 3:54 am

Re: RouterOS v5.8 released

Sun Nov 06, 2011 1:29 am

*) snmp - fixed problem where some rows were missed
in a few tables when walking them;

This one is also not fixed yet. Simple queues do not show up correctly in snmp walk.

+1

*sigh* not upgrading our cores still using 4.17
 
User avatar
winet
Member Candidate
Member Candidate
Posts: 272
Joined: Fri Mar 16, 2007 4:49 pm
Location: Indonesia

Re: RouterOS v5.8 released

Sun Nov 06, 2011 8:06 am

I can't ping my LAN IP after updating to 5.8.
which version u upgraded from? because i think, i have the same problem on v5.7, i still don't upgrade to v5.8 since i see there's a lot of bugs posted here.

i have weird case related to ping of LAN IP.
here's what was my simple configuration:
 router] /interface vlan> pr de
 0 R  name="VLAN-01" mtu=1500 l2mtu=1516 mac-address=00:0C:42:AE:97:4B arp=enabled vlan-id=151 interface=ether3 
      use-service-tag=no

 router] /interface bridge> pr detail 
Flags: X - disabled, R - running 
 0  R name="bridge1" mtu=1500 l2mtu=1516 arp=enabled mac-address=00:0C:42:AE:97:4B protocol-mode=none priority=0x8000 auto-mac=yes 
      admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s transmit-hold-count=6 ageing-time=5m 

 router] /interface bridge port> pr detail 
Flags: X - disabled, I - inactive, D - dynamic 
 0    interface=VLAN-01 bridge=bridge1 priority=0x80 path-cost=1 edge=auto point-to-point=auto external-fdb=auto horizon=none 

 1    interface=ether2 bridge=bridge1 priority=0x80 path-cost=1 edge=auto point-to-point=auto external-fdb=auto horizon=none 

 router] /ip address> pr
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS            NETWORK         INTERFACE                                                                                       
 0   192.168.1.220/24  192.168.17.0    ether3                                                           
 1   [public IP] [public network] bridge1                                                                                         
ping to 192.168.1.220 gets disconnected and connected again every for few seconds. strangely, ping to [public IP] is stable. i triple-checked that there's no IP conflict at all on the local IPs.
subsequently, i change from ether3 into ether1. the problem is solved a little bit(i still get disconnection, but very rare(perhaps once a day, rather than few times in every minute). i hope this gets fixed.

EDIT: i've been dealing with this problem for about 2-3 months, i even replaced the RB750G with a new one, still gives the same result.
 
dbai
just joined
Posts: 14
Joined: Mon Mar 16, 2009 1:22 am
Location: Prague, Czech Republic

Re: RouterOS v5.8 released

Sun Nov 06, 2011 10:38 am

Winet, IP address 192.168.1.220/24 doesn't have network 192.168.17.0. There is something wrong.
 
User avatar
winet
Member Candidate
Member Candidate
Posts: 272
Joined: Fri Mar 16, 2007 4:49 pm
Location: Indonesia

Re: RouterOS v5.8 released

Sun Nov 06, 2011 10:42 am

Winet, IP address 192.168.1.220/24 doesn't have network 192.168.17.0. There is something wrong.
sorry, i copy pasted it and changing everything, only showing examples without revealing the true IPs :lol: it is 17.220 :lol: anyway, if i put the wrong network, it won't connect at all. but in this case, it is connected for a while, and disconnected later, then again, and again.
 
Smrk
just joined
Posts: 1
Joined: Sun Nov 06, 2011 12:52 pm

Re: RouterOS v5.8 released

Sun Nov 06, 2011 1:26 pm

There is some strange ipsec proposals settings behavior in 5.8.
For example:
1) proposal added using winbox or webfig with encr. algorithms=camellia-128 results in
1 name="test" auth-algorithms=sha1 enc-algorithms="" lifetime=30m pfs-group=none
2) proposal added using terminal with enc-algorithm=blowfish results in encr. algorithms=camellia-256 in winbox/webfig
It looks like all ciphers newly added to winbox/webfig in 5.8 (blowfish, camellia-128, camellia-192, camellia-256) are affected.
Tested on RB750 and RB750G.
 
tenenbaum
newbie
Posts: 34
Joined: Sat Oct 30, 2010 6:59 pm

Re: RouterOS v5.8 released

Sun Nov 06, 2011 10:22 pm

I upgraded our router from 5.7 to 5.8 and now I get page not found at /userman

Help.
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: RouterOS v5.8 released

Mon Nov 07, 2011 3:07 am

also appears usermanger and debug logs for usermanager are broke for rb750.

i can't get it to login to the web interface even with a default config and no other settings
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1369
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v5.8 released

Mon Nov 07, 2011 9:10 am

Missing User Manager Package ? :D
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24042
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v5.8 released

Mon Nov 07, 2011 9:26 am

Missing User Manager Package ? :D
It's not missing. It's in the ZIP file as always.
No answer to your question? How to write posts
 
pakjebakmeel
newbie
Posts: 32
Joined: Thu Jul 14, 2011 1:52 pm

Re: RouterOS v5.8 released

Mon Nov 07, 2011 9:29 am

50C is normal, more than 70C is probably start to worry. if you see CPU load, check "/tool profile" menu to see what is consuming it.

yes, there was a bug with 100MHz CPU in previous version of firmware, new one fixes it, you should not see it anymore.

Had this too after the firmware upgrade.. I was running at 680Mhz and reverted to 100Mhz after the upgrade.. Explained why I couldn't get more then 10Mb/s through :-) Almost blaimed my ISP.
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1369
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v5.8 released

Mon Nov 07, 2011 9:39 am

My question was to the previous poster who said his usermanager was not working. He might have forgotten to put in the package and upgraded only RouterOS.
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
User avatar
TrollMan
Member Candidate
Member Candidate
Posts: 168
Joined: Mon Apr 04, 2011 9:25 pm

Re: RouterOS v5.8 released

Mon Nov 07, 2011 12:10 pm

The latest firmware for the RB800, is that 2.30? I get that both in 5.7 and 5.8, but I can see that there are newer firmwares released after that. When a firmware is released, is it generic or device specific?
 
coolex
just joined
Posts: 5
Joined: Mon Nov 07, 2011 11:59 am

Re: RouterOS v5.8 released

Mon Nov 07, 2011 12:13 pm

Hi,
I don't know if I can report problem with MetaRouter in version 5.8 here.

But on boards with architecture mipsbe (i try it on RB750G and RB493G) MetaRouter doesn't boot.

It's writing this:

[Ctrl-A is the prefix key]
execve: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

In version 5.6 it was working.
After downgrade to version 5.7 it's working again.

Any idea?

Thx, Kuba
 
jandafields
Forum Guru
Forum Guru
Posts: 1514
Joined: Mon Sep 19, 2005 6:12 pm

Re: RouterOS v5.8 released

Mon Nov 07, 2011 4:52 pm

The latest firmware for the RB800, is that 2.30? I get that both in 5.7 and 5.8, but I can see that there are newer firmwares released after that. When a firmware is released, is it generic or device specific?
If it isn't in the routeros package, then it isn't available. You can also go to routerboard.com and download the latest firmware for your device manually.
 
arpadffy
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon Jan 17, 2011 1:52 am
Location: Stockholm, Sweden
Contact:

Re: RouterOS v5.8 released

Mon Nov 07, 2011 4:53 pm

Hello,

I am terribly sorry, but seems after upgrade to v5.8 on a RB750 the 6to4 interface does not work any longer
 5  R  ;;; Hurricane Electric IPv6 Tunnel Broker
       name="sit1" type="sit" mtu=1280
[admin@MikroTik] /system package> print
Flags: X - disabled
 #   NAME                                              VERSION                                              SCHEDULED
 0   calea                                             5.8
 1   ntp                                               5.8
 2   system                                            5.8
 3   advanced-tools                                    5.8
 4   hotspot                                           5.8
 5   mpls                                              5.8
 6   multicast                                         5.8
 7   ipv6                                              5.8
 8   dhcp                                              5.8
 9   ups                                               5.8
10   gps                                               5.8
11   security                                          5.8
12   routing                                           5.8
13   routerboard                                       5.8
14   lcd                                               5.8
15   ppp                                               5.8
16   user-manager                                      5.8

Have anybody experienced such a behaviour?
Later tonight I will try to switch back to v5.6 that was previously working perfect.

Any help would be appreciated.

Thank you.

Regards,
Z
 
User avatar
cbrown
Trainer
Trainer
Posts: 1839
Joined: Thu Oct 14, 2010 8:57 pm
Contact:

Re: RouterOS v5.8 released

Mon Nov 07, 2011 6:52 pm

Hi,
I don't know if I can report problem with MetaRouter in version 5.8 here.

But on boards with architecture mipsbe (i try it on RB750G and RB493G) MetaRouter doesn't boot.

It's writing this:

[Ctrl-A is the prefix key]
execve: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

In version 5.6 it was working.
After downgrade to version 5.7 it's working again.

Any idea?

Thx, Kuba
We ran into the same issue. We also dropped back to 5.7
C.Brown

cbrown[at]ravenrocknetworks.com
MTCNA - MTCRE - MTCWE - MTCTCE
MTCSE - TRAINER-0179

Next Training
https://www.cbrown.co/2019/04/08/mtcna-june2019-wv/
 
User avatar
CristianDeluxe
Frequent Visitor
Frequent Visitor
Posts: 53
Joined: Fri Jun 05, 2009 10:59 am
Location: Spain
Contact:

Re: RouterOS v5.8 released

Mon Nov 07, 2011 7:56 pm

Hello,

I am terribly sorry, but seems after upgrade to v5.8 on a RB750 the 6to4 interface does not work any longer
I have 2 mikrotiks with hurricane 6to4 tunnel and v5.8 and are working correctly.
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: RouterOS v5.8 released

Mon Nov 07, 2011 9:31 pm

Missing User Manager Package ? :D

i wish, web interface comes up. just can't log into it period, everything is invalid user name and pw

even from a default config start point
 
jandafields
Forum Guru
Forum Guru
Posts: 1514
Joined: Mon Sep 19, 2005 6:12 pm

Re: RouterOS v5.8 released

Mon Nov 07, 2011 9:34 pm

Missing User Manager Package ? :D

i wish, web interface comes up. just can't log into it period, everything is invalid user name and pw

even from a default config start point
Did you specifically update user manager? When you go to system->packages, does it show usermanager specifically as 5.8?
 
makstex
newbie
Posts: 46
Joined: Fri Mar 27, 2009 6:31 am

Re: RouterOS v5.8 released

Mon Nov 07, 2011 9:50 pm

This error has stretches with the third version!
With the loss of PPP (pptp, l2tp, openvpn) connections - does not delete the IP address automatically.
If it is static, more impossible to establish a connection!
Image
 
nanito3k
just joined
Posts: 1
Joined: Mon Nov 07, 2011 10:19 pm

Re: RouterOS v5.8 released

Mon Nov 07, 2011 10:47 pm

thanks for releasing new version. Are there any wireless/nv2 improvements ?
MikroTik RouterOS version 5.9 will include very significant improvements for NV2 protocol!
Please write to support (support@mikrotik.com) to request prerelease packages for testing.
Ok, this makes me really curious! What are these "significant improvements"? Does it ´harden´ the AP-Client network better against interference related disconnects? The wordings could make us think there was a lot wrong in the present NV2 to be improved?

Since NV2 is my focus to have it working 100% (now it is 98%) on my network in a spectrum filled with NV2 and Airmax and Canopy I really would like to know what these "significant improvements" mean. Don't tease us with the statement only, please bare us a glimpse on what is in the pipeline.

MT, can we than please also have a full improved manual on the use of the different wireless protocols and what the different log messages tell us for each protocol used and in which direction to look in the troubleshooting process depending on the log messages. It would make life a lot easier as all the different messages and their source and possible solution(s) could be summarized in one matrix.
good topic, I'd like more information about wireless enhancements and NV2
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: RouterOS v5.8 released

Mon Nov 07, 2011 10:54 pm

Missing User Manager Package ? :D

i wish, web interface comes up. just can't log into it period, everything is invalid user name and pw

even from a default config start point
Did you specifically update user manager? When you go to system->packages, does it show usermanager specifically as 5.8?

yes, downgrading back to 4.17 and issue is completely gone. im at a loss

this is real simple once you do a default config you should be able to log in with user admin and it just doesn't happen

non of the debug logs work either to show me what the problem is
 
arpadffy
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon Jan 17, 2011 1:52 am
Location: Stockholm, Sweden
Contact:

Re: RouterOS v5.8 released

Tue Nov 08, 2011 10:13 am

I am terribly sorry, but seems after upgrade to v5.8 on a RB750 the 6to4 interface does not work any longer
I have 2 mikrotiks with hurricane 6to4 tunnel and v5.8 and are working correctly.
I went back to v5.6 and the same router with the same config started to work again.
Obviously, there is some problem with v5.8. The packages goes through the 6to4 interface but never reaches the uplink. v5.6 and earlier releases did not have this behaviour.

Is this issue interesting to anybody? Should I send some configurations, logs somewhere for further investigation... or should I wait in silence for v5.9 in hope that it will spontaneously fix this IPv6 issue.
 
netrat
Member
Member
Posts: 403
Joined: Thu Jun 07, 2007 1:16 pm
Location: Virginia

Re: RouterOS v5.8 released

Tue Nov 08, 2011 11:44 am

I am terribly sorry, but seems after upgrade to v5.8 on a RB750 the 6to4 interface does not work any longer
I have 2 mikrotiks with hurricane 6to4 tunnel and v5.8 and are working correctly.
I went back to v5.6 and the same router with the same config started to work again.
Obviously, there is some problem with v5.8. The packages goes through the 6to4 interface but never reaches the uplink. v5.6 and earlier releases did not have this behaviour.

Is this issue interesting to anybody? Should I send some configurations, logs somewhere for further investigation... or should I wait in silence for v5.9 in hope that it will spontaneously fix this IPv6 issue.
I have a HE ipv6 tunnel and am having no problems.
 
jtroybailey
Member Candidate
Member Candidate
Posts: 176
Joined: Thu Oct 07, 2010 10:24 am
Location: Brisbane, Australia

Re: RouterOS v5.8 released

Tue Nov 08, 2011 11:49 am

I am terribly sorry, but seems after upgrade to v5.8 on a RB750 the 6to4 interface does not work any longer
I have 2 mikrotiks with hurricane 6to4 tunnel and v5.8 and are working correctly.
I went back to v5.6 and the same router with the same config started to work again.
Obviously, there is some problem with v5.8. The packages goes through the 6to4 interface but never reaches the uplink. v5.6 and earlier releases did not have this behaviour.

Is this issue interesting to anybody? Should I send some configurations, logs somewhere for further investigation... or should I wait in silence for v5.9 in hope that it will spontaneously fix this IPv6 issue.
I have 5 x 6to4 tunnels up, I suggest creating a new post with as much details as possible.
 
User avatar
winet
Member Candidate
Member Candidate
Posts: 272
Joined: Fri Mar 16, 2007 4:49 pm
Location: Indonesia

Re: RouterOS v5.8 released

Tue Nov 08, 2011 5:05 pm

bugger! i got another device (RB751U-2HnD) running on similiar bug, but this time with ether1 losing packets (when bridge and VLAN activated)

EDIT: ok, it is confirmed, that the packet loss happens when the bridge and VLAN interface activated. i replaced the VLAN interface with eoip, and this packet loss is not happening again.

EDIT: i downgraded to RB751U-2HnD v5.8 into v5.6 ROS, gonna give result here, if the problem is gone.
EDIT: and it's still there :cry:
EDIT: something odd. i disabled
/ip neighbor discovery
for the bridge interface, and so far still no packet loss (it's been about 30 minutes), usually it won't take more than 5 minutes.
Last edited by winet on Wed Nov 09, 2011 11:27 am, edited 4 times in total.
 
digicomtech
Frequent Visitor
Frequent Visitor
Posts: 75
Joined: Fri Apr 20, 2007 5:03 pm
Location: Alma, Qc, Canada
Contact:

Re: RouterOS v5.8 released

Tue Nov 08, 2011 6:15 pm

Bug in nand space display after upgrade...
[admin@mplourde] > sys resource pr
                   uptime: 4h30m42s
                  version: 5.8
              free-memory: 11348KiB
             total-memory: 29708KiB
                      cpu: MIPS 24Kc V7.4
                cpu-count: 1
            cpu-frequency: 300MHz
                 cpu-load: 6%
           free-hdd-space: 17596KiB
          total-hdd-space: 126976KiB
  write-sect-since-reboot: 4552
         write-sect-total: 10188661
               bad-blocks: 0.1%
        architecture-name: mipsbe
               board-name: RB411
                 platform: digicom
admin@mplourde] > file pr        
 # NAME                                        TYPE                                                             SIZE CREATION-TIME       
 0 routeur.generic-NOIP-3.0.auto.rsc           script                                                         12 215 jan/01/1970 19:01:01
 1 routeur.generic-NOIP-3.0.auto.log           .log file                                                         134 jan/01/1970 19:01:04
 2 log.0.txt                                   .txt file                                                      67 164 nov/08/2011 11:05:44
 3 autosupout.old.rif                          .rif file                                                     333 734 nov/03/2011 04:03:56
 4 log.1.txt                                   .txt file                                                      69 101 oct/27/2011 18:20:13
 5 autosupout.rif                              .rif file                                                     377 470 nov/03/2011 04:42:48
 6 skins                                       directory                                                             aug/13/2011 03:30:55
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: RouterOS v5.8 released

Wed Nov 09, 2011 3:37 am

well i found the problem, not sure how to fix it.


the default for the 750 config

is a 192.168.88.1 main address off the eth2 port
and a dhcp server with the same info

if i change that address to 10.0.1.1
with a dhcp server that serves the same info

that is when usermanager breaks.

any idea's


i will try to prove this in a vm as well

the following config below will break usermanager.

if anyone is running vmworkstation i can provid the actual vm if interested. is there something im setting wrong?

# nov/08/2011 20:21:43 by RouterOS 5.8
# software id = K2V1-K279
#
/interface ethernet
set 0 arp=enabled auto-negotiation=yes cable-settings=default \
    disable-running-check=yes disabled=no full-duplex=yes mac-address=\
    00:0C:29:83:8C:F0 mtu=1500 name=ether1 speed=100Mbps
set 1 arp=enabled auto-negotiation=yes cable-settings=default \
    disable-running-check=yes disabled=no full-duplex=yes mac-address=\
    00:0C:29:83:8C:FA mtu=1500 name=ether2 speed=100Mbps
/interface wireless security-profiles
set default authentication-types="" eap-methods=passthrough group-ciphers=\
    aes-ccm group-key-update=5m interim-update=0s management-protection=\
    disabled mode=none name=default radius-eap-accounting=no \
    radius-mac-accounting=no radius-mac-authentication=no radius-mac-caching=\
    disabled radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username \
    static-algo-0=none static-algo-1=none static-algo-2=none static-algo-3=\
    none static-sta-private-algo=none static-transmit-key=key-0 \
    supplicant-identity=MikroTik tls-certificate=none tls-mode=\
    no-certificates unicast-ciphers=aes-ccm
/ip hotspot profile
set default dns-name="" hotspot-address=0.0.0.0 html-directory=hotspot \
    http-cookie-lifetime=3d http-proxy=0.0.0.0:0 login-by=cookie,http-chap \
    name=default rate-limit="" smtp-server=0.0.0.0 split-user-domain=no \
    use-radius=no
/ip hotspot user profile
set default idle-timeout=none keepalive-timeout=2m name=default shared-users=\
    1 status-autorefresh=1m transparent-proxy=no
/ip ipsec proposal
set default auth-algorithms=sha1 disabled=no enc-algorithms=3des lifetime=30m \
    name=default pfs-group=modp1024
/ip pool
add name=pool1 ranges=10.1.1.10-10.1.1.254
/ip dhcp-server
add address-pool=pool1 address-pool6="" authoritative=after-2sec-delay \
    bootp-support=static disabled=no interface=ether1 lease-time=3d name=\
    server1
/port
set 0 baud-rate=9600 data-bits=8 flow-control=none name=serial0 parity=none \
    stop-bits=1
set 1 baud-rate=9600 data-bits=8 flow-control=none name=serial1 parity=none \
    stop-bits=1
/ppp profile
set default change-tcp-mss=yes name=default only-one=default \
    remote-ipv6-prefix-pool=none use-compression=default use-encryption=\
    default use-ipv6=yes use-mpls=default use-vj-compression=default
set default-encryption change-tcp-mss=yes name=default-encryption only-one=\
    default remote-ipv6-prefix-pool=none use-compression=default \
    use-encryption=yes use-ipv6=yes use-mpls=default use-vj-compression=\
    default
/queue type
set default kind=pfifo name=default pfifo-limit=50
set ethernet-default kind=pfifo name=ethernet-default pfifo-limit=50
set wireless-default kind=sfq name=wireless-default sfq-allot=1514 \
    sfq-perturb=5
set synchronous-default kind=red name=synchronous-default red-avg-packet=1000 \
    red-burst=20 red-limit=60 red-max-threshold=50 red-min-threshold=10
set hotspot-default kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=\
    5
set only-hardware-queue kind=none name=only-hardware-queue
set multi-queue-ethernet-default kind=mq-pfifo mq-pfifo-limit=50 name=\
    multi-queue-ethernet-default
set default-small kind=pfifo name=default-small pfifo-limit=10
/routing bgp instance
set default as=65530 client-to-client-reflection=yes disabled=no \
    ignore-as-path-len=no name=default out-filter="" redistribute-connected=\
    no redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no \
    redistribute-static=no router-id=0.0.0.0 routing-table=""
/routing ospf instance
set default disabled=no distribute-default=never in-filter=ospf-in \
    metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=\
    auto metric-rip=20 metric-static=20 name=default out-filter=ospf-out \
    redistribute-bgp=no redistribute-connected=no redistribute-other-ospf=no \
    redistribute-rip=no redistribute-static=no router-id=0.0.0.0
/routing ospf area
set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=\
    default
/routing ospf-v3 instance
set default disabled=no distribute-default=never metric-bgp=auto \
    metric-connected=20 metric-default=1 metric-other-ospf=auto metric-rip=20 \
    metric-static=20 name=default redistribute-bgp=no redistribute-connected=\
    no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no \
    router-id=0.0.0.0
/routing ospf-v3 area
set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=\
    default
/snmp
set contact="" enabled=no engine-id="" location="" trap-version=1
/snmp community
set public address=0.0.0.0/0 authentication-protocol=MD5 encryption-protocol=\
    DES name=public read-access=yes security=none write-access=no
/system logging action
set memory memory-lines=100 memory-stop-on-full=no name=memory target=memory
set disk disk-file-count=2 disk-file-name=log disk-lines-per-file=100 \
    disk-stop-on-full=no name=disk target=disk
set echo name=echo remember=yes target=echo
set remote bsd-syslog=no name=remote remote=:: remote-port=514 src-address=\
    0.0.0.0 syslog-facility=daemon syslog-severity=auto target=remote
/user group
set read name=read policy="local,telnet,ssh,reboot,read,test,winbox,password,w
    eb,sniff,sensitive,api,!ftp,!write,!policy" skin=default
set write name=write policy="local,telnet,ssh,reboot,read,write,test,winbox,pa
    ssword,web,sniff,sensitive,api,!ftp,!policy" skin=default
set full name=full policy="local,telnet,ssh,ftp,reboot,read,write,policy,test,
    winbox,password,web,sniff,sensitive,api" skin=default
/interface bridge settings
set use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=\
    no
/interface l2tp-server server
set authentication=pap,chap,mschap1,mschap2 default-profile=\
    default-encryption enabled=no max-mru=1460 max-mtu=1460 mrru=disabled
/interface ovpn-server server
set auth=sha1,md5 certificate=none cipher=blowfish128,aes128 default-profile=\
    default enabled=no keepalive-timeout=60 mac-address=FE:07:A6:6E:29:17 \
    max-mtu=1500 mode=ip netmask=24 port=1194 require-client-certificate=no
/interface pptp-server server
set authentication=mschap1,mschap2 default-profile=default-encryption \
    enabled=no keepalive-timeout=30 max-mru=1460 max-mtu=1460 mrru=disabled
/interface sstp-server server
set authentication=pap,chap,mschap1,mschap2 certificate=none default-profile=\
    default enabled=no keepalive-timeout=60 max-mru=1500 max-mtu=1500 mrru=\
    disabled port=443 verify-client-certificate=no
/interface wireless align
set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=\
    00:00:00:00:00:00 filter-mac=00:00:00:00:00:00 frame-size=300 \
    frames-per-second=25 receive-all=no ssid-all=no
/interface wireless sniffer
set channel-time=200ms file-limit=10 file-name="" memory-limit=10 \
    multiple-channels=no only-headers=no receive-errors=no streaming-enabled=\
    no streaming-max-rate=0 streaming-server=0.0.0.0
/interface wireless snooper
set channel-time=200ms multiple-channels=yes receive-errors=no
/ip accounting
set account-local-traffic=no enabled=no threshold=256
/ip accounting web-access
set accessible-via-web=no address=0.0.0.0/0
/ip address
add address=10.1.1.1/24 comment="default configuration" disabled=no \
    interface=ether1 network=10.1.1.0
/ip dhcp-server config
set store-leases-disk=5m
/ip dhcp-server network
add address=10.1.1.0/24 dns-server=10.1.1.1 gateway=10.1.1.1 netmask=24
/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB \
    max-udp-packet-size=512
/ip dns static
add address=192.168.88.1 disabled=no name=router ttl=1d
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
    tcp-close-wait-timeout=10s tcp-established-timeout=1d \
    tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
    tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
    tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061 sip-direct-media=yes
set pptp disabled=no
/ip hotspot service-port
set ftp disabled=no ports=21
/ip neighbor discovery
set ether1 disabled=no
set ether2 disabled=no
/ip proxy
set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=no enabled=no max-cache-size=none max-client-connections=\
    600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 \
    parent-proxy-port=0 port=8080 serialize-connections=no src-address=\
    0.0.0.0
/ip service
set telnet disabled=no port=23
set ftp disabled=no port=21
set www disabled=no port=80
set ssh disabled=no port=22
set www-ssl certificate=none disabled=yes port=443
set api disabled=yes port=8728
set winbox disabled=no port=8291
/ip socks
set connection-idle-timeout=2m enabled=no max-connections=200 port=1080
/ip ssh
set forwarding-enabled=no
/ip traffic-flow
set active-flow-timeout=30m cache-entries=4k enabled=no \
    inactive-flow-timeout=15s interfaces=all
/ip upnp
set allow-disable-external-interface=yes enabled=no show-dummy-rule=yes
/ipv6 nd
add advertise-dns=no advertise-mac-address=yes disabled=no hop-limit=\
    unspecified interface=all managed-address-configuration=no mtu=\
    unspecified other-configuration=no ra-delay=3s ra-interval=3m20s-10m \
    ra-lifetime=30m reachable-time=unspecified retransmit-interval=\
    unspecified
/ipv6 nd prefix default
set autonomous=yes preferred-lifetime=1w valid-lifetime=4w2d
/mpls
set dynamic-label-range=16-1048575 propagate-ttl=yes
/mpls interface
add disabled=no interface=all mpls-mtu=1508
/mpls ldp
set distribute-for-default-route=no enabled=no hop-limit=255 loop-detect=no \
    lsr-id=0.0.0.0 path-vector-limit=255 transport-address=0.0.0.0 \
    use-explicit-null=no
/port firmware
set directory=firmware
/ppp aaa
set accounting=yes interim-update=0s use-radius=no
/queue interface
set ether1 queue=ethernet-default
set ether2 queue=ethernet-default
/radius incoming
set accept=no port=3799
/routing bfd interface
set all disabled=no interface=all interval=0.2sec min-rx=0.2sec multiplier=5
/routing igmp-proxy
set query-interval=2m5s query-response-interval=10s quick-leave=no
/routing mme
set bidirectional-timeout=2 gateway-class=none gateway-keepalive=1m \
    gateway-selection=no-gateway origination-interval=5s preferred-gateway=\
    0.0.0.0 timeout=1m ttl=50
/routing pim
set switch-to-spt=yes switch-to-spt-bytes=0 switch-to-spt-interval=1m40s
/routing rip
set distribute-default=never garbage-timer=2m metric-bgp=1 metric-connected=1 \
    metric-default=1 metric-ospf=1 metric-static=1 redistribute-bgp=no \
    redistribute-connected=no redistribute-ospf=no redistribute-static=no \
    routing-table=main timeout-timer=3m update-timer=30s
/routing ripng
set distribute-default=never garbage-timer=2m metric-bgp=1 metric-connected=1 \
    metric-default=1 metric-ospf=1 metric-static=1 redistribute-bgp=no \
    redistribute-connected=no redistribute-ospf=no redistribute-static=no \
    timeout-timer=3m update-timer=30s
/store
add disabled=no disk=primary-master name=user-manager1 type=user-manager
add disabled=no disk=primary-master name=web-proxy1 type=web-proxy
/system clock
set time-zone-name=manual
/system clock manual
set dst-delta=+00:00 dst-end="jan/01/1970 00:00:00" dst-start=\
    "jan/01/1970 00:00:00" time-zone=+00:00
/system console
add disabled=no port=serial0 term=vt102
set [ find vcno=1 ] disabled=no term=linux
set [ find vcno=2 ] disabled=no term=linux
set [ find vcno=3 ] disabled=no term=linux
set [ find vcno=4 ] disabled=no term=linux
set [ find vcno=5 ] disabled=no term=linux
set [ find vcno=6 ] disabled=no term=linux
set [ find vcno=7 ] disabled=no term=linux
set [ find vcno=8 ] disabled=no term=linux
/system console screen
set line-count=25
/system gps
set channel=0 enabled=no set-system-time=no
/system hardware
set multi-cpu=yes
/system health
set state-after-reboot=enabled
/system identity
set name=MikroTik
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set ether1 disabled=yes display-time=5s
set ether2 disabled=yes display-time=5s
/system logging
add action=memory disabled=no prefix="" topics=info
add action=memory disabled=no prefix="" topics=error
add action=memory disabled=no prefix="" topics=warning
add action=echo disabled=no prefix="" topics=critical
/system note
set note="" show-at-login=yes
/system ntp client
set enabled=no mode=unicast primary-ntp=0.0.0.0 secondary-ntp=0.0.0.0
/system ntp server
set broadcast=no enabled=no manycast=yes multicast=no
/system resource irq
set 0 cpu=auto
set 1 cpu=auto
set 2 cpu=auto
set 3 cpu=auto
set 4 cpu=auto
set 5 cpu=auto
set 6 cpu=auto
set 7 cpu=auto
set 8 cpu=auto
set 9 cpu=auto
/system routerboard bios
set
/system upgrade mirror
set check-interval=1d enabled=no primary-server=0.0.0.0 secondary-server=\
    0.0.0.0 user=""
/system watchdog
set auto-send-supout=no automatic-supout=yes no-ping-delay=5m watch-address=\
    none watchdog-timer=yes
/tool bandwidth-server
set allocate-udp-ports-from=2000 authenticate=yes enabled=yes max-sessions=\
    100
/tool e-mail
set address=0.0.0.0 from=<> password="" port=25 user=""
/tool graphing
set page-refresh=300 store-every=5min
/tool mac-server
set (unknown) disabled=no interface=all
/tool mac-server ping
set enabled=yes
/tool sms
set allowed-number="" channel=0 keep-max-sms=0 receive-enabled=no
/tool sniffer
set file-limit=1000KiB file-name="" filter-stream=yes interface=all \
    memory-limit=100KiB memory-scroll=yes only-headers=no streaming-enabled=\
    no streaming-server=0.0.0.0
/tool traffic-generator
set latency-distribution-scale=10 test-id=0
/tool user-manager customer
add backup-allowed=yes disabled=no login=admin parent=admin \
    paypal-accept-pending=no paypal-allowed=no paypal-secure-response=no \
    permissions=owner signup-allowed=no time-zone=-00:00
/user aaa
set accounting=yes default-group=read interim-update=0s use-radius=no

 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: RouterOS v5.8 released

Wed Nov 09, 2011 3:58 am

actually it appears just changing the main router ip, will cause it to break.

am i missing something?
 
User avatar
Xymox
Member
Member
Posts: 387
Joined: Thu Jan 21, 2010 5:04 pm
Location: Phoenix, Arizona US
Contact:

Re: RouterOS v5.8 released

Wed Nov 09, 2011 6:47 am

Not specifically related to 5.8 but 5.8 does do it..

If you download Winbox from the Webfig screen using WIndows 8 in either IE or Firefox when you try and run it windows 8 stop you from running it and has no option to override and run anyway.

"Windows protected your PC" "Windows Smart Screen prevented a unrecognized program from starting ...."

If you download Winbox from the web site it works fine.. Its only if you download it from Webfig.


Also... I think isaw a NTP issue with 5.8 that I did not see with 5.7.. Im running NTP client/server. My computers were not able to obtain the time from the server while it appeared to be working from Webbox. I rebooted it and that seemed to fix the issue..
 
MRMISSY
newbie
Posts: 45
Joined: Sun Mar 07, 2010 3:26 pm

Re: RouterOS v5.8 released

Wed Nov 09, 2011 11:49 pm

Still problem in UserManager, as I said before after rebooting the MikroTik, for a while "Time Left" and "Total Time Left" shown correctly, after 5 mins this data starts to disappearing from USER page in UserManager, I'm wondering why Mikrotik doesn't solve this BIG problem from v4.17 to v5.8! I'm disappointed!
same here
I'm so disappointed too
 
User avatar
winet
Member Candidate
Member Candidate
Posts: 272
Joined: Fri Mar 16, 2007 4:49 pm
Location: Indonesia

Re: RouterOS v5.8 released

Thu Nov 10, 2011 2:18 am

same here
I'm so disappointed too
and support is getting slow on replying things here too, i wonder what makes them so busy and don't care to our posts anymore. usually it won't take more than a day to get a satisfying answer, but nowadays, u won't even get a single answer even for a week.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24042
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v5.8 released

Thu Nov 10, 2011 8:30 am

same here
I'm so disappointed too
and support is getting slow on replying things here too, i wonder what makes them so busy and don't care to our posts anymore. usually it won't take more than a day to get a satisfying answer, but nowadays, u won't even get a single answer even for a week.
the user manager has not been updated for several months now. it has already been said that development is halted. so please don't be surprised, that we don't fix the user manager problems as fast as the other things in RouterOS.
No answer to your question? How to write posts
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2277
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RouterOS v5.8 released

Thu Nov 10, 2011 10:12 am

Can not see health (voltage) when rb800 is powered by 56V supply. And when the power source is 48V then SNMP displays bad value 57V.
ROS 5.8
Routerboot 2.30
ticket 2011082666000329
You do not have the required permissions to view the files attached to this post.
LAN, FTTx, Wireless. ISP operator
 
onowojemma
Member Candidate
Member Candidate
Posts: 129
Joined: Sun Sep 11, 2005 5:27 pm
Location: Nigeria

Re: RouterOS v5.8 released

Thu Nov 10, 2011 11:06 pm

Hello My good people here i just got Rb1200 but find finding difficult to create time base ticket . unlike the v4 were i can create credit and add uptime.
I would like appreciate any help on how to go about it thanks.
Mikrotik! making networking easy
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24042
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS v5.8 released

Fri Nov 11, 2011 9:42 am

Hello My good people here i just got Rb1200 but find finding difficult to create time base ticket . unlike the v4 were i can create credit and add uptime.
I would like appreciate any help on how to go about it thanks.
please make a new forum topic in the appropriate section
No answer to your question? How to write posts
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1369
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v5.8 released

Fri Nov 11, 2011 3:52 pm

The sniffer filter just made my life a whole lot easier :) High 5 !

BUT ! When opened with Wireshark - still no VLAN ID is decoded properly/probably not in the cap file ?

As well sniffer filer by VLAN would be great?
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1369
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v5.8 released

Sat Nov 12, 2011 12:12 am

While I am clicking on the Copy button in Bridge filter for a New rule, WinBox just quits, disappears, so I have to relaunch. Latest WinBox.exe from 5.8
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1369
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v5.8 released

Sat Nov 12, 2011 4:16 am

[minor annoyance] old routing marks stay in the lists after they are removed from everywhere in the configuration. Old connection marks disappear as soon as they are removed from all rules they were in. I would like for the routing marks to disapper just like the conenction marks do. Thanks.
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1210
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: RouterOS v5.8 released

Sat Nov 12, 2011 3:37 pm

+1 on routing marks issue
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
User avatar
mramos
Member Candidate
Member Candidate
Posts: 230
Joined: Sun Nov 23, 2008 1:05 am
Location: S. B do Campo - SP - Brazil

Supout.rif content

Sat Nov 12, 2011 6:50 pm

Hi ...

I'm dealing with some daily reboots at two 433 (AH and UAH) and I've been upgrading them to the lastest version. Kernel failure, rebooted without proper shutdown (cause = 1).

Inspecting the supout.rif I noticed this content under routerboard fields:
routerboard: yes
model: 433AH
serial-number: 28030145C900
current-firmware: 2.37
upgrade-firmware: 2.37


BIOS
bad command name bios (line 3 column 18) <==== ???

SETTINGS
           baud-rate: 115200
           boot-delay: 5s
           enter-setup-on: any-key
           boot-device: nand-if-fail-then-ethernet
           cpu-frequency: 680MHz
           boot-protocol: bootp
           enable-jumper-reset: yes
           force-backup-booter: no
           silent-boot: no
What "bad command name bios (line 3 column 18)" means ??

This brand new 433AH came with already 1.5% badblocks. Today (48h in service) it's 2.3%.

A 433UAH was replaced by this 433AH. The UAH has 0.7% badblocks so via serial console I formatted nand + 5.8 netinstall a couple of times to get rid of such 0.7% (now is 0.0%).

Anyway, I'm inspecting config script to clean it up and after that will netinstall 5.8 back to 433AH.

Regards;
Marcus Ramos
Electronics Technician
(Microwave HW, RF, antennas, propagation)
S.Paulo - Brazil
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: RouterOS v5.8 released

Sun Nov 13, 2011 12:06 am

Hello Folks!

Suddenly after several months of operation we are facing a nasty situation.

Router after router is becoming unavailable or very slow.

When managing to login on a router high CPU on FLASH is detected.

A hard reboot is only way to solve problem.

This is scary, what happens here.

Can anyone explain, or is this a new bug discovered.
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1369
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v5.8 released

Sun Nov 13, 2011 12:38 am

Steen please post a screenshot of the problem and/or answer:

- what router? What exact model of hardware?
- what version of software, date in /system packages


Thank you.
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
Zalex
just joined
Posts: 2
Joined: Wed Apr 14, 2010 1:49 pm

Re: RouterOS v5.8 released

Sun Nov 13, 2011 1:08 am

sorry for my English
...it seems bug in 5.8 in e-mail sending. Confuse with area "To" and "Subject". I try to send mail, but have a log error "Error sending <MT export> invalid TO adsress", but phrase "MT export" in my "subject" area. In 5.7 it works good.
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RouterOS v5.8 released

Sun Nov 13, 2011 2:08 am

Mikrotik, why don't you write a test suite for Router OS ?

Most bugs inside 5.8 would have been catched by a test suite.


It is anormal to see that something really simple to test like Metarouter is not working at all inside a release version.

I did advice a test suite on Oct 07, 2010 and still no better testing.

Every serious programming project has a test suite. Why Router OS don't ? Please stop developping Router OS during 2 weeks and write a test suite.

It will be better for you and for your clients.
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1369
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: RouterOS v5.8 released

Sun Nov 13, 2011 3:11 am

Removing a bridge that has a PPPoE Server on it causes interfase statistic to not be show in WinBox so a router restart was needed.
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service
 
FIPTech
Member
Member
Posts: 469
Joined: Tue Dec 22, 2009 1:53 am

Re: RouterOS v5.8 released

Sun Nov 13, 2011 3:42 am

IPv6 dynamic bindings cannot be removed

IPv6 ND do not work anymore if IPv6 interface address is changed. Needs rebooting.

Ipv6 address on PPPoE interface cannot be enabled. Needs reboot.

Disabling an IPv6 address on an interface do not fully disable it. -> IPv6 PD DHCP client does not work on this interface before rebooting.
 
aries
just joined
Posts: 11
Joined: Mon Dec 27, 2010 3:50 pm

Re: RouterOS v5.8 released

Mon Nov 14, 2011 7:36 pm

I agree with FIPTech.
Why Mikrotik calls 5.x version - stable? It is development version. Each version - new surprises!
It is becoming difficult to trust Mikrotik anymore.

It would be very nice to have not only - Change log, but also to have - known isues.

Thanks.
 
glucz
Member Candidate
Member Candidate
Posts: 123
Joined: Wed Jun 06, 2007 10:25 pm

Re: RouterOS v5.8 released

Mon Nov 14, 2011 11:56 pm

This error has stretches with the third version!
With the loss of PPP (pptp, l2tp, openvpn) connections - does not delete the IP address automatically.
If it is static, more impossible to establish a connection!
Image
Don't feel bad about this. This problem has been in RouterOS since 3.x You can write a simple script to delete all IPs that are attached to invalid interfaces ... something like /ip address remove [/ip address find invalid] . Check your queues also. You may have some mopping up to do there as well. Schedule the script to run every minute.
 
User avatar
mramos
Member Candidate
Member Candidate
Posts: 230
Joined: Sun Nov 23, 2008 1:05 am
Location: S. B do Campo - SP - Brazil

Re: RouterOS v5.8 released

Tue Nov 15, 2011 2:56 am

Hi ...

5.8 routerboard package have 2.37 firmware on it. At RB433AH & UAH there's V 2.38 fwf. Is there any changelog for fw versions?

And the default "ethernet-default" queue was replaced by "only-hardware-queue" - queue type = none - selected by default when netinstalled but not when upgrading from an earlier version. Benefits?

Regards;
Marcus Ramos
Electronics Technician
(Microwave HW, RF, antennas, propagation)
S.Paulo - Brazil

Who is online

Users browsing this forum: No registered users and 85 guests