Community discussions

MUM Europe 2020
 
User avatar
airstream
Member Candidate
Member Candidate
Topic Author
Posts: 188
Joined: Fri Feb 03, 2006 6:33 am
Location: New Zealand

PPPoE Service name Ignored

Thu Dec 15, 2011 4:05 am

Hi all

We seem to have an issue with PPPoE service names. on our AC we have two PPPoE servers running on the same interface. one has the service name as "" (blank), the other has the service name 'unmetered'

Both servers have different profiles as default so that PPPoE client connections to either will get different subnet addresses.

However, it seems that even if the PPPoE client has also got a blank service name it will be served an IP from the profile with the service name 'unmetered'. if we disable the 'unmetered' server the clients reconnect and get the correct IP subnet from the blank servername.

If we add a third server with servername "whatever" with the same default profile as the blank servername profile all works properly and clients get the right subnet address served from blank servername.

Is this by design? why would a client with blank service name be served up from our AC as if it had 'unmetered' entered in the CPE? Is there something about having a blank servername alongside PPPoE server with a servername that causes this weirdness?

Entire network is routeros. tried version 5.4-5.11 on both CPE and AC - all have the same weirdness with PPPoE connections.
Keep tryin' its bound to work!!
-----
-----
ROOT@COSMOS> Reality.sys corrupted -- Reboot Universe (Y/N)?
>_
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8346
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: PPPoE Service name Ignored

Thu Dec 15, 2011 3:15 pm

AFAIR, blank name means "any name" (in Windows?)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5971
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: PPPoE Service name Ignored

Thu Dec 15, 2011 3:22 pm

Yes, blank service name means any service name.
 
User avatar
airstream
Member Candidate
Member Candidate
Topic Author
Posts: 188
Joined: Fri Feb 03, 2006 6:33 am
Location: New Zealand

Re: PPPoE Service name Ignored

Thu Dec 15, 2011 9:55 pm

Thanks for the reply's, it all makes sense now.
Keep tryin' its bound to work!!
-----
-----
ROOT@COSMOS> Reality.sys corrupted -- Reboot Universe (Y/N)?
>_

Who is online

Users browsing this forum: MSN [Bot], scracha, stanelie and 82 guests