Community discussions

MikroTik App
 
User avatar
marioclep
Trainer
Trainer
Topic Author
Posts: 140
Joined: Sat Jul 11, 2009 4:36 pm
Location: Cordoba - Argentina
Contact:

RouterOS future requests

Wed Dec 21, 2011 9:56 pm

Hi to all...

According to the wiki in IP -> Pool: "... Note: Whenever possible, the same ip address is given out to each client (OWNER/INFO pair)..:".

Would it be possible to have an option for not giving the same IP?

Regards.
---------------------

Ing. Mario D. Clep
CTO - MKE Solutions
MikroTik Certified Trainer
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24608
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS future requests

Thu Dec 22, 2011 8:18 am

Basically this is against the standard.
No answer to your question? How to write posts
 
dog
Member Candidate
Member Candidate
Posts: 186
Joined: Wed Aug 12, 2009 3:37 pm
Location: Germany

Re: RouterOS future requests

Fri Dec 23, 2011 12:44 am

Actually this has been a long standing feature request, and the wiki explains why:
Our ADSL subscribers are served by a Huawei/Cisco Access Concentrator using PPPoE and assigns dynamic IP addresses which change with every session establishment. This is the kind of behaviour the customer expects. Some subscribers actually demand that their IP address change when they intentionally restart their ADSL modem. On the other hand, our wireless subscribers are served by Mikrotik RouterOS machines also using PPPoE with dynamic address pools. For some reason they receive the SAME IP address each and every time, unless of course that IP address is no longer available. Can this behaviour be changed to dole out a different IP address (i.e. not the same address) available from the pool to the same MAC client for each session?
http://wiki.mikrotik.com/wiki/MikroTik_ ... e_Requests
 
sup5
Member
Member
Posts: 325
Joined: Sat Jul 10, 2010 12:37 am

Re: RouterOS future requests

Mon Dec 26, 2011 12:10 am

I partially solved this issue with this cumbersome solution:

Imagine you want to hand out these 64 addresses to your customers:
100.73.12.0/26

so you might just create one IP-Pool in RouterOS which allocated the mentioned 100.73.12.0/26 in one block.

To simulate pseudo random IP-assignment to your customers create MANY very SMALL IP-Pools which are chained using the next-pool parameter.

I use /29 subnets for each pool.
(you could even use single IP-Adresses per Pool, but this is very uncomfortable to administrate!)

/ip pool
add name=pppoe-1 ranges=100.73.12.0/29
add name=pppoe-2 next-pool=pppoe-1 ranges=100.73.12.8/29
add name=pppoe-3 next-pool=pppoe-2 ranges=100.73.12.16/29
add name=pppoe-4 next-pool=pppoe-3 ranges=100.73.12.24/29
add name=pppoe-5 next-pool=pppoe-4 ranges=100.73.12.32/29
add name=pppoe-6 next-pool=pppoe-5 ranges=100.73.12.40/29
add name=pppoe-7 next-pool=pppoe-6 ranges=100.73.12.48/29
add name=pppoe-8 next-pool=pppoe-7 ranges=100.73.12.56/29
.
.

you'll have to specify the last defined IP-Pool (PPPoE-8) of this list in your PPPoE-Server.

This way the IP-Pool always prefers to saturate the stack of single IP-Pools from the bottom.
This won't ensure full randomization on each reconnect but in most cases, it works and the customer gets another IP-Address.

Who is online

Users browsing this forum: hauskaimneha, olivier2831 and 57 guests