Community discussions

MikroTik App
 
ochm
just joined
Topic Author
Posts: 19
Joined: Wed Oct 29, 2008 2:58 pm
Location: Czech Republic

ROS 5.11 x86 problem - unstable version

Fri Dec 23, 2011 12:10 pm

This version is unstable on PC. :(
After few days (two is maximum) the router stops respond without any information, only way how to get them online is reboot.
Router contains 8 wireless cards and one on board ethernet.
With previous version (5.7) router runs excelently all the time after instalation.
I downgraded the PC router to 5.7 :
--
Martin Och
MTCNA, MTCWE, MTCTCE
 
jandafields
Forum Guru
Forum Guru
Posts: 1514
Joined: Mon Sep 19, 2005 6:12 pm

Re: ROS 5.11 x86 problem - unstable version

Fri Dec 23, 2011 10:56 pm

This version is unstable on PC. :(
After few days (two is maximum) the router stops respond without any information, only way how to get them online is reboot.
Router contains 8 wireless cards and one on board ethernet.
With previous version (5.7) router runs excelently all the time after instalation.
I downgraded the PC router to 5.7 :
There are a lot of posts here regarding this problem. 5.8 seems to be ok. 5.11 seems to be bad.
 
siprox
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Fri Apr 01, 2011 11:14 am

Re: ROS 5.11 x86 problem - unstable version

Sat Dec 24, 2011 4:11 pm

my x86 router lock up to, after upgrade from 5.8 to 5.9 and then unstable occured.
tried upgrade to 5.11 but wouldn't help.
my conf :
webproxy internal, couples of mangling and queue tree, thats it.
with version 5.8 run flawlessly.
 
jandafields
Forum Guru
Forum Guru
Posts: 1514
Joined: Mon Sep 19, 2005 6:12 pm

Re: ROS 5.11 x86 problem - unstable version

Sat Dec 24, 2011 5:54 pm

my x86 router lock up to, after upgrade from 5.8 to 5.9 and then unstable occured.
tried upgrade to 5.11 but wouldn't help.
my conf :
webproxy internal, couples of mangling and queue tree, thats it.
with version 5.8 run flawlessly.
That is one of the bugs with 5.9, 5.10, 5.11. You have to use 5.8 with x86 for now.
 
alexspils
Member Candidate
Member Candidate
Posts: 176
Joined: Thu Jun 05, 2008 8:57 pm

Re: ROS 5.11 x86 problem - unstable version

Thu Dec 29, 2011 11:03 am

i`m running 5.11 on x86 (core 2 duo, intel nics, multicpu=yes) for about 14 days, no problems...
 
User avatar
otgooneo
Trainer
Trainer
Posts: 573
Joined: Tue Dec 01, 2009 3:24 am
Location: Mongolia
Contact:

Re: ROS 5.11 x86 problem - unstable version

Wed Jan 11, 2012 6:50 am

i`m running 5.11 on x86 (core 2 duo, intel nics, multicpu=yes) for about 14 days, no problems...
Hi Alexspils. What is your ethernet controller model? I have some intel ethernet controllers. Have a problem of high latency if traffic exceeds 100Mbps.
----------------------------
Want to learn more and more...
 
dimabar
newbie
Posts: 31
Joined: Fri Sep 03, 2010 7:43 am

Re: ROS 5.11 x86 problem - unstable version

Fri Jan 13, 2012 6:44 pm

Having reboot proplems on x86 with pppoe and bpg too... And no logs and somthing useful... Too bad...
 
dimabar
newbie
Posts: 31
Joined: Fri Sep 03, 2010 7:43 am

Re: ROS 5.11 x86 problem - unstable version

Mon Jan 16, 2012 11:18 am

Having reboot proplems on x86 with pppoe and bpg too... And no logs and somthing useful... Too bad...
Does anybody know any stable version? Could anybody tell: is it possible to downgrade? How?
 
cdemers
Member Candidate
Member Candidate
Posts: 189
Joined: Sun Feb 26, 2006 3:32 pm
Location: Canada
Contact:

Re: ROS 5.11 x86 problem - unstable version

Mon Jan 16, 2012 3:54 pm

Only x86 unit I have been having a problem on myself is my testing unit, it's a Soekris net4501. Works fine most of the time. Only have has a couple random reboots, need reattach the serial cable and see if there are any messages on the console. Seems random though haven't actually caught it yet. Only other strangeness I see is the unusual queuing CPU usage that I have seen go up to like 40%, I have no queues setup, tried setting up some to see if it made a difference and no real change.
 
dimabar
newbie
Posts: 31
Joined: Fri Sep 03, 2010 7:43 am

Re: ROS 5.11 x86 problem - unstable version

Mon Jan 16, 2012 4:07 pm

Only x86 unit I have been having a problem on myself is my testing unit, it's a Soekris net4501. Works fine most of the time. Only have has a couple random reboots, need reattach the serial cable and see if there are any messages on the console. Seems random though haven't actually caught it yet. Only other strangeness I see is the unusual queuing CPU usage that I have seen go up to like 40%, I have no queues setup, tried setting up some to see if it made a difference and no real change.
Thank you for info... But, I think only developers can do something to help us...
 
dadosonic
just joined
Posts: 10
Joined: Fri Jul 04, 2008 3:55 pm

Re: ROS 5.11 x86 problem - unstable version

Wed Jan 18, 2012 8:49 pm

I also have a lot of problems with my core router which is also multicore with 8 cores.
Since router OS 5.x is announced we have tried every of them but router is working maximum 20 days and then reboots by it self.
Interesting thing about rebooting is that it happens in time when traffic load is not on maximum values. Mostly it happens when the traffic is 50% and less of maximum traffic we have.
CPU is o.k. and there is no sign of any problem at the moment but router just reboots (this is better scenario) or it just hangs, no ping to it, we can not see it in ip neighbour and just turn off/turn on power is helping.
On v.5.7, 5.8 and 5.9 we had a problem with rebooting on every 1-2 days so now we are on 5.orc11 which is, by our experience most stable of all 5.x.
On this OS router works 15-20 day at the most before it chrashes and reboot.
 
User avatar
omidkosari
Trainer
Trainer
Posts: 634
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: ROS 5.11 x86 problem - unstable version

Thu Jan 19, 2012 9:22 am

I guess the crash is related to PPP or PCQ .
MTCNA , MTCRE, MTCWE, Mikrotik Certified Trainer
 
User avatar
huigezi
newbie
Posts: 43
Joined: Sat Dec 24, 2011 4:39 am
Location: apple

Re: ROS 5.11 x86 problem - unstable version

Thu Jan 19, 2012 10:40 am

Since there are so many problems at 5.11

So I have been fortunate in 5.8

If you want knowledge, you must toil for it
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24608
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: ROS 5.11 x86 problem - unstable version

Thu Jan 19, 2012 10:47 am

anyone with x86 problems in v5.11, send supout.rif file with your config to support
No answer to your question? How to write posts
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24608
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: ROS 5.11 x86 problem - unstable version

Thu Jan 19, 2012 11:00 am

we have made a pre-release version with a potential fix for x86 reboots. please email us to get the beta
No answer to your question? How to write posts
 
Neovr
newbie
Posts: 38
Joined: Wed Aug 27, 2008 10:13 pm

Re: ROS 5.11 x86 problem - unstable version

Thu Jan 19, 2012 5:36 pm

5.11 is very unstable in my configuration... 3-4 reboots at day
i install v5.8 to other new hardware (intel i3 s1155), 2 nics - Realtek 8111 Gigabit adapter...
and have a problem with this nics... at random time nics stop working and tx drop packets are very big increasing... only reboot fix problem...
this error occurs several times a day.
v4.17 don't work on this system, NIC is defined but dont working, and ahve a message on screen about STOPING IRQ16
 
dimabar
newbie
Posts: 31
Joined: Fri Sep 03, 2010 7:43 am

Re: ROS 5.11 x86 problem - unstable version

Thu Jan 19, 2012 10:54 pm

we have made a pre-release version with a potential fix for x86 reboots. please email us to get the beta
Wow! great news! Thank you very mutch! Could you please tell us: patch or new release?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: ROS 5.11 x86 problem - unstable version

Mon Jan 23, 2012 12:09 pm

5.12 released, use that. And it was pre-release you could try out.
 
User avatar
AlxFirst
just joined
Posts: 15
Joined: Sat Jan 22, 2011 1:08 pm
Location: Russia, Moscow

Re: ROS 5.11 x86 problem - unstable version

Sun Jan 29, 2012 1:22 pm

upgrade my two routers-x86 (dual-core) from 5.7 to 5.12 - 3 days, all is right. Using bgp, queue-tree, mangles, nat, mpls, gre-tunnels - all works fine (at one router - 350-450 Mbit transfer, and 40-70 Mbit at other).
 
cdemers
Member Candidate
Member Candidate
Posts: 189
Joined: Sun Feb 26, 2006 3:32 pm
Location: Canada
Contact:

Re: ROS 5.11 x86 problem - unstable version

Sun Feb 05, 2012 11:22 am

So far new version has been really stable on x86, have installed on be/le routers also with similar results so far. How has it been running on PPC, all core routers are 1100's and don't want to upgrade those until i know it's stable. No spares of those to test with right now.
 
User avatar
otgooneo
Trainer
Trainer
Posts: 573
Joined: Tue Dec 01, 2009 3:24 am
Location: Mongolia
Contact:

Re: ROS 5.11 x86 problem - unstable version

Mon Feb 06, 2012 8:19 am

upgrade my two routers-x86 (dual-core) from 5.7 to 5.12 - 3 days, all is right. Using bgp, queue-tree, mangles, nat, mpls, gre-tunnels - all works fine (at one router - 350-450 Mbit transfer, and 40-70 Mbit at other).
Hi AlxFirst, How is your packet loss and latency, when using mangle, queue tree and traffic exceeds 200Mbps? I have problem with my 8core x86 and RB1100AHx2. When using queue tree with prerouting marked packets and traffic exceeds 150Mbps, there is very high latency and packet loss occurs for prerouted packets.
----------------------------
Want to learn more and more...
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8393
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: ROS 5.11 x86 problem - unstable version

Mon Feb 06, 2012 5:00 pm

Hi AlxFirst, How is your packet loss and latency, when using mangle, queue tree and traffic exceeds 200Mbps? I have problem with my 8core x86 and RB1100AHx2. When using queue tree with prerouting marked packets and traffic exceeds 150Mbps, there is very high latency and packet loss occurs for prerouted packets.
what CPU load?
is it in PCQ queues?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
otgooneo
Trainer
Trainer
Posts: 573
Joined: Tue Dec 01, 2009 3:24 am
Location: Mongolia
Contact:

Re: ROS 5.11 x86 problem - unstable version

Tue Feb 07, 2012 4:21 am

Hi Chupaka,
On X86: CPU load is less that 50%, queue type is simple PFIFO. About 700 dynamic simple queues and pppoe sessions, 2 queue tree rules using 2 rules that preroutes, postroutes packets.
On RB1100AHx2: CPU load is less that 80%, 180 pppoe sessions, PCQ queues, no dynamic simple queues, 2 queue tree rules using 2 rules that preroutes, postroutes packets. Mangles and PCQ queues are following:
/ip firewall mangle export
add action=change-mss chain=forward disabled=no new-mss=1440 passthrough=yes protocol=tcp tcp-mss=1441-65535
add action=mark-connection chain=forward comment=Eco_512k disabled=yes dst-address-list=!OTHERISP new-connection-mark=Eco_512k passthrough=yes src-address-list=Eco_512k
add action=mark-packet chain=forward comment=Eco_512k connection-mark=Eco_512k disabled=yes new-packet-mark=Eco_512k passthrough=no
add action=mark-connection chain=forward comment=Eco_5120k disabled=yes dst-address-list=!OTHERISP new-connection-mark=Eco_5120k passthrough=yes src-address-list=Eco_5120k
add action=mark-packet chain=forward comment=Eco_5120k connection-mark=Eco_5120k disabled=yes new-packet-mark=Eco_5120k passthrough=no
add action=mark-connection chain=forward comment=Eco_4096k disabled=yes dst-address-list=!OTHERISP new-connection-mark=Eco_4096k passthrough=yes src-address-list=Eco_4096k
add action=mark-packet chain=forward comment=Eco_4096k connection-mark=Eco_4096k disabled=yes new-packet-mark=Eco_4096k passthrough=no
add action=mark-connection chain=forward comment=Eco_3072k disabled=yes dst-address-list=!OTHERISP new-connection-mark=Eco_3072k passthrough=yes src-address-list=Eco_3072k
add action=mark-packet chain=forward comment=Eco_3072k connection-mark=Eco_3072k disabled=yes new-packet-mark=Eco_3072k passthrough=no
add action=mark-connection chain=forward comment=Eco_256k disabled=yes dst-address-list=!OTHERISP new-connection-mark=Eco_256k passthrough=yes src-address-list=Eco_256k
add action=mark-packet chain=forward comment=Eco_256k connection-mark=Eco_256k disabled=yes new-packet-mark=Eco_256k passthrough=no
add action=mark-connection chain=forward comment=Eco_2048k disabled=yes dst-address-list=!OTHERISP new-connection-mark=Eco_2048k passthrough=yes src-address-list=Eco_2048k
add action=mark-packet chain=forward comment=Eco_2048k connection-mark=Eco_2048k disabled=yes new-packet-mark=Eco_2048k passthrough=no
add action=mark-connection chain=forward comment=Eco_128k disabled=yes dst-address-list=!OTHERISP new-connection-mark=Eco_128k passthrough=yes src-address-list=Eco_128k
add action=mark-packet chain=forward comment=Eco_128k connection-mark=Eco_128k disabled=yes new-packet-mark=Eco_128k passthrough=no
add action=mark-connection chain=forward comment=Eco_1024k disabled=yes dst-address-list=!OTHERISP new-connection-mark=Eco_1024k passthrough=yes src-address-list=Eco_1024k
add action=mark-packet chain=forward comment=Eco_1024k connection-mark=Eco_1024k disabled=yes new-packet-mark=Eco_1024k passthrough=no
add action=mark-connection chain=forward comment=Eco_10240k disabled=yes dst-address-list=!OTHERISP new-connection-mark=Eco_10240k passthrough=yes src-address-list=Eco_10240k
add action=mark-packet chain=forward comment=Eco_10240k connection-mark=Eco_10240k disabled=yes new-packet-mark=Eco_10240k passthrough=no
/queue tree export
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Total_download packet-mark="" parent=global-out priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_512k_down packet-mark=Eco_512k parent=Total_download priority=8 queue=Eco_512k_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Total_upload packet-mark="" parent=ether1 priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_512k_up packet-mark=Eco_512k parent=Total_upload priority=8 queue=Eco_512k_up
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_1024k_down packet-mark=Eco_1024k parent=Total_download priority=7 queue=Eco_1024k_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_1024k_up packet-mark=Eco_1024k parent=Total_upload priority=8 queue=Eco_1024k_up
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_10240k_down packet-mark=Eco_10240k parent=Total_download priority=8 queue=Eco_10240k_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_10240k_up packet-mark=Eco_10240k parent=Total_upload priority=8 queue=Eco_10240k_up
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_5120k_down packet-mark=Eco_5120k parent=Total_download priority=8 queue=Eco_5120k_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_5120k_up packet-mark=Eco_5120k parent=Total_upload priority=8 queue=Eco_5120k_up
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_128k_down packet-mark=Eco_128k parent=Total_download priority=8 queue=Eco_128k_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_128k_up packet-mark=Eco_128k parent=Total_upload priority=8 queue=Eco_128k_up
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_256k_down packet-mark=Eco_256k parent=Total_download priority=8 queue=Eco_256k_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_256k_up packet-mark=Eco_256k parent=Total_upload priority=8 queue=Eco_256k_up
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_2048k_down packet-mark=Eco_2048k parent=Total_download priority=8 queue=Eco_2048k_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_2048k_up packet-mark=Eco_2048k parent=Total_upload priority=8 queue=Eco_2048k_up
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_4096k_down packet-mark=Eco_4096k parent=Total_download priority=8 queue=Eco_4096k_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_4096k_up packet-mark=Eco_4096k parent=Total_upload priority=8 queue=Eco_4096k_up
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_3072k_down packet-mark=Eco_3072k parent=Total_download priority=8 queue=Eco_3072k_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 name=Eco_3072k_up packet-mark=Eco_3072k parent=Total_upload priority=8 queue=Eco_3072k_up
----------------------------
Want to learn more and more...
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8393
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: ROS 5.11 x86 problem - unstable version

Tue Feb 07, 2012 9:01 am

don't you think that the reason is not your 2 queues in Queue Tree, but your 700 Simple Queues? %)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
otgooneo
Trainer
Trainer
Posts: 573
Joined: Tue Dec 01, 2009 3:24 am
Location: Mongolia
Contact:

Re: ROS 5.11 x86 problem - unstable version

Tue Feb 07, 2012 10:08 am

Guess so. Therefor first I tried to solve problem of RB1100AHx2, removing dynamic queues adding PCQ queues, which is advised by Normis http://forum.mikrotik.com/viewtopic.php?t=24224&f=2
But there is no success on RB1100AHx2. If PCQ is better, I am ready to change dynamic queues.
----------------------------
Want to learn more and more...
 
User avatar
otgooneo
Trainer
Trainer
Posts: 573
Joined: Tue Dec 01, 2009 3:24 am
Location: Mongolia
Contact:

Re: ROS 5.11 x86 problem - unstable version

Tue Feb 07, 2012 10:09 am

Also when I disable mangle rules of queue tree, problem doesn`t occur.
----------------------------
Want to learn more and more...
 
User avatar
AlxFirst
just joined
Posts: 15
Joined: Sat Jan 22, 2011 1:08 pm
Location: Russia, Moscow

Re: ROS 5.11 x86 problem - unstable version

Tue Feb 07, 2012 11:58 pm

Hi AlxFirst, How is your packet loss and latency, when using mangle, queue tree and traffic exceeds 200Mbps? I have problem with my 8core x86 and RB1100AHx2. When using queue tree with prerouting marked packets and traffic exceeds 150Mbps, there is very high latency and packet loss occurs for prerouted packets.
what CPU load?
is it in PCQ queues?
CPU usage is 60-70%, then max bandwidth (250Mbit IN and 150-200Mbit out = total around 400-450Mbit) - then CPU usage around 85-90% :) New MT based on Core-i7 prepared ;)

No, pfifo queue
--------
set 0 kind=pfifo name=default pfifo-limit=500
set 1 kind=pfifo name=ethernet-default pfifo-limit=2000
..
add kind=pfifo name=q-Upload pfifo-limit=200
add kind=pfifo name=q-Download pfifo-limit=200
------
example of queue-tree
------
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=10445k name=Q-Login10-in packet-mark=Login10-in parent=\
global-out priority=8 queue=q-Upload
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=10445k name=Q-Login10-out packet-mark=Login10-out parent=\
global-out priority=8 queue=q-Download
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=6144k name=Q-Login11-in packet-mark=Login11-in parent=\
global-out priority=8 queue=q-Upload
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=6144k name=Q-Login11-out packet-mark=Login11-out parent=\
global-out priority=8 queue=q-Download
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=22M name=Q-Login12-in packet-mark=Login12-in parent=global-out \
priority=8 queue=q-Upload
-------
and example of mangles (eth1 - for all LocalNetworks, ACL, named with "list-LoginXXX" for client's IPs - may be one, may be two or six.. :) - one bandwidth for one account, witch may have some IPs):
-------
/ip firewall mangle
add action=mark-packet chain=forward comment=In-Login11 disabled=no \
dst-address-list=list-Login11 new-packet-mark=Login11-in out-interface=\
eth1 passthrough=no
add action=mark-packet chain=forward comment=Out-Login11 disabled=no \
in-interface=eth1 new-packet-mark=Login11-out passthrough=no \
src-address-list=list-Login11
add action=mark-packet chain=forward comment=In-Login12 disabled=no \
dst-address-list=list-Login12 new-packet-mark=Login12-in out-interface=\
eth1 passthrough=no
add action=mark-packet chain=forward comment=Out-Login12 disabled=no \
in-interface=eth1 new-packet-mark=Login12-out passthrough=no \
src-address-list=list-Login12
------
All rules doing dynamically by special terminal program in full automatic (sync with billing and rules at MT - mangles, static ARP, lists, NAT-list)
 
User avatar
AlxFirst
just joined
Posts: 15
Joined: Sat Jan 22, 2011 1:08 pm
Location: Russia, Moscow

Re: ROS 5.11 x86 problem - unstable version

Wed Feb 08, 2012 12:08 am

upgrade my two routers-x86 (dual-core) from 5.7 to 5.12 - 3 days, all is right. Using bgp, queue-tree, mangles, nat, mpls, gre-tunnels - all works fine (at one router - 350-450 Mbit transfer, and 40-70 Mbit at other).
Hi AlxFirst, How is your packet loss and latency, when using mangle, queue tree and traffic exceeds 200Mbps? I have problem with my 8core x86 and RB1100AHx2. When using queue tree with prerouting marked packets and traffic exceeds 150Mbps, there is very high latency and packet loss occurs for prerouted packets.
use forward thread, not prerouting - in prerouting I see the strange results too :)
Packet loss not big - queue-size must be big (2Gb of fast memory - we can do big buffers for queue). Latency in normal - only cpu usage at picks of traffic give some problem with it :)
May be you don't turn off RMS? Or you using the slack realtek's-netcards or integrated ? (may be! I see it some times :) ) We are (company, where I working) using Intel server netcards with biggest buffer-size and hardware queue.
 
User avatar
otgooneo
Trainer
Trainer
Posts: 573
Joined: Tue Dec 01, 2009 3:24 am
Location: Mongolia
Contact:

Re: ROS 5.11 x86 problem - unstable version

Fri Feb 10, 2012 4:41 am

Hi AlxFirst,
1. What is RMS?
2. When I`m using dynamic simple queues, forward chain of packet marks doesn`t pass over simple queues. I use marked packets for queue tree, that pass over simple queues. For example: Packets sourced from some internal media sharing servers must be not rated by simple queues.
3. My second try is to use PCQ queues instead of dynamic simple queues. In that case mangle forward chain works. Because PCQ rule created at queue tree. But there is very strange big packet loss at PCQ handling packets.

Sorry for my bad english and thank you for your kind advise. Please advise me once again if you have any idea.
----------------------------
Want to learn more and more...
 
User avatar
AlxFirst
just joined
Posts: 15
Joined: Sat Jan 22, 2011 1:08 pm
Location: Russia, Moscow

Re: ROS 5.11 x86 problem - unstable version

Fri Feb 10, 2012 1:06 pm

Hi AlxFirst,
1. What is RMS?
Sorry - mistake. "RPS" of couse :)
System->Resources->RPS (Presented at all multi-cores system).
2. When I`m using dynamic simple queues, forward chain of packet marks doesn`t pass over simple queues. I use marked packets for queue tree, that pass over simple queues. For example: Packets sourced from some internal media sharing servers must be not rated by simple queues.
3. My second try is to use PCQ queues instead of dynamic simple queues. In that case mangle forward chain works. Because PCQ rule created at queue tree. But there is very strange big packet loss at PCQ handling packets.
In my experience the simple-queue more slowly, more cpu-usage than queue-tree rules and more "bugs" :) Now I'm using only queue-tree for all task about client's bandwidths. PCQ-type is very powerful for simple rule: one fixed guarantee speed for fixed clients number and when count of clients less of max in rule, then all clients get more guarantee-speed and separate the total rule-speed :)
I think that you must read the mikrotik-wiki about using the PCQ-queue (search the PCQ and you'll find that)

Who is online

Users browsing this forum: No registered users and 84 guests