Community discussions

MUM Europe 2020
 
User avatar
vetusa2
Member Candidate
Member Candidate
Topic Author
Posts: 122
Joined: Sat Jun 18, 2011 8:24 pm

how to hide the public ip address from network users ?

Thu Dec 29, 2011 9:20 pm

how to hide the public ip address from network users so if any user visited google or any websites like let say "whatismyip.com" he gets his local ip on the network.

i don't know how to do it and not sure if it can be done by a script or the proxy of the mikrotik server.

in simple english "hidden public ip" .....how?
 
sup5
Member
Member
Posts: 322
Joined: Sat Jul 10, 2010 12:37 am

Re: how to hide the public ip address from network users ?

Thu Dec 29, 2011 10:25 pm

you cannot hide it.

these sites will always show the address of your NAT-Router, your Proxy, or simply the public-address given to the user.
 
User avatar
guilhermeramires
Trainer
Trainer
Posts: 56
Joined: Fri Jan 22, 2010 9:06 pm

Re: how to hide the public ip address from network users ?

Fri Dec 30, 2011 6:32 pm

You can make an address list with all websites that provides this service and make a drop rule to this list.
Mikrotik Training Partner
MPLS for the Masses
 
Vaelen
just joined
Posts: 18
Joined: Fri Aug 24, 2007 3:35 am

Re: how to hide the public ip address from network users ?

Sun Jan 01, 2012 8:55 pm

Yes, but even gmail shows the last and current address accessed from, are you going to block that?
Ryan Carter
Network Engineer C4ISR
MTCNA, MTCRE, MTCWE, MTCTCE
CCNA
 
inibir
Member Candidate
Member Candidate
Posts: 116
Joined: Thu Nov 25, 2010 2:25 pm
Location: lebanon
Contact:

Re: how to hide the public ip address from network users ?

Mon Jan 02, 2012 5:56 am

what is the problem if the user show this ip ????
 
inibir
Member Candidate
Member Candidate
Posts: 116
Joined: Thu Nov 25, 2010 2:25 pm
Location: lebanon
Contact:

Re: how to hide the public ip address from network users ?

Mon Jan 02, 2012 5:59 am

u can use external proxy,then user show ip of proxy
 
User avatar
vetusa2
Member Candidate
Member Candidate
Topic Author
Posts: 122
Joined: Sat Jun 18, 2011 8:24 pm

Re: how to hide the public ip address from network users ?

Mon Jan 02, 2012 5:51 pm

i am sure that a script can do the job ,just remember guys everything is possible in the pc world,just how to do it,or how it can be done?

i am thinking to redirect codes that include the the word "your ip address" into a local page with some scary words about safety!

can it be done?

http://www.whatismyip.com/faq/automation.asp


html code:
<div id="ip">Your IP Address Is: <span id="203">4</span><span id="145">1</span>.<span id="63">2</span>34.<label class="135">1</label><label id="144">4</label><!--Do not scrape your IP from here, go to www.whatismyip.com/faq/automation.asp for more information on our automation rules.-->5.1<label id="22">0</label>5<br></div>
wth?
i found this while googling
http://groanmyip.com/
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24337
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: how to hide the public ip address from network users ?

Tue Jan 03, 2012 12:55 pm

Not possible. Every site will use different wording. Other site will not use "your ip address" but will use "Current IP", "Your IP" or any other combination of words, or maybe even in a different language. You can't block half the internet just for this.
No answer to your question? How to write posts
 
inibir
Member Candidate
Member Candidate
Posts: 116
Joined: Thu Nov 25, 2010 2:25 pm
Location: lebanon
Contact:

Re: how to hide the public ip address from network users ?

Tue Jan 03, 2012 3:01 pm

/ip firewall layer7 add name=ip regexp="your Real IP"
/ip firewall filter add action=drop layer7-protocol=ip
But this code have problen, not all browser can open websites content your ip
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24337
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: how to hide the public ip address from network users ?

Tue Jan 03, 2012 3:04 pm

Like I said, you will need many such rules, for each language, different expression and word order. Plus, L7 rules will slow down your router, as they inspect every packet.
No answer to your question? How to write posts
 
Vaelen
just joined
Posts: 18
Joined: Fri Aug 24, 2007 3:35 am

Re: how to hide the public ip address from network users ?

Wed Jan 04, 2012 8:38 am

Also what if the page doesn't use a URL that obviously marks it as a "What's my ip" site or some such and then uses SSL?
Ryan Carter
Network Engineer C4ISR
MTCNA, MTCRE, MTCWE, MTCTCE
CCNA
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24337
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: how to hide the public ip address from network users ?

Wed Jan 04, 2012 8:46 am

Also what if the page doesn't use a URL that obviously marks it as a "What's my ip" site or some such and then uses SSL?
the L7 rule above will inspect all content, not just URL.
No answer to your question? How to write posts
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: how to hide the public ip address from network users ?

Wed Jan 04, 2012 12:49 pm

and your L7 cannot look into encrypted packets. So going to block all TLS/SSL? traceroute also should be banned.
 
Vaelen
just joined
Posts: 18
Joined: Fri Aug 24, 2007 3:35 am

Re: how to hide the public ip address from network users ?

Wed Jan 04, 2012 6:15 pm

That's what I was getting at just phrased poorly as I was tired.
Ryan Carter
Network Engineer C4ISR
MTCNA, MTCRE, MTCWE, MTCTCE
CCNA
 
User avatar
vetusa2
Member Candidate
Member Candidate
Topic Author
Posts: 122
Joined: Sat Jun 18, 2011 8:24 pm

Re: how to hide the public ip address from network users ?

Sat Feb 25, 2012 5:35 pm

lets do it for the decrypted then !
 
User avatar
cybercoder
Member Candidate
Member Candidate
Posts: 176
Joined: Tue Dec 07, 2010 11:20 pm
Location: Guilan, Iran
Contact:

Re: how to hide the public ip address from network users ?

Sat Feb 25, 2012 7:31 pm

hiding the IP is not the security thing, it is not true logically and will no help to secure your network!
study the network security essentials, and train the real world security issues will helpful, i think this the right but hide the public IP address behind the nat? (if it possible) like erase the problem and no solve!
Any sufficiently advanced technology is indistinguishable from magic. ( Arthur C Clarke )
Mikrotik certified consultant
Microsoft Certified Technology Specialist, Microsoft Certified IT Proffessional
http://www.netd.ir
 
User avatar
vetusa2
Member Candidate
Member Candidate
Topic Author
Posts: 122
Joined: Sat Jun 18, 2011 8:24 pm

Re: how to hide the public ip address from network users ?

Sun Feb 26, 2012 6:48 am

/ip firewall layer7 add name=ip regexp="your Real IP"
/ip firewall filter add action=drop layer7-protocol=ip
But this code have problen, not all browser can open websites content your ip

firewall chain is forward correct?

can i use the true static ip address"bla.bla.bla.bla" instead of the phrase "your Real IP"?

of course i didn't try this idea,but i think it will be a mess
 
kurtkraut
Frequent Visitor
Frequent Visitor
Posts: 73
Joined: Wed Feb 15, 2012 2:55 am

Re: how to hide the public ip address from network users ?

Sun Feb 26, 2012 7:15 am

I'm not saying that this applies to the original poster, but as far as I know, this kind of wish (to hide public IP address) is used by illegal ISPs that just share an residential internet conection from another ISP to its customers. They just purchase a regular ADSL link in downtown and set up a backhaul to bring internet where the big telcos don't have coverage.

Here in Brazil this is very common (despite the act this is a crime here) and what the legitimate ISP do is campaings teaching how users can see their public address and identify the real company providing the internet service.
 
User avatar
vetusa2
Member Candidate
Member Candidate
Topic Author
Posts: 122
Joined: Sat Jun 18, 2011 8:24 pm

Re: how to hide the public ip address from network users ?

Sun Feb 26, 2012 10:12 am

may be in Brazil there are lots of criminals ,but in our situation we need that option to limit users that are not on our network from trying get the identity of the network runing in the air.
 
rajathiraja
just joined
Posts: 3
Joined: Fri Mar 02, 2012 1:47 pm

Re: how to hide the public ip address from network users ?

Sat Mar 31, 2012 8:44 am

You can hide the ip address easily using the hide ip address software.You can search in Google and Download it.You can also use the proxy server to hide the Ip-address...It hide the original ip address and display fake ip address.You can check ip-address before and after hiding ip at Ip-Details.com it shows location and details of your ip address....
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1220
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: how to hide the public ip address from network users ?

Mon Apr 02, 2012 11:19 pm

may be in Brazil there are lots of criminals ,but in our situation we need that option to limit users that are not on our network from trying get the identity of the network runing in the air.
So if they set up a web server on a public address and open that page from your network, they will find your IP in the server log.
And it does not matter what you do on your network, the http request will include the public address.
So your only option is to enforce a transparent proxy by using a preroute redirect rule, and then the proxy address will show up.
Last edited by docmarius on Sun May 13, 2012 1:28 am, edited 1 time in total.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
User avatar
vetusa2
Member Candidate
Member Candidate
Topic Author
Posts: 122
Joined: Sat Jun 18, 2011 8:24 pm

Re: how to hide the public ip address from network users ?

Tue Apr 10, 2012 11:17 am

i respect talented people

:shock:
 
sasaunict
just joined
Posts: 1
Joined: Sun Jan 27, 2013 11:44 am

Re: how to hide the public ip address from network users ?

Wed Jan 30, 2013 6:58 pm

To hide ip address you need to use a proxy server. To do that you can use some useful software or you can do it by do some changes on your browser.
 
dinaafifi
just joined
Posts: 2
Joined: Mon Nov 25, 2013 10:25 pm

Re: how to hide the public ip address from network users ?

Mon Nov 25, 2013 10:31 pm

VPN is the best choice to hide your IP address. I use this VPN https://www.waselpro.com/en/ all servers are encrypted, this one worked great for me.
 
angelia
just joined
Posts: 1
Joined: Sat Dec 27, 2014 7:04 pm

Re: how to hide the public ip address from network users ?

Sat Dec 27, 2014 9:12 pm

Hiding your real IP address is useful for anonymity, privacy, security and for hiding your online identity to be able to bypass country censorship, firewalls ad IP bans without any restriction and in complete security all with this VPN software http://www.unblockingyoutube.com/en/proxy-vpn/

Who is online

Users browsing this forum: MSN [Bot] and 72 guests