Community discussions

 
ChildOTK
Member Candidate
Member Candidate
Topic Author
Posts: 111
Joined: Sat Nov 25, 2006 7:40 am

Linksys / Cisco RVS4000 VPN

Fri Dec 30, 2011 9:00 am

Good Day All,

I am trying to get my Routerboard to connect to another location's VPN which is run by a Linksys / Cisco RVS4000 unit. I believe the VPN is using IPSec.

I am having a hard time getting this setup and functional. Could anybody please help me?

Thank you!
 
User avatar
SiB
Member Candidate
Member Candidate
Posts: 163
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Linksys / Cisco RVS4000 VPN

Thu Sep 15, 2016 4:27 pm

Hello,
I just created a UP Tunnel between MikroTik RouterBoard 1100 v6.35 with RVS 4000.
Tunnel is UP but I must say it's cannot be work properly... because:
* RVS4000) Cannot add advanced routing via tunnel1
* RVC4000) Cannot create additional tunnel on IPSec tunnel for MikroTik problems
* RVC4000) re-connection is not possible, the traffic can UP the tunnel only or click on Connect button on-demand
* MikroTik ) Cannot add new routing because you havent a virtual ipsec interface, routing via Public IP not work too (of course SNAT rules are done)

Maybe in v7

HowTo SetUp:

First configure LOGs on Both site.
RVS4000)
Administration > Log > Log Setting > Log Level > [tik] All (0~7)
Administration > Log > Local Log > Local Log: [radio_button] Enable

MikroTik)
/system logging action
add name=IPSec target=memory
/system logging
set 1 topics=error,!ipsec
add action=IPSec topics=ipsec
/

Set IP on Both Site Public IP to Public IP without private subnetwork
Screenshot_1.png
Set Phase1
Screenshot_2.png
Set Phase2 and IKEv1
Screenshot_3.png
And you can now see in logs both site that Phase1 is established.
To do tunnel1 UP you must on rvs4000 press connect - tunnel will be working only between device.

Image

And you cannot use it more :(.
I try from MTK site do a SNAT's via local 2.2.2.2 IP, ping a remote 1.1.1.1 etc. and sorry but please read a header of my message = I write what is problem on both devices.
PS. If you think to use a local IP subnets to this tunnel then tunnel1 will be UP but how you use it when MTK not create any routings? Created manual to what IP? PBR it's not help too.
You do not have the required permissions to view the files attached to this post.
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL | WebChat: Tokonda
WinBox Tip: F6 works as ALT+TAB

Who is online

Users browsing this forum: MSN [Bot] and 85 guests