Page 1 of 1

> 254 IPs

Posted: Thu Jan 05, 2012 3:05 pm
by sgb32
I’m going to need more than 254 IP addresses so I guess I'll need to configure an RB750 to lease class B IP addresses.

I assume that I configure a Pool of 192.168.0.1 – 192.168.1.254 on the 192.168.0.0/23 network for example and have DHCP use it.

I’ve never needed this number of IPs before and wondered which is the best way to go about it?

Many thanks.

Re: > 254 IPs

Posted: Fri Jan 06, 2012 4:21 am
by dasiu
192.168.0.0/23 will work normally, id doesn't differ from 192.168.0.0/24 - you will have 512 normal addresses :).

Re: > 254 IPs

Posted: Wed Jan 11, 2012 5:06 pm
by karlos
/30 = 4IP
/29 = 8IP
/28 = 16IP
/27 = 32IP
/26 = 64IP
/25 = 128IP
/24 = 256IP
/23 = 512IP
/22 = 1024IP
/21 = 2048IP
/20 = 4096IP
....
but you cant use the borders so 0 and 255 are not ussable.

so always minus 2


so 192.168.0.1/23 will give you space for clients from 192.168.0.2 to 192.168.1.254 (192.168.0.0 border, 192.168.0.1 Gateway, 192.168.1.255 border)

Or you can also use 2 or more pools so you can use for your DHCP pool1 = 192.168.0.0/24 and second pool2 = 192.168.1.0/24 as the "next pool" and the DPHS will give at the first all adresses from pool1 and than from pool2.


If it helps you please give me carma

Re: > 254 IPs

Posted: Wed Jan 11, 2012 7:07 pm
by CCDKP
Depending on how / what you are setting up, I would typically set:
/ip address
add address=192.168.0.1/23 disabled=no interface=<INTERFACE> network=192.168.0.0

/ip pool
add name=DHCP2 ranges=192.168.1.6-192.168.1.249
add name=DHCP1 next-pool=DHCP2 ranges=192.168.0.6-192.168.0.249

/ip dhcp-server
add address-pool=DHCP1 authoritative=yes bootp-support=static disabled=no interface=<INTERFACE> lease-time=1d name=DHCP

/ip dhcp-server network
add address=192.168.0.0/23 dns-server=192.168.0.1 gateway=192.168.0.1 netmask=23
While you could use a single large DHCP pool, I typically use multiple for two reasons:

1) I have run into some issues from time to time with poorly written clients choking on the .255 and .0 addresses in the middle, so I just avoid handing them out, even if they are technically valid.

2) I like to leave a 5 IP buffer on both sides of a pool, so I have static IP's reserved if I ever need them, and if for some reason I need to split them back into /24's, i don't have to rebuild as much, and keep things consistent. (i always know 1-5 and 250-254 are reserved)

Is it overkill? Probably. Has it worked great for me? Absolutely. Another thought, if this is for a network where you have a lot of turnover (public hotspots, schools, etc), try turning down the lease time to 6-8h and you will find you can stretch an address pool a lot further.