Community discussions

MikroTik App
 
User avatar
nickshore
Member
Member
Topic Author
Posts: 485
Joined: Thu Mar 03, 2005 4:14 pm
Location: Suffolk, UK.
Contact:

Feature Request: Simple config for per packet load balancing

Tue Jan 10, 2012 6:05 pm

We often need to use per packet nth mangle rules to route packets up multiple DSL lines.

The config can be achieved using nth mangle, but it would be nice if a simple method could be introduced.

on a cisco the following in each dialler can do it:
ip per packet load balancing
it would be great if a simple command would allow the default route to be set on a round robin packet basis
like ECMP but per packet.

eg something like
/ip route add dst-address=0.0.0.0/0 gateway=10.0.0.12,10.0.0.13 mode=per-packet
or even
/ip route add dst-address=0.0.0.0/0 gateway=pppoe1,pppoe2 mode=per-packet


Anyone else like this ?
Nick.
Nick Shore MTCNA MTCWE MTCRE MTCINE MTCTCE
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/brand/mikrotik
Official UK MikroTik Distributor
IRC chan: #routerboard on irc.z.je (IPv4 and IPv6)
 
User avatar
nest
Forum Veteran
Forum Veteran
Posts: 820
Joined: Tue Feb 27, 2007 1:52 am
Location: UK
Contact:

Re: Feature Request: Simple config for per packet load balan

Tue Jan 10, 2012 6:09 pm

Brilliant idea and long overdue! Also, add a wizard (like there is for hotspot setup and DHCP Server setup) to just allow the wizard set it all up for you! Tick the interfaces, punch in any IPs/GWs, job done! :-)
Ron Touw - Mikrotik Certified Trainer
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/category/166
Largest Official UK MikroTik Distributor
 
Sanity
Member Candidate
Member Candidate
Posts: 175
Joined: Sun Mar 06, 2011 8:51 am

Re: Feature Request: Simple config for per packet load balan

Wed Jan 11, 2012 12:09 pm

This is actually TOTALLY NOT NEEDED.

INSTEAD - Mikrotik should finally give us a MLPPP server. Then we get dynamic balancing over multuiple lines with full bndwidth management without writing mangle rules.

The MLPPP client is there, just the server is missing. I would rather prefer that becasue it handles things like single links being down a lot better than nth mangling.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8394
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Feature Request: Simple config for per packet load balan

Fri Jan 13, 2012 11:16 am

nickshore, per-packet balancing is only possible if you don't use NAT. do you?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
nickshore
Member
Member
Topic Author
Posts: 485
Joined: Thu Mar 03, 2005 4:14 pm
Location: Suffolk, UK.
Contact:

Re: Feature Request: Simple config for per packet load balan

Mon Jan 16, 2012 5:51 pm

No we don't use NAT, we use a decent IP which provides us with a real internet link :P
Nick Shore MTCNA MTCWE MTCRE MTCINE MTCTCE
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/brand/mikrotik
Official UK MikroTik Distributor
IRC chan: #routerboard on irc.z.je (IPv4 and IPv6)
 
User avatar
nickshore
Member
Member
Topic Author
Posts: 485
Joined: Thu Mar 03, 2005 4:14 pm
Location: Suffolk, UK.
Contact:

Re: Feature Request: Simple config for per packet load balan

Mon Jan 16, 2012 5:53 pm

This is actually TOTALLY NOT NEEDED.

INSTEAD - Mikrotik should finally give us a MLPPP server. Then we get dynamic balancing over multuiple lines with full bndwidth management without writing mangle rules.

The MLPPP client is there, just the server is missing. I would rather prefer that becasue it handles things like single links being down a lot better than nth mangling.


For our scenario an MLPPP server would not help, we do not have control of the far end.

Our ISP can already round robin the packets down to us, proportionately to the link speeds. We just need to be able to do the same on the uplink.
Nick Shore MTCNA MTCWE MTCRE MTCINE MTCTCE
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/brand/mikrotik
Official UK MikroTik Distributor
IRC chan: #routerboard on irc.z.je (IPv4 and IPv6)
 
bazzer
Trainer
Trainer
Posts: 82
Joined: Sat Mar 07, 2009 11:51 pm
Contact:

Re: Feature Request: Simple config for per packet load balan

Mon Jan 16, 2012 6:44 pm

I agree with original topic. A Long overdue option, either that or provide IPv6 Mangle Nth in the interim. Another long overdue option!
Barry Higgins
Mikrotik Certified Trainer
MTCRE MTCWE MTCTCE MTCUME MTCIPv6E MTCINE MTCSE
https://www.allness.it
 
tomascampeon2
just joined
Posts: 4
Joined: Tue Nov 02, 2010 5:13 pm

Re: Feature Request: Simple config for per packet load balan

Tue Jan 17, 2012 10:51 pm

Friends ideally something that allows load balancing wan of different value, for example:

WAN1 (20 Mb) -------->
| -------------> Edge router (mikrotik)
WAN2 (8Mb) --------->

considering the burden of wan and doing round-robin.

Cisco and others use various methods such as MLPPP, eirgp and some protocols gateway.

Today the problem is that all methods of balancing used in mikrotik connection, and when several large downloads agree connection (Megaupload, etc), complete with an overload of customers wan to go for it have a bad service.This problem occurs with the same capacity also wan

Regards, Tomas.
 
cybrsaver
just joined
Posts: 1
Joined: Tue Feb 10, 2009 7:07 am

Re: Feature Request: Simple config for per packet load balan

Wed Feb 01, 2012 7:37 am

Why can't Mikrotik support MLPPP? Looks like it's been a big request for a few years now.

Who is online

Users browsing this forum: akakua, amala and 131 guests