Community discussions

 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Export compact (new in v5.12)

Mon Jan 23, 2012 12:49 pm

A new feature in v5.12 is the ability to export only that configuration which you have changed (if the device had default configuration, then also that). This gives you ability to debug configuration problems, compare routers more easily, and even simplify the process of migrating configuration to other devices.

to try:
/export compact
and this is all I get, instead of the usual 4 page blob:

[admin@Normis] > export compact
# jan/02/2012 01:57:23 by RouterOS 5.12
#
/ip pool
add name=dhcp_pool1 ranges=10.1.0.2-10.1.0.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether3 name=dhcp1
/ip address
add address=10.1.0.1/24 interface=ether3
/ip dhcp-client
add disabled=no interface=ether1
/ip dhcp-server network
add address=10.1.0.0/24 gateway=10.1.0.1
/ip dns
set allow-remote-requests=yes max-udp-packet-size=512 servers=10.5.8.1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
/ip smb shares
set [ find default=yes ] directory=/pub
/system identity
set name=Normis
/system ntp client
set primary-ntp=10.1.1.1 secondary-ntp=10.1.1.2
/system routerboard settings
set cpu-frequency=266MHz
/tool bandwidth-server
set authenticate=no
[admin@Normis] > 


No answer to your question? How to write posts
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Mon Jan 23, 2012 12:51 pm

please discuss! let us know if you find any issues
No answer to your question? How to write posts
 
tibordp
just joined
Posts: 7
Joined: Fri May 13, 2011 2:04 pm

Re: Export compact (new in v5.12)

Mon Jan 23, 2012 1:20 pm

Great news! I've wished for this feature for a long time!
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Mon Jan 23, 2012 1:22 pm

good to hear you like it.

Small note, if defaults have been changed since you configured your router, these also will appear as your special config.
 
andreacoppini
Trainer
Trainer
Posts: 486
Joined: Wed Apr 13, 2005 11:51 pm
Location: Malta, Europe

Re: Export compact (new in v5.12)

Mon Jan 23, 2012 1:46 pm

Yay for clean configs!
- No strings attached -

<< Please give good Karma if this post helped you. Press the + button above the Location entry
 
User avatar
NoXy
just joined
Posts: 15
Joined: Thu Sep 15, 2005 11:07 am
Location: Hungary

Re: Export compact (new in v5.12)

Mon Jan 23, 2012 2:21 pm

Normis, Janisk yes this is greak. Many thanks! (+1, Like, etc.)
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2293
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: Export compact (new in v5.12)

Mon Jan 23, 2012 2:48 pm

good work
LAN, FTTx, Wireless. ISP operator
 
User avatar
mandrade
Member Candidate
Member Candidate
Posts: 106
Joined: Fri Sep 08, 2006 12:35 pm
Location: Brazil
Contact:

Re: Export compact (new in v5.12)

Mon Jan 23, 2012 2:55 pm

I had just asked it from santa on last cristimas.. :D :D :D

THANKS!!!!!!!

BR
 
alfagius
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Mon Feb 21, 2011 4:07 pm

Re: Export compact (new in v5.12)

Mon Jan 23, 2012 4:54 pm

The only word that describes this feature:

<3!
 
User avatar
Belyivulk
Member Candidate
Member Candidate
Posts: 285
Joined: Mon Mar 06, 2006 10:53 pm
Location: Whangarei, New Zealand
Contact:

Re: Export compact (new in v5.12)

Mon Jan 23, 2012 8:50 pm

Agreed! Awesome thanks MT
 
User avatar
nest
Forum Veteran
Forum Veteran
Posts: 811
Joined: Tue Feb 27, 2007 1:52 am
Location: UK
Contact:

Re: Export compact (new in v5.12)

Mon Jan 23, 2012 9:59 pm

I'm still stunned by the simplicity of this. The amount of hours I must have wasted over the years having to remove all the default 'rubbish' from a config. Thank you Mikrotik!
Ron Touw - Mikrotik Certified Trainer
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/category/166
Largest Official UK MikroTik Distributor
IRC channel: #routerboard on irc.z.je (IPv4), 6.irc.z.je (IPv6)
 
dominicbatty
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Wed Jul 07, 2010 12:26 pm

Re: Export compact (new in v5.12)

Tue Jan 24, 2012 11:51 am

excellent and much needed addition .... thanks Mikrotik!
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: Export compact (new in v5.12)

Tue Jan 24, 2012 12:12 pm

Thanks Mikrotik, a very welcome new feature.

Another great thing to implement would be candidate configurations, commits and rollbacks.

This means that any changes are made to a "candidate configuration" that is not active until the user "commits" the configuration. At the time they commit the config it saves a "rollback" point allowing the user to rollback previous commits, then commits their new config making it active.

This is kind of like the existing safe-mode but is a lot more flexible and logical. If you have ever used JunOS or Palo Alto Networks devices you will already be familiar with these concepts.


I have also recently encountered a system where administrators are able to "lock" parts of the configuration, e.g. 3 administrators are logged in to a core router, adding routes, adding queues, adding address lists, adding ip firewall policies. If an administrator wants to make a change without other administrators inadvertently making a conflicting change, they are able to "lock" the part of the configuration e.g. "firewall filters" they are working on. This give them the exclusive right to edit that part of the configuration. Other administrators who try to add/remove/disable/enable a locked section will be warned, and if they are in the correct user group are able to override the lock.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Tue Jan 24, 2012 12:15 pm

all of the described can be achieved with safe mode. you say that it's not logical, but that's only if you have used JunOS. if you get used to safe mode approach, it's quite logical.
No answer to your question? How to write posts
 
ste
Forum Guru
Forum Guru
Posts: 1813
Joined: Sun Feb 13, 2005 11:21 pm

Re: Export compact (new in v5.12)

Tue Jan 24, 2012 12:29 pm

please discuss! let us know if you find any issues
Looks good. Esp. there are no mac-addresses in interfaces so config
can be copied to a new system without editing.

Does it sort config now to resolve dependencies?
E.g. first security profile and then interface depending on this security profile?


Stefan
 
slech
Long time Member
Long time Member
Posts: 533
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Re: Export compact (new in v5.12)

Tue Jan 24, 2012 2:31 pm

Please add last modification time in export, like current time
# jan/02/2012 01:57:23 by RouterOS 5.12 - last modified jan/01/2011 01:57:23 by user12345
This will be very useful for Backup Mikrotik config to Subversion repository via SSH
sorry for my english
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Tue Jan 24, 2012 2:37 pm

modification of what?
No answer to your question? How to write posts
 
slech
Long time Member
Long time Member
Posts: 533
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Re: Export compact (new in v5.12)

Tue Jan 24, 2012 2:55 pm

modification of what?
Modification of configuration. I want to see in export when ROS config was changed last time.
Last edited by slech on Tue Jan 24, 2012 2:56 pm, edited 1 time in total.
sorry for my english
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Tue Jan 24, 2012 2:56 pm

export is not for such things. use the "history" menu and the "log" to see these things.
No answer to your question? How to write posts
 
slech
Long time Member
Long time Member
Posts: 533
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Re: Export compact (new in v5.12)

Tue Jan 24, 2012 3:14 pm

In history I can't see time and date - and how I can use history to view via ssh if I must create full backup ?
In logs is a lot of entry.
sorry for my english
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Tue Jan 24, 2012 3:16 pm

In logs is a lot of entry.
it's not an argument. use a remote syslog tool and filter out exactly what you need. export is not for security management, it's for configuration export.
No answer to your question? How to write posts
 
slech
Long time Member
Long time Member
Posts: 533
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Re: Export compact (new in v5.12)

Tue Jan 24, 2012 3:34 pm

export is not for security management, it's for configuration export.
How I can see that configuration was changed ?
If I add new user I can't see any changes in export - this is ok for security.
But backup is changed in time and I can't orientate on backup size or content.

Difference between backup and export-how to monitor changes

I want to make a backup only if config was changed.
sorry for my english
 
andriys
Forum Guru
Forum Guru
Posts: 1187
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: Export compact (new in v5.12)

Tue Jan 24, 2012 6:52 pm

The status (enabled/disabled) of the default entry in the telnet mac-server configuration is always missing from the compact export output. To illustrate:
[admin@WhiteIron] > /tool mac-server 

[admin@WhiteIron] /tool mac-server> print
Flags: X - disabled, * - default 
 #    INTERFACE
 0  * all

[admin@WhiteIron] /tool mac-server> export
# jan/02/1970 02:47:49 by RouterOS 5.12
#
/tool mac-server
set [ find default=yes ] disabled=no interface=all
/tool mac-server mac-winbox
set [ find default=yes ] disabled=no interface=all
/tool mac-server ping
set enabled=yes

[admin@WhiteIron] /tool mac-server> export compact 
# jan/02/1970 02:47:52 by RouterOS 5.12
#

[admin@WhiteIron] /tool mac-server> set 0 disabled=yes

[admin@WhiteIron] /tool mac-server> export 
# jan/02/1970 02:48:05 by RouterOS 5.12
#
/tool mac-server
set [ find default=yes ] disabled=yes interface=all
/tool mac-server mac-winbox
set [ find default=yes ] disabled=no interface=all
/tool mac-server ping
set enabled=yes

[admin@WhiteIron] /tool mac-server> export compact 
# jan/02/1970 02:48:09 by RouterOS 5.12
#

[admin@WhiteIron] /tool mac-server> 
Export of the WinBox mac-server configuration works as expected.
 
tjc
Member Candidate
Member Candidate
Posts: 279
Joined: Sun Jul 10, 2011 3:08 am

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 4:51 am

Compact export of firewall address lists produces funky results. This:
/ip firewall address-list
add address=0.0.0.0/8 comment=bogons disabled=no list=blacklist
add address=10.0.0.0/8 comment=bogons disabled=no list=blacklist
add address=127.0.0.0/8 comment=bogons disabled=no list=blacklist
add address=169.254.0.0/16 comment=bogons disabled=no list=blacklist
add address=172.16.0.0/12 comment=bogons disabled=no list=blacklist
add address=192.0.0.0/24 comment=bogons disabled=no list=blacklist
add address=192.0.2.0/24 comment=bogons disabled=no list=blacklist
add address=198.18.0.0/15 comment=bogons disabled=no list=blacklist
add address=198.51.100.0/24 comment=bogons disabled=no list=blacklist
add address=203.0.113.0/24 comment=bogons disabled=no list=blacklist
add address=224.0.0.0/3 comment=bogons disabled=no list=blacklist
Turns into this, which is not quite the same:
/ip firewall address-list                                                       
add comment=bogons list=blacklist                                               
add address=10.0.0.0/8 comment=bogons list=blacklist                            
add address=127.0.0.0/8 comment=bogons list=blacklist                           
add address=169.254.0.0/16 comment=bogons list=blacklist                        
add address=172.16.0.0/12 comment=bogons list=blacklist                         
add address=192.0.0.0/24 comment=bogons list=blacklist                          
add address=192.0.2.0/24 comment=bogons list=blacklist                          
add address=198.18.0.0/15 comment=bogons list=blacklist                         
add address=198.51.100.0/24 comment=bogons list=blacklist                       
add address=203.0.113.0/24 comment=bogons list=blacklist                        
add address=224.0.0.0/3 comment=bogons list=blacklist 
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 7:45 am

what's the difference? import them both and get same result
No answer to your question? How to write posts
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 9:10 am

The status (enabled/disabled) of the default entry in the telnet mac-server configuration is always missing from the compact export output.
thanks
 
changeip
Forum Guru
Forum Guru
Posts: 3803
Joined: Fri May 28, 2004 5:22 pm

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 9:35 am

what's the difference? import them both and get same result
i think he was mentioning this: address=0.0.0.0/8, the /8 is not accounted for.
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
mangust
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Jun 14, 2007 11:14 am

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 1:26 pm

/export compact
Will be nice to have somthing like
/export compact file=some_backup_file

and to see as result the difference between some_backup_file configuration and current one.
I mean it's better to have way to compare between few configurations.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 1:37 pm

currently file= will save export to file (as you might know), will consider export comparison., but no promises.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 1:48 pm

/export compact
Will be nice to have somthing like
/export compact file=some_backup_file

and to see as result the difference between some_backup_file configuration and current one.
I mean it's better to have way to compare between few configurations.
there is a utility for RSC file comparison. you can search the forum
No answer to your question? How to write posts
 
rodolfo
Long time Member
Long time Member
Posts: 543
Joined: Sat Jul 05, 2008 11:50 am

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 3:25 pm

rodolfo
IZ0UQV
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 3:26 pm

thanks, that's what I meant!
No answer to your question? How to write posts
 
mangust
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Jun 14, 2007 11:14 am

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 3:49 pm

 
User avatar
Aug
Member
Member
Posts: 313
Joined: Thu Jun 07, 2007 2:10 am

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 7:34 pm

export compact vs export
just one line so you can see the difference.

compact -
add chain=forward comment="ICMP 11:0 and limit for 5pac/s" disabled=yes icmp-options=11 limit=5 protocol=icmp

normal export-
add action=accept chain=forward comment="ICMP 11:0 and limit for 5pac/s" disabled=yes icmp-options=11:0-255 limit=5,5 protocol=icmp

appears to have problems with commas and colons.

Other than that, I'm happy to see the compact export option.
Aug
 
User avatar
Aug
Member
Member
Posts: 313
Joined: Thu Jun 07, 2007 2:10 am

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 7:46 pm

ssid missing from compact export.

Thanks for the file compare script. Haven't tried it yet but should prove very useful.
Aug
 
Gerard
Trainer
Trainer
Posts: 336
Joined: Wed Apr 26, 2006 4:21 am
Location: Kentucky, USA
Contact:

Re: Export compact (new in v5.12)

Wed Jan 25, 2012 11:25 pm

Compact:
/routing ospf area range
add area=backbone

Regular:
/routing ospf area range
add advertise=yes area=backbone cost=calculated disabled=no range=0.0.0.0/0

Should be:
/routing ospf area range
add area=backbone range=0.0.0.0/0
Certified Mikrotik Trainer
 
tjc
Member Candidate
Member Candidate
Posts: 279
Joined: Sun Jul 10, 2011 3:08 am

Re: Export compact (new in v5.12)

Sun Jan 29, 2012 5:31 pm

With the export changes in 5.12 a lot of the exported items in both compact and normal mode were converted to a form that works better with existing settings (e.g. using "set [ find default=yes ]" rather than "add"), however, there are still a lot that use add in ways that might conflict with a default configuration or at least created duplicate entries (e.g. "/system logging", possibly "/ip firewall filter"). For things like this it might make sense to preceed the list of adds with a "remove [ find ]".
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Mon Jan 30, 2012 8:01 am

With the export changes in 5.12 a lot of the exported items in both compact and normal mode were converted to a form that works better with existing settings (e.g. using "set [ find default=yes ]" rather than "add"), however, there are still a lot that use add in ways that might conflict with a default configuration or at least created duplicate entries (e.g. "/system logging", possibly "/ip firewall filter"). For things like this it might make sense to preceed the list of adds with a "remove [ find ]".
This is not a problem, it's a feature. Since v5.12 a lot of new "default" settings have been added, and what you described as a problem, will actually work in all routers, even with no config.
No answer to your question? How to write posts
 
tjc
Member Candidate
Member Candidate
Posts: 279
Joined: Sun Jul 10, 2011 3:08 am

Re: Export compact (new in v5.12)

Tue Jan 31, 2012 6:57 am

This is not a problem, it's a feature. Since v5.12 a lot of new "default" settings have been added, and what you described as a problem, will actually work in all routers, even with no config.
So the claim is no more editing the exported configuration to be able to restore using it? That would be pretty cool.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Tue Jan 31, 2012 8:20 am

So the claim is no more editing the exported configuration to be able to restore using it? That would be pretty cool.
yes, that is final goal.
 
erroneous
just joined
Posts: 3
Joined: Thu Mar 15, 2007 4:26 pm

Re: Export compact (new in v5.12)

Sat Feb 04, 2012 12:12 am

Hi
export compact is great, but
changed value of default remote syslog server is missing, see:

Without compact:
/system logging export
/system logging action
set 0 memory-lines=100 memory-stop-on-full=no name=memory target=memory
set 1 disk-file-count=2 disk-file-name=log disk-lines-per-file=100 disk-stop-on-full=no name=disk target=disk
set 2 name=echo remember=yes target=echo
set 3 bsd-syslog=no name=remote remote=XXX.YYY.XXX.ZZZ remote-port=514 src-address=:: syslog-facility=daemon syslog-severity=auto target=remote
/system logging
set 0 action=memory disabled=no prefix="" topics=info
set 1 action=memory disabled=no prefix="" topics=error
set 2 action=memory disabled=no prefix="" topics=warning
set 3 action=echo disabled=no prefix="" topics=critical
add action=remote disabled=no prefix="" topics=critical
add action=remote disabled=no prefix="" topics=info
add action=remote disabled=no prefix="" topics=error
add action=remote disabled=no prefix="" topics=system
add action=remote disabled=no prefix="" topics=wireless
with compact:
 /system logging export compact
/system logging
add action=remote topics=critical
add action=remote topics=info
add action=remote topics=error
add action=remote topics=system
add action=remote topics=wireless
Thanks
 
User avatar
ryohnosuke
just joined
Posts: 7
Joined: Mon Nov 17, 2008 12:42 am

Re: Export compact (new in v5.12)

Sat Feb 04, 2012 6:37 pm

My export is broken, no tcp-flags on it.

Saludos.
 
troy
Member
Member
Posts: 304
Joined: Thu Jun 30, 2005 6:47 pm

Re: Export compact (new in v5.12)

Mon Feb 06, 2012 4:54 pm

MT Guys:

Thank you so much for the compact exports. Much easier to see what's what!

How about a feature in The Dude to manage configurations? If The Dude senses that a router's config has changed, have it automatically pull that config and store it.

Put a tftp client in ROS so that we can save a configuration directly to a tftp server.
export compact tftp=some.server.com/path/to/file.rsc
 
asmozre
just joined
Posts: 7
Joined: Sun Jan 22, 2012 1:40 am

Re: Export compact (new in v5.12)

Wed Feb 08, 2012 7:30 pm

The TCP flags in firewall filter aren't in compact or full as noted above

Compact
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input comment="Drop Port Scanners" \
    in-interface=ether1 protocol=tcp
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=tcp
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=tcp
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=tcp
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=tcp
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=tcp
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input in-interface=ether1 protocol=tcp
add action=jump chain=input in-interface=ether1 jump-target=droplog \
    src-address-list="port scanners"


Full
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input comment="Drop Port Scanners" \
    disabled=no in-interface=ether1 protocol=tcp psd=21,3s,3,1
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input disabled=no in-interface=ether1 \
    protocol=tcp
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input disabled=no in-interface=ether1 \
    protocol=tcp
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input disabled=no in-interface=ether1 \
    protocol=tcp
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input disabled=no in-interface=ether1 \
    protocol=tcp
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input disabled=no in-interface=ether1 \
    protocol=tcp
add action=add-src-to-address-list address-list="port scanners" \
    address-list-timeout=2w chain=input disabled=no in-interface=ether1 \
    protocol=tcp
add action=jump chain=input disabled=no in-interface=ether1 jump-target=\
    droplog src-address-list="port scanners"
 
User avatar
otgooneo
Trainer
Trainer
Posts: 570
Joined: Tue Dec 01, 2009 3:24 am
Location: Mongolia
Contact:

Re: Export compact (new in v5.12)

Fri Feb 10, 2012 5:25 am

Hi Normis, Thank you for great feature. Can I add my special configurations like RoS default config?
----------------------------
Want to learn more and more...
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: Export compact (new in v5.12)

Fri Feb 10, 2012 2:57 pm

This feature shows difference from
/system reset-configuration no-defaults=yes

You can Netinstall board with script of your configuration and ensure that that configuration is used as default after every
/system reset-configuration

So - No it is not possible to hide your default configuration from /export compact ;)
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
otgooneo
Trainer
Trainer
Posts: 570
Joined: Tue Dec 01, 2009 3:24 am
Location: Mongolia
Contact:

Re: Export compact (new in v5.12)

Fri Feb 10, 2012 3:47 pm

Thank you macgaiver. Is it not possible even change default configuration using Netinstall?
If so, I need option that able to
/export [find where comment!="MyDefault"] file=blabla
----------------------------
Want to learn more and more...
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Mon Feb 13, 2012 8:55 am

default configuration is one thing while empty configuration is another.

Default you can change using netinstall tool and installing RouterOS with script file that is going to be loaded on the router automatically - it has nothing to do with configuration that export is formed against.

here you can see manual of what defaults there are on different boards:
http://wiki.mikrotik.com/wiki/Manual:De ... igurations

and get some inspiration when creating yours.
 
troy
Member
Member
Posts: 304
Joined: Thu Jun 30, 2005 6:47 pm

Re: Export compact (new in v5.12)

Mon Feb 13, 2012 9:32 pm

2 items i noticed...

DNS and NTP settings are not being marked as dynamic when they're set by dhcp-client, and are therefore included in a compact export.

This goes off topic, but while I'm talking about setting NTP via DHCP, it might be a good idea if the client was enabled and set to broadcast (
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Tue Feb 14, 2012 9:10 am

1) That will change in 5.13

2) why the current default of unicast is not good enough, also, NTP server on the RouterOS defaults to unicast mode and additional modes (broadcast, multicast and manycast) can be enabled in addition to unicast. So now the only thing that you have to do is to set up ntp-client to get the time, enable ntp-server and point other ntp clients to your RouterOS router.
 
engineertote
Member Candidate
Member Candidate
Posts: 177
Joined: Tue May 19, 2009 1:36 pm

Re: Export compact (new in v5.12)

Tue Feb 14, 2012 2:51 pm

i saw in the web site that 5.12 been removed this mornning and back again just now ,, is there any modifications on the new package ??

with thanks
Ahmed
MTCNA , MTCTCE , MTCRE , MTCINE
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Tue Feb 14, 2012 2:52 pm

no, just site maintenance
No answer to your question? How to write posts
 
troy
Member
Member
Posts: 304
Joined: Thu Jun 30, 2005 6:47 pm

Re: Export compact (new in v5.12)

Tue Feb 14, 2012 4:03 pm

2) why the current default of unicast is not good enough, also, NTP server on the RouterOS defaults to unicast mode and additional modes (broadcast, multicast and manycast) can be enabled in addition to unicast. So now the only thing that you have to do is to set up ntp-client to get the time, enable ntp-server and point other ntp clients to your RouterOS router.
I got that backwards... it's set to broadcast and not enabled. Here's the NTP config as set from DHCP:
/system ntp client
set enabled=no mode=broadcast primary-ntp=172.17.2.4 secondary-ntp=0.0.0.0
it needs to be set to unicast and enabled when configured via DHCP.
 
jt2048
newbie
Posts: 40
Joined: Mon Feb 06, 2012 9:53 pm

Re: Export compact (new in v5.12)

Sat Feb 18, 2012 3:06 am

Ok, what's with the version numbers? My system reports 5.4 yet I don't have a compact argument to export. Is the a doc somewhere that talks to version trees and the like?

JT
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Export compact (new in v5.12)

Sat Feb 18, 2012 3:22 am

Ok, what's with the version numbers? My system reports 5.4 yet I don't have a compact argument to export. Is the a doc somewhere that talks to version trees and the like?

JT
5.4 < 5.12

5.4 is not a short way to write 5.40 (a version that doesn't yet exist). It is instead what came before 5.5, 5.6...., 5.9, 5.10, 5.11, and 5.12. The compact argument was only introduced in 5.12.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
otgooneo
Trainer
Trainer
Posts: 570
Joined: Tue Dec 01, 2009 3:24 am
Location: Mongolia
Contact:

Re: Export compact (new in v5.12)

Fri Mar 09, 2012 1:13 pm

Please please please add feature, that can be export only special user defined configurations.
[admin@mikrotik] > export [find where comment!="MyDefault"]
Pls pls pls :-)
----------------------------
Want to learn more and more...
 
falz
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Tue Jun 03, 2008 10:54 pm

Re: Export compact (new in v5.12)

Mon Mar 19, 2012 7:08 pm

Great addition, I've been hoping this would be added since I've started using Mikrotik devices. Thanks for listening to customer requests.
 
shinn
just joined
Posts: 1
Joined: Thu Jun 02, 2011 6:43 pm

Re: Export compact (new in v5.12)

Tue Mar 27, 2012 4:28 pm

please export config with fixed order that i can compare with tools like WinMerge.
 
miro10hr
Frequent Visitor
Frequent Visitor
Posts: 99
Joined: Fri Nov 11, 2011 3:03 pm

Re: Export compact (new in v5.12)

Tue May 08, 2012 12:33 pm

I was testing this function and found some errors. Maybe it would help to improve it (or maybe I am the problem :-) )

I used RB450 and RB750GL, software v5.14.

I did just basic configuration of RB450 - added two IP addresses, did export compact and tried to import configuration to RB750GL.

First error is this one:
/interface wireless security-profiles
set [ find default=yes ] group-ciphers="" unicast-ciphers=""
For some reason RB450 compact export adds the line interface wireless (although it does not have wireless interfaces), which does not exists in RB750GL.

Second "error" is this one:
/tool mac-server
add disabled=no
After this import stops and asks for interface
interface:
This line in full exports looks like this:
/tool mac-server
add disabled=no interface=all
So if I write "all" after it stops, it continues, but maybe it would be better that import is done without stopping.

Hope this helps a little.
 
User avatar
skot
Long time Member
Long time Member
Posts: 586
Joined: Wed Nov 30, 2011 3:05 am

Re: Export compact (new in v5.12)

Thu May 17, 2012 12:46 am

Is there a status report on the bugs people have found? Changelog doesn't say anything about export compact since it was introduced in 5.12
I don't need any karma... I have Ιησους Χριστος!
 
tjc
Member Candidate
Member Candidate
Posts: 279
Joined: Sun Jul 10, 2011 3:08 am

Re: Export compact (new in v5.12)

Thu May 17, 2012 2:54 am

There have definitely been fixes in this area since 5.12. Based on comparing compact exports from 5.12 and 5.16 they seem to have fixed the problems with 0.0.0.0, script policies, logging, nieghbor discovery, ... So far 5.16 is looking like a very solid release.
 
maxstel
Trainer
Trainer
Posts: 70
Joined: Fri Jun 18, 2010 1:54 pm

Re: Export compact (new in v5.12)

Wed Jun 06, 2012 2:15 pm

My experience using export compact.
Two RB 711.
RouterOS 5.16 on both board.
Basic configuration applied on the first (ip on interfaces, wireless link configuration, dhcp client, OSPF).
Import on the second RB (after /system routerboard reset-configuration no-default=yes) and I got this error:
[line 38]/snmp community
[line 39]set [ find default=yes ] addresses=0.0.0.0/0

[line 73]set starttls=no
[line 74] (the last line was empty)

I removed this 4 lines and the script has been imported without errors.

Any suggestion?

Thanks!
Massimo Passerini
STEL S.r.l.
Ferrara - Italy
MikroTik Certified Trainer
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: Export compact (new in v5.12)

Wed Jun 06, 2012 2:22 pm

maxstel, perhaps one of the pre-release 5.16 version was installed on your router.
Install MikroTik RouterOS 5.17 on both routers and address=0.0.0.0/0 and tls options are available there.
 
maxstel
Trainer
Trainer
Posts: 70
Joined: Fri Jun 18, 2010 1:54 pm

Re: Export compact (new in v5.12)

Wed Jun 06, 2012 3:56 pm

maxstel, perhaps one of the pre-release 5.16 version was installed on your router.
Install MikroTik RouterOS 5.17 on both routers and address=0.0.0.0/0 and tls options are available there.
Thank you Sergejs... I will try asap... ;)
Massimo Passerini
STEL S.r.l.
Ferrara - Italy
MikroTik Certified Trainer
 
maxstel
Trainer
Trainer
Posts: 70
Joined: Fri Jun 18, 2010 1:54 pm

Re: Export compact (new in v5.12)

Fri Jun 22, 2012 10:52 am

Another problem with export compact.
Two routers. Both RB433 with 2 wlan and ROS 5.15.
Import stops at this section:
/ip neighbor discovery
at this line
set 012-eoip-tunnel disabled=yes

Without this line, everything works fine...
Of course discovery on some interfaces is disabled by default, so in this case it's not a problem, but every time I import a "compact" I have to cross my fingers... ;)
Massimo Passerini
STEL S.r.l.
Ferrara - Italy
MikroTik Certified Trainer
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Fri Jun 22, 2012 11:32 am

no interface named 012-eoip-tunne exist when neighbour discovery entries are executed?
 
maxstel
Trainer
Trainer
Posts: 70
Joined: Fri Jun 18, 2010 1:54 pm

Re: Export compact (new in v5.12)

Fri Jun 22, 2012 12:29 pm

no interface named 012-eoip-tunne exist when neighbour discovery entries are executed?
Nop...
The interface are created on lines 11, 12 and 13:

/interface eoip
add mac-address=02:29:0E:84:41:8D name=012-eoip-tunnel remote-address=\
172.32.10.254 tunnel-id=12
Massimo Passerini
STEL S.r.l.
Ferrara - Italy
MikroTik Certified Trainer
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Export compact (new in v5.12)

Fri Jun 22, 2012 2:40 pm

update to latest RouterOS i did export compact on 5.18 and there interface creation is before ip settings.
 
maxstel
Trainer
Trainer
Posts: 70
Joined: Fri Jun 18, 2010 1:54 pm

Re: Export compact (new in v5.12)

Fri Jun 22, 2012 5:32 pm

update to latest RouterOS i did export compact on 5.18 and there interface creation is before ip settings.
In my "export compact" rsc file (ROS 5.15), the eoip tunnel is set on lines 11, 12, 13.
..................................................................................
# jan/02/1970 00:01:11 by RouterOS 5.15
# software id = QJAC-J6BC
#
/interface ethernet
set 0 name=ether1
set 1 name=ether2
set 2 name=ether3
/interface bridge
add name=bridge1
add l2mtu=1526 name=bridge_pp
/interface eoip
add mac-address=02:29:0E:84:41:8D name=012-eoip-tunnel remote-address=\
172.32.10.254 tunnel-id=12
....................................................................................
The discovery is set on lines 83, 84, 85, 86
................................................
/ip neighbor discovery
set wlan1 disabled=yes
set wlan2 disabled=yes
set 012-eoip-tunnel disabled=yes
................................................
Is it correct? In this case, the script should be ok or not? In my case, the script stops with an error at line 86...
I don't understand why it stop with error, but when I remove the line "set 012-eoip-tunnel disabled=yes" the script doesn't stop...

Thats all...

Thanks Janis
Massimo Passerini
STEL S.r.l.
Ferrara - Italy
MikroTik Certified Trainer
 
User avatar
hassibi
Trainer
Trainer
Posts: 130
Joined: Wed Jun 13, 2012 5:58 am
Location: Iran,Kerman

Re: Export compact (new in v5.12)

Mon Aug 06, 2012 11:21 am

Thanks Mikrotik.its useful feature.
 
hfarnoudi
Trainer
Trainer
Posts: 2
Joined: Fri Jun 29, 2012 11:04 pm

Re: Export compact (new in v5.12)

Fri Aug 10, 2012 1:27 am

i think it is very useful but i must be test 8)
 
nosovk
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Wed Jan 25, 2012 11:25 am
Location: Ukraine
Contact:

Re: Export compact (new in v5.12)

Sat Jun 29, 2013 9:22 am

We are using SVN to monitor configuration changes, but first line of export compact is
# jan/12/1970 14:40:51 by RouterOS 6.1
can you add some flag to turn off timestamp in it, becouse now each export looks like new commit in svn, even if there nothing changed in it cause of timestamp...

(and really say - there is the same prblem with binarry backup... Or there is more than just config in it?)
Аренда Програмного обеспечения
https://www.CloudZZ.com
Микротики на Украине оптом
mikrotik.kharkov.ua
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Export compact (new in v5.12)

Mon Jul 22, 2013 5:43 pm

first line of export compact is
# jan/12/1970 14:40:51 by RouterOS 6.1
can you add some flag to turn off timestamp in it
use "tail -n +2" :)
(and really say - there is the same prblem with binarry backup... Or there is more than just config in it?)
AFAIR, there's also Graphing, etc.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
nosovk
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Wed Jan 25, 2012 11:25 am
Location: Ukraine
Contact:

Re: Export compact (new in v5.12)

Wed Jul 24, 2013 8:29 am

unfortunatly I dont know how to integrate
tail -n +2 into svn.
But it's good idea :)

this example even settled in wikipedia
http://en.wikipedia.org/wiki/Tail_(Unix)
This example shows all lines of report from the second line onwards:
tail -n +2 report
Аренда Програмного обеспечения
https://www.CloudZZ.com
Микротики на Украине оптом
mikrotik.kharkov.ua
 
solelunauno
Member Candidate
Member Candidate
Posts: 109
Joined: Mon Jul 16, 2012 7:00 pm
Location: Roseto Capo Spulico CS Italy
Contact:

Re: Export compact (new in v5.12)

Fri Aug 16, 2013 9:27 pm

I'm making an automated fetch script with the "export compact" function. I noticed that if you use: export compact file=file , all things goes well; instead, if you use: /tool export compact file=file you have a file "file.rsc" with only 2-3 lines in it, and not all the configuration. Why?
I use RouterOS 6.1 on mipsbe .
SL1 Systems srl MTCNA MTCRE
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Export compact (new in v5.12)

Wed Aug 21, 2013 12:06 am

it's because "/tool export" exports settings from /tool menu. you can use 'export' everywhere, for example "/ip firewall export" to export only firewall settings. use "/export" on any submenu to export full config
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
solelunauno
Member Candidate
Member Candidate
Posts: 109
Joined: Mon Jul 16, 2012 7:00 pm
Location: Roseto Capo Spulico CS Italy
Contact:

Re: Export compact (new in v5.12)

Wed Sep 04, 2013 1:20 pm

Thank you Chupaka. It's a very good point.
SL1 Systems srl MTCNA MTCRE

Who is online

Users browsing this forum: MSN [Bot] and 108 guests