Page 1 of 1

PPTP server routing question

Posted: Thu Feb 02, 2012 1:08 am
by michaelcarey
Hi Everybody.

I am a RouterOS newbie so please be gentle. So far I have my RB750 set up with a PPPoE connection to my ISP, set up NAT, prevented external access to the RB750 via the internet and set up port forwarding to various PC's on my internal network. It's working very well. At the moment my exposure to RouterOS configuration is mainly via WinBox. The learning curve was a little steep... but I am happy with my progress over the last few weeks.

I have now set up a PPTP server on the RB750 and wish get similar VPN functionality that my now orphaned Snapgear/Cyberguard SG570 router provided. I use the PPTP VPN for two purposes :-

1) To access my home network/computers while out on the road.
2) To provide me security while using open/public WiFi access points.


Right now I have PPTP working, I can establish a PPTP connection to RouterOS from an external machine on the internet... but that is as far as it goes.

My internal network is 192.168.0.0/24, the Ether2-local-master is 192.168.0.2.24. I have a pool of IP addresses for the PPTP server, 192.168.0.81-89. When I connect via PPTP I get assigned an IP address from the pool.

How do I set up a route in RouterOS so I can access other machines/devices on my internal network? At the moment I can only access/ping 192.168.0.2 (and the assigned IP address of course). I would also like to be able to access the internet via my home ADSL connection through the PPTP VPN connection when I enable the "Use default gateway on remote network" check box in the advanced IP settings on the Windows VPN connection.

Basically I want a PPTP connection to the RB750 make me appear to be connected directly to my home network.

I look foward to any replies!

Regards,

Michael.

Re: PPTP server routing question

Posted: Thu Feb 02, 2012 1:26 am
by ditonet
On 'Ether2-local-master' interface set 'arp=proxy-arp'.

HTH,

Re: PPTP server routing question

Posted: Thu Feb 02, 2012 4:53 am
by michaelcarey
Thank you very, very much.

Regards,

Michael.