Community discussions

MikroTik App
 
bobwalker
just joined
Topic Author
Posts: 23
Joined: Sun Apr 03, 2011 6:07 am

RouterOS 5.14 Webfig Two Terrible Bugs

Sun Feb 26, 2012 9:04 am

From version 5.14,Some button move to left in webfig,such as "Design Skin","Logout","Undo".
I design skin deleting "Logout","Undo",or "Redo", then I login webfig again, the webfig cant load.

another bug:

in previous version , I can create a user who dont have permission to design skin.(the group dont have "policy" permission). But in version 5.14, how to creat a user who dont have permission to design skin.
Last edited by bobwalker on Fri Mar 02, 2012 10:00 am, edited 1 time in total.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24550
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS 5.14 Design Skin Bugs

Mon Feb 27, 2012 8:13 am

The same way as before. Assign a group that has "policy" unchecked. Is there a problem doing that?
No answer to your question? How to write posts
 
Tbird
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Tue Dec 09, 2008 8:32 pm

Re: RouterOS 5.14 Design Skin Bugs

Thu Mar 01, 2012 1:23 pm

Hmm, I think bobwalker may be right - might be issues on the new skin implementation;

I can create a skin for users with no policy rights, and the Design skin still shows up in their webfig. Furthermore, from that design skin mode they can then load any other "admin skins" and get full access to all menus - not just the skin that belongs to the "guest group"

I think you better look into this normis - could be a security issue.
 
bobwalker
just joined
Topic Author
Posts: 23
Joined: Sun Apr 03, 2011 6:07 am

Re: RouterOS 5.14 Design Skin Bugs

Fri Mar 02, 2012 9:46 am

Hmm, I think bobwalker may be right - might be issues on the new skin implementation;

I can create a skin for users with no policy rights, and the Design skin still shows up in their webfig. Furthermore, from that design skin mode they can then load any other "admin skins" and get full access to all menus - not just the skin that belongs to the "guest group"

I think you better look into this normis - could be a security issue.

Yes,that is what i want to say.I speak chinese.
 
OrCAD
Member Candidate
Member Candidate
Posts: 132
Joined: Wed Apr 20, 2005 12:37 pm

Re: RouterOS 5.14 Webfig Two Terrible Bugs

Sun Apr 01, 2012 9:16 pm

I confirm... Design skin still available!!
MTCNA - MTCRE - MTCTCE - MTCINE
 
dtoffo
Trainer
Trainer
Posts: 98
Joined: Tue May 17, 2011 9:19 am

Re: RouterOS 5.14 Webfig Two Terrible Bugs

Fri Apr 06, 2012 12:28 pm

Yesterday I was installing a 751U-2hnd in my customer's office.
The internal networking
I had the bad idea to say to my costumer "you want a simplified management interface? I'll customize it for you in minutes!"
What a bad, bad , BAD! , BAD!!, BAD!!!!
BAD!!!
impression to the customer!
I spent two hours trying to customize skin, without success!

1. the famous button "design skin"... even if the group has no "policy" permission, the button is there, clickable, and when clicked al the tree shows up with all the options. The user can't save modifications, but it's not good at all: he can delete object (I tried with a firewall rule)!

2. if I remove some tabs i see unwanted pages. Example: I want the customer to see only access list tab on the wireless menu, just to add to add mac addresses for known devices: at login wireless alignment settings show up.
I tried to select access list and click save skin while displaying it: at login he sees the access list tab, but if he changes on the left menu and returns to wireless again he sees wireless alignment and has no chance to go to access lists. I tried to change directly in the json adding "Wireless: {'Access List': 1" at the first position (I know: when I finish good ideas I try with stupid ones...) . Nothing changes.
For dhcp I want him to see leases, to make reservations, but he sees only lease options.
I can continue...


Please make me know if I am wrong or I missed something.
... or fix webfig!


My configuration: I gave the group these policyes: read, write, web and assignet this skin:

{
Interfaces: 0,
Wireless: {
'Nstreme Dual': 0,
Interfaces: 0,
'Connect List': 0,
'Security Profiles': 0,
VirtualAP: {
'&': { remove: 0 }
},
WDS: {
'&': { remove: 0 }
},
Scanner: 0,
'Freq. Usage': 0,
Alignment: 0,
'Wireless Sniffer': 0,
'Wireless Snooper': 0,
Registration: 0
},
Bridge: 0,
Switch: 0,
PPP: 0,
Mesh: 0,
IP: {
ARP: 0,
Accounting: 0,
Addresses: 0,
'DHCP Client': 0,
'DHCP Relay': 0,
'DHCP Server': {
DHCP: 0,
Networks: 0,
Options: 0,
Alerts: 0
},
DNS: 0,
Firewall: 0,
Hotspot: 0,
IPsec: 0,
Neighbors: 0,
Packing: 0,
Pool: 0,
Routes: 0,
SMB: 0,
SNMP: 0,
Services: 0,
Socks: 0,
TFTP: 0,
'Traffic Flow': 0,
UPnP: 0,
'Web Proxy': 0
},
MPLS: 0,
Routing: 0,
System: {
'Auto Upgrade': 0,
Certificates: 0,
Clock: 0,
Console: 0,
Drivers: 0,
History: 0,
Identity: 0,
LEDs: 0,
License: 0,
Logging: 0,
Packages: 0,
Password: 0,
Ports: 0,
'Reset Configuration': 0,
Resources: 0,
Routerboard: 0,
'SNTP Client': 0,
Scheduler: 0,
Scripts: 0,
Shutdown: 0,
'Special Login': 0,
Stores: 0,
Users: 0,
Watchdog: 0
},
Queues: 0,
Files: 0,
Radius: 0,
Tools: 0,
'New Terminal': 0,
MetaROUTER: 0,
'Make Supout.rif': 0,
Manual: 0,
WinBox: 0,
Graphs: 0,
License: 0
}
 
dtoffo
Trainer
Trainer
Posts: 98
Joined: Tue May 17, 2011 9:19 am

Re: RouterOS 5.14 Webfig Two Terrible Bugs

Mon Apr 16, 2012 5:34 pm

No one reading this thread and giving me any suggestion?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24550
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS 5.14 Webfig Two Terrible Bugs

Tue Apr 17, 2012 8:31 am

I am really sorry you had such bad experience with your first try. The mentioned issues are fixed in v5.15 which is about to be released this week.
No answer to your question? How to write posts
 
dtoffo
Trainer
Trainer
Posts: 98
Joined: Tue May 17, 2011 9:19 am

Re: RouterOS 5.14 Webfig Two Terrible Bugs

Tue Apr 17, 2012 7:18 pm

It was not my first try.
I made some skins correctly in previous versions, I couldn't imagine such a nightmare with the latest one.
 
dtoffo
Trainer
Trainer
Posts: 98
Joined: Tue May 17, 2011 9:19 am

Re: RouterOS 5.14 Webfig Two Terrible Bugs

Fri May 04, 2012 12:13 pm

Today I can spend some time testing skins on 5.15.

Ok for removing "design skin"

BUT

given that the user "cicci" in in a group with read,write and web policy linked to the "minimal-wlan" skin, I attach my configuration and my results.

configuration screenshot: on wireless I enabled only "address list" and "registration"
Wireless Tables at admin@201.0.1.130 - Webfig v5.15 on _2012-05-04_10-54-26.png
user screenshot: when the user logs in he sees this, and nothing else to reach the other wireless configurations
Wireless Alignment Settings at cicci@201.0.1.130 - Webf_2012-05-04_10-53-46.png
this is the json file for that skin:
minimal-wlan.json.txt
SOMEONE CAN EXPLAIN ME?
- is it my error?
- is skin design already broken?

SOMEONE CAN GIVE ME A SUGGESTION?

- which version I have to downgrade to give my customer a skin just for adding some mac addresses to a wlan interface?
- should I go through API? I'm not a programmer, someone can hint?
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], jebz, petertosh, Renfrew, sindy, tdw, vntnet and 88 guests