Community discussions

MUM Europe 2020
 
BWC
newbie
Topic Author
Posts: 34
Joined: Tue Mar 21, 2006 5:36 pm
Location: Würzburg, Germany
Contact:

SSTP: sstp-client for linux not working properly?

Thu Mar 01, 2012 12:14 pm

Hi there,

I'am trying to connect with the linux sstp-client to on of my ROS 5.14 RB750G. If I crank up the client manually with:
sstpc --ca-cert ca.crt --user michael --password supersecret test.bwc.internal

the connection works for exactly 60 seconds and goes down with:
**Error: Connection was aborted, Reason was not known, (-1)

Why does the connection gets terminated after 60 seconds, which looks like a timeout?

/interface sstp-server server
set authentication=pap,chap,mschap1,mschap2 certificate=sstp default-profile=\
default enabled=yes keepalive-timeout=120 max-mru=1500 max-mtu=1500 mrru=\
disabled port=443 verify-client-certificate=no

The log is telling me this:
Mar/01/2012 11:07:26 sstp,info,account michael logged in, 192.168.140.10
Mar/01/2012 11:07:56 sstp,debug,packet <sstp-michael>: rcvd LCP EchoReq id=0x1
Mar/01/2012 11:07:56 sstp,debug,packet <magic 0xf85a5feb>
Mar/01/2012 11:07:56 sstp,debug,packet <sstp-michael>: sent LCP EchoRep id=0x1
Mar/01/2012 11:07:56 sstp,debug,packet <magic 0x40d8ab81>
Mar/01/2012 11:08:26 sstp,debug send abort
Mar/01/2012 11:08:26 sstp,debug send status
Mar/01/2012 11:08:26 sstp,packet <sstp-michael> sent control packet type: abort
Mar/01/2012 11:08:26 sstp,packet 10 01 00 14 00 05 00 01 00 02 00 0c 00 00 00 02
Mar/01/2012 11:08:26 sstp,packet 00 00 00 00
Mar/01/2012 11:08:26 sstp,debug <sstp-michael>: LCP lowerdown
Mar/01/2012 11:08:26 sstp,debug <sstp-michael>: LCP closed
Mar/01/2012 11:08:26 sstp,debug <sstp-michael>: CCP lowerdown
Mar/01/2012 11:08:26 sstp,debug <sstp-michael>: BCP lowerdown
Mar/01/2012 11:08:26 sstp,debug <sstp-michael>: BCP down event in starting state
Mar/01/2012 11:08:26 sstp,debug <sstp-michael>: IPCP lowerdown
Mar/01/2012 11:08:26 sstp,debug <sstp-michael>: IPCP closed
Mar/01/2012 11:08:26 sstp,info,account michael logged out, 60 5029 5067 67 69
Mar/01/2012 11:08:26 sstp,debug <sstp-michael>: IPV6CP lowerdown
Mar/01/2012 11:08:26 sstp,debug <sstp-michael>: MPLSCP lowerdown
Mar/01/2012 11:08:26 sstp,info <sstp-michael>: terminating... - negotiation timeout
Mar/01/2012 11:08:26 sstp,debug <sstp-michael>: LCP lowerdown
Mar/01/2012 11:08:26 sstp,debug <sstp-michael>: LCP down event in starting state
Mar/01/2012 11:08:26 sstp,info <sstp-michael>: disconnected


I'am somewhat lost, any help highly appreciated.

--Michael
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5965
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: SSTP: sstp-client for linux not working properly?

Thu Mar 01, 2012 5:48 pm

Try to run sstpc via sudo.
 
BWC
newbie
Topic Author
Posts: 34
Joined: Tue Mar 21, 2006 5:36 pm
Location: Würzburg, Germany
Contact:

Re: SSTP: sstp-client for linux not working properly?

Thu Mar 01, 2012 8:22 pm

I'am always running in sudo :)
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5965
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: SSTP: sstp-client for linux not working properly?

Fri Mar 02, 2012 11:27 am

It seems to be a bug in linux SSTP client. It does not send one packet needed to finalize ppp negotiation.
 
BWC
newbie
Topic Author
Posts: 34
Joined: Tue Mar 21, 2006 5:36 pm
Location: Würzburg, Germany
Contact:

Re: SSTP: sstp-client for linux not working properly?

Fri Mar 02, 2012 3:24 pm

Hi,

thanks for the update, I tried on Ubuntu 10.04 and 12.04 (alpha/beta) with the same result.

Is anybody else using sstp-client on linux with success?

--Michael
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5965
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: SSTP: sstp-client for linux not working properly?

Fri Mar 02, 2012 3:29 pm

try to enable only pap authentication on sstp server and then try to connect.
 
BWC
newbie
Topic Author
Posts: 34
Joined: Tue Mar 21, 2006 5:36 pm
Location: Würzburg, Germany
Contact:

Re: SSTP: sstp-client for linux not working properly?

Fri Mar 02, 2012 3:59 pm

Nope, same result with just PAP selected, 60 seconds it is.
 
mdenadal
just joined
Posts: 9
Joined: Sun Oct 02, 2005 10:04 am

Re: SSTP: sstp-client for linux not working properly?

Mon Sep 30, 2013 1:35 pm

I have exactly the same issue here.

Everything fine for 60 seconds and then:

<sstp-test>: terminating.... - negotiation timeout
<sstp-test>: disconnected

The client works fine against Windows 2008 sstp server.

Any ideas ??
Thanks.
 
dirtonth
Trainer
Trainer
Posts: 25
Joined: Fri Aug 20, 2004 7:54 pm
Location: Ireland
Contact:

Re: SSTP: sstp-client for linux not working properly?

Mon Feb 24, 2014 12:47 pm

Hey Guys,

I have hit this problem in a different scenario. All my routers where running 5.26, and I have upgraded one router acting as sstp client to 6.10 and I am seeing the exact same problem.

Any Ideas?

Thanks,
 
angmar26
just joined
Posts: 1
Joined: Fri Mar 14, 2014 6:08 am

Re: SSTP: sstp-client for linux not working properly?

Fri Mar 14, 2014 6:32 am

Same problem, 6.10 after update SSTP abort connections after 60 sec
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5965
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: SSTP: sstp-client for linux not working properly?

Fri Mar 14, 2014 9:56 am

As it was mentioned in one of previous posts. It is a bug in linux sstp client implementation.

Who is online

Users browsing this forum: Bing [Bot] and 120 guests