Page 1 of 1

The usb2 port channel count is changing

Posted: Tue Mar 06, 2012 8:17 pm
by Ivoshiee
I am trying to get a GSM mpci-e card (Option M00201) to work on RB411U running ROS 5.14 and after some initial poking I have it running.
I have a strange issue with that setup:
for some unknown reason the /port print is reporting as usb2 port having hard time of deciding how many channels it has:
[admin@MikroTik] > /port  print
Flags: I - inactive 
 #   NAME                           CHANNELS USED-BY                         BAUD-RATE
 0   serial0                               1 Serial Console                  auto     
 1   usb2                                  2 PPP <ppp-out1>                  9600     
[admin@MikroTik] > 
some time later
[admin@MikroTik] > /port  print
Flags: I - inactive 
 #   NAME                           CHANNELS USED-BY                         BAUD-RATE
 0   serial0                               1 Serial Console                  auto     
 1   usb2                                  3 PPP <ppp-out1>                  9600     
[admin@MikroTik] > 
That channel count flipping does happen randomly and is not related to system startup or anything.
Unfortunately the data and info channel for the PPP to work is migrating to last channel available as well and thus breaking the PPP configuration and Internet.

What is it? Is it feature or a bug? How to work around that?

Re: The usb2 port channel count is changing

Posted: Tue Mar 06, 2012 8:57 pm
by Ivoshiee

Re: The usb2 port channel count is changing

Posted: Tue Mar 06, 2012 9:03 pm
by Ivoshiee
Both ROS 5.14 and ROS 5.12 are flipping usb2 port channel count between 2 and 3.

I am now back to originally shipped ROS 5.2 what has stayed for some time on usb2 as having 2 channels.
Unfortunately I updated the RB411U firmware with ROS 5.14 and it is hard to point is it ROS or firmware+ROS issue.

Re: The usb2 port channel count is changing

Posted: Wed Mar 07, 2012 9:39 am
by uldis
please contact support@mikrotik.com and provide us remote access to this router so we could debug this problem.
Also tell us why you do to make the modem add or loose a channel.

Re: The usb2 port channel count is changing

Posted: Wed Mar 07, 2012 9:47 pm
by Ivoshiee
please contact support@mikrotik.com and provide us remote access to this router so we could debug this problem.
Also tell us why you do to make the modem add or loose a channel.
Ticket#2012030766000391

Also, cold boot will tend to bring the usb2 port up with 2 channels. Warm boot/reboot will bring it up with 3 channels.

Re: The usb2 port channel count is changing

Posted: Sat Mar 17, 2012 9:19 pm
by Ivoshiee
Any news on that issue?

Re: The usb2 port channel count is changing

Posted: Sun Jul 15, 2012 11:39 am
by Ivoshiee
Update: According to the MT support it is unsolvable issue for now. Just use an older ROS or just implement some script magic to detect the situation and act accordingly.

Re: The usb2 port channel count is changing

Posted: Tue Jun 11, 2013 6:41 pm
by Ivoshiee
v6.0 and later have somehow dropped the support for that modem. Why?