Community discussions

MikroTik App
 
ditonet
Forum Veteran
Forum Veteran
Topic Author
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Webfig skin error

Sat Mar 17, 2012 11:40 pm

Today I've tried to make Webfig skin, just for testing, only few menus removed.
When I'm logging to Webfig as user with this skin selected, web browser window is empty.
Web browser reports: 'Uncaught TypeError: Cannot read property 'firstChild' of null' in 'engine.js'.
I've tried almost every browser (FF, Chrome, Opera, IE), still the same.
RouterOS 5.14, RB433AH.
Any ideas???

TIA,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6624
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: Webfig skin error

Tue Mar 20, 2012 9:29 am

Please post your settings from /user, that are used for skin user.
 
ditonet
Forum Veteran
Forum Veteran
Topic Author
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: Webfig skin error

Tue Mar 20, 2012 10:32 am

@Sergejs,

Below are user setting, affected user is userro:
/user group
set read name=read policy=local,telnet,ssh,reboot,read,test,winbox,password,web,sniff,sensitive,api,!ftp,!write,!policy skin=default
set write name=write policy=local,telnet,ssh,reboot,read,write,test,winbox,password,web,sniff,sensitive,api,!ftp,!policy skin=default
set full name=full policy=local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,password,web,sniff,sensitive,api skin=default
add name=safe policy=ssh,ftp,!local,!telnet,!reboot,!read,!write,!policy,!test,!winbox,!password,!web,!sniff,!sensitive,!api skin=default
add name=skinny policy=local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,password,web,sniff,sensitive,api skin=testowa
/user
add address=0.0.0.0/0 disabled=no group=full name=grzegorz
add address=0.0.0.0/0 disabled=no group=skinny name=userro
and content of 'testowa.json':
{
    Files: 0,
    'New Terminal': 0,
    MetaROUTER: 0,
    'Make Supout.rif': 0,
    Manual: 0,
    WinBox: 0,
    Graphs: 0,
    License: 0,
    Undo: 0,
    Redo: 0,
    'Hide Passwords': 0,
    'Safe Mode': 0
}
This skin was also tested on RB751U, ROS 5.14, same problem :(

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
ditonet
Forum Veteran
Forum Veteran
Topic Author
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: Webfig skin error

Wed Mar 28, 2012 10:00 am

@Sergejs,

Any news???

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24605
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Webfig skin error

Thu Mar 29, 2012 9:40 am

Well but did you try to delete the JSON file?
No answer to your question? How to write posts
 
ditonet
Forum Veteran
Forum Veteran
Topic Author
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: Webfig skin error

Thu Mar 29, 2012 10:06 am

Normis,
Well but did you try to delete the JSON file?
Many times :D
Default skin works fine and there is no problem with users with 'skin=default'.
Problem is with newly designed skin as described above.
Removing this skin (testowa.json in this case) and making new one (even with different name) don't resolve my problem.
Recently I found other error reported by Firefox: 'A is null'.

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24605
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Webfig skin error

Thu Mar 29, 2012 10:54 am

email support, we will give you a pre-release version where this should be fixed.
No answer to your question? How to write posts
 
ditonet
Forum Veteran
Forum Veteran
Topic Author
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: Webfig skin error

Thu Mar 29, 2012 11:45 am

Still the same with 5.15rc1 :(
Packages are dated Mar/29/2012, 7 a.m
Is this latest RC version with mentioned fix?

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24605
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Webfig skin error

Thu Mar 29, 2012 11:54 am

yes of course, we couldn't give you packages of the future, so we gave you fresh packages that were built an hour before you asked :)

we will see why the fix didn't work on your system.
No answer to your question? How to write posts
 
ditonet
Forum Veteran
Forum Veteran
Topic Author
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: Webfig skin error

Thu Mar 29, 2012 12:14 pm

yes of course, we couldn't give you packages of the future, so we gave you fresh packages that were built an hour before you asked
I've asked you because is possible that new version was compiled, but not uploaded to server.
If you need additional information let me know.

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
thantoldo
just joined
Posts: 22
Joined: Tue Apr 10, 2012 10:08 pm

Re: Webfig skin error

Tue Apr 10, 2012 10:15 pm

I confirm exactly the same error, routeros 5.14 at RB750. Checked at all browsers.
Firefox reports: 'A is null' at engine.js (line 1).

Regards,
Thanos
 
User avatar
marioclep
Trainer
Trainer
Posts: 140
Joined: Sat Jul 11, 2009 4:36 pm
Location: Cordoba - Argentina
Contact:

Re: Webfig skin error

Wed Apr 11, 2012 3:21 am

Do not uncheck the menues "undo", "redo" and "hide menu" and check again.
---------------------

Ing. Mario D. Clep
CTO - MKE Solutions
MikroTik Certified Trainer
 
ditonet
Forum Veteran
Forum Veteran
Topic Author
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: Webfig skin error

Wed Apr 11, 2012 5:25 pm

Do not uncheck the menues "undo", "redo" and "hide menu" and check again.
It's workaround only, which shows that Webfig contains some bugs :(
Webfig is great feature and I hope MT will fix it soon.

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
thantoldo
just joined
Posts: 22
Joined: Tue Apr 10, 2012 10:08 pm

Re: Webfig skin error

Thu Apr 12, 2012 2:00 am

Do not uncheck the menues "undo", "redo" and "hide menu" and check again.
results into q is null -> doesnt work! :shock:

menus "undo", "redo", "hide menu" and "safe mode" checked -> works, but then after log in "design skin" is active and that user can see everything in design mode, although his privileges are constrained by his group permissions :shock:

menu "safe mode" checked, the other three unchecked -> z is null -> doesnt work :shock:

Any other combination of these doesnt work!

Any clues?

Regards,
Thanos
 
User avatar
marioclep
Trainer
Trainer
Posts: 140
Joined: Sat Jul 11, 2009 4:36 pm
Location: Cordoba - Argentina
Contact:

Re: Webfig skin error

Fri Apr 13, 2012 7:34 pm

It's a bug... use Ros V5.15

Regards
---------------------

Ing. Mario D. Clep
CTO - MKE Solutions
MikroTik Certified Trainer
 
ditonet
Forum Veteran
Forum Veteran
Topic Author
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: Webfig skin error

Sat Apr 14, 2012 12:30 pm

I tried latest 5.15rc1, it seems that some bugs are fixed, but I'm still unable to create 'Status' page.

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
ditonet
Forum Veteran
Forum Veteran
Topic Author
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: Webfig skin error

Fri Apr 20, 2012 9:43 pm

There is a new ROS version (5.15) but my problem with 'Status' still exist :(
If someone have skin with working 'Status' page, post it (.json file) please.

TIA,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert

Who is online

Users browsing this forum: anav, Bing [Bot], vanishoxigen and 88 guests