Community discussions

MUM Europe 2020
 
rviteri
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 84
Joined: Fri Nov 18, 2011 5:53 pm

Transparent Web Proxy Cache feels slow

Sat Mar 31, 2012 7:18 pm

Hi all,

I have noticed that after a few days of the transparent proxy activated internet browsing feels slower. I have a redirect rule that caches traffic from the local bridge and forwards it to the 8080 port of the MK router.

I have an RB450G v5.14, I don't have a microSD card on it so everything gets stored in RAM. I don't have any QoS rules active. The idea of using this is to have a faster browsing experience. In my house my wife and I usually browse the same websites so if one browses first than the other should load quickly. However, this is not the case. It feels that the website loads halfway and then it takes a few seconds to complete. Sometimes, some images will fail to load and will not be displayed. This happens every now and then and pretty much randomly with any website I test it.

These are my settings:
/ip firewall nat
add action=redirect chain=dstnat disabled=yes in-interface=bridge port=80 protocol=tcp to-addresses=0.0.0.0 to-ports=\
    8080
add action=masquerade chain=srcnat disabled=no out-interface=ether1-gateway


[Ricardo@MikroTik] /ip proxy> print 
                 enabled: yes
             src-address: 192.168.88.1
                    port: 8080
            parent-proxy: 0.0.0.0
       parent-proxy-port: 0
     cache-administrator: webmaster
          max-cache-size: 150000KiB
           cache-on-disk: no
  max-client-connections: 600
  max-server-connections: 600
          max-fresh-time: 2w1d
   serialize-connections: no
       always-from-cache: yes
          cache-hit-dscp: 4
             cache-drive: system

 
rviteri
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 84
Joined: Fri Nov 18, 2011 5:53 pm

Re: Transparent Web Proxy Cache feels slow

Wed Apr 18, 2012 12:58 pm

I added a SanDisk SDHC 8 GB card. It still feels slow.


Any ideas anyone?

Who is online

Users browsing this forum: Sapo and 132 guests