Community discussions

MUM Europe 2020
 
hkusulja
just joined
Topic Author
Posts: 15
Joined: Fri Apr 13, 2012 1:14 am

Route problem for LAN with VRRP , is a bug ?

Fri Apr 13, 2012 1:21 am

Hi,
I have two RB450G with 5.12 version.

On both i have interface named "LAN" with normal local ip (10.23.2.3/24) and (10.23.2.4/24). Ofcorse this automatically implicates to have routes (DAC - 10.23.2.0/24 gateway: LAN).
After setting up VRRP with shared IP 10.23.2.1, network: 10.23.2.1 on new vrrp-lan interface, everthing works.

Problem (or bug) is, that after mikrotik reboot. it looses its own ip route for local network (DAC as mentioned before). Router does not respond to direct ping or anything else. After going to IP address list, changing interface for my ip 10.23.2.3/24 from LAN to wan (or anything else), and making option back to LAN. DAC ip route is created and everything works.

Maybe the problem is when powering on and loading configuration with wrong config order, becase DAC should always be presented.

One approach could be to write startup script to recreate normal local ip, which will recreate DAC ip route.

Please advise.
 
User avatar
andrewluck
Forum Veteran
Forum Veteran
Posts: 702
Joined: Fri May 28, 2004 9:05 pm
Location: Norfolk, UK

Re: Route problem for LAN with VRRP , is a bug ?

Tue Apr 17, 2012 1:35 pm

Post your VRRP configuration from both routers.

Regards

Andrew
 
hkusulja
just joined
Topic Author
Posts: 15
Joined: Fri Apr 13, 2012 1:14 am

Re: Route problem for LAN with VRRP , is a bug ?

Tue Apr 17, 2012 5:30 pm

Hi,
After few reboots of both routers it seems it runs fine. However maybe sometimes, after boot, my LACP and VLAN interfaces are not ready so it want assigne this ip addres and create DAC route for interfaces. (it has IP address, but can not ping anybody on local network except itself, DAC route is missing, recreating IP address with /24 fixes the issue). Maybe this does not have nothing with VRRP at all.

First router (master):
/interface ethernet
set 0 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1520 mac-address=00:0C:42:A0:85:A5 master-port=none mtu=1500 name=wan speed=100Mbps
set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1520 mac-address=00:0C:42:A0:85:A6 master-port=none mtu=1500 name=ether2 speed=100Mbps
set 2 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1520 mac-address=00:0C:42:A0:85:A7 master-port=none mtu=1500 name=ether3 speed=100Mbps
set 3 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1520 mac-address=00:0C:42:A0:85:A8 master-port=none mtu=1500 name=ether4 speed=100Mbps
set 4 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1520 mac-address=00:0C:42:A0:85:A9 master-port=none mtu=1500 name=ether5 speed=100Mbps
/interface vrrp
add arp=enabled authentication=none disabled=no interface=wan interval=2s mtu=1500 name=vrrp-wan on-backup="" on-master="" password=ss preemption-mode=yes priority=101 v3-protocol=ipv4 version=3 vrid=6
/interface bonding
add arp=enabled arp-interval=100ms arp-ip-targets="" disabled=no down-delay=0ms lacp-rate=30secs link-monitoring=none mii-interval=100ms mode=802.3ad mtu=1500 name=lacp-lan primary=none slaves=\
    ether2,ether3,ether4,ether5 transmit-hash-policy=layer-2 up-delay=0ms
/interface vlan
add arp=enabled disabled=no interface=lacp-lan mtu=1500 name=lan use-service-tag=no vlan-id=2
add arp=enabled disabled=no interface=lacp-lan mtu=1500 name=chyperv use-service-tag=no vlan-id=3
/interface vrrp
add arp=enabled authentication=none disabled=no interface=lan interval=2s mtu=1500 name=vrrp-lan on-backup="" on-master="" password="" preemption-mode=yes priority=101 v3-protocol=ipv4 version=3 vrid=2

/ip address
add address=10.23.2.1/32 disabled=no interface=vrrp-lan network=10.23.2.1
add address=10.0.201.12/24 disabled=no interface=wan network=10.0.201.0
add address=10.0.201.10/32 disabled=no interface=vrrp-wan network=10.0.201.10
add address=10.23.2.3/24 disabled=no interface=lan network=10.23.2.0
add address=10.0.201.11/32 disabled=no interface=vrrp-wan network=10.0.201.11
Second router (slave):
/interface ethernet
set 0 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1520 mac-address=00:0C:42:AC:6E:A1 master-port=none mtu=1500 name=wan speed=100Mbps
set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1520 mac-address=00:0C:42:AC:6E:A2 master-port=none mtu=1500 name=ether2 speed=100Mbps
set 2 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1520 mac-address=00:0C:42:AC:6E:A3 master-port=none mtu=1500 name=ether3 speed=100Mbps
set 3 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1520 mac-address=00:0C:42:AC:6E:A4 master-port=none mtu=1500 name=ether4 speed=100Mbps
set 4 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1520 mac-address=00:0C:42:AC:6E:A5 master-port=none mtu=1500 name=ether5 speed=100Mbps
/interface vrrp
add arp=enabled authentication=none disabled=no interface=wan interval=2s mtu=1500 name=vrrp-wan on-backup="" on-master="" password="" preemption-mode=yes priority=100 v3-protocol=ipv4 version=3 vrid=6
/interface bonding
add arp=enabled arp-interval=100ms arp-ip-targets="" disabled=no down-delay=0ms lacp-rate=30secs link-monitoring=none mii-interval=100ms mode=802.3ad mtu=1500 name=lacp-lan primary=none slaves=ether2,ether3,ether4,ether5 transmit-hash-policy=\
    layer-2 up-delay=0ms
/interface vlan
add arp=enabled disabled=no interface=lacp-lan mtu=1500 name=lan use-service-tag=no vlan-id=2
add arp=enabled disabled=no interface=lacp-lan mtu=1500 name=chyperv use-service-tag=no vlan-id=3
/interface vrrp
add arp=enabled authentication=none disabled=no interface=lan interval=2s mtu=1500 name=vrrp-lan on-backup="" on-master="" password="" preemption-mode=yes priority=100 v3-protocol=ipv4 version=3 vrid=2

/ip address
add address=10.0.201.13/24 disabled=no interface=wan network=10.0.201.0
add address=10.23.2.1/32 disabled=no interface=vrrp-lan network=10.23.2.1
add address=10.0.201.10/32 disabled=no interface=vrrp-wan network=10.0.201.10
add address=10.23.2.4/24 disabled=no interface=lan network=10.23.2.0
add address=10.0.201.11/32 disabled=no interface=vrrp-wan network=10.0.201.11
 
bitshop
just joined
Posts: 2
Joined: Fri Jul 06, 2012 11:11 am

Re: Route problem for LAN with VRRP , is a bug ?

Fri Jul 06, 2012 11:23 am

I posted in another post also on VRRP - i think perhaps something comes up out of order and you may need to change priority (or disable/enable) the vrrp interface and see if things come back up properly (instead of rebooting). That may give them another hint.

Is there any way to log more info about the ip addresses / interfaces / routes being added/removed when it occurs due to interface coming up/down?
 
hkusulja
just joined
Topic Author
Posts: 15
Joined: Fri Apr 13, 2012 1:14 am

Re: Route problem for LAN with VRRP , is a bug ?

Mon Jul 09, 2012 9:29 am

After few reboots, did not help, but after few days, it worked normally. Yes, problem is with interface up/down order. Now it is running for a weeks.
I could not figure how to change interface up/down order on boot.

Who is online

Users browsing this forum: No registered users and 193 guests