Community discussions

 
xunil76
newbie
Topic Author
Posts: 43
Joined: Fri May 20, 2011 12:48 am

can someone please double-check my queues?

Wed Apr 25, 2012 6:46 am

i have an RB493G (RouterOS 5.11) with ports 2 thru 9 and wlan1 bound to a bridge called "LAN-Bridge". port 1 is the WAN interface. i have 3 subnets set up on the LAN-Bridge:

192.168.75.0/24 - all packets from this subnet are marked either "Priority 1 UP" or "Priority 1 DOWN", depending on the direction of traffic flow
/ip firewall mangle
add action=mark-packet chain=forward comment=Fastest src-address=192.168.75.0/24 new-packet-mark="Priority 1 UP" passthrough=no
add action=mark-packet chain=forward comment=Fastest dst-address=192.168.75.0/24 new-packet-mark="Priority 1 DOWN" passthrough=no
192.168.175.0/24 - all packets from this subnet are marked either "Priority 2 UP" or "Priority 1 DOWN", depending on the direction of traffic flow
/ip firewall mangle
add action=mark-packet chain=forward comment=Medium src-address=192.168.175.0/24 new-packet-mark="Priority 2 UP" passthrough=no
add action=mark-packet chain=forward comment=Medium dst-address=192.168.175.0/24 new-packet-mark="Priority 2 DOWN" passthrough=no
192.168.200.0/24 - all packets from this subnet are marked either "Priority 3 UP" or "Priority 1 DOWN", depending on the direction of traffic flow
/ip firewall mangle
add action=mark-packet chain=forward comment=Slowest src-address=192.168.200.0/24 new-packet-mark="Priority 3 UP" passthrough=no
add action=mark-packet chain=forward comment=Slowest dst-address=192.168.200.0/24 new-packet-mark="Priority 3 DOWN" passthrough=no
i can watch the traffic as i upload/download things from PC's on each subnet, and packets are getting sent to the correct individual PCQ queues....however, what i'm not sure about is the type of queue that should be set for the parent connections. i have both "All Download" and "All Upload" set to a queue type of "default", and all of the child queues set to "pcq queue" (pcq-rate=0), with the proper priority assigned to each child:
/queue tree

add burst-limit=0 burst-threshold=0 burst-time=0s limit-at=0 max-limit=8500k name="All Download" parent=LAN-Bridge priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s limit-at=4500k max-limit=8500k name="Priority 1 DOWN" packet-mark="Priority 1 DOWN" parent="All Download" priority=1 queue="pcq queue"
add burst-limit=0 burst-threshold=0 burst-time=0s limit-at=2M max-limit=4500k name="Priority 2 DOWN" packet-mark="Priority 2 DOWN" parent="All Download" priority=2 queue="pcq queue"
add burst-limit=0 burst-threshold=0 burst-time=0s limit-at=16k max-limit=16k name="Priority 3 DOWN" packet-mark="Priority 3 DOWN" parent="All Download" priority=8 queue="pcq queue"

add burst-limit=0 burst-threshold=0 burst-time=0s limit-at=0 max-limit=768k name="All Upload" parent=global-out priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s limit-at=640k max-limit=768k name="Priority 1 UL" packet-mark="Priority 1 UP" parent="All Upload" priority=1 queue="pcq queue"
add burst-limit=0 burst-threshold=0 burst-time=0s limit-at=128k max-limit=128k name="Priority 2 UL" packet-mark="Priority 2 UP" parent="All Upload" priority=2 queue="pcq queue"
add burst-limit=0 burst-threshold=0 burst-time=0s limit-at=16k max-limit=16k name="Priority 3 UL" packet-mark="Priority 3 UP" parent="All Upload" priority=8 queue="pcq queue"
is it fine to leave the parents set to "default" on the queue type, or would a different queue type be better?
 
User avatar
dasiu
Trainer
Trainer
Posts: 232
Joined: Fri Jan 30, 2009 11:41 am
Location: Reading, UK
Contact:

Re: can someone please double-check my queues?

Thu Apr 26, 2012 10:15 am

http://forum.mikrotik.com/viewtopic.php ... 63#p276863 - it is already here :).
In a few words - the parents' queue types are IRRELEVANT :). In /queue tree (generally - HTB) only the children do the actual queueing (waiting room for packets), and the parents only count bandwidth for their children. (see: http://wiki.mikrotik.com/wiki/Manual:HTB)

Who is online

Users browsing this forum: No registered users and 87 guests