Community discussions

MUM Europe 2020
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Weird dhcp-client behaviour

Thu May 10, 2012 11:17 am

I have recently 2 Groove's (ROSv5.15 updated firmware. Issue already exist on 5.11, .12, .13 and .14) with a very weird dhcp-cl behaviour.

Groove is CPE that associates to AP with its wlan1 mac address (mac address access list in AP).
Same mac address is used to assign CPE with fixed dynamic IP from dhcp-server in this same AP.

This works for 250+ units and I use this system for 6 years now without issues...

But now I have these two units that several times a day request a new IP at the dhcp-server with a mac address that is different from the wlan1 interface. In fact, the mac address is almost the same as the mac of the ethernet port, but one digit (the last pair) higher. So for instance 00:0C:42:89:49:14 is the ethernet interface where the server gets a request from 00:0C:42:89:49:14.15.
The dhcp server give an IP to this mac now and the Groove is now only reachable on this new IP address. The old, original, IP address is shown in the server as 'bound' but is unreachable since it doesn't exist anylonger.

The newly assigned IP is residing on the wlan1 interface, which in itself is still allowed to assign by the AP with its normal mac..
Since this new IP is not known by the rest of my system client has no more internet access.

I tried bypassing this problem by making this new mac address the one to use in the system (so I make it 'fixed' in the IP-server lease list) but next thing that happens after some hours the CPE request yet again a new address with yet again a new mac address!

Like the CPE doesn't like it that the AP is binding IP addresses fixed to a mac.!

Anybody seen same issue?
Anybody has any suggestions?

Client:
/interface ethernet
set 0 arp=enabled auto-negotiation=yes disabled=no full-duplex=yes l2mtu=1598 mac-address=00:0C:42:89:49:14 mtu=1500 name=\
    ether1 speed=100Mbps
/interface wireless
set 0 adaptive-noise-immunity=client-mode allow-sharedkey=no antenna-gain=0 area="" arp=enabled band=5ghz-a \
    basic-rates-a/g=6Mbps bridge-mode=enabled channel-width=20mhz compression=no country=spain default-ap-tx-limit=0 \
    default-authentication=no default-client-tx-limit=0 default-forwarding=yes dfs-mode=none disable-running-check=no \
    disabled=no disconnect-timeout=3s distance=dynamic frame-lifetime=0 frequency=5640 frequency-mode=manual-txpower \
    frequency-offset=0 hide-ssid=no ht-ampdu-priorities=0 ht-amsdu-limit=8192 ht-amsdu-threshold=8192 ht-basic-mcs=\
    mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-guard-interval=any ht-rxchains=0 ht-supported-mcs="mcs-0,mcs-1,mcs-2\
    ,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20\
    ,mcs-21,mcs-22,mcs-23" ht-txchains=0 hw-fragmentation-threshold=1500 hw-protection-mode=rts-cts \
    hw-protection-threshold=256 hw-retries=4 l2mtu=2290 mac-address=00:0C:42:2B:95:2B max-station-count=2007 mode=station \
    mtu=1500 multicast-helper=default name=wlan1 noise-floor-threshold=default nv2-cell-radius=30 nv2-noise-floor-offset=\
    default nv2-preshared-key=erwtennet@R nv2-qos=default nv2-queue-count=2 nv2-security=enabled on-fail-retry-time=100ms \
    periodic-calibration=default periodic-calibration-interval=60 preamble-mode=short proprietary-ex
    radio-name=R1-025 rate-selection=advanced rate-set=default scan-list=5495-5705 security-profile=
    station-bridge-clone-mac=00:00:00:00:00:00 supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,
    tdma-period-size=2 tx-power-mode=default update-stats-interval=disabled wds-cost-range=50-150 wd
    wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled wireless-protocol=nv2-nstreme-802.11 w
/ip dhcp-client> print detail
Flags: X - disabled, I - invalid 
 0   interface=wlan1 host-name="R1-025" add-default-route=yes default-route-distance=1 use-peer-dns=yes use-peer-ntp=yes status=bound 
     address=172.25.60.35/25 gateway=172.25.60.1 dhcp-server=172.25.60.1 primary-dns=208.67.222.222 secondary-dns=208.67.220.220 
     primary-ntp=10.50.50.1 expires-after=2d23h30m3s 
 /ip> address print detail
Flags: X - disabled, I - invalid, D - dynamic 
 0   address=192.168.50.1/24 network=192.168.50.0 interface=ether1 actual-interface=ether1 

 1 D address=172.25.60.35/25 network=172.25.60.0 interface=wlan1 actual-interface=wlan1 

Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.

Who is online

Users browsing this forum: MSN [Bot] and 85 guests