Community discussions

MUM Europe 2020
 
unisman
newbie
Topic Author
Posts: 29
Joined: Mon Jan 11, 2010 9:26 pm

Mikrotik hotspot jams my inter-lan connctivity

Wed Jun 13, 2012 10:00 pm

Hi there

I'd like to post an issue that- i think -.. a lot of mikrotik users experience

i have an RB1200 used as a hotspot gateway in a large lan

Subnet/22
DhCP IP addresses 10.0.0.2-10.0.2.254

when mikrotik is on

It's to hard to communicate between a pc and another (or a ubnt device with an ip on the same range) on the same lan (http or sharing) even when the addresses are (for example) (10.0.0.5-10.0.0.10)

sometimes the connection works , some times it freezes
the same with pinging .


when mikrotik is off

I'm able to communicate with all pcs and devices on the lan with no single disconnection (untill devices loose their DHCP lease)

i tried to use the filter rule that allows all connections through the local interface to be passed ... no news

how can i get my inter-network connectivity stable in the presence of mikrotik hotspot+DHCP


thanks
 
CelticComms
Forum Guru
Forum Guru
Posts: 1766
Joined: Wed May 02, 2012 5:48 am

Re: Mikrotik hotspot jams my inter-lan connctivity

Wed Jun 13, 2012 10:31 pm

A network diagram would help and it would help to know what traffic levels you are seeing on the RB1200 interfaces when it is on.
Interlynx | Networking and Information Security Consultants & Trainers | Email: routerlynx@gmail.com
BGP | EIGRP | OSPF | MPLS | Firewall | VPN | IPsec | Multicast | QOS | IPv4/6 | STP | VLAN | PON | AE | M2M | and more!

 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8345
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Mikrotik hotspot jams my inter-lan connctivity

Thu Jun 14, 2012 12:36 am

seems like you set 'address-pool' for Hotspot - set it to 'none'

with ip pool set, Hotspot uses ARP poisoning technique to serve clients with wrong network settings
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
unisman
newbie
Topic Author
Posts: 29
Joined: Mon Jan 11, 2010 9:26 pm

Re: Mikrotik hotspot jams my inter-lan connctivity

Sun Jun 17, 2012 9:41 pm

Thanks .. helped a little although i still got some inaccessible devices ..
 
rebel2234
newbie
Posts: 42
Joined: Sat May 20, 2006 6:23 am

Re: Mikrotik hotspot jams my inter-lan connctivity

Wed Jun 20, 2012 11:07 pm

How about something like this:
/ip hotspot walled-garden ip
add action=accept disabled=no dst-address=10.0.0.0/22 server='your-hotspot-server-HERE' src-address=10.0.0.0/22
Or if you want this to apply to all of your hotspot servers (incase your running more than one).
/ip hotspot walled-garden ip
add action=accept disabled=no dst-address=10.0.0.0/22  src-address=10.0.0.0/22
 
nitrium
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Wed Apr 04, 2007 9:00 pm

Re: Mikrotik hotspot jams my inter-lan connctivity

Fri Jun 22, 2012 5:46 pm

Maybe if you separate the hotspot on another interface using VLAN, it should stop messing with your other devices. But I can be wrong about this!!!

Who is online

Users browsing this forum: intersaar, mzahor123 and 112 guests