Community discussions

MUM Europe 2020
 
Annihilator
just joined
Topic Author
Posts: 8
Joined: Wed May 30, 2007 12:38 am

Kernel 3.4 please - Hyper-V support OOTB

Fri Jun 29, 2012 9:34 am

Please switch to the 3.4 kernel (or newer) for ROS 6, since Hyper-V is natively supported from thereon out.

http://mythoughtsonit.com/?p=1155
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2298
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: Kernel 3.4 please - Hyper-V support OOTB

Fri Jun 29, 2012 10:12 am

6.0b3 will have
*) upgraded drivers and kernel (to linux-3.3.5);
LAN, FTTx, Wireless. ISP operator
 
Annihilator
just joined
Topic Author
Posts: 8
Joined: Wed May 30, 2007 12:38 am

Re: Kernel 3.4 please - Hyper-V support OOTB

Tue Jul 03, 2012 11:56 am

Too bad... 3.3 doesn't have the necessary drivers. Only 3.4 and above are Hyper-V ready.
If there's any chance to up this version for the next beta it would be greatly appreciated.
Last edited by Annihilator on Tue Jul 03, 2012 11:57 am, edited 1 time in total.
 
hkusulja
just joined
Posts: 15
Joined: Fri Apr 13, 2012 1:14 am

Re: Kernel 3.4 please - Hyper-V support OOTB

Tue Jul 03, 2012 11:56 am

Yes, we also need Hyper-V support for RouterOS.
 
Annihilator
just joined
Topic Author
Posts: 8
Joined: Wed May 30, 2007 12:38 am

Re: Kernel 3.4 please - Hyper-V support OOTB

Fri Sep 21, 2012 12:31 pm

Too bad... 3.3 doesn't have the necessary drivers. Only 3.4 and above are Hyper-V ready.
If there's any chance to up this version for the next beta it would be greatly appreciated.
ROS 6 is in RC, but the kernel does not appear to be updated to >3.4.
Please do so before RTM-ing ROS 6.
 
mhugo
newbie
Posts: 49
Joined: Mon Sep 19, 2005 11:48 am

Re: Kernel 3.4 please - Hyper-V support OOTB

Sat Sep 22, 2012 10:40 pm

We would like it too - we use it a lot in our hyper-v enviroment.
 
hkusulja
just joined
Posts: 15
Joined: Fri Apr 13, 2012 1:14 am

Re: Kernel 3.4 please - Hyper-V support OOTB

Sun Nov 11, 2012 12:33 pm

Current, RouterOS 5.x and 6.x does not work at all in any network adapter combination on Hyper-V, we must use 4.x and legacy adapters. If you upgrade to kernel to 3.4, everything will be natively supported. I believe this will be great opportunity for Mikrotik and number of users.

Are there any news for final version 6 regarding to kernel 3.4 ?
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Kernel 3.4 please - Hyper-V support OOTB

Sun Nov 11, 2012 1:34 pm

It was already stated here http://forum.mikrotik.com/viewtopic.php?f=15&t=47191 that modules in the kernel are disabled, and HyperV is not a priority for Mikrotik.

Sad news :(
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
nosovk
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Wed Jan 25, 2012 11:25 am
Location: Ukraine
Contact:

Re: Kernel 3.4 please - Hyper-V support OOTB

Thu Nov 15, 2012 11:57 am

It was already stated here http://forum.mikrotik.com/viewtopic.php?f=15&t=47191 that modules in the kernel are disabled, and HyperV is not a priority for Mikrotik.

Sad news :(
Damn. New HyperV in Win2012 is awesome. But now to move from ESXi I need to change ros to something else.
Аренда Програмного обеспечения
https://www.CloudZZ.com
Микротики на Украине оптом
mikrotik.kharkov.ua

Who is online

Users browsing this forum: No registered users and 73 guests