Community discussions

MikroTik App
 
a76
just joined
Topic Author
Posts: 7
Joined: Tue May 22, 2012 6:42 am

VPN connection issue

Fri Jul 20, 2012 9:38 pm

Hello all,

I have setup a L2TP IPsec VPN on my Mikrotik. I can connect from all of my devices with no issues. However, If i have two devices that are connecting to my Mikrotik from behind the same WAN IP the second connection replaces the first under my "interfaces" tab and kills the connection. Any thoughts?

Thanks much,
 
User avatar
lordcoke
newbie
Posts: 29
Joined: Thu Jun 10, 2010 10:11 am
Location: Germany
Contact:

Re: VPN connection issue

Mon Jul 23, 2012 2:41 pm

Is on your mikrotik NAT-T active?
/ip ipsec peer ... nat-traversal=yes
 
a76
just joined
Topic Author
Posts: 7
Joined: Tue May 22, 2012 6:42 am

Re: VPN connection issue

Mon Jul 23, 2012 9:31 pm

Yes it is. See below.

[admin@MikroTik] > ip ipsec peer print
Flags: X - disabled
0 address=0.0.0.0/0 port=500 auth-method=pre-shared-key secret="******"
generate-policy=yes exchange-mode=main send-initial-contact=yes
nat-traversal=yes my-id-user-fqdn="" proposal-check=obey
hash-algorithm=sha1 enc-algorithm=3des dh-group=modp1024 lifetime=1d
lifebytes=0 dpd-interval=2m dpd-maximum-failures=5
 
User avatar
lordcoke
newbie
Posts: 29
Joined: Thu Jun 10, 2010 10:11 am
Location: Germany
Contact:

Re: VPN connection issue

Tue Jul 24, 2012 3:32 pm

I can't explain why but it seems to be impossible to call out more than 1 times from behind one WAN-IP to IPsec-L2TP even with NAT-T. :/
 
a76
just joined
Topic Author
Posts: 7
Joined: Tue May 22, 2012 6:42 am

Re: VPN connection issue

Tue Jul 24, 2012 7:29 pm

Well I appreciate you looking at that. Do you know how I make this a feature request/bug report?
 
norpan
newbie
Posts: 35
Joined: Sat Dec 19, 2009 12:40 pm

Re: VPN connection issue

Wed Aug 08, 2012 6:16 pm

I've experienced this too, my guess is that the generated policy is not created with 'level=unique'...
Would be very nice if it worked though.
 
User avatar
lordcoke
newbie
Posts: 29
Joined: Thu Jun 10, 2010 10:11 am
Location: Germany
Contact:

Re: VPN connection issue

Wed Aug 15, 2012 11:58 am

I think the problem is the mikrotik kernel or the l2tp-server does not implement ipsec saref. File a feature request for ipsec saref! :)

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], rukverc, stefki, vialli and 137 guests