Community discussions

MikroTik App
 
masc
just joined
Topic Author
Posts: 24
Joined: Fri Apr 09, 2010 1:35 am

email not working in 5.19

Sun Aug 05, 2012 10:35 pm

We been trying to sen a email in routeros 5.19 and is not working, when we send from a 4.11 os version it´s ok, sents the email ok
 
psamsig
Member Candidate
Member Candidate
Posts: 161
Joined: Sun Dec 06, 2009 1:36 pm
Location: Denmark

Re: email not working in 5.19

Mon Aug 06, 2012 1:23 am

Works fine for me. You did notice that parameters changed a bit between 4.11 and 5.19 right?
 
masc
just joined
Topic Author
Posts: 24
Joined: Fri Apr 09, 2010 1:35 am

Re: email not working in 5.19

Mon Aug 06, 2012 3:15 am

This is what we are doing:
/tool
/e-mail
send to="user@domain.com" from="<user1>" body="test0" subject="test0" server="x.x.x.x" password="xxxxx" user="me@mydomain.com" port="25"
and in 4.11 works fine, not with the same parameters
but in 5.19 we get error connecting to server
if we ping the server, it pings ok, its in the same subnet

Thank´s
 
psamsig
Member Candidate
Member Candidate
Posts: 161
Joined: Sun Dec 06, 2009 1:36 pm
Location: Denmark

Re: email not working in 5.19

Mon Aug 06, 2012 12:41 pm

I have had my fair share of e-mail problems, but it always comes down to misconfiguration (firewall in either end, spamfilter frontend and so on), never RouterOS. And as mentioned already, I have 5.19 sending mails like a charm.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: email not working in 5.19

Mon Aug 06, 2012 1:31 pm

If you want to check what is happening, then enable verbose email logging.
/system logging
add topics=e-mail,debug action=memory
Try another email send, then check the log.
 
masc
just joined
Topic Author
Posts: 24
Joined: Fri Apr 09, 2010 1:35 am

Re: email not working in 5.19

Tue Aug 07, 2012 1:13 am

Nothing just:
Error sending E-mail <subject>: error connecting to server

but we can ping the server, even telnet the email server
Thank´s
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24609
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: email not working in 5.19

Tue Aug 07, 2012 10:17 am

maybe server requires authentication, or uses another port ?
No answer to your question? How to write posts
 
masc
just joined
Topic Author
Posts: 24
Joined: Fri Apr 09, 2010 1:35 am

Re: email not working in 5.19

Tue Aug 07, 2012 9:56 pm

We tried also with gmail
tls activated, port 587
and we get the same error
We are doing this in a 450g
and in a 411 with 4.11 that is in the same subnet we can get it working
Thank´s
 
biomesh
Member Candidate
Member Candidate
Posts: 141
Joined: Fri Feb 10, 2012 8:25 pm

Re: email not working in 5.19

Tue Aug 07, 2012 11:19 pm

/tool e-mail
set address=173.194.77.108 from=mikrotik@mydomain.net password=emailpwd port=587 starttls=yes user=user@gmail.com

/tool e-mail send to="user@gmail.com" body="Router email" subject="$[/system identity get name] $[/system clock get time] $[/system clock get date] Alert" from="mikrotik@mydomain.net" server="$[:resolve "smtp.gmail.com"]" tls=yes

This works for me (you need to update the email addresses and password, of course)
 
masc
just joined
Topic Author
Posts: 24
Joined: Fri Apr 09, 2010 1:35 am

Re: email not working in 5.19

Wed Aug 08, 2012 1:16 am

Solved!
different port
Thanks to anyone
 
tnakir
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Thu Aug 19, 2010 4:29 pm

Re: email not working in 5.19

Wed Jan 08, 2014 4:08 pm

I'm having other e-mail issues with 6.7

I'm sending email with this:
/tool e-mail> send from=mail@mail.com to=mail2@mail2-com server=x.x.x.x port=25 user=someuser password=somepwd subject="Message subject"
body="Message"

and the command does not send subject or the body (check the attachment). Any ideas?
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: faxxe, leonh, Majestic-12 [Bot], SinTeZ and 92 guests