Community discussions

MUM Europe 2020
 
afolmer
just joined
Topic Author
Posts: 1
Joined: Tue Feb 21, 2012 1:29 pm

v6.0beta3 x86 - lost ethernet interface, driver issue?

Fri Aug 24, 2012 11:22 am

I Just tested to upgrade from ros 5.20 -> 6.03b i noticed that i lost my ethernet interfaces, they are quite old so im wondering if they are not supported annymore ,
forgot to mention that while i can see them, they dont work , eg if i do a /interface ethernet print , the router hangs and have to be rebooted


[admin@MikroTik] /system resource> pci print
# DEVICE VENDOR NAME IRQ
0 04:04.0 Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev: 16) 12
1 04:03.0 Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev: 16) 5
2 04:02.0 Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev: 16) 9
3 03:04.1 Intel Corporation 82546GB Gigabit Ethernet Controller (rev: 3) 11
4 03:04.0 Intel Corporation 82546GB Gigabit Ethernet Controller (rev: 3) 11
5 02:04.1 Intel Corporation 82546GB Gigabit Ethernet Controller (rev: 3) 11
6 02:04.0 Intel Corporation 82546GB Gigabit Ethernet Controller (rev: 3) 11
7 01:1f.0 Intel Corporation 82870P2 P64H2 Hub PCI Bridge (rev: 4) 0
8 01:1e.0 Intel Corporation 82870P2 P64H2 I/OxAPIC (rev: 4) 0
9 01:1d.0 Intel Corporation 82870P2 P64H2 Hub PCI Bridge (rev: 4) 0
10 01:1c.0 Intel Corporation 82870P2 P64H2 I/OxAPIC (rev: 4) 0
11 00:1f.3 Intel Corporation 82801CA/CAM SMBus Controller (rev: 2) 9
12 00:1f.1 Intel Corporation 82801CA Ultra ATA Storage Controller (rev: 2) 0
13 00:1f.0 Intel Corporation 82801CA LPC Interface Controller (rev: 2) 0
14 00:1e.0 Intel Corporation 82801 PCI Bridge (rev: 66) 0
15 00:1d.1 Intel Corporation 82801CA/CAM USB Controller #2 (rev: 2) 12
16 00:1d.0 Intel Corporation 82801CA/CAM USB Controller #1 (rev: 2) 11
17 00:02.0 Intel Corporation E7500/E7501 Hub Interface B PCI-to-PCI Bridge (re... 0
18 00:00.1 Intel Corporation E7500/E7501 Host RASUM Controller (rev: 1) 0
19 00:00.0 Intel Corporation E7501 Memory Controller Hub (rev: 1) 0
 
coffeecoco
Member Candidate
Member Candidate
Posts: 175
Joined: Wed Oct 12, 2005 1:17 pm

Re: v6.0beta3 x86 - lost ethernet interface, driver issue?

Sun Aug 26, 2012 2:00 pm

If anyone is looking for confirmation that this is an issue I have the same issue on my x86 board
none of the ethernet interfaces showed but the wlan did.

below is a copy of the PCI when i reverted it back to 5.X
# DEVICE VENDOR NAME IRQ
0 04:07.0 Realtek Semiconductor Co., ... RTL-8110SC/8169SC Gigabi... 11
1 04:06.0 Realtek Semiconductor Co., ... RTL-8110SC/8169SC Gigabi... 10
2 04:04.0 Realtek Semiconductor Co., ... RTL-8110SC/8169SC Gigabi... 7
3 03:00.0 Realtek Semiconductor Co., ... RTL8111/8168B PCI Expres... 7
4 02:00.0 Realtek Semiconductor Co., ... RTL8111/8168B PCI Expres... 5
5 01:00.0 Atheros Communications Inc. unknown device (rev: 1) 11
6 00:1f.3 Intel Corporation 82801G (ICH7 Family) SMB... 10
7 00:1f.2 Intel Corporation 82801GB/GR/GH (ICH7 Fami... 10
8 00:1f.0 Intel Corporation Tigerpoint LPC Controlle... 0
9 00:1e.0 Intel Corporation 82801 Mobile PCI Bridge ... 0
10 00:1d.7 Intel Corporation 82801G (ICH7 Family) USB... 11
11 00:1d.3 Intel Corporation 82801G (ICH7 Family) USB... 11
12 00:1d.2 Intel Corporation 82801G (ICH7 Family) USB... 7
13 00:1d.1 Intel Corporation 82801G (ICH7 Family) USB... 10
14 00:1d.0 Intel Corporation 82801G (ICH7 Family) USB... 11
15 00:1c.2 Intel Corporation 82801G (ICH7 Family) PCI... 7
16 00:1c.1 Intel Corporation 82801G (ICH7 Family) PCI... 5
17 00:1c.0 Intel Corporation 82801G (ICH7 Family) PCI... 11
18 00:1b.0 Intel Corporation 82801G (ICH7 Family) Hig... 10
19 00:02.0 Intel Corporation unknown device (rev: 9) 11
20 00:00.0 Intel Corporation unknown device (rev: 3) 0
 
vacarosie200
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sun Jun 15, 2008 11:49 am
Location: Romania

Re: v6.0beta3 x86 - lost ethernet interface, driver issue?

Fri Sep 07, 2012 11:58 pm

i get this also. i upgrade from 6.0b2 to 6.0b3
 
User avatar
kolorasta
Member Candidate
Member Candidate
Posts: 299
Joined: Sun Jun 25, 2006 11:55 pm
Location: Argentina

Re: v6.0beta3 x86 - lost ethernet interface, driver issue?

Mon Sep 24, 2012 9:23 pm

this issue is also present in rc1
 
marcin21
Member Candidate
Member Candidate
Posts: 193
Joined: Tue May 04, 2010 4:50 pm

Re: v6.0beta3 x86 - lost ethernet interface, driver issue?

Tue Sep 25, 2012 12:04 am

I confirm. Looks like RTL8111 is not supported in RC1 :(
 
User avatar
NetworkPro
Forum Guru
Forum Guru
Posts: 1370
Joined: Mon Jan 05, 2009 6:23 pm
Location: Worldwide
Contact:

Re: v6.0beta3 x86 - lost ethernet interface, driver issue?

Sat Oct 13, 2012 1:47 am

RTL8111 driver missing in 6rc2 2012.10.12 x86 as well. Supouts submitted to Support as test reports

I had access to the router over other interface + backup before test upgrade so I was able to restore previous version in 3 reboots.
wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service

Who is online

Users browsing this forum: Bing [Bot], MSN [Bot], victorzx91 and 83 guests