Community discussions

MikroTik App
 
kgninfos
Member
Member
Topic Author
Posts: 387
Joined: Thu Jun 21, 2012 7:34 pm
Location: Earth
Contact:

VLAN Problem

Thu Sep 06, 2012 7:25 am

i need to make a VLAN tunnel form RB433L(Ether3) to RB750GL
both devices are over WiFi Link
on RB433 Ether1, Ether2,Wlan1 is on bridge

tried creating Vlan on Bridge1 of RB433L
created another Bridge on RB433 with Vlan and Ether3 as ports

on RB750GL created a vlan (both end shows status as R)

But from vlan of RB750 to not able to ping devices of Ether3 on RB433L

Please Help
You do not have the required permissions to view the files attached to this post.
 
MikroTikIQ
Trainer
Trainer
Posts: 44
Joined: Sat Jun 16, 2012 1:42 pm

Re: VLAN Problem

Sun Sep 09, 2012 3:19 am

Hi..

Here is you what you should to do..

Let call RB#1 (config)

Wireless mode ap-bridge

simple bridge technique.. like EoIP or VPLS or even more simple..

/interface bridge add name=wlan-bridge
/interface bridge port add interface=wlan1 bridge=wlan-bridge
/interface bridge port add interface=ether1 bridge=wlan-bridge

###########

RB 750GL

add two vlan on ether1 interface that connected to wireless router

/interface vlan add vlan-id=1 interface=ether1
/interface vlan add vlan-id=1 interface=ether1

now you should bridge the vlan with the target ether.. for example

/interface bridge add name=bridge-squid
/interface bridge add name=bridge-switch

/interface bridge port add interface=vlan1 bridge=bridge-squid
/interface bridge port add interface=ether2 bridge=bridge-squid

/interface bridge port add interface=vlan2 bridge=bridge-switch
/interface bridge port add interface=ether3 bridge=bridge-switch

############

RB#2 ( config )

wireless interface mode station

/interface vlan add vlan-id=1 interface=wlan1
/interface vlan add vlan-id=2 interface=wlan1
Note( if you create EoIP interface you should add vlan on EoIP interface and if you add vpls interface you should add vlan on vpls interface istead of wlan1 interface)

/interface bridge add name=bridge-squid
/interface bridge add name=bridge-switch

/interface bridge port add interface=vlan1 bridge=bridge-squid
/interface bridge port add interface=ether2 bridge=bridge-squid

/interface bridge port add interface=vlan2 bridge=bridge-switch
/interface bridge port add interface=ether3 bridge=bridge-switch


this is what you need to have the correct configuration..

Please let me know if all is okay... waiting you reply

Ali Sami

Who is online

Users browsing this forum: bpolat, cndas, Google [Bot], ifoel, IlCarletto, MSN [Bot], omnet, sindy and 60 guests