Page 1 of 1

About OSPF

Posted: Fri Sep 21, 2012 3:23 pm
by kuroda
There will be any improvements or bugs fix on OSPF routing protocol?

Re: About OSPF

Posted: Mon Sep 24, 2012 6:01 am
by mistiq
There will be any improvements or bugs fix on OSPF routing protocol?
+1
It is very important question!

Re: About OSPF

Posted: Tue Sep 25, 2012 7:54 pm
by mhugo
+1

We want to roll out like 80 cloudcore routers in our DC but with the current state of OSPF we will be getting too many issues we feel.

Re: About OSPF

Posted: Wed Sep 26, 2012 12:13 am
by adairw
What ospf issues are you having?

Re: About OSPF

Posted: Sat Oct 06, 2012 11:05 am
by mhugo
Sudden master flags wrong and the ospf recalculates many times before stabilizing and sometime triggering a crash on one of the OSPF routers.

100% Mikrotik OSPF network with some IPv4 BGP.

There are some threads on this which MT has been very absent on.

Re: About OSPF

Posted: Sat Oct 06, 2012 11:08 pm
by samsung172

Re: About OSPF

Posted: Tue Feb 26, 2013 3:41 am
by mhugo
We have made some investigation into the issue now, and it seems it has to do with when the links change.

Like switching port and moving the ip along, the system crashing and booting, etc.

So im guessing there is a small issue somewhere in the internal code making the LSAs wrong in these conditions.

Re: About OSPF

Posted: Tue Feb 26, 2013 10:24 am
by mrz
Has anyone tried v6? Those routing crashes should be fixed.

Re: About OSPF

Posted: Tue Feb 26, 2013 10:55 am
by mistiq
Has anyone tried v6? Those routing crashes should be fixed.
No, it shoud not be fixed!

Re: About OSPF

Posted: Wed Feb 27, 2013 7:18 pm
by CelticComms
Are NSSA areas fixed in v6?

Re: About OSPF

Posted: Wed Feb 27, 2013 11:44 pm
by samsung172
Has anyone tried v6? Those routing crashes should be fixed.
Not possible. due to the crash in vrf.

Re: About OSPF

Posted: Thu Feb 28, 2013 10:43 am
by mrz
What kind of crash in VRF? Is it reported to support?

Re: About OSPF

Posted: Fri Mar 01, 2013 6:59 pm
by samsung172
What kind of crash in VRF? Is it reported to support?

At all system/boards I have tried with 6.rcXX, the enabling of MPLS-BGP is ok, but at once as a VRF is created, the system stop responding to commands.

Its not even possible to do a supout.rif file.

http://forum.mikrotik.com/viewtopic.php?f=19&t=68374

I was told by normis that the bug was known.