Community discussions

 
User avatar
honzam
Forum Guru
Forum Guru
Topic Author
Posts: 2286
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

5.21 released

Sat Oct 13, 2012 10:19 pm

What's new in 5.21 (2012-Oct-12 08:25):

*) route - fix dst-prefix filtering did not return routes when routes with
different routing-mark were present;
*) wireless - improved nv2 stability;
*) winbox & webfig - added simple new version downloading & upgrading panel;
*) dhcp server - immediately store to disk changes for lease configuration;
*) lcd - improve graphs screen
*) lcd - improve touch screen (must /lcd reset-calibration)
*) smb - fix smb share mounting on linux systems
*) ovpn - fixed memory leak on disconnects;
*) userman - fix unpaid profile activation while authenticating;
*) sstp - fix high CPU usage on SSL handshake;
*) winbox - added ability to add time & date to dashboard;
*) metarouter - fixed lockups on RB110AH;
*) metarouter - fixed occasional lockups on RB450G;
*) ups - fixed problem connecting to USB device, introduced in 5.20;
*) quickset - added Wireless PTP Bridge mode;
*) fix MPLS MTU configuration usage;
*) dns - fix empty response;

http://www.mikrotik.com/download
LAN, FTTx, Wireless. ISP operator
 
ludvik
Frequent Visitor
Frequent Visitor
Posts: 59
Joined: Mon May 26, 2008 4:36 pm

Re: 5.21 released

Sat Oct 13, 2012 10:32 pm

 
patrickmkt
Member Candidate
Member Candidate
Posts: 157
Joined: Sat Jul 28, 2012 5:21 pm

Re: 5.21 released

Sat Oct 13, 2012 11:24 pm

I don't have the 'can't add ups' error anymore, but the ups shows as invalid :(
 
w0lt
Member
Member
Posts: 481
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: 5.21 released

Sun Oct 14, 2012 12:50 am

I don't have the 'can't add ups' error anymore, but the ups shows as invalid :(

It appears that this service is still not fixed. I now no longer show an available USB port.
I guess we'll have to hope that this will be fixed in v5.22 or a future v6.x candidate.
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "
 
rmichael
Forum Veteran
Forum Veteran
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

Re: 5.21 released

Sun Oct 14, 2012 5:41 am

Results for NV2 on the CPE side are not very encouraging (v5.20 AP):

Version 5.21: (82/20 value is CCQ)
v5.21.JPG
Version 5.9:
v5.9.JPG
EDIT: 5.9 with 3.41 firmware (from 5.21), had low CCQ as well, once "upgraded" to fw 3.38 CCQ improved.

EDIT2: keeping old firmware (3.38) I upgraded AP and CPE to 5.21 and CCQ came back to it's normal values. Bandwidth tests show no degradation in throughput. So far so good...
You do not have the required permissions to view the files attached to this post.
Last edited by rmichael on Mon Oct 15, 2012 7:23 pm, edited 1 time in total.
 
smile__2006
newbie
Posts: 26
Joined: Sat Nov 10, 2007 10:57 pm

Re: 5.21 released

Sun Oct 14, 2012 11:16 am

and what about ssh problem(( http://forum.mikrotik.com/viewtopic.php?f=2&t=66068
if not fixed, it`s a very bad....(
support team, please don`t ignore these posts and do answer...
 
User avatar
bambangs2komputer
Frequent Visitor
Frequent Visitor
Posts: 89
Joined: Tue Oct 04, 2011 4:22 pm
Location: Kota Malang-Indonesia
Contact:

Re: 5.21 released

Sun Oct 14, 2012 12:55 pm

 
rzirzi
Member
Member
Posts: 377
Joined: Mon Oct 09, 2006 2:33 pm

Re: 5.21 released

Sun Oct 14, 2012 1:38 pm

What does it mean?:
*) dns - fix empty response;
I'm asking about it, because I have problems with MikroTik DNS long time. Maybe this fil will repair it, but what do You mean "empty response"??
 
slech
Long time Member
Long time Member
Posts: 533
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Re: 5.21 released

Sun Oct 14, 2012 2:42 pm

*) winbox - added ability to add time & date to dashboard;
RB751U-2HnD - only 3 boxex persists between winbox sessions, not all 5.
RB433UAH - all is ok.
RB110AH - all is ok.
sorry for my english
 
slech
Long time Member
Long time Member
Posts: 533
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Re: 5.21 released

Sun Oct 14, 2012 2:58 pm

*) winbox - added ability to add time & date to dashboard;
RB751U-2HnD - only 3 boxex persists between winbox sessions, not all 5.
RB433UAH - all is ok.
RB110AH - all is ok.
Hm, strange. Now all is ok on 751. Maybe happenstance.
sorry for my english
 
User avatar
bambangs2komputer
Frequent Visitor
Frequent Visitor
Posts: 89
Joined: Tue Oct 04, 2011 4:22 pm
Location: Kota Malang-Indonesia
Contact:

Re: 5.21 released

Sun Oct 14, 2012 5:45 pm

Can anyone explain, why system routerboard on 2.38 like my pict?
You do not have the required permissions to view the files attached to this post.
 
patrickmkt
Member Candidate
Member Candidate
Posts: 157
Joined: Sat Jul 28, 2012 5:21 pm

Re: 5.21 released

Sun Oct 14, 2012 5:57 pm

Can anyone explain, why system routerboard on 2.38 like my pict?
Per http://routerboard.com/RB1200 the latest firmware for the RB1200 is 2.38
 
Ivoshiee
Member
Member
Posts: 470
Joined: Sat May 06, 2006 4:11 pm

Re: 5.21 released

Sun Oct 14, 2012 10:14 pm

What does it mean?:
*) dns - fix empty response;
I'm asking about it, because I have problems with MikroTik DNS long time. Maybe this fil will repair it, but what do You mean "empty response"??
Indeed, what does it mean?
 
ropebih
Member Candidate
Member Candidate
Posts: 109
Joined: Tue May 22, 2007 5:35 pm

Re: 5.21 released

Sun Oct 14, 2012 10:43 pm

What about the bug with IGMP proxy? Do you think will it ever be fixed????? Very frustrating and very unprofessional from Mikrotik! I wait for fix over one year!!!!!!!!
 
User avatar
bambangs2komputer
Frequent Visitor
Frequent Visitor
Posts: 89
Joined: Tue Oct 04, 2011 4:22 pm
Location: Kota Malang-Indonesia
Contact:

Re: 5.21 released

Mon Oct 15, 2012 5:38 am

Can anyone explain, why system routerboard on 2.38 like my pict?
Per http://routerboard.com/RB1200 the latest firmware for the RB1200 is 2.38
OK, thank's
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3082
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: 5.21 released

Mon Oct 15, 2012 11:00 am

Results for NV2 on the CPE side are not very encouraging (v5.20 AP):

Version 5.21: (82/20 value is CCQ)
v5.21.JPG
Version 5.9:
v5.9.JPG
EDIT: btw, 5.9 with 3.41 firmware (from 5.21), had low CCQ as well, once "upgraded" to fw 3.38 CCQ improved.
your example proofs nothing. Low, or high, CCQ is also depending on traffic and wireless link conditions. I have links showing with all kinds of 5.x version very low CCQ but the moment I put traffic on them the CCQ goes up to near 100%.

So, unless you made more funded shortcomings examples in the wireless before to MT I am afraid they will not even consider to answer your tread here...
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
BeLZeBuT
just joined
Posts: 3
Joined: Wed Feb 25, 2009 11:35 am

Re: 5.21 released

Mon Oct 15, 2012 1:59 pm

*) winbox & webfig - added simple new version downloading & upgrading panel;
What this mean?
Who can explain?
 
User avatar
honzam
Forum Guru
Forum Guru
Topic Author
Posts: 2286
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 5.21 released

Mon Oct 15, 2012 2:07 pm

*) winbox & webfig - added simple new version downloading & upgrading panel;
What this mean?
Who can explain?
This
You do not have the required permissions to view the files attached to this post.
LAN, FTTx, Wireless. ISP operator
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: 5.21 released

Mon Oct 15, 2012 4:12 pm

router with internet connection configured will connect to mikrotik.com and check if new version is available. If update is possible you have options to "download" or "download & upgrade" packages from the internet.

So if, you have just some routers around, you can in easy and fast way upgrade your router. if you have a lot of routers, better opt for some tool like TheDUDE to mange updates over the network.
 
victornunes
just joined
Posts: 22
Joined: Sun Aug 05, 2012 7:48 am

Re: 5.21 released

Mon Oct 15, 2012 5:57 pm

*) fix MPLS MTU configuration usage;

Can anyone explain what the error was occurring with the mpls mtu?

Att,
 
Kindis
Member Candidate
Member Candidate
Posts: 246
Joined: Tue Nov 01, 2011 6:54 pm

Re: 5.21 released

Tue Oct 16, 2012 8:36 pm

What does it mean?:
*) dns - fix empty response;
I'm asking about it, because I have problems with MikroTik DNS long time. Maybe this fil will repair it, but what do You mean "empty response"??
Indeed, what does it mean?
http://forum.mikrotik.com/viewtopic.php?t=58243

Sent from my Galaxy Nexus using Tapatalk 2
 
gluetea
just joined
Posts: 15
Joined: Tue Dec 21, 2010 8:19 am

Re: 5.21 released

Wed Oct 17, 2012 2:33 am

I use RB450G and RB493AH, i'm upgrade from ROS 5.20 to 5.21 using file: routeros-mipsbe-5.21.npk , it's seem that i having lost packages at /system/packages , like PPP and Security.

I'm solve this problem by downgrade to ROS 5.17 then restore backup then upgrade again to 5.21.

Why ROS became like this? Missing packages?
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3082
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: 5.21 released

Wed Oct 17, 2012 11:45 am

Alignment tool in winbox lost its configuration options. Maybe it should be using the set data in the normal wireless fields.
But in my Groove's I can't use the tool anymore. It doesn't 'see' anything....
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
angboontiong
Forum Guru
Forum Guru
Posts: 1115
Joined: Fri Jan 16, 2009 9:59 am

Re: 5.21 released

Wed Oct 17, 2012 1:26 pm

can we have the option that, may be pair off the pin on the board we can make use as alignment tools???
what i mean is, we can just connect the voltmeter to that 2 pin, then based on the voltmeter to do the alignment.

this will be great and easy for us.
 
dzieva
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Fri Mar 25, 2011 4:51 pm
Location: Iguassu Falls, Brasil

Re: 5.21 released

Wed Oct 17, 2012 5:06 pm

Results for NV2 on the CPE side are not very encouraging (v5.20 AP):

Version 5.21: (82/20 value is CCQ)
v5.21.JPG
Version 5.9:
v5.9.JPG
EDIT: btw, 5.9 with 3.41 firmware (from 5.21), had low CCQ as well, once "upgraded" to fw 3.38 CCQ improved.
your example proofs nothing. Low, or high, CCQ is also depending on traffic and wireless link conditions. I have links showing with all kinds of 5.x version very low CCQ but the moment I put traffic on them the CCQ goes up to near 100%.

So, unless you made more funded shortcomings examples in the wireless before to MT I am afraid they will not even consider to answer your tread here...
Finally NV2 this very stable. (was a long wait for it)

Thanks Mikrotik team.
 
rmichael
Forum Veteran
Forum Veteran
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

Re: 5.21 released

Wed Oct 17, 2012 6:57 pm

Results for NV2 on the CPE side are not very encouraging (v5.20 AP):

[...]

EDIT: btw, 5.9 with 3.41 firmware (from 5.21), had low CCQ as well, once "upgraded" to fw 3.38 CCQ improved.
your example proofs nothing. Low, or high, CCQ is also depending on traffic and wireless link conditions. I have links showing with all kinds of 5.x version very low CCQ but the moment I put traffic on them the CCQ goes up to near 100%.

So, unless you made more funded shortcomings examples in the wireless before to MT I am afraid they will not even consider to answer your tread here...
:lol: Sure take it for what is worth, I'm not forcing you to upgrade...just reporting what I see under specific conditions...
Last edited by rmichael on Fri Oct 19, 2012 9:13 pm, edited 2 times in total.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: 5.21 released

Thu Oct 18, 2012 2:47 pm

Alignment tool in winbox lost its configuration options. Maybe it should be using the set data in the normal wireless fields.
But in my Groove's I can't use the tool anymore. It doesn't 'see' anything....
thank you for the report, we will try to fix it.
 
fbi
newbie
Posts: 26
Joined: Fri Nov 04, 2011 11:38 am
Location: Miskolc, Hungary

Re: 5.21 released

Thu Oct 18, 2012 6:01 pm

Hi all!

The ROS 5.21 version doesn't show the sfp-rate, when I use the following command:
/ interface ethernet print detail

This was the output in 5.20, with same command

Flags: X - disabled, R - running, S - slave
0 ;;; RB (Zyxel duplex sfp modul)
name="sfp1" mtu=1500 l2mtu=1598 mac-address=00:0C:42:A7:D0:9E arp=enabled auto-negotiation=yes full-duplex=yes speed=100Mbps master-port=none bandwidth=unlimited/unlimited switch=switch1 sfp-rate-select=high
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: 5.21 released

Thu Oct 18, 2012 10:21 pm

Almost a week after release and only 27 comments. To me this says we have a nice stable version. going to give it a go
 
NumLock
Frequent Visitor
Frequent Visitor
Posts: 66
Joined: Mon Jun 16, 2008 3:38 am

Re: 5.21 released

Thu Oct 18, 2012 10:27 pm

Upgrade from 5.20 to 5.21 to Edge Router very stable no issues.
 
w0lt
Member
Member
Posts: 481
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: 5.21 released

Thu Oct 18, 2012 10:55 pm

With v5.21, and using a RB2011UAS-2HnD, I am having a difficult time getting my Verizon UML290 4G stick to stay online with it connected to the USB port. It initially connects, then disconnects.
I've noticed the USB port becoming invalid from the "Ports" command.
The same UML290 when connected to a RB751G-2Hnd, works perfectly and very stable.
It is my opinion that there is something unstable with the RB2011 USB driver.

A supout file has been sent in.
Ticket# 2012101866000543
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "
 
User avatar
c0d3rSh3ll
Long time Member
Long time Member
Posts: 558
Joined: Mon Jul 25, 2011 9:42 pm
Location: [admin@Chile] >

Re: 5.21 released

Fri Oct 19, 2012 6:13 am

if..

*) winbox & webfig - added simple new version downloading & upgrading panel;


why not for downgrading?
nothing
 
User avatar
erebusodora
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Mon Jan 23, 2012 3:46 pm
Location: Bulgaria

Re: 5.21 released

Fri Oct 19, 2012 9:39 am

if..

*) winbox & webfig - added simple new version downloading & upgrading panel;


why not for downgrading?

A very good idea. Example, to switch between versions. And view Changelog for all versions !.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24142
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 5.21 released

Fri Oct 19, 2012 9:43 am

if..

*) winbox & webfig - added simple new version downloading & upgrading panel;


why not for downgrading?

A very good idea. Example, to switch between versions. And view Changelog for all versions !.
our download servers only host new versions. also hosting old versions would futher kill our bandwidth, but we may think about it.
No answer to your question? How to write posts
 
JanezFord
Member Candidate
Member Candidate
Posts: 263
Joined: Wed May 23, 2012 10:58 am

Re: 5.21 released

Fri Oct 19, 2012 12:05 pm


our download servers only host new versions. also hosting old versions would futher kill our bandwidth, but we may think about it.
Host it as torrents only and bandwith should not be an issue any more ...

JF.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24142
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 5.21 released

Fri Oct 19, 2012 12:09 pm


our download servers only host new versions. also hosting old versions would futher kill our bandwidth, but we may think about it.
Host it as torrents only and bandwith should not be an issue any more ...

JF.
slow and unreliable, plus would require a torrent client on routeros (which would have to seed!!). we host on S3 now, which is much faster
No answer to your question? How to write posts
 
User avatar
c0d3rSh3ll
Long time Member
Long time Member
Posts: 558
Joined: Mon Jul 25, 2011 9:42 pm
Location: [admin@Chile] >

Re: 5.21 released

Fri Oct 19, 2012 6:04 pm

lack a mirror....

Or add a option for install a package like user-manager o any
nothing
 
WirelessDSL
newbie
Posts: 29
Joined: Thu Nov 24, 2011 12:43 pm
Location: Germany
Contact:

Re: 5.21 released

Fri Oct 19, 2012 9:41 pm

*) fix MPLS MTU configuration usage;

What does it mean?
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCINE
 
abyss
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Wed Sep 21, 2005 10:51 am

Re: 5.21 released

Sat Oct 20, 2012 12:43 am

Hi,

Do I need to uprgrade CPE as well as AP to increase nv2 stability ?

Best Regards
 
rmichael
Forum Veteran
Forum Veteran
Posts: 718
Joined: Sun Mar 08, 2009 11:00 pm

Re: 5.21 released

Sat Oct 20, 2012 1:58 am

Hi,

Do I need to uprgrade CPE as well as AP to increase nv2 stability ?

Best Regards
Yes

EDIT: "increase nv2 stability" comes with increased latencies and packet loss, just wanted to clarify that...
Last edited by rmichael on Sat Oct 20, 2012 3:34 pm, edited 2 times in total.
 
hapi
Member Candidate
Member Candidate
Posts: 222
Joined: Fri Mar 11, 2011 11:21 am
Location: Czech Republic

Re: 5.21 released

Sat Oct 20, 2012 12:09 pm

Some sectors randomly stop sending data. You need to reboot or off / on wifi. He does it more sectors. With v5.21 it started and where previously no.

802.11n + nv2 tdma 2ms.

Image
 
mars
Member Candidate
Member Candidate
Posts: 228
Joined: Sun Mar 14, 2010 1:43 pm

Re: 5.21 released

Sat Oct 20, 2012 6:54 pm

ros 5.21 definitely has problems with links slowing down and link must be switched off and on or rb must be rebooted
 
User avatar
honzam
Forum Guru
Forum Guru
Topic Author
Posts: 2286
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 5.21 released

Sat Oct 20, 2012 7:25 pm

Some sectors randomly stop sending data. You need to reboot or off / on wifi. He does it more sectors. With v5.21 it started and where previously no.
802.11n + nv2 tdma 2ms.
I have the same problem. It happens only with combination 802.11N with NV2
Reboot, or disable and enable AP solves problem
LAN, FTTx, Wireless. ISP operator
 
networx
just joined
Posts: 5
Joined: Sat Oct 20, 2012 8:17 pm

Re: 5.21 released

Sat Oct 20, 2012 8:51 pm

Hi,

have some problems with date get via WinBox (show: Okt/20/2012 - correct: Oct/20/2012) on RB2011UAS-2HnD.
So you can't hit the "Apply" button.

Please note yellow marks:
Wrong-Date.png
Will where be a fix?
You do not have the required permissions to view the files attached to this post.
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1218
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: 5.21 released

Sun Oct 21, 2012 8:33 pm

This version just seems unstable. Some connection just stop working. Web pages fail to open and IMs stop sporadically. After router reboot everything is ok again (for some time). Sometimes even restarting the PPPoE link solves it. Reverting to 5.20 seemed to fix this behavior.
It could also be my providers having issues exactly to the minute I was trying out 5.21...
Used on a RB450G in a dual stack IPV4/IPV6 and 2 PPPoE link configuration.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
User avatar
Hotz1
Member
Member
Posts: 386
Joined: Tue Oct 09, 2007 6:55 am

Re: 5.21 released

Mon Oct 22, 2012 3:55 am

router with internet connection configured will connect to mikrotik.com and check if new version is available. If update is possible you have options to "download" or "download & upgrade" packages from the internet.
Is the checking & downloading done directly by the RB, or by the PC running Winbox? (I hope the former, since the latter would mean all sorts of traffic going through the PC.)
Principal, Engineering
Cape Ann Communications, Inc.
Gloucester, MA, USA
 
Ivoshiee
Member
Member
Posts: 470
Joined: Sat May 06, 2006 4:11 pm

Re: 5.21 released

Mon Oct 22, 2012 5:58 am

I updated portion of my network to a ROS v5.21 and thus far it seems to work except OSPF developed a loop - one box routed a network to another box and that routed it back. It was a bit strange because that the first box has that given network connected to it and had static routing for that. Rebooting of one unit fixed it for now, but it is a bit uncomfortable.

Does the OSPF have loop avoidance or at least detection capabilities?
Is is some new bug?
 
dzieva
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Fri Mar 25, 2011 4:51 pm
Location: Iguassu Falls, Brasil

Re: 5.21 released

Mon Oct 22, 2012 5:13 pm

Hi,

Do I need to uprgrade CPE as well as AP to increase nv2 stability ?

Best Regards
Yes

EDIT: "increase nv2 stability" comes with increased latencies and packet loss, just wanted to clarify that...
I'm using NV2, and have not seen any packet loss, or increased latencies, but at least 10 percent bandwidth, without further desconnection.

Best regards
Dzieva
 
dzieva
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Fri Mar 25, 2011 4:51 pm
Location: Iguassu Falls, Brasil

Re: 5.21 released

Mon Oct 22, 2012 5:17 pm

Some sectors randomly stop sending data. You need to reboot or off / on wifi. He does it more sectors. With v5.21 it started and where previously no.
802.11n + nv2 tdma 2ms.
I have the same problem. It happens only with combination 802.11N with NV2
Reboot, or disable and enable AP solves problem
I have the same problem. It happens only with combination 802.11N with NV2
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: 5.21 released

Mon Oct 22, 2012 5:25 pm

Some sectors randomly stop sending data. You need to reboot or off / on wifi. He does it more sectors. With v5.21 it started and where previously no.
802.11n + nv2 tdma 2ms.
I have the same problem. It happens only with combination 802.11N with NV2
Reboot, or disable and enable AP solves problem
I have the same problem. It happens only with combination 802.11N with NV2
provide us with the support output files and also remote access to those problematic links could help us.
 
robelder
just joined
Posts: 6
Joined: Fri Nov 06, 2009 12:57 am

Re: 5.21 released OSPF

Mon Oct 22, 2012 9:27 pm

Any chance version 5.21 resolves the issues we've been having for ever it seems with OSPF? Tried all the many different ways to resolve the constant drops and having the major ones from time to time where we just have to reboot constantly. Run RIP ontop of it as well to help with the issues, but it's really getting anoying. Thanks guys!!
 
marcin21
Member Candidate
Member Candidate
Posts: 186
Joined: Tue May 04, 2010 4:50 pm

Re: 5.21 released

Mon Oct 22, 2012 11:39 pm

I confirm, that 5.21 introduces some serious problems with interrupting traffic.
I pointed this in other topic, but it seems i'm there only one and here looks i'm not alone.
SO what can I say to Mikrotik team? 5.21 is buggy....
 
gnuttisch
Member
Member
Posts: 309
Joined: Fri Sep 10, 2010 3:49 pm

5.21 released

Mon Oct 22, 2012 11:52 pm

Does the error shows when running 802.11A/N whit NV2 or only whit 802.11 N?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5921
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: 5.21 released

Tue Oct 23, 2012 4:40 pm

OSPF was not changed in v5.21. IF you have problems that you did not have in previous versions then most likely it is not ospf related. Check the stability of the link on which OSPF is running.
 
robelder
just joined
Posts: 6
Joined: Fri Nov 06, 2009 12:57 am

Re: 5.21 released OSPF

Tue Oct 23, 2012 4:56 pm

The Link is stable. And we have Ethernet based links, and 3 seperate wireless links, one is about 1/2 a mile and never drops. We use to run a single router at the main location, then added another 100 meg fiber to the tower and starting using OSPF on each of the routers with redundant links to each Headend. It seemed to work fine for awhile, but the log shows the status changing constantly on each router as one or more of the routes go away in regards to OSPF (even the one that is lan based sitting right next to each other). Could it be a timeout issue that can be adjusted? We went from broadcast to nbma and have the same issues. Don't want to, but due to the issues we are having may have to go back to a single router at each head end and custom route it it continues to go down. Any suggestions (preferably with examples) would be greatly appreciated. (I've read everywhere I can and it seems OSPF has been an issue for a number of years now). I would prefer to use ospf as it is relatively easy to setup and works great when it's working, but i don't really care what I have to use as long as it's stable. Thanks in advance!!
 
vishvas
just joined
Posts: 2
Joined: Thu Oct 28, 2010 2:29 pm

Re: 5.21 released

Tue Oct 23, 2012 6:12 pm

Dear Sir
After version upgrade to 5.21 in bridge mode in wireless option advance not all option are shown in winbox .Please find attched screen shot.
You do not have the required permissions to view the files attached to this post.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: 5.21 released

Tue Oct 23, 2012 6:19 pm

vishvas, only the wireless option that is used for your wireless-protocol is shown under winbox. In your case most likely you are using Nv2 or Nstreme wireless protocol.
 
Ivoshiee
Member
Member
Posts: 470
Joined: Sat May 06, 2006 4:11 pm

Re: 5.21 released

Tue Oct 23, 2012 7:30 pm

OSPF was not changed in v5.21. IF you have problems that you did not have in previous versions then most likely it is not ospf related. Check the stability of the link on which OSPF is running.
I upgraded from v5.16. Are there any OSPF changes over those releases?
 
brainy
Member Candidate
Member Candidate
Posts: 149
Joined: Fri Sep 29, 2006 3:08 pm
Location: Unterschleissheim, Germany
Contact:

Re: 5.21 released

Tue Oct 23, 2012 7:55 pm

i already had that lockup issue since at least 5.15 that the wifi is not passing any traffic. i disconnected all clients (only 2 SXTs at this time) from the AP (OmniTik) and then it worked again without disable/enable ...

Maybe that helps?!
 
User avatar
ohara
Member
Member
Posts: 369
Joined: Mon Jun 13, 2011 11:30 pm
Location: Warsaw

Re: 5.21 released

Tue Oct 23, 2012 8:18 pm

i already had that lockup issue since at least 5.15 that the wifi is not passing any traffic. i disconnected all clients (only 2 SXTs at this time) from the AP (OmniTik) and then it worked again without disable/enable ...
A similar wireless traffic issue was recently visible in version 5.15. It looks as if MT developers reused some portions of the code or took a similar approach to improve stability of nv2 than in 5.15. Anyhow nv2 still needs some hardening.
 
Inssomniak
Member
Member
Posts: 326
Joined: Fri Apr 13, 2007 11:21 pm

Re: 5.21 released

Wed Oct 24, 2012 1:56 am

*) fix MPLS MTU configuration usage;

Can anyone explain what the error was occurring with the mpls mtu?

Att,
I'm gonna guess. ...

The only config that made any difference was the "all" setting. Selecting an interface and giving it an MTU seemingly did nothing.

As far as I know this bug is older than time itself.
 
gsloop
Member Candidate
Member Candidate
Posts: 213
Joined: Wed Jan 04, 2012 11:34 pm
Contact:

Re: 5.21 released

Wed Oct 24, 2012 8:09 pm

What does it mean?:
*) dns - fix empty response;
I'm asking about it, because I have problems with MikroTik DNS long time. Maybe this fil will repair it, but what do You mean "empty response"??
Please MikroTik - what does this mean?
- If I helped you solve your problem ... Karma is an appropriate gift! :) -
 
biomesh
Member Candidate
Member Candidate
Posts: 139
Joined: Fri Feb 10, 2012 8:25 pm

Re: 5.21 released

Wed Oct 24, 2012 8:44 pm

What does it mean?:
*) dns - fix empty response;
I'm asking about it, because I have problems with MikroTik DNS long time. Maybe this fil will repair it, but what do You mean "empty response"??
Please MikroTik - what does this mean?
My guess is that it is related to the truncated flag with udp DNS queries:

http://www.dslreports.com/forum/r276417 ... allcentric

Is a good example of how different DNS implementations on devices are broken.
 
snowflake
just joined
Posts: 8
Joined: Thu Oct 25, 2012 1:53 pm

Re: 5.21 released

Thu Oct 25, 2012 2:01 pm

On RB751G-2HnD I'm having problems with the stability of PPPoE.

It takes many attempts before the link goes up. It does not stay up for long.

I also have problems with telneting into the modem, a VIgor 120.

It all started with 5.21. 5.20 and previous were rock solid.

Followup:

After downgrading to 5.20, I noticed that the Ethernet link to the modem
was set at 10Mbps, half duplex. Although this worked on 5.12 to 5.20
for the last eight months,
it was obviously not optimal. My ADSL line runs at 6Mbps and it was close
to saturating the link. I disabled auto-negotiation and set the link to
100Mbps full-duplex. It has now been running on 5.20 for the last
24 hours with no problems.

I will now try reverting to 5.21 and see what happens. Stay tuned.

Followup to followup:

5.21 installed. After reboot, the ethernet link to the modem did not
come up (modem is a Draytek Vigor 120). The LAN led on the modem
was flashing rapidly and the "1" led on the router board was off.

After power cycling the modem the ethernet link was established. After a few seconds
the PPPoE link came up. It has now been up for 52 minutes.

There is nothing in the change log for 5.21 that affects the ethernet ports so I
wonder what is going on.
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

5.21 error firewall info

Mon Oct 29, 2012 10:01 pm

Sorry, the board attachment quota has been reached.

hmm :-x
 
ibermi
just joined
Posts: 22
Joined: Mon Dec 13, 2010 12:26 pm

Re: 5.21 released

Wed Oct 31, 2012 10:52 am

For the next version, you can have if you do a test for the hardware, to verify that everything works fine.

Thank you.
miguelbatista at ibersystems.es
Experto en redes WiFi y enlaces WiFi.

Facebook: @Ibersystems
Twitter: @Ibersystems

Expert in Wireless, Hotspots, Linux and Radius Servers
 
JanezFord
Member Candidate
Member Candidate
Posts: 263
Joined: Wed May 23, 2012 10:58 am

Re: 5.21 released

Thu Nov 01, 2012 9:53 pm

On RB751G-2HnD I'm having problems with the stability of PPPoE.

It takes many attempts before the link goes up. It does not stay up for long.

<stuff deleted>
I have two RB751G-2HnD and also did an upgrade from 5.20 to 5.21 on both. I use PPPoE for internet access and did not notice any problems at all. It is running rock solid for weeks now and also under heavy load (ipsec traffic).

Check or eplace your cables since you also have ethernet port issues. I don't think it is a 5.21 issue.

JF

P.S.: I don't have a Drytek Vigor connected to it, but Genexis modem.
 
dadaniel
Member Candidate
Member Candidate
Posts: 155
Joined: Fri May 14, 2010 11:51 pm

5.21: config export error

Wed Nov 07, 2012 4:33 pm

/interface ethernet export file=if.rsc

expected output:
/interface ethernet
set 0 name=ether1-modem
set 1 name=ether2-wan1
set 2 name=ether3-wan2 master-port=ether2-wan1
set 3 name=ether4-wan3 master-port=ether2-wan1
set 4 name=ether5-lan
actual output:
/interface ethernet switch
set 0 mirror-source=none mirror-target=none name=switch1
/interface ethernet switch port
set 0 vlan-header=leave-as-is vlan-mode=fallback
set 1 vlan-header=leave-as-is vlan-mode=fallback
set 2 vlan-header=leave-as-is vlan-mode=fallback
set 3 vlan-header=leave-as-is vlan-mode=fallback
set 4 vlan-header=leave-as-is vlan-mode=fallback
set 5 vlan-header=leave-as-is vlan-mode=fallback

Any ideas?
 
Segir
just joined
Posts: 4
Joined: Thu Nov 08, 2012 12:54 am

Re: 5.21 released

Thu Nov 08, 2012 1:18 am

Few days ago I upgraded my RB750G from 5.19 to 5.21 and found the following problem - often I can't login, there is a following message on logon web-page "Internal server error".
As I read changelog, similar problem has already been solved in version 5.7, but now it seems to appear again in 5.21
Does anyone met such problem? Can it be fixed?
 
spire2z
Long time Member
Long time Member
Posts: 517
Joined: Mon Feb 14, 2005 2:48 am

Re: 5.21 released

Sat Nov 10, 2012 4:13 am

I confirm, that 5.21 introduces some serious problems with interrupting traffic.
I pointed this in other topic, but it seems i'm there only one and here looks i'm not alone.
SO what can I say to Mikrotik team? 5.21 is buggy....
I think ive had this happen three times. Its odd though as we only really use point to point and have lots of links and this has happened only on one certain link three times and the only difference is I think its the only one we have a rb800. We mostly have rb600a but its only happened about once a month (not often) it seems to happen! It can be solved by disabling and reenabling wireless interface on AP or Station concerned to resolve problem. The fact it seems resolved by disabling link either end makes me think it may be WDS related. Only a guess though. I still haven't been bale to do a supout when prob is happening as I was on wireless side at time. Don't know if its any use to do one afterwards?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: 5.21 released

Sat Nov 10, 2012 1:25 pm

I confirm, that 5.21 introduces some serious problems with interrupting traffic.
I pointed this in other topic, but it seems i'm there only one and here looks i'm not alone.
SO what can I say to Mikrotik team? 5.21 is buggy....
I think ive had this happen three times. Its odd though as we only really use point to point and have lots of links and this has happened only on one certain link three times and the only difference is I think its the only one we have a rb800. We mostly have rb600a but its only happened about once a month (not often) it seems to happen! It can be solved by disabling and reenabling wireless interface on AP or Station concerned to resolve problem. The fact it seems resolved by disabling link either end makes me think it may be WDS related. Only a guess though. I still haven't been bale to do a supout when prob is happening as I was on wireless side at time. Don't know if its any use to do one afterwards?
Please contact support for RouterOS v5.22rc1 as that version has fix for Nv2 wireless stalls.
 
spire2z
Long time Member
Long time Member
Posts: 517
Joined: Mon Feb 14, 2005 2:48 am

Re: 5.21 released

Sat Nov 10, 2012 3:35 pm

cool, thanks.
 
Megophrys
just joined
Posts: 1
Joined: Sat Nov 10, 2012 9:40 pm

Re: 5.21 released

Sun Nov 11, 2012 3:05 pm

What about PoE firmware upgrade in 5.21?
I have RB751G-2HnD, updated from 5.16 to 5.21. But the PoE firmware is still 1.0. Of course, I performed /interface ethernet poe settings upgrade and then reboot the router – no changes.
 
User avatar
erebusodora
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Mon Jan 23, 2012 3:46 pm
Location: Bulgaria

Re: 5.21 released

Mon Nov 12, 2012 10:50 am

I confirm, that 5.21 introduces some serious problems with interrupting traffic.
I pointed this in other topic, but it seems i'm there only one and here looks i'm not alone.
SO what can I say to Mikrotik team? 5.21 is buggy....
I think ive had this happen three times. Its odd though as we only really use point to point and have lots of links and this has happened only on one certain link three times and the only difference is I think its the only one we have a rb800. We mostly have rb600a but its only happened about once a month (not often) it seems to happen! It can be solved by disabling and reenabling wireless interface on AP or Station concerned to resolve problem. The fact it seems resolved by disabling link either end makes me think it may be WDS related. Only a guess though. I still haven't been bale to do a supout when prob is happening as I was on wireless side at time. Don't know if its any use to do one afterwards?
Please contact support for RouterOS v5.22rc1 as that version has fix for Nv2 wireless stalls.
The problem occurs in WDS mode and NV2 protocol . I try to cnahge channel-width=20/40mhz-ht-below and mode=bridge to station bridge.... for now no problems but waiting.....
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 5.21 released

Thu Nov 15, 2012 9:45 pm

RB433UAH RouterOS 5.21 error:

firewall NAT statistic (xxxxxxxxxxx.xx GiB)
web-proxy enable USB1 (restart routerboard random enable "system drive")
bandwidth-test UDP send (start-stop,start-stop,...start-no trafic [receive is OK] reboot OK)

+ no remove Leds indications ? (system leds add interface=wlan3 leds=user-led type=interface-activity)
 
krajnalic
newbie
Posts: 34
Joined: Wed Nov 30, 2011 1:39 am

Re: 5.21 released

Sat Nov 17, 2012 6:47 pm

nv2 5.18 vs 5.21. ptp link 7km, rock solid as before 5.21, but ping is better
You do not have the required permissions to view the files attached to this post.
 
frbaia
just joined
Posts: 3
Joined: Mon Feb 06, 2012 12:50 pm

Re: 5.21 released

Tue Nov 20, 2012 5:57 pm

Hi

After upgrade from 5.19 to 5.21, API don´t work more, when go to ip/services and try to enable API, I give this error message: "Couldn´t chance IP Service <api> - feature is not implemented (2)"

any idea?

Fabio
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 5.21 released

Wed Nov 21, 2012 8:29 pm

RB433UAH

ethernet & wlan 802.11 b/g :D
You do not have the required permissions to view the files attached to this post.
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 5.21 released

Thu Nov 22, 2012 1:27 am

RB433UAH

After you restart the metarouter disappeared

Who is online

Users browsing this forum: Google [Bot] and 34 guests